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For Those of you on Zoom, I Apologize in Advance

for the Barking You Might Hear in the Background  

They mean well, but delivery vans are just too-tempting a bark-target…



mjb – July 15, 2025

3

Computer Graphics

Handy Blender Shortcuts
Shortcut What it Does

LMB Select something

Shift-LMB Add something else to the selection

MMB Rotate the scene

Shift-MMB Pan the scene

Shift-spacebar Bring up the transformation menu

Scroll Wheel Zoom in and out

Tab Toggle between Object Mode and Edit Mode

Control-Tab Bring up Mode pie menu

`  (back quote)
Bring up View pie menu

a Select all

Click in empty space Unselect all

Alt-a Unselect all

Shift-a Bring up the Add menu

Escape Get you out of almost anything (including stopping a render or an animation)

b, c Box or circle select

C Center the scene (good if you are lost in 3D)

Shift-d Duplicate

e Extrude (in edit mode)

F3 Search

g Grab (translate) an object
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Shortcut What it Does

Shift-g Group

i Insert a keyframe

Control-j Join 2 or more objects

m Send object to a collection (layer)

n Toggle the Sidebar menu

Shift-n Recalculate normals

p Partition (only in edit mode)

Control-p Establish a parent-child relationship (the last object selected will be the parent)

Alt-p Destroy a parent-child relationship

Control-Alt-q Toggle quad viewing

r Rotate an object

s Scale an object

Shift-s Pie menu for using the 3D Cursor

Spacebar Start / Pause an animation

t Toggle the Object Tools menu

x Delete whatever is selected

z Bring up a display mode pie menu

Control-z Undo

Alt-z Toggle x-ray mode

Control-Shift-z Redo

F12 Render a scene image

F11 Return to the interactive scene

Handy Blender Shortcuts
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Not Exactly a Shortcut, but Really, Really Useful

If you would like to be able to rotate 
the entire scene around a particular 
object, click on the object and then 
select:

View → Frame Selected

You can also hit the period (.) on 
the number pad on the keyboard.
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A Recommendation

If you don't have one already, I strongly, 
strongly, strongly recommend that you get a 3-
button mouse for use with Blender.

The middle button is both a push-button and a 
scroll wheel.

Blender makes liberal use of all 3 buttons and 
the scroll wheel.

You can get by with a 2-button mouse, but your 
Blender life will be considerably easier and 
more productive with a 3-button mouse.
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What is Blender?

Blender is a free program that lets you do professional-looking 
3D modeling, rendering, and animation.  This, not this.  

You can get Blender for yourself by going to:  http://www.blender.org

Note: The version number
changes often.  These notes
have been written against Blender 

version 4.4

Blender likes to change elements of 
its user interface every new version. It 
is recommended that you have 4.4 
installed on your own system to 
match these notes!

X
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Flow – an award-winning Blender-animated movie

See:
https://en.wikipedia.org/wiki/Flow_(2024_film)

Winner of the 2025 Academy Award for
Best Picture



mjb – July 15, 2025

9

Computer Graphics

Why Do We Have These Notes?

Blender has thousands of buttons you can press.  It is difficult to understand them 
all.  These notes are here to show you what certain combinations of buttons do in 
order to learn them, and to remind you later when you’ve forgotten.

http://xkcd.com
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cloth.mp4cloth.blend

In these notes, what do these icons mean?

They tell you that if you go to our notes web site:

http://cs.oregonstate.edu/~mjb/blender

you will find Blender input files (*.blend), texture map files (*.bmp), and animation 
movie files (*.mp4).

You can read a .blend file right into Blender (File → Open) so that you can 
experiment with these examples without having to first create them yourself.

You can play an .mp4 movie file right from your browser so that you can see how 
these examples look without having to run Blender at all.

worldtex.bmp
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What Blender does

What I know

What the
notes cover

A warning about me and the Notes
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What We Will Cover in these Notes

1. Navigating the screen layout

2. Viewing in 3D

3. Moving things around in 3D

4. Modeling, I

5. Appearance, I

6. Modeling, II

7. Rendering

8. Particle Systems

9. Physics Animation

10. Appearance, II

11. Vertex Sculpting

12. Vertex Painting

13. Keyframe Animation

14. 3D Printing

15.Stereographics

16. References
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1. Navigating the 
Screen Layout
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Full Screen Layout

Outliner
Main MenuObject Tools 

(‘t’)

Animation Controls

Property-specific Options
Object Properties (‘n’)

View 
Control
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The Object Tools Menu
Select

Toggled on and off with the ‘t’ key

Cursor

Transform

Move

Rotate

Scale

Annotate

Measure

Add Cube
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The Add Menu

Create geometry

Create lights

Create other cool stuff

This is the Add tab – you will spend a lot of time here!
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The Add→Mesh Menu

You will especially spend a lot of time here!



mjb – July 15, 2025

18

Computer Graphics

The Sidebar Panels

Toggled on and off with the ‘n’ key
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The Blender Interface Widgets
If Blender shows you something that looks like this …

… you are expected to click a button to put yourself in a particular mode
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The Blender Interface Widgets

If Blender shows you something that looks like this …

… you are expected to click in the box to bring up something else, 
like this
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If Blender shows you something that looks like this …

… you are expected to turn features on and off by clicking in all or none of 
the checkboxes

The Blender Interface Widgets

If Blender shows you something that looks like this …

… you are expected to make a choice of just one of these options
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The Blender Interface Widgets

If Blender shows you something that looks like this …

… you are expected to either left-click in the box and (keeping the left button 
down) drag the mouse left-right like a slider, or single-click in the box and 
type in a new value

If Blender shows you something that looks like this …

… you are expected to click in the box 
and then select from the resulting list
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The Blender Interface Widgets

If Blender shows you an “Apply” button …

… it means that you can click this button to get rid of your original model and 
replace it with a model that has the edits you have just made

If Blender shows you this icon (with or without the word “Open” …

… it means that you can click this button to open a file
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The Blender Interface Widgets

If Blender shows you something that looks like this …

… you are expected to click in the box and select from a 
list of other objects in the scene

If Blender shows you something that looks like this …

… the red color is telling you that you haven’t yet entered 
enough information in this panel
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The Blender Interface Widgets

If Blender shows you something that looks like this …

… it allows you to hide and unhide something (the Outliner is where you use 
this most often).  Hiding an object is useful for decluttering your scene.

Hint #2: If you hide something, don’t forget that you have hidden it.  It is pretty 
freaky to be certain that you once created something, but now you can’t find it 
anywhere in the scene.  

Hint #1: If you no longer want an object in the scene, hiding it for a while before 
deleting it is usually a smart idea.  It is surprising how often you need something 
not long after you deleted it.  
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The File Menu

Bring an image or object in from somewhere else

Send an image or object to somewhere else

Save the current scene in a file

Start a new Blender scene (thus closing the 
scene you currently have open)

Open a previously-created Blender scene (thus 
closing the scene you currently have open)

Bring elements from another Blender file 
into this scene



mjb – July 15, 2025

27

Computer Graphics

The Difference Between New, Open, Link, and Append

New closes the scene you currently have, then initiates 
a new Blender scene.

Open closes the scene you currently have, then reads 
in a previously-stored Blender scene.

Append leaves the scene you currently have open, 
and adds elements of a previously-created scene into it.

Link is like Append, but every time you open the scene 
again, it will look at the file you are Linking from to see if 
changes have been made, and if so, will bring those 
into the scene instead of the first ones.
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The Edit Menu

Control-Z or Edit→Undo are two of your best friends!

You can also select Undo History and go 
back in time to several commands ago
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The Render Menu
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The Help Menu
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Blender Windows

When Blender launches, there are four sub-windows visible.  But 
Blender has 23 Possible sub-window types that you can bring up 
and change the size of. 
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Changing the Border Line on Blender Windows

To change a sub-window boundary, left-click on the horizontal or vertical 
border line, wait for the cursor to change to a double-arrow, then move the 
mouse up/down or left/right.
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Adding a New Blender Window

To change a sub-window boundary to create a new window, hover over the 
boundary, wait for the cursor to change to a double-arrow, then right-click.  
This menu will pop up.  Select Vertical Split or Horizontal Split and move 
the mouse up/down or left/right.  This will create a copy of a Blender sub-
window that you already have.
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Changing the Type of a Blender Window

“This will create a copy of a Blender sub-window you already have.”
Well, what good is that?

Blender sub-windows have a type, designated by the icon in the upper-left corner.
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Changing the Type of a Blender Window

Clicking the down arrow, will bring up the list of the 23 types you can 
change that sub-window into:

Congratulations!  You have now added a new Blender sub-window to your display.
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Deleting a Blender Window

To delete a window, hover over the boundary, wait for the cursor to 
change to a double-arrow, then right-click.  This menu will pop up.  
Select Join Areas and move the mouse up/down or left/right.  This 
symbol shows you which window will be eliminated when you click the 
mouse button.

˃
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2. Viewing in 3D
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Right-handed

X

Y

Z

X

Y

Z

Left-handed

3D Coordinate Systems

Blender uses this convention
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X

Y

Z

• Right-handed coordinate system
• X = Red
• Y = Green
• Z = Blue
• Middle mouse button (MMB) – orbit (rotate)
• Shift MMB – pan
• Scroll wheel – zoom
• View → Viewpoint → Left, Right, …
• View → Area → Toggle Quad View
• View → View Perspective/Orthographic

The Coordinate and Viewing System
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The View Menu

The View Menu gives you access to lots of ways to 
change how you are viewing the scene
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Rotating About a Particular Object

If you would like to be able to rotate 
the entire scene around a particular 
object, click on the object and then 
select:

View → Frame Selected

You can also hit the period (.) on 
the number pad on the keyboard.
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Toggling Between Perspective and Orthographic Views

Orthographic

Perspective
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Toggling Between Perspective and Orthographic Views

In orthographic, lines that are parallel in 3D 
remain parallel on the screen.  Objects appear 
to be the same size as they get farther away.

In perspective, lines that are parallel in the 3D depth 
direction appear to converge on the screen.  Objects 
appear to get smaller as they get farther away.

“Vanishing Point”

Use perspective when you want a more 
realistic view (which is most of the time).

Use orthographic to see if things 
separated in depth are the same size.
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Toggling Between Perspective and Orthographic Views

Use orthographic to see if things separated in depth are the same size:

Use perspective when you want a more realistic view (which is most of the time):

scene.blend
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Single View vs. Quad View

Or hit Control-Alt-q
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Setting the initial Rendering Mode

On the vertical 
strip of icons on 
the right, click 
this one:

And then be sure the Render Engine is set to Eevee for now.

BTW, Eevee stands for Extra Easy Virtual Environment Engine
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Setting the initial Display Mode
X-ray Wireframe

Viewport
Shading Rendered

X-ray

No
X-ray

Use Viewport Shading to start.  
It gives good generic lighting.

Later, when we cover Rendering, 
we will use Rendered lighting, 
but not now.
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Setting the initial Display Mode

2. Find this vertical 
column of icons, then 
click on this one, called 
Material Properties

3. Click on New

4. Scroll way down and select Viewport Display

5. Click here and use 
the color wheel to 
select the color you 
want this object to be

1. Click on the 
object whose 
color you 
want to set
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Metallic and Roughness Specify How the Color 
Interacts with Light

Metallic

R
o

ug
h

ne
ss

0.0 0.5 1.0

0.0

0.5

1.0

In some graphics 
programs, they use the 
word "smoothness" 
instead of "roughness".

If smoothness is small, 
roughness is large.

If smoothness is large, 
roughness is small.
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3. Moving Things 
Around in 3D
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We will get into this in more detail later, but just so that you 
have something on the screen, here is the Add Menu

These are all the different geometry things you can add 
into the scene.  We will cover many of them, but not all.

This group is the meshes.

This group is the curves.
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The Add→Mesh Menu

The UV Sphere, Torus, and 
Monkey are my favorites
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Summary of the Mesh Objects



mjb – July 15, 2025

54

Computer Graphics

• Right-handed coordinates
• Right-handed rotation rule
• Angles are in degrees

Coordinate System Conventions

X

Y

Z
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X

Y

Z

+

+

Right-handed Rotation Rule

+
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Selecting an Object to Work On

LMB-click on the object you want to select.  It 
will then be highlighted with an orange outline.
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Selecting Multiple Objects to Work On:
Two Ways to Do This

1. Hold down the Shift key while RMB-clicking

2. LMB a rectangular region around objects
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Moving Things By Clicking and Dragging

Translate (“grab”)

Use Global or Local 
Coordinate System

Rotate

Scale
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Global and Local Coordinates

Global Coordinates 
align with the screen

Global

X

Y

Local Coordinates 
align with the object

Local
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• LMB click to select an object
• Grab: g
• Rotate: r
• Scale: s
• Grab using global axis: g → x, etc.
• Grab using local axis: g → x → x
• Pick all but a particular axis: g → X, g → X → X, etc.
• Grab a specific distance: g → x → 12.25 <return>
• Rotate a specific angle: r → x → 45 <return>
• Scale a specific factor: s → 2.0 <return>
• Scale a specific factor: s → x → 2.0 <return>

Saying How to Move Things by Using the Keyboard

X

Y

Z

This is important – you will use this a lot!

The arrows (→) mean “and then hit”
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You Can Also Use the Sidebar Panel

Hit the ‘n’ key to toggle this panel on and off
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Applying the Transformation

When you transform an object, Blender doesn’t change the object’s coordinates.  
It keeps the object’s original coordinates plus a record of the transformation.  
So, for example, if you scale an object by 2.0, Blender remembers it like this:
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Applying the Transformation

If you want to actually alter the object’s coordinates, choose Object → Apply

You can pick a specific 
transformation to apply, but 
most of the time it is easiest 
to select All Transforms
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Applying the Transformation

Once you apply the transformation, the Object Properties Box looks like this: 

Before After



mjb – July 15, 2025

65

Computer Graphics

The Outliner

In the upper-right portion of the screen 
is the Outliner.  Like the name implies, it 
shows an outline of your scene.  

It is sometimes nice to have a summary 
of the scene so you can remind yourself 
of what all is in it.

Also, if your scene is cluttered, you can 
select on object by left-clicking on its 
name in the outliner as opposed to 
selecting it in the scene.

Double-clicking on a name will allow 
you to rename that object to something 
more sensible than, say, “sphere”

Also, you can use the outliner to hide 
certain objects.  Just click on the eye 
icon to hide/unhide.

Hint: If you hide something, don’t forget that you have hidden it.  It is pretty freaky to be 
certain that you once created something, but now can’t find it anywhere in the scene.  
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The 3D Cursor

You have probably noticed that when you start up Blender, there is a mysterious 
cursor positioned at the origin.

This is Blender’s 3D View Editor Cursor.

With this, you can point anywhere in space.
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One way to position the 3D View Editor Cursor is to click on 
the Cursor icon and start left-clicking around the scene.

When you are done, be sure to let go of the 3D Cursor by 
clicking here

Positioning the  3D Cursor
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Positioning the  3D Cursor

But, it is hard to get the 3D Cursor exactly where you want it to be.  For example, if 
you want to position the 3D Cursor at the corner of the cube indicated by the 
yellow dot, LMB click on it.  But, upon rotating, you realize that it is at the wrong 
depth.  So, get a view roughly 90˚ from the last view, and click again.  You might 
have to do this a couple more times.
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The 3D Cursor

You can also automatically position the 3D Cursor using the Object → Snap menu

For example, choosing Cursor to Selected will move the 3D Cursor to the median 
point of the object you have most recently selected.  Choosing Selected to Cursor 
will move the selected object’s median point to where the 3D Cursor is. 
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A Use for the 3D Cursor – Arbitrary Pivot Point

Suppose you then wanted to rotate the cube about 
the yellow corner point.  After positioning the 3D 
Cursor there, you would then go to the Pivot 
Center menu and select 3D Cursor.  Rotations 
and Scaling will now take place around the yellow 
corner.

Later, you probably want to change the pivot point 
back to Median Point.



mjb – July 15, 2025

71

Computer Graphics

Another Way to Set the Arbitrary Pivot Point

Select the object, tab to Edit Mode, select all vertices (‘a’) and translate 
them (‘g’).  

In Edit mode, the pivot point stays put while the vertices move.

Tab back to Object mode, and rotate the object to confirm that the pivot 
point has changed.

In contrast, in Object Mode, the pivot point moves with the vertices.

The little orange dot is the 
pivot point.
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4. Modeling, I
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The Add Menu

These are all the different geometry things you can add 
into the scene.  We will cover many of them, but not all.

This group is the meshes.

This group is the curves.
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The Add → Mesh Menu

The UV Sphere, Torus, and 
Monkey are my favorites
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When you Add a Mesh, a Small Menu Appears 
in the LL Corner

UV Sphere
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When you Add a Mesh, a Small Menu Appears 
in the LL Corner

Try clicking on it.

The small menu lets you modify how the last thing you did works.  In this 
case, the most important thing it is doing is letting you change the polygon 
resolution of the sphere.  But, this menu only exists until you do 
something else.  After that, the ability to change these values is gone.

Personally, I like changing these two 
values to 64 and 32, respectively.
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Summary of the Mesh Objects
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Blender is able to play a graphics trick to make your 
curved geometry look better.  Select the object 
(LMB) then click the RMB and select 
Shade Smooth.  To go back, select Shade Flat.

Making the Mesh Objects Look Nicer

This doesn’t actually change any geometry –
it’s just a really good computer graphics 
display trick.  There are other ways to truly 
create smoother underlying geometry.

Flat

Smooth
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How to Find Out How Detailed a Mesh Object Is

In the overlay menu,
turn on Statistics

The number of Vertices, Edges, Faces, and 
Triangles show on the left side of the screen
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Select the object (LMB) then click the RMB and select 
Duplicate Objects. This leaves the new object right on 
top of the old object and leaves you in Grab mode.  Just 
move the mouse to separate the two objects.

Duplicating an Object from the RMB Menu
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Mirroring an Object
Oftentimes you want to create an object that is identical to itself but is 
symmetric about an axis.  This type of operation is called mirroring.

Create an object, in this case, Suzanne the Monkey.

Let’s say that we want to mirror this object left-right (y).  
Select the monkey, right click, then select Mirror,
and then select Y Global.

Before

After
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Select and edit:

A vertex An edge A face

Editing a Vertex, Edge, or Face on a Mesh

Click here, or hit the Tab
key, to get into Edit Mode

Using the Tab key is so common, that “tab” has become a verb in the 
Blender community.  As we like to say, “Just tab over into edit mode.”
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Editing a Vertex

Be sure you are in vertex-editing mode

Left click on a vertex

Hit ‘g’ (grab) and move the mouse

You can also hit ‘x’, ‘y’, or ‘z’ to restrict motion
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Editing a Vertex with Proportional Editing

Be sure you have Proportional Editing enabled

LMB click on a vertex

Hit ‘g’ (grab) and move the mouse

You can also hit ‘x’, ‘y’, or ‘z’ to restrict motion

The mouse Scroll Wheel changes the size of the 
Circle of Influence

You can also LMB select an edge or a 
face for editing or proportional editing.
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Subdividing and Smoothing Really Show the Difference 
Between Localized and Proportional Editing



mjb – July 15, 2025

86

Computer Graphics

An Unexpected Use for Proportional Editing
Create a Plane, then go to Edit Mode, then box select all the edges, then click on
Edge  Subdivide and subdivide it several times
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An Unexpected Use for Proportional Editing

Enable Proportional Editing, then go one widget to the right and change the kind 
of Proportional Editing from Smooth to Random
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An Unexpected Use for Proportional Editing

Go to Edit Mode, select a vertex, and lift it along with those around it
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In Edit Mode, you can delete 
things.  For example, here 
four faces have been 
selected.  Right-click and 
select Delete Faces from the 
pop-up menu

Deleting

Here’s what you get:
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You can also right-click and 
select Dissolve Faces from 
the pop-up menu

Dissolving

In which case, you get this:
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5. Appearance, I
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Tells you that we are in the Button Properties Menu

Output Properties

The Button Properties Menus

Render Properties

View Layer Properties

Scene Properties

World Properties

Object Properties

Modifier Properties

Particle Properties

Physics Properties

Object Constraint Properties

Object Data Properties

Material Properties (colors)

Clicking one of these brings up a 
much more detailed menu of options

Collection Properties
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Using the Material Properties Menu

Click on this … to get this

Then, click on New
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Using the Material Properties Menu

To make our lives simpler for now, click here 

to turn off Use Nodes mode

This is what you will see next.
Don’t click anywhere here!
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Using the Material Properties Menu

Scroll way down and click on Viewport Display
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Using the Material Properties Menu

Open up the Viewport Display and click in here …

… to bring up this color wheel.  Click in here 
to get the color you want to give that object.
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Metallic and Roughness Specify How the Color 
Interacts with Light

Metallic

R
o

ug
h

ne
ss

0.0 0.5 1.0

0.0

0.5

1.0

In some graphics 
programs, they use the 
word "smoothness" 
instead of "roughness".

If smoothness is small, 
roughness is large.

If smoothness is large, 
roughness is small.
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Using the Material Properties Menu
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The Color Wheel

Click in here to change
the Value (brightness)

Hue is angle around the wheel
Saturation is the radius

Click in here to change
the Hue and Saturation

These are the possible ways 
the color will be defined

If you know the color definition 
numbers you want, you can 
type or slider them here
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Color Scales

Red-Green-Blue Hue-Saturation-Value Hexadecimal

Eyedropper
(lets you select a color you see somewhere else on the screen)
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C=G+B

M=R+B W=R+G+B

Y=R+G

B

G

R

RGB Additive Color Scale

Blender’s RGB scale lets you give the red, green, and blue 
components in the range 0. – 1.

Blender’s hexadecimal scale lets you give the red, green, 
and blue components in the range 00 00 00 – FF FF FF

R = Red
G = Green
B = Blue
W = White

C = Cyan
M = Magenta
Y = Yellow
K = Black
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Hue

Value Black

White
Saturation

240º

120º

0º

White

Hue-Saturation-Value (HSV) Color Scale

Blender’s HSV scale lets you give the hue, saturation, 
and value components in the range 0. – 1.



mjb – July 15, 2025

103

Computer Graphics

Subtractive Colors (CMYK) are Something Different

M

C

BGR

BG

B

R = Red
G = Green
B = Blue
W = White

C = Cyan
M = Magenta
Y = Yellow
K = Black
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Subtractive Color (CMYK)

R=M+Y

G=C+Y K=C+M+Y

B=C+M

Y

M

C

R = Red
G = Green
B = Blue
W = White

C = Cyan
M = Magenta
Y = Yellow
K = Black



mjb – July 15, 2025

105

Computer Graphics

Color Printing

• Uses subtractive colors

• Uses 4 separate passes (CMYK)

R = Red
G = Green
B = Blue
W = White

C = Cyan
M = Magenta
Y = Yellow
K = Black
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Changing the Color of Individual Faces

Let's say that we have created and colored 
this yellow cube and you want to color the 
front face cyan instead.

With the yellow cube selected, add 
another color slot (+).

Then define that color by clicking on New

This will assign a Material name to the 
slot you just created.
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Changing the Color of Individual Faces

Now select the yellow cube and Tab into Edit 
Mode.  Tell Blender that we will be selecting faces.

Let go of all faces by clicking in an empty area and 
then click on the front face.

Click on the Material Properties menu icon

From this list, select the new color you want 
this face to be.

Click Assign
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Changing the Color of Individual Faces

You have now changed the color of an 
individual face.

I especially like this for highlighting the 
results of Boolean operations:
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So Far We Have Been Using Viewport Shading

We have gotten pretty 
good views of our 
objects without having 
to position light 
sources, cameras, etc.
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We Could Switch to Rendered Shading

But, that would 
require us to position 
light sources, 
cameras, etc.  We’re 
not ready for that yet.
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But, here comes MatCap, a More Creative Use of Viewport Shading

Click on Viewport Shading
and then click on the down-facing arrow

Studio Lighting is what you have been using.  
Instead, select MatCap, which stands for 
“Material Capture”.

Then, click on the sphere.
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Up Pops a Lot of Material Options!

Try them, especially the shiny ones!

A

A

B

CB

C
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6. Modeling, II
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To change the text string, tab into Edit mode.  The white rectangle 
acts as a text cursor.  Backspace over “Text” and type your new text.  
The return key will let you enter multiple lines.

Adding 3D Text

Select Add → Text

It ends up giving you the fairly-useless line “Text”
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Extrude: give the letters height
Depth: bevel the top and bottom
Resolution: round the bevel

Changing the Style of 3D Text

So far, not very 3D, huh?
Tab back to Object Mode, click on your text,
then click on this Font button

Try out the Geometry
and Bevel sub-menus
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From here on, your 3D text acts like any other 3D object.  
It can be grabbed (translated), rotated, and scaled.

It can be colored, too. 

Changing the Look of 3D Text
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At this point, your text is, well, text.  That is, it is characters, not vertices, edges, and 
faces.  If all you want to do is look at it or change the characters, that’s fine.  But if you 
want to do Mesh-things to it, you can’t because it is not a mesh.

To make it a mesh, right-click on the text in Object Mode and select
Convert To → Mesh

Changing the 3D Text to a Mesh

You can confirm that this worked by tabbing to 
Edit Mode and seeing all of the new vertices, 
lines, and faces:
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Edit Mode Subdivision

1. Object Mode

The Edit Mode subdivision feature adds more vertices, but doesn’t do any sort 
of smoothing (like the Subdivision Surface Modifier does).  So, when you are 
done, you will have more vertices to sculpt with, but, in Object Mode, your 
object will look exactly the same as it did before.

2. Tab into Edit Mode

3. Get Ready to Edit Faces
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Edit Mode Subdivision
4. Right-click Subdivide

5. You now have more vertices

6. Tab back into Object Mode

Note that the resulting sphere doesn’t look any different from 
what it looked like before you subdivided.  This is because 
subdividing flat planes gives you more flat planes.  This 
operation is meant to add more vertices for editing, not 
smooth your object.  (There is a Modifier for exactly that.)
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First, make this model:
1. Object Mode → Add → Mesh → Cylinder
2. Tab to Edit Mode → RMB → Subdivide

A Multi-Vertex Picking Hint

Edit a vertex
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Now, LMB-sweep over these vertices.  (I call them 
the “equator” or the “belt”.)

A Multi-Vertex Picking Hint

This will now let you select 
all the points in the belt.

But, if you do that, you will only end up selecting the 
front vertices, that is, the ones you can see.

The trick is to go into X-ray Mode, by clicking here.
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Why do that?  Well, if you have those vertices selected and you hit 
the s key (for scale) and move the mouse, then you can get this: 

A Multi-Vertex Picking Hint

Or, this:
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To create this model:
1. Add → Cube
2. Tab to Edit Mode → RMB → Subdivide → Subdivide

Suppose you want to select an entire row of faces in order to 
“fatten the belt”.  You could select all the faces individually 
(LMB → Shift-LMB).  But, here’s a better trick

1. Click on one face in the row

2. Alt-LMB on another face down the row

A Multi-Face Picking Hint

Face Select Mode
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A Multi-Face Picking Hint

Scaling (‘s’)
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Similarly, if you put yourself into face-picking mode:

A Face Picking Hint

And hit the r and z keys (for rotate about the z axis) 
and move the mouse, then you get this:

And click on the top face of the cylinder (you don’t need 
the belt and don’t need to be in X-ray Mode for this):
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Intentionally Joining Two Objects

Let’s say that you have two objects and want to join them together so 
that you can act on them as one object.
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Intentionally Joining Two Objects
Easy!  LMB on one, then Shift-LMB on the other, then hit RMB → Join
(or Control-’j’ on the keyboard).  The orange “selection outline” now 
goes around both objects and the outliner shows just one object.
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Separating Objects By Loose Parts
Select the Joined object.  Tab over to Edit Mode.  Then hit the ‘p’ key 
(“Partition”).  You will then have three options on how to partition the joined 
object.  If you select By Loose Parts, then the Joined object will be 
partitioned based on the original primitives that made it up.

Before
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Inset Faces (aka, Offset Curves)

Often you want to create a “face-within-a-face”.  In Blender, this is called an 
Inset Face.  (CAD systems often call this sort of thing an Offset Curve.)

In Edit Mode, select the top face.

Then, either RMB → Inset Faces, 
or click on this icon on the left side:
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Inset Faces (aka, Offset Curves)

With the LMB, push the little handle down 
until the Inset Face is the size you want.

At this point, you can select the inner face and hit 
g and z (grab in the z direction) to do this, or this.

Try rotating or scaling the inner face.

You can also create a new inset face inside the inset face you just created.
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Select X-ray mode and select 
all the vertices

Extrude Tool

Start with a cube

Tab into Edit Mode.
Click on the Extrude Tool
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Extrude Tool

Grab one of the +’s and pull

I like XYZ mode so that you can extrude in any direction

You can even keep doing it

When you get back to Object Mode, you will find 
that all of these are part of the same object.
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Spin Tool

Tab into Edit Mode.
Click on the Spin Tool

Start with a cube translated 
along the x axis (gx)
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Spin Tool

Pick the axis/axes about which to spin

Pick the number of duplicates to make

Be sure all of the object’s vertices are selected.

Grab one of the blue +’s and rotate
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Vertex Groups
Using a group of vertices together is very useful.  It is used for editing (like we are doing 
here), but also to pin certain vertices for cloth animation, to grow hair for hair simulation, and 
to rig objects for animation.

1. Select the vertices in Edit Mode (Shift-LMB)

2. Select the Object Data 
Properties button

3. Click the + to add this as 
a new Vertex Group

For that reason, Blender allows you to select the 
group and give them a name for later.  This is 
called a Vertex Group.
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Vertex Groups

4. Double-click on whatever the default 
name is (“Group” in this case) and type in a 
descriptive name for this Vertex Group

5. Click Assign

From now on, this group of vertices can be selected just by selecting 
the name from the list of Vertex Groups and clicking Select.
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Extrude Individual Faces (cracks in between skyscrapers)
Extrude Faces Along 

Normals (push each face 
perpendicular to the surface)

Face Select Mode

Extruding Faces – three ways

Extrude Faces (push each face 
along the group average 

perpendicular to the surface)

First, tab into Edit Mode.  Then select one or more faces.  Then right-click and select:
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Shrink/Fatten and Push/Pull are very much like extruding 
faces.  Here are the differences:

Extruding lifts the selected faces along their normals.  It 
leaves behind a “cliff” that connects them to the surrounding 
faces.

Shrink/Fatten lifts the selected faces along their normals, but 
leaves behind a “ramp” connecting those faces to the 
surrounding ones.

Push/Pull essentially scales the selected faces around their 
centroid.

For example, suppose we start
with this object and these
selected faces

Shrink/Fatten and Push/Pull

Find this edit icon in the column on 
the left side of the screen.  Click it 
with the LMB and leave the button 
down for a couple of seconds.

It will then expand into both of these 
commands, and you can pick the 
one you want:

Every one of the edit-icons that has a little 
arrow in the lower-right corner expands in this 
same way.  Check ‘em out!
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Extrude, Shrink/Fatten, and Push/Pull

Extrude Shrink/Fatten Push/Pull

Out

In
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Tells you that we are in the Button Properties Menu

Output Properties

The Button Properties Menus, Again

Render Properties

View Layer Properties

Scene Properties

World Properties

Object Properties

Modifier Properties

Particle Properties

Physics Properties

Object Constraint Properties

Object Data Properties

Material Properties (colors)

Clicking one of these brings up a 
much more detailed menu of options
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The Modifiers Menu

Modifiers don’t actually change an object’s permanent
geometry – just the object’s appearance on the screen.  
The geometry only gets permanently changed if you click 
the Apply button
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Blender Modifiers

Modifiers don’t actually change the object’s permanent geometry –
just the object’s appearance on the screen.

You Create 
an Original 

Object

You See a 
Modified Object 
on the Screen

You Apply a 
Blender 
Modifier

Cube with 
Bevel Modifier 
in Edit Mode



mjb – July 15, 2025

143

Computer Graphics

The Modifiers Menu
Modifiers don’t actually change the object’s permanent geometry –
just the object’s appearance on the screen.

Example: Here a cube has been beveled (one of the Modifiers).  In Edit Mode 
you can see both the beveled cube and the original cube.  You can edit the 
vertices and the new shape will get beveled as you edit.

You can eventually Apply the Modifier so its geometry becomes 
permanent, but I recommend you hold off on this as long as possible.
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The Edit Modifiers
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The Generate Modifiers
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The Deform Modifiers
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The Normals Modifiers
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The Physics Modifiers
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The Hair Modifiers
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My Favorite Modifier -- Subdivision Surface

This controls how much to subdivide.  
Here we’ve changed this value from 1 to 2

Fun: try it on a cube!

This modifier increases the number of polygons in your object.  At the same time, it 
smooths your object out.  Be careful!  It very quickly increases your polygon count.

Levels = 1

Levels = 2
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Deleting and Moving Modifiers

Delete this Modifier

Oftentimes you have a list of several Modifiers that are used with a single object.  The 
Modifiers take effect in the order that they are in the list.  To change this, you can:
• Delete a Modifier
• Move a Modifier elsewhere in the list and thus change how it modifies the object

Move this Modifier elsewhere 
in the list of Modifiers
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Making Your Modifier Effect Permanent

Click here

To bring up this menu.  
Then click on Apply.

Despite the name, Modifiers do not actually modify the object’s underlying coordinates.  
They create an “alternate representation” that you can see.  Most of the time, this is good.  
It lets you edit the underlying coordinates and have the Modifier then use them.  If you want 
the Modifier to change the object’s underlying coordinates permanently, bring up this sub-
menu and click on Apply.
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Bevel Modifier

How much to bevel

Smooth shading makes bevels look much better!

No beveling Segments = 1 Segments = 2 Segments = 3

Beveling causes edges to be 
rounded instead of sharp
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Remember Venn Diagrams (Boolean Operators)?

Two Overlapping Shapes Union

Difference
Intersection
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Two Overlapping Solids Union

Intersection Difference

Booleans (also known as Constructive Solid Geometry)

Think of them as Venn diagrams in 3D!
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Boolean Modifier

1. Select the cube
2. Click on Modifiers
3. Click on Add Modifier→Generate →Boolean
4. Specify the Difference Operator
5. Specify the Cylinder as what to the difference with

“Block minus Cylinder”

6. Click Apply



mjb – July 15, 2025

157

Computer Graphics

Select the cylinder, hit it g (grab) and slide the cylinder away

Boolean Modifier
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The Resolution of the Second Object Determines the 
Resolution of the Resulting Surface

First object Second objectResulting surface
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Remember 3D Text?  One Fun Thing to do with 
Booleans is to Attach Text to a Block

Start with a block and the text:

You cannot directly Boolean with text, so you 
must first convert the text to a mesh: 
RMB  Convert To  Mesh

Warning: if you want to use 
text with Booleans, do not 
Bevel the text.  That is, 
leave the BevelDepth
setting equal to 0.
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Now Boolean the Text with the Block

Union

Difference
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The Simple Deform Modifier

With an object selected, go to Modifiers → Add Modifier → Deform → Simple Deform

You will then see this:

You get to pick one of four deformation types: Twist, Bend, Taper and Stretch.  You also 
get to pick the axis about which that deformation will take place: X, Y, or Z.

After you’ve picked those, you get to change this value to control how much deformation 
you get.
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The Simple Deform Modifier

Twist about Z Bend about X

Stretch along ZTaper along Z
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The Simple Deform Modifier
You can also compound multiple deformations just by repeating the modifier:

Bend, then Twist

Twist, then Bend

The order counts! Click here and drag to change the order of the two modifiers.
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But, that mirrored object will reflect about the object origin, this 
little dot right here.  Which means that you will end up with 
something like this, which is probably not what you wanted.

The Mirror Modifier

Let’s say that you want to create a mirror image of the monkey, but by using a Modifier, 
the mirror monkey will be linked to the original monkey so that any edits you do to the 
original will automatically end up in the mirror object.
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The Mirror Modifier

So, the first thing we need to do is to move the object away from the little dot.
You do this by Tabbing into Edit Mode and grabbing all the vertices and sliding them (gy).
In Edit Mode, the dot doesn’t move when you do this:

Now, Tab back to Object Mode, add the Mirror 
Modifier, and select Y.
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The Mirror Modifier

So, now if you sculpt the original object, the mirrored object will get the same edits.

This is often good for creating a full object by only 
creating one half of it (e.g., a car) and mirroring it.
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Array Modifier

The Array Modifier is used to duplicate an object according to a particular 
pattern.  Suppose we want to turn a block into a staircase. We start with 
the block and add an Array modifier.

The duplication count

How much to offset each duplication.
It can be Constant, that is, based on a 
number of units. Or it can be Relative, that is, 
based on a number of size-of-this-object

Apply button (if we want 
to make this permanent)
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Array Modifier to Make Stairs

→

How many total steps to make

Move each block in Y and Z 
to make the next stair step

Z

Y

X
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Screw Modifier

Before

After
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Wireframe Modifier

How thick to make the thick lines

Turns each polygon into thick lines outlining each polygon

But, these lines have thickness, keeping this as a Mesh.
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Subdivision Surface, then Wireframe

Wireframe, then Subdivision Surface

Modifier Order Matters !
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The Shrinkwrap Modifier

Turn on both X-ray Mode 
and Wireframe Mode

Add a UV Sphere and a 
Cone.  Either scale the 
sphere up or scale the 
cone down so the cone is 
inside the sphere.
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The Shrinkwrap Modifier

Click on the sphere and 
select the
Shrinkwrap Modifier

Select the cone 
as the Target

Adjust the Offset value.  Positive values make most sense, 
but negative values are fun too!
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The Shrinkwrap Modifier

Offset = 2

Offset = 1

Offset = 0

Offset = -1

Offset = -2
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The Build Modifier

I suspect this is more applicable to engineering-
ish objects, but it fun no matter what.  Let’s use 
our old friend Suzanne the monkey.

Go to Modifers → Select Modifer → Build
You get the following Modifer box.  All the values 
are good defaults: 

At this point, Suzanne has disappeared.  What!?  To bring her back, grab the blue 
animation time slider at the bottom of the screen and slowly move it to the right:
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The Build Modifier
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The Displace Modifier

This Modifier pushes vertices out perpendicular 
to the surface.  I would describe it as “puffing out 
the object”.

Go to Modifers → Select Modifer → Displace
You get the following Modifer box.  If your object 
suddenly looks weird, don’t worry!  Set this value to 0:

Now, slowly increase to Strength to be greater than 0.  What happens?  Is it 
possible to set it to a value less than 0?  What happens?
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The Displace Modifier

Strength = 0.0

Strength = 0.3

Strength = -0.3
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Add a UV Sphere

Vertex Groups
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In Object Mode, turn on Orthographic

Select a group of sphere vertices to turn into a Vertex Group.

In Object Mode, turn on X-ray

Vertex Groups
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In Edit Mode, sweep over a group of sphere vertices

Click on the Object Data Properties icon

In Vertex Groups, click on the +
This creates a new Vertex Group

Vertex Groups
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Now click on Assign to assign 
the vertices you picked to vertex 
group Group.

Double-click on Group and give that Vertex 
Group a more descriptive name

I named mine “Right” because these vertices 
are on the right side of the sphere.

Vertex Groups
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In Object Mode, turn on Perspective

In Object Mode, turn off X-ray

Vertex Groups
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Click the Lattice button and (perhaps) add more lattice detail.

Add a Lattice to the 
scene.

The Lattice Modifier
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Select Add → Lattice

The Lattice Modifier

This adds a wireframe lattice to your scene.
(You might have to move your object out of the way to see it.)
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Then click on the Lattice icon 

The Lattice Modifier

Scale and translate the lattice to surround your object, 
especially the vertices you put in the Vertex Group.  
Change the lattice’s resolution as you see fit.

You can change these numbers to affect 
the number of sub-cubes in the Lattice
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Select the Sphere and add a Lattice Modifier to it.
Tell it the name of the Lattice that you’ll be editing.
Tell it the name of the Vertex Group that the edits will affect.

The Lattice Modifier
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Select the Lattice, toggle to Edit Mode, select some of the vertices, and  
move, rotate, and scale them them:

The Lattice Modifier
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Shape Keys:  A Modeling Aid

1. Select the object

Shape keys are a way to do a variable 
morphing between two versions of the 
same object.  The two (or more) instances 
must have the same number of vertices, 
but the vertices can (and should) be in 
different locations.  Shape keys lets you 
interpolate vertex coordinates between 
those instances.

2. Click on Object Data

3. Under Shape Keys, click the plus sign +.  
This establishes the Basis shape.
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Shape Keys:  A Modeling Aid

4. Under Shape Keys, click the plus sign + again.  Give the 
new Shape key a more descriptive name

5. Now edit the original object by moving
vertices, edges, or faces.  Do this in Edit Mode.

6. When you’re done editing, go back to Object Mode and change the Value slider.  A 
Value of 0. gives you the Basis object.  A Value of 1. gives you the edited object.  
Experiment with values in-between.
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Shape Keys:  A Modeling Aid

Normally, the Value slider should go between 0. and 1., but it doesn’t have to.  By 
changing Value’s Min and Max value beyond that range, you can do object 
extrapolation as well as interpolation.
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Deforming Along a Curve
In Object Mode, select Add → Curve → Path

Tab to Edit Mode then RMB → Subdivide 
so it looks like this:

Still in Edit Mode, grab some of the red 
control points and move them in Y or Z:

Now Tab back to Object Mode
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Deforming Along a Curve

In Object Mode, the curve looks smooth: Now create a 3D mesh object and place it 
at the left end of the Path:

To the non-Path object (monkey in this case), 
add a Modifier → Deform → Curve
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Deforming Along a Curve

Select the Path object here

Move the Monkey along the Y axis.  This 
deforms the object along the curve. 

Select a Deform Axis direction
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Texture Pattern Displacements

Click on the Texture 
Property button Select which texture you want for 

the displacement pattern.
I like Voronoi because of the cells

Remember the texture “name” 
(Texture.002) – you will need it later.
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Texture Pattern Displacements
Create an object, add a couple of levels of Subdivision 
Surface Modifier, then add a Displace Modifier.
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Texture Pattern Displacements
When you select the Displace Modifier, a texture icon will 
appear here.  Click it.  Then select New.
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Texture Pattern Displacements

Select Image or Movie.  

You can select anything in this list that 
you want.  I am partial to Voronoi!
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Texture Pattern Displacements
At this point, your object might have gone wild.  If you like it this way, then 
leave it alone.  If you want to change it, adjust these numbers:

I wanted this to look 
more like a rock than an 
exploding star:
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Metaball Objects
Metaball Objects are another way to 3D model:
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Metaball Objects
The cool thing is that, if you move (g) them close enough, 

they will “glom” into a single object
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Metaball Objects

There is a special Metaball properties menu 
to control their characteristics:

A smaller number here gives 
a better surface quality.

How close 2 meatball objects 
need to be to “glom”
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Metaball Objects

But, Metaball objects are not meshes, so you cannot do a lot of the 
cool editing that you can with meshes.  But, you can turn a Metaball
object into a mesh by selecting RMB → Convert To → Mesh

After tabbing into Edit Mode
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Parent-Child Relationships in Modeling

Many times, one object is connected to another object.  
In modeling, this is called a Parent-Child relationship.  
(It is also sometimes called a Hierarchical Relationship.)

When the Parent moves, the Child moves with them.

When the Child moves, the Parent is unaffected.

This is really useful !

1. Move the Child’s pivot-point to where you want it connected to the Parent.  A convenient 
way to do this is to Tab into Edit Mode and translate (‘g’) the object, moving it until the 
pivot-point is where you want it to be.  Then Tab back to Object mode and translate the 
object and pivot-point back where they belong.

2. Select the Child piece
3. Shift-select the Parent piece
4. Hit Control-’p’ on the keyboard

Parent

Child You can create as many levels of Parent-
Child relationships as you want:  As the 
song goes:

“The foot bone’s connected to the ankle bone, 
the ankle bone’s connected to the leg bone, the 
leg bone’s connected to the thigh bone, …”
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Parent-Child Relationships in Modeling

If you rotate the blue (child) piece (‘ryy’), then just it will move

If you rotate the yellow (parent) piece (‘rz’), then both it and the child piece will move
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Importing Objects from Other Places

Collada = export format from game 
modeling systems

Stl = 3D printer format

3ds = format from Autodesk 3D Studio

Obj = Probably world’s most common 
export format There are a ton of .obj 
models for free on the Internet!  
Google the phrase:

free obj files

Select  File → Import

.obj files are also pretty straightforward to create.  
So, if you have a shape in mind and can write a 
computer program to generate it, you can write 
your own .obj file and Import it into Blender.
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Go up one folder

Refresh the file list

Create a new folder

Recent folders accessed Disc volumes

System locations

The Blender File Navigator
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File = dino.obj

You can get this file from the web page:
http://cs.oregonstate.edu/~mjb/blender

As-is, flat shaded

Subdivision surfaced
+

Smooth shaded

Importing Objects from Other Places
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Abusively edited using a Lattice

Importing Objects from Other Places
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Here are some places to find OBJ files to use yourself:

• https://www.blenderkit.com/asset-gallery?query=category_subtree:model%20order:-created
• https://polyhaven.com/
• http://thefree3dmodels.com 
• https://free3d.com/3d-models/star-wars 
• http://lodbook.com/models 
• http://people.sc.fsu.edu/~jburkardt/data/data.html 
• https://sketchfab.com/features/free-3d-models
• http://www.turbosquid.com/Search/3D-Models/free/obj 

Or Google the phrase:   "free obj files"

Importing Objects from Other Places

Links checked: July 12, 2024

The blenderkit link also provides a Blender plugin.  If you 
install it into Blender, then you can search for OBJ files 
without ever leaving Blender.
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Exporting Objects to Other Places

Blender has a number of file formats it knows how 
to export to.  If you are looking for a nice, general 
one to experiment with, try the .obj format.

Just be sure to use the RMB menu to select 
Shade Smooth first

Select  File → Export → Wavefront (.obj)
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Exporting to an OBJ File
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Exporting to an OBJ File

This is the Blender file-output selection dialog box:

OBJ-specific settings 
(see next slide)
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In the export dialog, be sure to click on
• UV Coordinates
• Normals
• Triangulated Mesh

OBJ-Specific File Settings
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7. Rendering
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We have been using this one.
This one gave you good 
generic lighting so you could 
model without worrying about 
light sources.

Now switch to this one.
This one will give you a pretty-
good preview of what happens 
when you actually render the 
scene.  But, we now have to deal 
with Rendering specifics.

On-screen Rendering Mode
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Rendering

“Rendering” is Blender’s process for creating really high-quality images.  Click on Render → 
Render Image or hit the F12 key (you might have to hit the fn key at the same time).  The 
rendering operation can often take some time, depending on how complex your scene is.

scene.blend
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Rendering Properties

Clicking on the Rendering Properties button will allow you to set various 
rendering parameters.

You want at least some Anti-Aliasing, which 
is done by making more than one sample per 
pixel. 16 and 64 are good values.

The rest of these are interesting, 
but are not needed right now.

For now, be sure the Render 
Engine is set to EEVEE.



mjb – July 15, 2025

219

Computer Graphics

Output Properties
Clicking on the Output Properties button will allow 
you to set various rendering parameters.  The one 
you care about the most is pixel resolution.

These are OK values, but you can improve your 
rendering speed by making them smaller.  Don’t 
make them smaller by changing the 1920x1080, 
make them smaller by changing the 100%.

The rest of these are interesting, 
but not needed right now.

Notice that the image aspect ratio being 
used here is 16:9 (=1920:1080).  This is the 
most common aspect ratio today for TVs 
and computer monitors.
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What is Anti-aliasing?

4x 16x

Not Anti-aliased Anti-aliased

Anti-aliasing is a good-news bad-news joke.
Good news: the scene looks much smoother
Bad news: the scene takes longer to generate
Good news: you probably want to do it anyway
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Anti-aliasing is Implemented by Oversampling
within Each Pixel

4x 16x

NVIDIA
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Lighting

Let’s say that you are in Viewport Shading Mode 
and your scene situation looks like this

You now change to Render Mode and get this:

Blech!  Why is the bottom 
part of my scene so dark?
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Lighting

The answer is that Solid Shading Mode doesn’t require your scene to be lit but 
Render Mode does. 
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Lighting

By default, your scene has a single light in it.
It looks like this.

If you can’t find it, try zooming out.

If you still can’t find it, select it in the Outliner.

This is like any other object.
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Lighting

A light is like any other object.  It can be LMB clicked on (or 
selected in the Outliner).  It can be grabbed (g) and moved 
around.  Moving it around will change how the lighting looks.
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Lighting

But, to make this work better, you 
probably want to add more lights.
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Lighting

There are four types of Lights that you can Add

1. A Point Lamp shines light in all directions.  The light is local to the scene.  This is usually 
the best type of light to start out with.

2. A Sun Lamp appears to come from a single direction and its rays are parallel.  This acts 
as if the light is very far away.

3. A Spot Lamp is like a Point Lamp, but only shines in one particular direction.

4. An Area Lamp is light coming from a finite surface, like most lights really are.
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Lighting – try this

1. Add another Point Light

2. Position the Light (‘g’).

3. The Point Light has no obvious local 
coordinate system, so it just uses the 
global coordinate system.

4. As you move the Light, you will see 
the lighting of the scene change

5. You will probably have to rotate the 
scene (MMB) to get the light position 
where you think it should be.  Or, you 
can also toggle the Quad View 
mode (Control-Alt-q).



mjb – July 15, 2025

229

Computer Graphics

Lighting – Quad View
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Lighting – Quad View
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Be sure this is clicked on in 
order to get this light to cast 
shadows

This preview shows how the 
Light spreads out

Lighting – Properties

How bright to make the 
Light shine.

What color to make the Light
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LR

LG

LB

ER

EG

EB

What the 
eye sees

ER =  LR * MR

EG =  LG * MG

EB =  LB * MB

White Light

Green Light

MR

MG

MB

What the material 
can reflect

Lighting – What does it Mean to Have a Colored Light?
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Lighting – Principles

In modeling, rendering, and animation, there are two major roles that lights play:

1. Key
2. Fill

Let’s say we want to put a spotlight on the 
Monkey (and who doesn’t?).  We add a Spot 
Light. We position it over the Monkey and angle 
it down, like this. This is our “Key Light”.  It does 
what we most want to do. 

We render and get this.

The Key Light is working really well, but the rest 
of the scene is too dark.  We now need to use 
one or more Fill Lights.
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We Add a Point Light and position it over the scene.  Because we are in Render 
Mode, we can interactively see when we have it positioned well.  

The scene looks much better.  But, there are still two problems.

1. The rest of the scene is now bright enough that our “star” is no longer highlighted.
2. The Fill Light is casting another shadow which is distracting.

Lighting – Principles
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We lower its brightness.

So, we make two adjustments to our Fill Light:

We un-click here to force it to not cast 
shadows.

Lighting – Principles
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10 W

100 W

250 W

500 W

Lighting – Blender Wattages

These are not absolute specifications 
however.  Your perception of brightness will 
depend on how far the light is from the object 
and what color the light and object are.
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Rendering

The view that is rendered is not the same orientation that you see on the 
screen.  It is from the Camera position, which needs to be set separately.

If you the Camera icon, LMB click on it.  
If you don’t see it, zoom out some.  If 
you still don’t see it, click on the Camera 
in the Outliner.
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The Camera

The eye’s 
position

Where the eye is looking towards

The “up vector”
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The Camera

The camera is just like any other object in the scene.
1. It can be selected with a LMB click
2. It has its own local coordinate system attached to it.

Note the local coordinate system for the camera:

• X is to the right of where the eye is looking
• Y is the up-vector
• Z is opposite of where the eye is looking

This is useful to know.  For 
example, to dolly the camera in or 
out, select it and then move it in 
its local coordinates:

g → z → z
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Aligning The Camera to Your Current Screen View

But, if you like your current screen view and want to move the camera there, just do this:

View → Align View → Align Active Camera to View
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Setting a Background Color
Click on the World Properties button Click on Color and dial in 

the background color
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Setting a Background Texture
Click on the yellow dot next to Color

That brings up a whole 
bunch of options

As always, I am 
partial to Voronoi 
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Superimposed Wireframes
I don’t know why I find this so pleasing to look at.  I just do.

Before

After
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Triggering a Rendering

What you see on your screen

What you see on the separate render window
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What You See in the Separate Render Window
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Saving a Rendered Image to a File

Save As doesn’t appear until the 
full rendering has completed.
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Saving a Rendered Image to a File

Image file typeAmount of compression
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Saving a Rendered Image to a File
Different image file types
(PNG is good if you don’t have any preference)
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Saving a Rendered Image to a File

If this is called Compression, then smaller numbers will give 
you a larger image file with greater image quality.

If this is called Quality, then larger numbers will give you a 
larger image file with greater image quality.
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JPEG: 10% Quality setting

11 KBytes
JPEG: 100% Quality setting

72 KBytes

Saving a Rendered Image to a File
There is an important trade-off between image file size and the image Quality you set.
There is also a trade-off between image size and web page download time.
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Importing an Image into PowerPoint
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Importing an Image into HTML (i.e., a web page)

Add this line to your HTML file:

<img src=“ball.png”>
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There is an additional internal renderer called Freestyle.  Suppose you start with 
this scene:

Another Type of Rendering
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You render it, and the 
image looks like this:

Now, go to the Render Properties
menu and turn on Freestyle

Another Type of Rendering
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You render it again, and now you get this:

Freestyle Rendering

The computer graphics world calls this Non-Photorealistic Rendering, or NPR.  
It is good for illustrations where you want to see objects and outlines more than 
you want to see realism.
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Freestyle Rendering

If you look under the View Layer Properties 
button, you will find a lot of Freestyle 
adjustments that you can make.
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8. Particle Systems
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Particle System Examples
Paramount

Sony/Marvel

Disney/Pixar

Pixar
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Particle System Examples

(Particles don’t have to actually be particles.)

Disney

Disney

20th Century Fox
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Particles Bouncing Off Other Objects

particles.blend
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Particles– The Setup
1. Select the 
object to emit the 
particles from, then 
click this property 
button

2. Click the + sign to start a new particle system

3. Set the number of 
particles

Optional: Set the particles’ 
initial velocities – see the 
next slide

Optional: Set the 
rendering properties -- see 
two slides from here
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Particles – Expand the Velocity Dialog Box

The velocity perpendicular 
to the surface

The velocity parallel to the 
surface
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Particles – Expand the Render and Viewport Display 
Dialog Boxes

What material definition 
to color the particles with

What particles to draw (this 
is fun to change!)

Start with a small size, like 
this, but then experiment

If you like physics, change 
this to velocity
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Click here to at the bottom 
of the screen start the 
particle animation

Hit the ESC key when you 
want it to stop
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1. Draw a plane to bounce particles from
2. Click the Physics Property Button
3. Click on the Collision option
4. Turn on the animation

Particles Bouncing Off Other Objects
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Particles Bouncing Off Other Objects

Bouncing particles

Physics properties of the surface 
being bounced off of
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Something fun – Tip the Plane
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Something Fun – Put Something Else in the Way

Need to make it a 
Collision surface too.
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More Fun – Make the Particles Another Object
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To Blow particles, We need a Force Field –
Attach it to an Empty Object

Ironically, one of the most useful objects is 
the one you can’t see.  Blender calls this an 
Empty.

It’s invisible on the screen, but you can 
treat it like a real object, and can attach 
forces to it.  These forces will influence the 
behavior of other objects.

Find the Empty under the Add tab at the 
top of the screen.  When you click on it, this 
sub-menu pops up.



mjb – July 15, 2025

271

Computer Graphics

Surprise!  Even though it is invisible, an 
Empty has a shape!

For this exercise, pick the Single Arrow

On the screen, it will look like this:.

We need a Force Field – Attach it to an Empty Object
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Blowing the Particles -- Force Fields

A really good use for Force 
Fields is to blow particles and 
cloth around

With the Empty Object selected, click on the 
Physics icon and then click on Force Field
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Position and Orient the Empty

Using the usual object-rotate commands, orient the Empty so that it is pointing 
at the particles.

Hint: it is easiest to position it in Global Coordinates (g → x) and easiest to 
rotate it in Local Coordinates  (r → x → x) .

And, under Force Field Type, 
select  Wind

You will use this to change the 
Strength of the wind

It will look like this on the screen:
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Blowing the Particles
Turn on the animation (Control-’a’).  You can adjust the orientation and the Strength
of the Wind while the animation is playing to get just the effect you want.

blowing.blend
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Particle Systems for Hair
1. Select the 
object to emit the 
hair from, then 
click this property 
button

2. Click the + sign to start a new particle system

4. Set the number of 
strands

7. Apply physics to the 
hairs – click this on

8. Set the rendering 
properties

3. Select Hair

5. Set the hair length

6. Set the number of 
segments per strand 
(bigger looks better but 
renders slower – try 
10-20)
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It Will Start Out Looking Terrible

Try setting the Hair Length to something small-ish like 0.5 or 1.0
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Making the Hair Droop

Turn on and expand 
Hair Dynamics

Start animating to start 
the hair-droop simulation
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Animating the Object and the Hair

At this point, I like to keyframe-
animate the object with the hair 
or just translate the head (‘gy’).  

Here Suzanne is translating and 
rotating, as the hair movement 
is showing.

Start animating
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Making the Droop Permanent

Get the droop the 
way you want it

Select Modifiers – a 
ParticleSystem modifier will 
already magically be there

Click on Convert to Mesh.  
This will turn the hair into a 
mesh object.



mjb – July 15, 2025

280

Computer Graphics

Making the Droop Permanent

Before clicking Convert After clicking Convert

But this new mesh is 
independent of the object that 

particle’d it.  To make them one 
object again, select both and 
hit RMBJoin (or Control-j)
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Making the Droop Permanent
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Boids Particle Systems

Boids are a special particle system technique 
to simulate living things that naturally want to 
group together such as flocks of birds, 
schools of fish, etc.

As before, create an object and attach 
a particle system to it.  Select Emitter
for the type.  Under the Physics tab, 
change Newtonian to Boids. 
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Boids Particle Systems

Select the Boid Brain tab.

Click the plus sign (+),
Select Follow Leader from the menu,
and use the arrow symbols to move it to 
the top of the list
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Boids Particle Systems

Create a new object and animate it 
(keyframe or physics).  This will become the 
“leader” that the boids will follow.  If you 
want to see it, leave it visible.  Otherwise, 
turn its eyeballs off in the Outliner.

Now select the object that the boids were 
created from.  In the boids menu area, 
click in the Object area and select the 
name of the object you animated.

Now, turn on animation and watch the 
boids follow that object.
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Boids Particle Systems

The boids now follow the leader
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Boids Particle Systems

If you just want to see the boids and not the 
emitter object, go to the particle emitter 
object’s Viewport Display tab and click the 
Show Emitter checkbox off.
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9. Physics Animation
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Quick Physics Cheats

Original Scene
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Quick Physics Cheats
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There are Eight Types of Physics Simulations
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Rigid Body Collision Example

Set this up using what you know about 
modeling.

Slightly rotate the left-most domino to the right 
so that it will tip and start the sequence.

dominos.blend

dominos.mp4
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Let Blender Know You Want to do Rigid Body Physics

Click on the Scene 
Properties Button

Set Gravity
(this value indicates gravity 
points downward and has a 
value of -9.8 meters/second2)

Be sure this is turned on
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For each object that will be pulled by gravity (the dominos and 
the ball), select the object, click on the Physics Property 
Button, click on on Rigid Body,  and set the Type to Active

Tell the Physics which Objects will be Involved
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For each object that will not be pulled by gravity but 
will still be involved in the collisions (the floor), 
select it and set the Type to Passive

Tell the Physics which Objects will be Involved
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Turn the Animation On

Hit the Escape key to stop the animation

dominos.mp4

dominos.blend
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Blender wants your simulation to run as fast as possible.  For this reason, it defaults 
to wanting to use a simplified version of your geometry called a Convex Hull.

You probably don’t want this.  In that case, change Convex Hull to Mesh.

Consider links on a chain.  The yellow one is Passive and the blue one is Active.

You Probably Need to Change “Convex Hull” to “Mesh”
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With both chain links using Convex Hull, they fly apart:

You Probably Need to Change “Convex Hull” to “Mesh”

With both chain links using Mesh, they correctly behave like a chain:
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Setting Gravity

This is the default, but you can set Gravity to anything you want, including turning it off 
completely, or making it point upwards, or making it point sideways.

In order to do physics animations, Blender needs to have an idea of what Gravity 
is.  The acceleration due to gravity near the surface of the earth is 9.81 
meters/sec2 (pointing down), which also equals 32.2 feet/sec2.

You can set this by clicking on the Scene Properties Button and then scrolling 
down to the Gravity dialog area.
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Gravity on Other Worlds

The acceleration due to gravity is not the same on all worlds.  It depends on the 
mass of the body and its radius.

For fun, try setting the gravity to the Gravity Acceleration that other bodies have in 
our solar system:

Body
Gravity Acceleration 

(m/sec2) g’s
Mercury 3.70 0.38
Venus 8.87 0.90
Earth 9.81 1.00
Moon 1.62 0.17
Mars 3.71 0.38
Jupiter 24.79 2.53
Saturn 10.44 1.06
Uranus 8.69 0.89
Neptune 11.15 1.14

https://www.universetoday.com/35565/gravity-on-other-planets/
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Gravity on Other Bodies

Or, invent your own planet!  Pick a different “m/sec2”.

21st Century Fox
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Pixar

Another Cool Thing: Modeling Cloth

Pixar: Geri's Game
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Modeling Cloth – Start with a Cube and a Grid

cloth.mp4

cloth.blend

There is a difference in what different Mesh types 
will do.  This needs to be a Grid – not a Plane!

Scale the Grid by 3 (s3) and move it in z (gz)
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Modeling Cloth -- Enable Collision with the Cube 

You don’t need to set any other parameters (unless you want to)

1. Select the cube.
2. Then go to the Physics Property Button.
3. Then click on Collision
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If you select the grid and tab over to Edit 
Mode, you will see that it is already 
subdivided somewhat.  To act as a cloth, 
we’d like it subdivided some more.

Modeling Cloth – Subdivide the Grid into More Pieces

4. Back in Object Mode, select the grid, then 
select Modifiers.

5. Then click Add Modifier and select 
Subdivision Surface.

6. Change the Viewport parameter from 1 to 2

7. Click the Apply button.
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Modeling Cloth – Tell the Grid that it is Really a Piece of Cloth

You can get away without changing any of 
these parameters, but, at some point, you will 
want to experiment with different values of 
Stiffness and Damping.

8. Select the grid.
Then go to the Physics Property Button.
Then click on Cloth.
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Modeling Cloth – Run the Animation

9. Select the grid, RMB, then select Shade Smooth.

10. Start the animation.
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Baking the Cloth Animation

Why does the animation run so slowly?  
That is because it is computing the 
simulation while it is animating.

Instead, tell it to precompute the 
animation.  You do this by selecting the 
Bake button (and waiting and waiting).

Now try animating.
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Cloth Animation with Color, Texture, and Lighting

cloth.mp4
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What if You Want the Cloth to Retain its 
Animated Shape Forever ?

That is, supposing you have used a cloth animation to drape a 
tablecloth over a table and now want to leave it that way.

You start with this:

Animate to 
get this:

Then, with the cloth selected, go to the 
Modifier menu.  You will see the Cloth modifier 
already magically there.  Select the down arrow 
and click on Apply.
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Cloth Animation: Pinning Vertices
One of the many fun parts of cloth animation is pinning 
some of the vertices.  There are lots of reasons to do this, 
such as to pin the edge of a flag to its flagpole, or to pin a 
cloth to a clothesline.

To do this, Tab into Edit Mode, Shift-LMB the vertices to 
be pinned, and create a Vertex Group from them.  (This 
was described in more detail in the Modeling section of 
these notes).
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Cloth Animation: Pinning Vertices

In the Cloth section of the grid’s Physics
menu, select the name of the Vertex Group to 
be pinned.

When you re-animate, those vertices will be 
stationary.
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Rendering an Animation

Hint: if this is just a test render, and you have 
lots of time-consuming visual effects going on, 
you might cut down the resolution and/or the 
number of rendered frames to speed things up.

Render Animation kicks off the 
rendering of all your animation 
frames in order

View Animation brings up a separate window 
and plays back your animation.
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We previously had this note-slide in which we looked at 
creating a vertex group that would become pinned in place.  
This slide shows what we did before for pinning the cloth 
horizontally.  Starting after the Vertex Groups, we will pin a 
column of vertices to create a flag waving.

To do this, Tab into Edit Mode, Shift-LMB the vertices to be 
pinned, and create a Vertex Group from them.  Vertex Groups 
were described earlier in these notes, but I am repeating them 
right after here so you don't have to go find them.

Cloth Flag Animation: Pinning Vertices
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Add a UV Sphere

Vertex Groups
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In Object Mode, turn on Orthographic

Select a group of sphere vertices to turn into a Vertex Group.

In Object Mode, turn on X-ray

Vertex Groups
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In Edit Mode, sweep over a group of sphere vertices

Click on the Object Data Properties icon

In Vertex Groups, click on the +
This creates a new Vertex Group

Vertex Groups
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Now click on Assign to assign 
the vertices you picked to vertex 
group Group.

Double-click on Group and give that Vertex 
Group a more descriptive name

I named mine “Right” because these vertices 
are on the right side of the sphere.

Vertex Groups
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In Object Mode, turn on Perspective

In Object Mode, turn off X-ray

Vertex Groups



mjb – July 15, 2025

319

Computer Graphics

Cloth Flag Animation: Pinning Vertices

Create a grid, scale it up, rotate in to be vertical, and subdivide it in Edit mode.
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Cloth Flag Animation: Pinning Vertices

Still in Edit mode, switch to Orthographic mode and rotate so the cloth is 
perpendicularly facing you.  Unselect everything (click in empty space) then 
box-select one column of vertices.
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Cloth Flag Animation: Pinning Vertices

Click on this icon.

Find the Vertex Groups area.  Click on the plus sign (+) then 
click on Assign.  You can leave these vertices labeled as 
Group, or give them something more descriptive, like Column.  
Tab back to Object Mode.  Go back to Perspective Projection.
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Cloth Flag Animation: Pinning Vertices

With the cloth selected, go to the Physics icon and select Cloth.
Scroll down to the Shape tab and set the Pin Group to whatever 
name you gave your column of points (Group, here).
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Cloth Flag Animation

Color and texture the cloth any way 
you’d like, and turn on the Animation.
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To Blow Cloth, We need a Force Field –
Attach it to an Empty Object

Ironically, one of the most useful objects is 
the one you can’t see.  Blender calls this an 
Empty.

It’s invisible on the screen, but you can 
treat it like a real object, and can attach 
forces to it.  These forces will influence the 
behavior of other objects.

Find the Empty under the Add tab at the 
top of the screen.  When you click on it, this 
sub-menu pops up.
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Surprise!  Even though it is invisible, an 
Empty has a shape!

For this exercise, pick the Single Arrow

On the screen, it will look like this:.

We need a Force Field – Attach it to an Empty Object
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Blowing the Cloth -- Force Fields

A really good use for Force 
Fields is to blow particles and 
cloth around

With the Empty Object selected, click on the 
Physics icon and then click on Force Field
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Position and Orient the Empty

Using the usual object-rotate commands, orient the Empty so that it is pointing 
at the particles.

Hint: it is easiest to position it in Global Coordinates (g → x) and easiest to 
rotate it in Local Coordinates  (r → x → x) .

And, under Force Field Type, 
select  Wind

You will use this to change the 
Strength of the wind

It will look like this on the screen:
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Cloth Flag Animation: Adjusting the Amount of Fluttering

In the Empty object, increase the 
Strength and the Wind Factor.

In the Cloth object, scroll down to the Field Weights 
and increase the Wind.
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Cloth Fluttering Flag Animation

fluttering.blend

fluttering.mkv
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Cloth Fluttering Flag Animation  
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Dropping an Object on the Cloth

Setup this scenario:

1. Have an object hovering up in the air (‘gz’)
2. Add a Grid object and scale it up
3. In Edit Mode, Subdivide the Grid a few times
4. In Edit Mode, select the 4 corner vertices of the grid and place them into a 

Vertex Group called Corners (see how to do this a few slides back)
5. Back in Object Mode, select the grid and hit RMBShade Smooth
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Dropping an Object on the Cloth

Select the object hovering up in the air:
Go to the Physics menu and select Soft Body
In the Soft Body sub-menu:
1. Uncheck Goal
2. In the Edges sub-menu:
• Set the Pull and Push each to 0.999
• Set Bending to 1.00
3. In the Self Collision sub-menu
• Check Self Collision
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Dropping an Object on the Cloth

With the hovering object still selected:
Go to the Physics menu and select Collision
In the Collision menu:
1. In the Softbody & Cloth sub-menu
• Set the Damping to 0.75
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Dropping an Object on the Cloth

Select the cloth grid, then:
Go to the Physics menu and select Cloth
In the Cloth menu:
1. Open the Shape sub-menu  and 

select the Corners Pin Group
2. Open the Collisions sub-menu and 

check Self Collisions
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Dropping an Object on the Cloth

With the cloth still selected:
Go to the Physics menu and select Collision
Then, in the Collision sub-menu:
1. In the Softbody & Cloth sub-menu
• Set the Damping to 0.75
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Dropping an Object on the Cloth

Click on the Play button in the animate controls

The cloth sags and the object plops into it
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Step #1: Create the Domain, the volume in which the fluid will be simulated.  Here, I 
scaled the default cube by 3 in X, 3 in Y, and 5 in Z:   ‘sx3<ret>sy3<ret>sz5<ret>’

Setting up a Fluids Simulation –
Create the Domain Object

Step #2: With the cube selected, go to the Physics tab and select Fluid

fluidmonkeycone.blend

Step #3: Under that Fluid tab, select Domain and Liquid
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Step #3: Scroll down in the Physics-Fluid menu until 
you find the Mesh tab..  Be sure it is turned on.

Setting up a Fluids Simulation –
Create the Domain Object
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Step #4: Create a mesh object that will be the original location and shape of the 
fluid.  A UV-Sphere works well.  A monkey works even better!   This object 
must lie totally within the Domain.  You should probably toggle into Wireframe or 
X-ray mode so you can see inside the Domain. 

Position this object near the top of the Domain.

Setting up a Fluids Simulation –
Create the Flow Object
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Setting up a Fluids Simulation –
Create the Flow Object

Step #5: With this object selected, go to the Physics menu, click on Fluid, 
select Flow, and select Liquid
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Setting up a Fluids Simulation –
Miscellaneous

Step #6: Miscellaneous Things:

• Change the color of the Domain object (cube) to the color you want the fluid to 
be.  Feel free to change the Metallic and Roughness parameters as well.

• Change the shading type of the Domain object (cube) to Shade Smooth

• Hide the Flow object (monkey?) by clicking off its eyeballs in the Outliner

• Select the Domain object (cube), go to the Physics menu, scroll down until you 
see this:    Be sure Liquid is turned on.  Now, go here and select the other 
option.  It doesn’t make a huge difference which one you pick, but changing the 
option resets the fluid simulation.
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Running the Fluids Simulation

Step #7: Run the animation!  Go to Viewport Shading mode and hit Play.  
The first time through will seem slow because it is computing the frames 
and storing them.  After that, the animation will be much smoother because 
Blender is playing back your frames.
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Adding a Barrier

Step #8: Add some shape (a cone perhaps) into the middle of the Domain.  
Give it a color and the proper shading type.  Then, go to the Physics
menu, click on Fluid, and select Effector.
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Adding a Barrier

Step 9: Select the Domain object, go to the Physics menu, scroll down until you 
see this again:    Go here and select the other option.  It doesn’t make a huge 
difference which one you pick, but changing the option resets the fluid simulation.

Step 10: Hit Play!
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Inflow
Select the Flow object (Suzanne in this case), and try changing the flow behavior 
from Geometry to Inflow.

Inflow means that we want the fluid 
to keep flowing into the domain:
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10. Appearance, II
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Procedural Texturing

Select an object, click on the Material Properties 
icon, and then click on New

Put the display in Render Preview mode
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Procedural Texturing

This time we're not going to go down to Viewport Display.
We are going to use the color settings at the top.

1. Select Principled BSDF 
(probably already selected)

2. Here, where you would 
normally select a color, click 
on this little circle instead

3. From that pop-up menu, 
select Voronoi Texture (or 
one of the others)
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Procedural Texturing

3. From that pop-up menu, select Voronoi Texture (or one of the others)
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4. Change the Scale to 
change the size of the 
Voronoi cells

Procedural Texturing

5. Try changing the Detail!

7. As before, changing 
Metallic and Roughness
affects the shininess.

6. Try changing the 
Randomness!
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Blender has these Built-in Procedural Textures
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Image Texturing

Start with a UV Sphere being shown in Render Preview mode
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Image Texturing

Says that you want to read 
a texture image from a file

Click here to open an image file
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Image Texturing

worldtex.bmp is a good texture to try!
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Image Texturing

worldtex.bmp is a good texture to try!
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Image Texturing

Sphere Tube

Box Flat

You can change the 
Flat parameter to one 
of the others 
depending on what 
your object is most like
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https://www.shutterstock.com/search/texture

https://ambientcg.com/list?sort=Popular

https://www.freepik.com/photos/texture

Places to Find Good Texture Images

Links checked: June 26, 2025

Your own photos should work well too!
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Turning on the Cycles Renderer
We have been using the Eevee renderer and have gotten some very nice 
results.  But we can do even better with the Cycles renderer.

In the Rendering Properties 
menu, select Cycles instead 
of Eevee.

And then select GPU Compute
instead of CPU (it's faster!).
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Turning on the Cycles Renderer

Then, right below that, turn on Denoise if it's not turned on already
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Selecting the GPU Options

Select EditPreferences
In the Preferences menu, select System.  These are 
your GPU options.  All might work on your system, or 
none might work on your system.  Depends on what 
graphics hardware you have.

Try them all to see which you have and which give the fastest Cycles 
render.  On my system, OptiX is fastest, followed by CUDA.  On my 
system, HIP and oneAPI aren't available.
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Back to Cycles: Let’s Say That We Want to 
Render This Scene

Cube and Monkey are opaque

Sphere is both reflective 
and refractive

Plane has a checkerboard 
texture on it

Scene has lighting and 
shadows

Sphere is both reflective 
and refractive

reflrefr.blend
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Making the Sphere Reflective and Refractive
Click on this small green circle.  Instead of making the surface 
shader Principled BSDF select Mix Shader:
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Making the Sphere Reflective and Refractive

Combine refraction and reflection effects 
together with the Mix Shader

How much to mix each shader

The first shader is Glass BSDF to get 
the refraction

The second shader is Glossy BSDF to 
get the reflection

Transmission color

Index of Refraction

Reflection color
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1. Select Principled BSDF 
(probably already selected)

2. Here, where you would 
normally select a color, click on 
this little yellow circle

3. From that pop-up menu, 
select Checker Texture (or one 
of the others)

Putting a Checkboard Pattern on the Plane
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5. Here you can select the two 
colors making up the 
checkerboard

6. Change the Scale to change 
the size of the checkerboard 
squares

Putting a Checkboard Pattern on the Plane
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Onscreen and Rendered Results with Eevee

On-screen

Rendered
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On-screen

Rendered

Onscreen and Rendered Results with Cycles
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Rendered Results with Cycles
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No Denoising
1 minute, 39 seconds

Denoising
2 minutes, 14 seconds

Rendered Results with Cycles

You may have noticed some “sparkling” in 
the rendered image on the previous slide.  
That is a natural artifact of the path-tracing 
algorithm that Cycles uses.  In computer 
graphics, this is called “render noise”.  
Blender has a denoising feature.  All you 
have to do is turn it on in the Denoising 
tab of the  Render Properties menu.



mjb – July 15, 2025

370

Computer Graphics

No Denoising
1 minute, 39 seconds

Denoising
2 minute, 14 seconds

Rendered Results with Cycles

BTW, I don’t recommend you turn Denoising 
on for the Viewport display.  It really slows 
down your interaction when using Cycles. 

X
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Splat!

It starts at the eye:

The pixel is painted the color of 
the nearest object that is hit.

What is Ray-Tracing?
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It’s also straightforward to see if this point lies in a shadow:

Fire another ray towards each light source.  If the ray 
hits anything, then the point does not receive that light.

What is Ray-Tracing?
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It’s also straightforward to handle reflection

Fire another ray that represents the bounce from the 
reflection.  Paint the pixel the color that this ray sees.

Normal 
Vector

What is Ray-Tracing?

Angle of 
incidence

Angle of 
reflection
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The Physics of Reflection

θi θr

Law of Reflection:

r i  
Angle of reflection = Angle of incidence

Normal (Perpendicular) Vector
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It’s also straightforward to handle refraction

Fire another ray that represents the bend from the 
refraction.  Paint the pixel the color that this ray sees.

What is Ray-Tracing?

Normal 
Vector
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The Index of Refraction, η

𝑠𝑖𝑛𝜃ଶ
𝑠𝑖𝑛𝜃ଵ

=
𝜂ଵ
𝜂ଶ

𝑠𝑖𝑛𝜃ଶ = 𝑠𝑖𝑛𝜃ଵ
𝜂ଵ
𝜂ଶ

The Index of Refraction (IOR) is a measure of how 
much light slows down as it passes through a 
particular material.
The larger the IOR, the slower the speed of light in 
that material.
The larger the change in IOR, the more the light 
will bend as it passes from one material to another.

Snell’s Law of Refraction says that:
Or:

Notice that there are certain combinations of the η’s that require 
sinΘ2 to be outside the range -1. → +1., which is not possible.   
This indicates that the refraction has actually become a reflection. 

Air

Water

𝜃ଵ

𝜃ଶ
η1

η2

https://en.wikipedia.org/wiki/Snell’s_law
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The Physics of Refraction

Material Index of
Refraction

Vacuum 1.00000

Air 1.00029

Ice 1.309

Water 1.333

Plexiglass 1.49

Glass 1.60

Diamond 2.42

http://en.wikipedia.org/wiki/Refractive_index

θA

θB

Snell’s Law of Refraction:

sin

sin
B A

A B









Material B

Material A


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Common Indices of Refraction
Material Index of

Refraction

Vacuum 1.00000

Air 1.00029

Ice 1.309

Water 1.333

Plexiglass 1.49

Glass 1.60

Diamond 2.42

Something New: Moissanite

𝜂=2.62
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You Can Also use a Mix Shader to Blend Glass 
and a Texture
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11. Vertex Sculpting
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Vertex Sculpting

Vertex Sculpting is, well, sculpting vertices.  But, 
in order to do this well, we need a lot of vertices.

Start with a UV sphere mesh object.

Tab over to Edit Mode.
RMB → Subdivide → Subdivide

When you get back to Object Mode, the sphere 
won’t look any different than before because you 
just subdivided the polygons, not smoothed 
them.  If you had wanted smoothing, you could 
have used the Subdivision Surface Modifier.

Now go to Sculpt Mode.
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Vertex Sculpting

Lots of new options will appear at the top:

Brush Radius
(I like 25-100, depending on the 

size of the object)

Brush
Strength
(height)

Add Material (+) or 
Subtract Material (-)

Brush 
Characteristics

Stroking 
Characteristics

Surface Falloff 
from the Center 

of the Brush
(I like Smoother)

Symmetry Control
(I recommend you 

click all of these off 
for now.)
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Vertex Sculpting -- Brushes

You will see a whole bunch of sculpting options along the bottom of the screen.  
Hover above each one and a description will pop up:

Confused about where to start?  I like this one, called "Draw":
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Vertex Sculpting
Add material

Subtract material

Sculpting usually looks better if you 
quick get over into Object Mode, 
RMB → Shade Smooth

Go back and forth over the object with the 
brush to increase the sculpting effect
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Vertex Sculpting with Dynamic Topology (“Dyntopo”)

Set the Sculpt 
Mode to Draw

Set Brush
Strength to 1.0

Add Material (+)

Surface Falloff from the Center 
of the Brush to Smoother No Symmetry

This cool – you are really going to like this!

Set Radius 
to 20

Click Dyntopo on
(if you get a message, 

just click OK)
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Vertex Sculpting with Dynamic Topology (“Dyntopo”)

Set Dyntopo Detailing to 
Brush Detail

And, have at it!
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Vertex Sculpting with Dynamic Topology (“Dyntopo”)
How does Dyntopo Mode make such a smooth sculpt?

Let’s look at this in Sculpt Mode and then in Edit Mode:

That’s why it is called Dynamic Topology!
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12. Vertex Painting
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Vertex Painting

Vertex Sculpting is, well, sculpting vertices.  But, 
in order to do this well, we need a lot of vertices.

Start with a UV sphere mesh object.

Tab over to Edit Mode.
RMB → Subdivide → Subdivide

When you get back to Object Mode, the sphere 
won’t look any different than before because you 
just subdivided the polygons, not smoothed 
them.  If you had wanted smoothing, you could 
have used the Subdivision Surface Modifier.

Now go to Vertex Paint Mode.
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Setting up for Vertex Painting

Brush Radius
(I like 25-100)

Brush Color
Don’t be fooled!  Even though this looks like a black-nothing color, 

it is the actual brush color.  You can, and should, change it.

Surface Falloff from the 
Center of the Brush
(I like Smoother)

Brush Strength Brush 
Characteristics

Stroking 
Characteristics

Be in Viewport Solid Shading mode
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Note: the brush size does not scale with 
zooming in or out.  It stays the same size.

A Word on Brush Size
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Selecting the Painting Color

Brush Color
Click here to get the color wheel

Set the brightness (“value”)

Set the hue and saturation
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The “paintbrush” only drops “paint” when a vertex is inside the 
circle brush.  This means that the paint does not smear along a 
nice line but can look splotchy like this.  This is why we 
subdivided before – so we get more vertex density.

How Does Vertex Painting Work?
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1. Make the object look smaller.  That way more vertices will end 
up inside the brush circle.

2. Use Subdivide or Subdivision Surfaces to add more vertices

How Do We Make it Look Less Splotchy?

Two approaches:
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Click on the small circle next to Base 
Color and select Mix (Legacy) from 

the pop-up menu

Be in Rendered Shading mode

Making Your Vertex Painting Show Up
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Then click here and select Color Burn or Multiply
from the pull-down menu

(“Mix” will change to whichever you picked)

Making Your Vertex Painting Show Up
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Click here and select a 
base color for the sphere

Click on the small yellow circle and select 
Color Attribute from the left column of the pop-up menu

Click and adjust the value of 
Fac (the interpolation Factor)

Making Your Vertex Painting Show Up
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Multiply
Fac = 0.00

All Object Color

Multiply
Fac = 0.50

Half of Each

Multiply
Fac = 1.00

All Paint Color

The Fac Parameter Tells Blender What to do 
on the Parts of Your Object that have both 

an Object Color and a Paint Color
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Have a Nice Day!
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13. Keyframe Animation
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Blender Drivers

There are times when we want to relate some aspect of a part's modeling to 
something else.  That is, we want one measurement to drive another.  Not 
surprisingly, these are called Blender Drivers.

Blender Drivers are very useful. But they don’t really fall under any specific 
major category.  So I put them here.  I am open to suggestions about where 
they should really go.

Here our goal is to control the rotation of the torus with the translation of the cube.
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Blender Drivers

Right-click in the torus’s X Rotation slot  
and select Add Driver

Select the torus and hit the ‘n’ key to bring up the Transform Properties Panel:
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This reminds us that the Torus object is what is being 
driven

This section is where we get to specify the Driver object

Click here and specify the Y translation as the driving direction

Click here and specify the Cube as the driver

Blender Drivers
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Blender Drivers

I decided to also specify the Cube’s X Location as driving the Torus’s  Y rotation:

So now moving the cube in X and Y (‘gZ’) will rotate the torus in 2 directions 
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http://ieeexplore.ieee.org/ieee_pilot/articles/05/ttg2009050853/figures.html

Now On To Keyframing
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Keyframe Animation

Keyframe animation is a technique that goes all the way back to the beginning of 
hand drawn animation (e.g., Walt Disney).  Senior animators would specify key 
positions for the animated characters and then more junior animators would fill in 
the frames in between.  This became known as keyframing and in-betweening.

Blender allows you to create the keyframes and gets the computer to do the in-
betweening.  Here, we will keyframe-animate the monkey as she slaloms around a 
group of colored cubes:



mjb – July 15, 2025

407

Computer Graphics

Keyframe Animation

Select the Animation workspace from the list at the top.  This creates a 
screen layout that looks like this: 

This makes your screen look like this.  These new sections are:  

Camera View Window – what you will see if you Render

Timeline Window – keeps track of what frame number we are on.

3D Viewport Window – what you are used to
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Keyframe Animation
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Keyframe Animation
Slide the timeline indicator to what frame number you want to set, position the 
object (grab, scale, rotate) how you want it to be (grab, scale, rotate), and
RMB → Insert Keyframe (or hit the ‘i’ key).  From the pop-up menu, select 
Location, Rotation, and Scale, indicating that you want to record location, rotation, 
and scale factor.
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Keyframe Animation
Do it again: slide the timeline indicator to what frame number you want to set, 
position the object how you want it to look, and RMB → Insert Keyframe (or hit 
the ‘i’ key).  From the pop-up menu, select Location, Rotation, and Scale, 
indicating that you want to record location, rotation, and scale factor.
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Keyframe Animation

After a while, your timeline will look like this:

Then, click here and change the type of display to the Graph Editor:
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Graph Editor
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Keyframe Animation

Your Graph Editor window should now look about like this.

Note that Blender has filled in the in-between values for you.  (This is the “In-Betweening”.)
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The Graph Editor Window

Click on the triangle.  This gives you access to the curves.
Clicking on the eye toggles whether or not you can see a curve.
Clicking on the name of the curve makes that the current curve.  You can then edit it.



mjb – July 15, 2025

415

Computer Graphics

The Graph Editor Window

Shortcuts when the cursor is in the Graph Window:

Shortcut What it does

LMB Select a keyframe dot

Scroll wheel Zoom in and out of the Graph

MMB Pan the Graph

Shift-scroll wheel Pan in Value (vertical)

Shift-MMB Pan in Value (vertical) and Time (horizontal)

Control-MMB Scale in Value (vertical) and Time (horizontal)
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Animation Mischief 

After you have selected one of the animation curves, hit the ‘n’ key.  
Like in the 3D View, a Number Panel pops up.

Click on the Modifier tab.

Then click on Add Modifier.
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Select Add Modifier.
From the list of Modifiers, select Noise.

Animation Mischief 
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Use this menu to change the noise parameters scale and strength.
Notice what this does to the curve.
Now play the animation.

Animation Mischief  
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Two Characters Interacting

To avoid a collision, the monkey jumps up and the cube squishes 

anim2.mp4anim2.blend
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Animating the Camera and the Lamps

Cameras and Lamps are just like any other object.  As you have seen, they can be 
positioned.  They can also be keyframe-animated.  Like other objects, just select them and 
hit the ‘i’ key to insert a keyframe.
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Animating (almost) Any Parameter
One of the many cool things about Blender is that you can do more than just keyframe-animate 
the objects, you can also keyframe-animate the parameters you are setting.  For example, 
suppose you want to animate the Metallic-ness.  To set a keyframe for this, right click on the 
Metallic box and select Insert Keyframe from the pop-up menu.  Do this for two keyframes and 
then animate.

Frame 0 Frame 60
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Animating Colors
Blender can also perform keyframe animation on colors.  This works in both of the 
ways that you can set color: Viewport Display and Base Color.  In either mode, set 
the frame counter, and then RMB → Insert Keyframe:

Frame 0 Frame 60

Interpolated Frame 30
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Animating a Human-ish Form

Start with this …

… and turn it into 
a Blender model:

model.blend

modelmoved.blend
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Animating a Human-ish Form

But, it’s more than just a collection of parts!

Be sure that the origins of the different parts are where you want the part to pivot around.

Then establish the proper parent-child relationships.
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Animating a Human-ish Form

Now tell Blender to do all rotations around each part’s origin.
Set the Transform Pivot Point by clicking here (near the top center of the Blender 
window):

Selecting this … 
causes object 
rotation to happen 
about the 
previously-set 
origin



mjb – July 15, 2025

426

Computer Graphics

Animating a Human-ish Form

Now try rotating the 
individual parts. Be sure you are rotating in 

local coordinates, e.g.,
r→y→y
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Rigging for Animation

There is a time-honored tradition in stop-
motion animation to use an internal 
support, called an armature, to help 
position the object at each frame.

Digital animation has adopted the same 
technique, and has even retained the same 
terminology, armature.

The process of creating this digital 
armature is referred to as Rigging.

Laika
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Rigging for Animation

Let’s say we have a cheesy noodle character named Mac.   
We would like to rig him to bend.

The first step is to create Mac’s geometry.  In this case, 
one cylinder was Boolean-subtracted from another and 
then was Edit → Subdivide’d a couple of times.

The second step is to go to the Add tab on the Object 
Tools and click on Armature.  This brings up the sub-
menu here.
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Rigging for Animation

Grab the armature just like you would any other object and position it next to Mac.
(I scaled it up a couple of times to make it more visible.)

Root

Tip

Body

This is what the pieces of a Blender 
armature look like.  The three sections of 
one of these bones are the root, the body, 
and the tip.
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Rigging for Animation

We could put lots of bones in place to animate Mac, but, for simplicity 
we will just use two.

Tab into Edit Mode, select the Armature, then select Extrude. Lift 
up on the plus sign. This will add a second armature on top of the 
first and connect them tip-to-root. Click here to let go.  Tab back to 
Object Mode.
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Rigging for Animation

In the Outliner, you can see the bones you have created. 

Also, in the Properties buttons, you will see that there are now 
Armature and Bone buttons.   
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Rigging for Animation

When you click the Armature Properties button, a bunch of new information comes up.  
The most important for right now is in the Viewport Display tab:

Try these.  They 
change the appearance 
of the Bones.

Click on Names.  It puts the 
name of the Bone next to it so 
you know which one is which.
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Rigging for Animation

It’s always good to name your Bones.  In the Outliner, double-left-click on Bone.001 and 
rename it Top.  Double-left-click on  Bone and rename it Bottom.  Your display now looks 
like this:
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Rigging for Animation

We next need to make the armature a Parent and the object (i.e., Mac) its Child.
Select Mac and then shift-select the armature.  (The order is important!)

To create the Parent-Child relationship, hit Control-P.  In the pop-up menu, select 
Armature Deform With Automatic Weights 

To verify that this worked, the Outliner will show 
that Mac is now part of the Armature.
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1. Select Mac
2. In the properties area, select the Object Data Properties
3. Tab into Edit Mode
4. Select View → Perspective/Orthographic  to place 

yourself in orthographic display mode
5. Turn on the X-ray button at the top
6. Hit ‘a’ to unselect everything

Rigging for Animation

Almost there – the last step is to assign which vertices on Mac will be deformed by the 
Bottom Bone and which will be deformed by the Top Bone.  These groups do not need to 
be mutually exclusive – they can (and should) have vertices in common.

Earlier in these notes we talked about selecting multiple vertices and Vertex Groups.  
We are going to do that again.  We are going to put some of Mac’s vertices into a Vertex 
Group called Bottom, and some into a Vertex Group called Top.  These must match the 
names of the respective Bones exactly,  
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7. Use the Border Select to select the top 2/3 of Mac’s vertices
8. Create a Vertex Group with them called Top by clicking on Top and then clicking on Assign
9. Hit ‘a’ to unselect everything

Rigging for Animation
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Rigging for Animation

10. Use the Border Select to select the bottom 2/3 of Mac’s vertices
11. Create a Vertex Group with them called Top by clicking on Bottom and then clicking on Assign
12. Hit ‘a’ to unselect everything
13. Turn off X-ray mode and go back to Perspective
14. Tab back to Object Mode
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Rigging for Animation

Select the Armature and go to Pose Mode.

Select the different Bones and try grabbing, rotating, and scaling them.  Obviously, a 
serious Mac animation will require more than two Bones!  Bone transformation can be 
keyframed just like transformation parameters of any other object.
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Rigging in the Pixar Movie Monsters, Inc.

This is from the travelling exhibit The Science Behind Pixar.  If you ever 
see that it is coming to a science museum near you, be sure to go see it!
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The Rigify Blender Add-on

If you are interested in rigging a human or an animal, there is a great Blender 
Add-on called Rigify that will setup the rigs for you.  To enable Rigify:

1. Go to Edit → Preferences
2. Click on Add-ons
3. Scroll down until you see Rigify, then click its checkbox
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The Rigify Blender Add-on

To bring in a rig, LMB → Add → Armature → Rigify Meta-Rigs → , , ,
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Rendering an Animation

Hint: if this is just a test render, and you have 
lots of time-consuming visual effects going on, 
you might cut down the resolution and/or the 
number of rendered frames to speed things up.

This kicks off the rendering of all 
your animation frames in order

This brings up a separate window and plays back 
your animation.
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Rendering an Animation to a File

Before saving the animation rendering, you 
need to specify the file name to put the 
animation into.  In my case, this was:

C:\tmp\boids

and the type of file format that it is to have

First, go to Output Properties

Then select Render Animation.  In my case, this rendered 300 
frames of a boids animation and placed the result in a file called:

C:\tmp\boids.0001-0300.mkv

that was 1.3 MB in size.
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Importing an Animation into YouTube

YouTube accepts videos in MPEG formats
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Importing an Animation into PowerPoint

Insert  Video
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Animation Tricks

1. In this example, we added the first keyframe, then the last 
keyframe, then three keyframes in the middle.  Sometimes 
it is easiest to work that way.  Other times it is easier to add 
them in sequential order.

2. Sometimes it is easier if you initially add a bunch of 
duplications of the object in various positions to get a feel 
for the motion, edit those positions as you see fit, and then 
use them as keyframe positions.

3. Extending from each keyframe dot is a line.  That line can 
be twisted to change the slope of the curve at that 
keyframe.  Select the dots at the end of that line and move 
them.

4. The Camera position and the Lamps can be animated too. 
For each, define an Empty object, force the Camera or 
Lamp to follow it (it’s one of the Constraints), then animate 
the Empty. Be sure to give the Empty a descriptive name –
all Empties look alike.
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1. Squash and Stretch -- Defining the rigidity and mass of an object  by distorting its 
shape during an action. 

2. Timing -- Spacing actions to define the weight and size of objects  and the 
personality of characters. 

3. Anticipation -- The preparation for an action. 

4. Staging -- Presenting an idea so that it is unmistakably clear. 

5. Follow Through and Overlapping Action – The termination of an action and 
establishing its  relationship to the next action. 

6. Straight  Ahead Action and Pose-To-Pose  Action -- The two contrasting 
approaches to  the creation of movement. 

7. Slow In and Out -- The spacing of the inbetween frames to  achieve subtlety of 
timing and movement. 

8. Arcs -- The visual path of action for natural movement. 

9. Exaggeration -- Accentuating the essence of an idea via the design and the action. 

10. Secondary Action -- The action of an object resulting from  another action, 

11. Appeal .-- Creating a design or an action that the audience enjoys  watching. 

John Lasseter, “Principles of Traditional Animation Applied to 3D  Computer Animation 
Computer Graphics”,  Computer Graphics, Volume 21, Number 4, July 1987. 

John Lasseter’s Principles of Animation
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14. 3D Printing
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In the Beginning, Manufacturing was “Subtractive”

1. The whirling drill bit follows a 3D path
2. Chips of metal (or wood or wax) fly
3. A block of metal becomes a part
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3D Printing is Additive

“3D Printing” is defined by some sort of “additive” process.  
The current trend in desktop 3D Printing consists mostly of 
systems that deposit layers of molten plastic:
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Examples of 3D Printing
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Portland’s Laika uses Color 3D Printing for
Stop-motion Movies

Kubo and the Two Strings
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solid

facet normal    0.00   0.00   -1.00
outer loop

vertex   -2.000000   -2.000000   0.250000
vertex   -1.980000   -1.980000   0.250000
vertex   -1.980000   -2.000000   0.250000

endloop
endfacet

facet normal   0.00   0.00   -1.00
outer loop

vertex   -2.000000   -2.000000   0.250000
vertex   -2.000000   -1.980000   0.250000
vertex   -1.980000   -1.980000   0.250000

endloop
endfacet

. . .

endsolid

The 3D Printing Geometry File

3D Printers are fed a file called an “STL File”, which lists all the 
triangles in the object.  Blender (as well as all CAD systems) can 
produce this type of file for you.

In this particular file, these 
coordinates were in units of 
inches.

Some 3D Printers still use 
inches, but most now use 
millimeters.  

Check!  It matters!

Note: there are 25.4 mm/inch
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Don’t make the part too big – it will take a 
long time to 3D print.  It's nice if you can fit 
several models in a single run.

Try to rotate the part so the smallest 
dimension is vertical. It’s stronger that way, 
and it builds faster.

The 3D Printer will like it better if the part 
gets smaller as it goes up, not the other way 
around.

Don’t design the part with long, thin edges.  
They will likely snap right off.  

Don’t make walls too thin – they might break.

Advice on 3D Printing

Worse

Better
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Object Rules for 3D Printing

Rule #1: The object must be a mesh and consist only of triangles.

1. Select the mesh object
2. Modifiers→Add Modifier→Generate→Triangulate →Apply

RMB→Convert To→Mesh to turn a Meta object or 3D Text into a mesh first
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Object Rules for 3D Printing

Rule #2: The object must be a legal solid.  It must have a definite 
inside and a definite outside.  It can’t have any missing face pieces.
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The Simplified Euler's Formula* for Legal Solids

F – E + V = 2

0 1

32

4 5

76

For a cube, 6 – 12 + 8 = 2  

F Faces
E Edges
V Vertices

*sometimes called the Euler-Poincaré formula
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Watch Out for Overhangs!

These layers will build fine

This layer will fall to the plate

Note that if you build it upside-
down, it will probably work fine
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Watch Out for Overhangs!

Some 3D printers handle this by 
leaving unused material in place to 
support the overhangs

Some 3D printers handle this by using 
software to add “support structures” to 
the overhangs

Some 3D printers handle this 
better than others…  

http://twistedsifter.com/2013/08/when-3d-printing-goes-wrong/
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Object Rules for 3D Printing

Rule #3: You can’t make a new object by simply overlapping two 
objects in 3D.  If you want both shapes together, do a Boolean 
union on them so that they become one complete object.

Overlapped in 3D Boolean union
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What Happens if You Do Overlap Objects?

Here’s what one of the 3D Printers in the OSU Library did:

Overlapped in 3D Boolean union

Not bad – it could have been lots worse …
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Object Rules for 3D Printing

Rule #4: Each edge in the mesh must bound 2 and only 2 triangles
(this is known as the Vertex-to-Vertex Rule).  If this is not true, then 
your model has cracks in it.
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Installing the Blender 3D Printing Extension

1. Select Edit → Preferences



mjb – July 15, 2025

464

Computer Graphics

Installing the Blender 3D Printing Extension

2. Click on Get Extensions 3. Type 3d print into the search box

4. You should see 3D Print Toolbox show up here
5. Click on Install
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Hit the ‘n’ key to see the sidebar menu.
The 3D Print Toolbox will be a tab like this.

Using the Blender 3D Printing Toolbox Extension
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Selecting your object and then 
clicking on Check All will give 
you this nice list of problems 
Blender thinks you will have if 
you try to 3D Print this object

Selecting Clean Up → Make Manifold 
can try to fix some of the problems

Using the Blender 3D Printing Toolbox Extension
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Tab over to Edit Mode.
Click in an empty area to unselect everything.
Then click in all the places that show problems.
Blender will light up the object in the places that 
provoked that problem, giving you a chance to fix them.

The Blender 3D Printing Toolbox Add-on
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Output for 3D Printing

To export an STL file for 3D Printing:

1. Use the Triangulate modifier to be 
sure all polygons in your object are 
triangles

2. Select the object you want to export
3. File → Export → Stl (.stl)
4. Navigate to where you want to save 

the file
5. Give it a filename that ends in .stl
6. Click Export STL

.stl is the most common 3D printing file 
format

“STL” stands for Stereolithography

The word “stereolithography” comes from 
the Greek words for “3D” and “writing”.
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Want to see 3D Printing in Action?

Oregon State University’s library has 3D Printers for use by OSU students.  
To see them via webcam, go to:  http://webcam.oregonstate.edu/3dprinter

Click here to see the live, streaming view.
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15. Stereographics
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Life Magazine

Stereoscopy is not new – it’s been in common use 
since the 1950s

For more information on stereoscopy, see: https://en.wikipedia.org/wiki/Stereoscopy

But, with virtual reality and 3D movies being so popular, stereoscopy 
has made a big comeback.  And, you can get at it through Blender!
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Newport Maritime Museum

And even longer than that in stills

Portland Art Museum's Ansel Adams Exhibit
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OSU's 16th President Dr. Jayathi Murthy

In everyday living, part of our perception of depth comes from the 
slight horizontal difference in how our two eyes see the world around 
us.  This is known as binocular vision.  We care about this because 
computer graphics can simulate that slight viewing difference and thus 
create the binocular viewing of a computer-generated scene.

We Humans have Binocular Vision
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Open the Render Properties menu

Step #1a – Be Sure You are Using the Eevee Renderer, not Cycles
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Enable the Stereoscopy
checkbox and open the menu

Open the Output Properties menu

Step #1b – Turn the Stereographics On

Be sure these are 
both checked

Select Stereo 3D. 
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While still in the Output Properties menu …

Step #1c – Turn the Stereographics On

Red-Cyan is good here if 
you picked Anaglyph 
before.  On the screen, the 
display will always be a 
Red-Cyan anaglyph. This 
menu controls how it will be 
drawn when you write a file 
after a Render. 

Click on Stereo 3D.

Pick one of these here
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Select your Camera (in the scene 
or in the Outliner) and then open 
the Camera Data menu

Any of these will work 
well.  I’m kind of partial to 
Off-Axis or Tow-In.

Step #2 – Set the Stereo Cameras

These are interesting to 
experiment with.  They control 
how deep the stereo focuses 
and how easy the stereo 
images are to converge.
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Open the Object Properties menu 
(hit ‘n’ on the keyboard) and click 
on the View tab

This tells the Renderer to produce both 
a left and right view, and to make a 
red-cyan stereopair from them

Step #3 – Tell the Renderer to Produce both a
Left and Right View
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Step #4 – Render → Render Image
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The universal convention is:
• Red goes over the left eye
• Cyan goes over the right eye

No, they are not red-blue glasses!
No, they are not red-green glasses!
They are red-cyan glasses!

If you want to own your own red-cyan glasses (and who doesn’t?) 
my go-to is:
https://the3dmarket.com/collections/anaglyphic/products/red-cyan

You can also find them on Amazon.  Search for anaglyph glasses

Red-Cyan Glasses
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This assumes you have 
already done the other steps

Step #5 – (if you want): From the Render window, 
write out a Stereographics Image File
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Select your Camera (in the scene or in 
the Outliner) and then open the 
Camera Data menu

The Convergence Plane Distance 
controls how much the scene appears to 
exist behind or in front of the display 
screen.  Use a small distance to make the 
scene look like it is living in the monitor.

Use a larger distance to make the scene 
look like it is living in the air in front of the 
monitor.  (Don’t go too crazy with this – it 
will look less cool than you are expecting.) 

How Deep your Scene Appears to be into and out of the 
Computer Screen -- Setting the Convergence Plane
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How Deep does the Scene Appear to be into and out of 
the Computer Screen?  Setting the Convergence Plane

The Convergence Plane is in front of the object –
the object will appear to be inside the monitor

The Convergence Plane is behind the 
object – the object will appear to be in the 
air in front of the monitor

I like placing the Convergence Plane 
about 1/3 of the way through the object
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There are many ways to display the correct view into 
the correct eye 
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mjb – July 15, 2025

486

Computer Graphics

http://cs.oregonstate.edu/~mjb/blender
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http://blenderkit.com

http://www.blender.org/education-help/
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Sam Brubaker, Realizing 3D Animation in Blender, Packt, 2024.

Jaime Kelley, 3D Character Rigging in Blender, Packt, 2024.

Ruan Lotter, Taking Blender to the Next Level,  Packt, 2022.

Blender References I Like
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http://polyhaven.com

https://free3d.com

http://www.turbosquid.com/Search/3D-Models/free/obj

https://sketchfab.com/features/free-3d-models

Getting Free 3D Models and Texture Images
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And Finally…

There is no badge for completing the Blender Camp, but if there was, it 
would probably look like this:*

*Thanks to Microsoft CoPilot for generating this image and thanks to my good friend Andrew Glassner for suggesting the prompts to do it.
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Camp Blender
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