Blender: Serious 3D for Students Who Think of Themselves as 3D Artists, Animators, Engineers, or Scientists

Mike Bailey
mjb@cs.oregonstate.edu

Blender Shortcuts You Will Use a Lot

<table>
<thead>
<tr>
<th>Shortcut</th>
<th>What it Does</th>
</tr>
</thead>
<tbody>
<tr>
<td>Shift-g</td>
<td>Group</td>
</tr>
<tr>
<td>Shift-a</td>
<td>Unselect all</td>
</tr>
<tr>
<td>Control-j</td>
<td>Join 2 or more objects</td>
</tr>
<tr>
<td>m</td>
<td>Send object to a collection (layer)</td>
</tr>
<tr>
<td>Shift-n</td>
<td>Recalculate normals</td>
</tr>
<tr>
<td>Shift-p</td>
<td>Partition (only in edit mode)</td>
</tr>
<tr>
<td>Control-p</td>
<td>Establish a parent-child relationship (last object selected will be the parent)</td>
</tr>
<tr>
<td>Shift-p</td>
<td>Destroy a parent-child relationship</td>
</tr>
<tr>
<td>Control-q</td>
<td>Toggle quad viewing</td>
</tr>
<tr>
<td>r</td>
<td>Rotate an object</td>
</tr>
<tr>
<td>s</td>
<td>Scale an object</td>
</tr>
<tr>
<td>Shift-s</td>
<td>Pie menu for using the 3D Cursor</td>
</tr>
<tr>
<td>Spacebar</td>
<td>Start / Pause an animation</td>
</tr>
<tr>
<td>t</td>
<td>Toggle the Object Tools menu</td>
</tr>
<tr>
<td>x</td>
<td>Delete whatever is selected</td>
</tr>
<tr>
<td>z</td>
<td>Bring up a display mode pie menu</td>
</tr>
<tr>
<td>Control-z</td>
<td>Undo</td>
</tr>
<tr>
<td>Alt-z</td>
<td>Toggle x-ray mode</td>
</tr>
<tr>
<td>Control-Shift-z</td>
<td>Redo</td>
</tr>
<tr>
<td>F12</td>
<td>Render a scene image</td>
</tr>
<tr>
<td>F11</td>
<td>Return to the interactive scene</td>
</tr>
</tbody>
</table>

Blender is a free program that lets you do professional-looking modeling, rendering, and animation. You can get Blender for yourself by going to the web site: [http://www.blender.org](http://www.blender.org)

In these notes, what do these icons mean?

- cloth.blend
- worldtile.bmp
- cloth.mp4

They tell you that if you go to our notes web site:

http://cs.oregonstate.edu/~mjb/blender

you will find Blender input files (*.blend), texture map files (*.bmp), and animation movie files (*.mp4).

You can read a .blend file right into Blender (File → Open) so that you can experiment with these examples without having to first create them yourself.

You can play an .mp4 movie file right from your browser so that you can see how these examples look without having to run Blender at all.

Navigating the Blender Screen Layout

What is Blender?

Blender: Serious 3D for Students Who Think of Themselves as 3D Artists, Animators, Engineers, or Scientists

Mike Bailey
mjb@cs.oregonstate.edu

Blender Shortcuts You Will Use a Lot

<table>
<thead>
<tr>
<th>Shortcut</th>
<th>What it Does</th>
</tr>
</thead>
<tbody>
<tr>
<td>Shift-g</td>
<td>Group</td>
</tr>
<tr>
<td>Shift-a</td>
<td>Unselect all</td>
</tr>
<tr>
<td>Control-j</td>
<td>Join 2 or more objects</td>
</tr>
<tr>
<td>m</td>
<td>Send object to a collection (layer)</td>
</tr>
<tr>
<td>Shift-n</td>
<td>Recalculate normals</td>
</tr>
<tr>
<td>Shift-p</td>
<td>Partition (only in edit mode)</td>
</tr>
<tr>
<td>Control-p</td>
<td>Establish a parent-child relationship (last object selected will be the parent)</td>
</tr>
<tr>
<td>Shift-p</td>
<td>Destroy a parent-child relationship</td>
</tr>
<tr>
<td>Control-q</td>
<td>Toggle quad viewing</td>
</tr>
<tr>
<td>r</td>
<td>Rotate an object</td>
</tr>
<tr>
<td>s</td>
<td>Scale an object</td>
</tr>
<tr>
<td>Shift-s</td>
<td>Pie menu for using the 3D Cursor</td>
</tr>
<tr>
<td>Spacebar</td>
<td>Start / Pause an animation</td>
</tr>
<tr>
<td>t</td>
<td>Toggle the Object Tools menu</td>
</tr>
<tr>
<td>x</td>
<td>Delete whatever is selected</td>
</tr>
<tr>
<td>z</td>
<td>Bring up a display mode pie menu</td>
</tr>
<tr>
<td>Control-z</td>
<td>Undo</td>
</tr>
<tr>
<td>Alt-z</td>
<td>Toggle x-ray mode</td>
</tr>
<tr>
<td>Control-Shift-z</td>
<td>Redo</td>
</tr>
<tr>
<td>F12</td>
<td>Render a scene image</td>
</tr>
<tr>
<td>F11</td>
<td>Return to the interactive scene</td>
</tr>
</tbody>
</table>

What is Blender?

Blender is a free program that lets you do professional-looking modeling, rendering, and animation. You can get Blender for yourself by going to the web site: [http://www.blender.org](http://www.blender.org)

Note: The version number changes often. These notes were written against Blender version 2.9

In these notes, what do these icons mean?

- cloth.blend
- worldtile.bmp
- cloth.mp4

They tell you that if you go to our notes web site:

http://cs.oregonstate.edu/~mjb/blender

you will find Blender input files (*.blend), texture map files (*.bmp), and animation movie files (*.mp4).

You can read a .blend file right into Blender (File → Open) so that you can experiment with these examples without having to first create them yourself.

You can play an .mp4 movie file right from your browser so that you can see how these examples look without having to run Blender at all.

Navigating the Blender Screen Layout

What is Blender?

Blender is a free program that lets you do professional-looking modeling, rendering, and animation. You can get Blender for yourself by going to the web site: [http://www.blender.org](http://www.blender.org)

Note: The version number changes often. These notes were written against Blender version 2.9

In these notes, what do these icons mean?

- cloth.blend
- worldtile.bmp
- cloth.mp4

They tell you that if you go to our notes web site:

http://cs.oregonstate.edu/~mjb/blender

you will find Blender input files (*.blend), texture map files (*.bmp), and animation movie files (*.mp4).

You can read a .blend file right into Blender (File → Open) so that you can experiment with these examples without having to first create them yourself.

You can play an .mp4 movie file right from your browser so that you can see how these examples look without having to run Blender at all.
The Object Tools Menu

- Select
- Cursor
- Transform
- Move
- Rotate
- Scale
- Annotate
- Measure

Toggled on and off with the 'T' key.

The Add Menu

- Create geometry
- Create lights
- Create other cool stuff

This is the Add tab — you will spend a lot of time here!

The Add→Mesh Menu

You will especially spend a lot of time here!

Viewing in 3D

3D Coordinate Systems

Left-handed

Right-handed

Blender uses this convention.
The Coordinate and Viewing System

- Right-handed coordinate system
- X = Red
- Y = Green
- Z = Blue
- Middle mouse button (MMB) – orbit
- Shift MMB – pan
- Scroll wheel – zoom
- View → Left, Right, ...
- View → Toggle Quad View
- View → View Persp/Ortho

The View Menu

The View Menu gives you access to lots of ways to change how you are viewing the scene.

Toggling Between Perspective and Orthographic Views

In orthographic, lines that are parallel in 3D remain parallel on the screen. Objects appear to be the same size as they get farther away.

In perspective, lines that are parallel in the 3D depth direction appear to converge on the screen. Objects appear to get smaller as they get farther away.

"Vanishing Point"

Use perspective when you want a more realistic view (which is most of the time).

Use orthographic to see if things separated in depth are the same size.

Setting the initial Display Mode

Use Viewport Shading to start. It gives good generic lighting. Later, when we cover Rendering, we will use Rendered lighting.
Moving Things Around in 3D

The Add→Mesh Menu

The UV Sphere, Torus, and Monkey are my favorites.

Selecting an Object to Work On

Selecting Multiple Objects to Work On: Two Ways to Do This

1. Hold down the Shift key while RMB-clicking
2. LMB a rectangular region around objects
Moving Things By Clicking and Dragging

- Translate ('grab')
- Rotate
- Scale

Use Global or Local Coordinate System

Local and Global Coordinates

- Local Coordinates align with the object
- Global Coordinates align with the screen

Saying How to Move Things by Using the Keyboard

- LMB click to select an object
- Grab 'g'
- Rotate 'r'
- Scale 's'
- Grab using global axis 'g' → 'x', etc.
- Grab using local axis: 'g' → 'x' → 'x'
- Pick all but a particular axis: 'g' → 'x', 'g' → 'X' → 'x', etc.
- Grab a specific distance 'g' → 'x' → 12.25 <return>
- Rotate a specific angle 'r' → 'x' → 45 <return>
- Scale a specific factor 's' → 'x' → 2.0 <return>
- Scale a specific factor 's' → 'x' → 2.0 <return>

This is important – you will use this a lot!

You Can Also Use the Sidebar Panel

Hit the 'n' key to toggle this panel

The Outliner

- In the upper-right portion of the screen is the Outliner. Like the name implies, it shows an outline of your scene.
- It is sometimes nice to have a summary of the scene so you can remind yourself of what all is in it.
- Also, if your scene is cluttered, you can select an object by clicking on its name in the outliner as opposed to selecting it in the scene.
- Double-clicking on a name will allow you to rename that object to something more sensible than, say, "sphere".
- Also, you can use the outliner to hide certain objects. Just click on the eye icon to hide/unhide.

Modeling, I
These are all the different geometry things you can add into the scene. We will cover many of them, but not all.

This group is the meshes.
This group is the curves.

The UV Sphere, Torus, and Monkey are my favorites.

Making the Mesh Objects Look Nicer
Blender is able to play a graphics trick to make your curved geometry look better. Select the object (LMB) then click the RMB and select Shade Smooth.

This doesn’t actually change any geometry – it’s just a really good computer graphics display trick. There are other ways to truly create smoother geometry.

Duplicating an Object from the Tools Menu
Select the object (LMB) then click the RMB and select Duplicate Objects. This leaves the new object right on top of the old object and leaves you in Grab mode. Just move the mouse to separate the two objects.

Click here, or hit the Tab key, to get into Edit Mode. Select and edit:
- A vertex
- An edge
- A face

Using the Tab key is so common, that “tab” has become a verb in the Blender community. “Just tab over into edit mode.”
Editing a Vertex

- Be sure you are in vertex-editing mode
- Left click on a vertex
- Hit ‘g’ (grab) and move the mouse
- You can also hit ‘x’, ‘y’, or ‘z’ to restrict motion

Editing a Vertex with Proportional Editing

- Be sure you have Proportional Editing enabled
- LMB click on a vertex
- Hit ‘g’ (grab) and move the mouse
- You can also hit ‘x’, ‘y’, or ‘z’ to restrict motion
- The mouse Scroll Wheel changes the size of the Circle of Influence
- You can also LMB select an edge or a face for editing or proportional editing.

Subdividing and Smoothing Really Show the Difference Between Localized and Proportional Editing

Appearance, I

The Button Properties Menues

- Clicking one of these brings up a much more detailed menu of options

Using the Material Properties Menu

- Click on this … to get this
- Then, click on New
To make our lives simpler for now, click here to turn off Use Nodes mode.

Clicking in here brings up a color wheel.

Use Nodes mode has been turned off.

Blender’s RGB scale lets you give the red, green, and blue components in the range 0. – 1.

Blender’s hexadecimal scale lets you give the red, green, and blue components in the range 00 00 00 – FF FF FF.

These are the possible ways the color will be defined.

If you know the color definition numbers you want, you can type or slider them here.

Click in here to change the Hue and Saturation.

Hue is angle around the wheel
Saturation is the radius

Value is a color’s brightness.

These are the possible ways the color will be defined.

If you know the color definition numbers you want, you can type or slider them here.

Click in here to change the Value.

Click in here to change the Value.

Value is a color’s brightness.

These are the possible ways the color will be defined.

If you know the color definition numbers you want, you can type or slider them here.

Modeling, II
A Face Picking Hint

Similarly, if you put yourself into face-picking mode:

And click on the top face of the cylinder (don’t need the belt and don’t need to be in X-ray Mode for this):

And hit the r and a keys (for rotate about the a axis) and move the mouse, then you get this:

Intentionally Joining Two Objects

Let’s say that you have two objects and want to join them together so that you can act on them as one object.

Intentionally Joining Two Objects

Easy! LMB on one, then Shift-LMB on the other, then hit Control-J (“join”) on the keyboard. The orange “selection outline” now goes around both objects and the outliner shows just one object.

Separating Objects By Loose Parts

Select the Joined object. Tab over to Edit Mode. Then hit the ’p’ key (“Partition”). You will then have three options on how to partition the joined object. If you select By Loose Parts, then the Joined object will be partitioned based on the original primitives that made it up.

Inset Faces (aka, Offset Curves)

Often you want to create a “face-within-a-face”. In Blender, this is called an Inset Face. (CAD systems often call this sort of thing an Offset Curve.)

Insert Faces (aka, Offset Curves)

With the LMB, push the little handle down until the Inset Face is the size you want.

Inset Faces (aka, Offset Curves)

At this point, you can select the inner face and hit g and x (grab in the x direction) to do this, or this.

Try rotating or scaling the inner face.

You can also create a new inset face inside the inset face you just created.
The Button Properties Menues, Again

Tells you that we are in the Button Properties Menu

Clicking one of these brings up a much more detailed menu of options

My Favorite Modifier -- Subdivision Surface

This modifier increases the number of polygons in your object. At the same time, it smooths your object out. Be careful! It very quickly increases your polygon count.

This controls how much to subdivide. Here we've changed this value from 1 to 2.

Remember Venn Diagrams (Boolean Operators)?

Two Overlapping Shapes

Union

Intersection

Difference

Booleans (also known as Constructive Solid Geometry)

Think of them as Venn diagrams in 3D!
1. Select the cube
2. Click on Modifiers
3. Select the Modifier called Boolean
4. Specify the Difference Operator
5. Specify the Cylinder as what to the difference with
6. Click Apply

Select the cylinder, hit it g (grab) and slide the cylinder away

But, that mirrored object will reflect about the object origin, this little dot right here. Which means that you will end up with something like this, which is probably not what you wanted.

The Mirror Modifier

Let’s say that you want to create a mirror image of the monkey, but by using a Modifier, the mirror monkey will be linked to the original monkey so that any edits you do to the original will automatically end up in the mirror object.

Now, Tab back to Object Mode, add the Mirror Modifier, and select Y.

So, now if you sculpt the original object, the mirrored object will get the same edits.

This is often good for creating a full object by only creating one half of it (e.g., a car) and mirroring it.
Modifier Order Matters!

Wireframe, then Subdivision Surface

Importing Objects from Other Places

Collada = export format from game modeling systems
Stl = 3D printer format
3ds = format from Autodesk 3D Studio
Obj = Probably world’s most common export format. There are a ton of .obj models for free on the Internet! Google the phrase: free obj files.

Importing Objects from Other Places

File = dino.obj
You can get this file from the web page:
http://cs.oregonstate.edu/~mjb/blender
As-is, flat shaded
Subdivision surfaced + Smooth shaded

Importing Objects from Other Places

Abusively edited

Exporting Objects to Other Places

Blender has a number of file formats it knows how to export to. If you are looking for a nice, general one to experiment with, try the .obj format.

Just be sure to use the RMB menu to select Shade Smooth first

Select File → Export → Wavefront (.obj)

Exporting to an OBJ File

This is the Blender file-output selection dialog box:
Obj-specific settings (see next slide)
In the export dialog, be sure to click on:
• Write Normals
• Include UVs
• Triangulate Faces

OBJ-Specific File Settings

Rendering
“Rendering” is Blender’s process for creating really high-quality images. Click on Render → Render Image or hit the F12 key (you might have to hit the fn key at the same time). The rendering operation can often take some time, depending on how complex your scene is.

We have been using this one. This one gave you good generic lighting so you could model without worrying about light sources.

Now switch to this one. This one will give you a pretty-good preview of what happens when you actually render the scene. But, we now have to deal with Rendering specifics.

On-screen Rendering Mode

Clicking on the Render Properties button will allow you to set various rendering parameters. The one you care about the most is pixel resolution.

You want at least some Anti-Aliasing, which is done by making more than one sample per pixel. 64 and 16 are good values.

The rest of these are interesting, but not needed right now.

Rendering Parameters

Let’s say that you are in Solid Shading Mode and your scene situation looks like this.

You now change to Render Mode and get this.

Lighting

Blech! Where did the bottom part of my scene go?
The answer is that **Solid Shading Mode** doesn't require your scene to be lit, but **Render Mode** does.

By default, your scene has a single light in it. It looks like this.

If you can't find it, try zooming out. If you still can't find it, select it in the **Outliner**.

This is like any other object.

A light is like any other object. It can be LMB clicked on. It can be grabbed (g) and moved around. Moving it around will change how the lighting looks.

But, to make this work better, you probably want to add more lights.

**Lights**

1. A **Point Lamp** shines light in all directions. The light is local to the scene. This is usually the best type of light to start out with.
2. A **Sun Lamp** appears to come from a single direction and its rays are parallel. This acts as if the light is very far away.
3. A **Spot Lamp** is like a Point Lamp, but only shines in one particular direction.
4. An **Area Lamp** is light coming from a finite surface, like most lights really are.

**Lighting – try this**

1. Add another Point Light
2. Position the Light (g).
3. The Point Light has no obvious local coordinate system, so it just uses the global coordinate system.
4. As you move the Light, you will see the lighting of the scene change
5. You will probably have to rotate the scene (MMB) to get the light position where you think it should be. Or, you can also toggle the **Quad View** mode (Control-Alt-q).
Lighting – Properties

- This shows how the light spreads out from the Light
- What color to make the Light
- How bright to make the Light shine.
- Be sure this is clicked on in order to get this light to cast shadows.

Rendering

- The view that is rendered is not the same orientation that you see on the screen. It is from the Camera position, which needs to be set separately.

The Camera

- The camera is just like any other object in the scene.
  1. It can be selected with a LMB click
  2. It has its own local coordinate system attached to it.

Note the local coordinate system for the camera:
- X is to the right of where the eye is looking
- Y is the up-vector
- Z is opposite of where the eye is looking

This is useful to know. For example, to dolly the camera in or out, select it and then move it in its local coordinates:

Aligning The Camera to Your Current Screen View

- But, if you like your current screen view and want to move the camera there, just do this:
  View → Align View → Align Active Camera to View

Triggering a Rendering

- What you see on your screen
- What you see on the separate render window
What You See in the Separate Render Window

Saving a Rendered Image to a File

Different image file types
(PNG is good if you don’t have any preference)

3D Printing
Object Rules for 3D Printing

1. The object must be a mesh and consist only of triangles.

2. Modifiers → Add Modifier → Triangulate

1. Alt-'c' to turn a Meta object or 3D Text into a mesh

Object Rules for 3D Printing

2. The object must be a legal solid. It must have a definite inside and a definite outside. It can’t have any missing face pieces.

Watch Out for Overhangs!

These layers will build fine

Note that if you build it upside-down, it will probably work fine

Watch Out for Overhangs!

Some 3D printers handle this by leaving unused material in place to support the overhangs

Some 3D printers handle this by using software to add “support structures” to the overhangs

Some 3D printers handle this better than others… ☺

http://twistedsifter.com/2013/08/when-3d-printing-goes-wrong/

3. You can’t make an object by simply overlapping two objects in 3D. If you want both shapes together, do a Boolean union on them so that they become one complete object.

What Happens if You Do Overlap Objects?

Here’s what one of the 3D Printers in the OSU Library did:

Overlapped in 3D

Boolean union

Not bad – it could have been lots worse …
Object Rules for 3D Printing

4. Each edge in the mesh must bound 2 and only 2 triangles (this is known as the Vertex-to-Vertex Rule).

Installing the 3D Printing Add-on

Select Edit → Preferences

Installing the 3D Printing Add-on

Select Add-ons → Mesh: 3D Print Toolbox

Installing the 3D Printing Add-on

Hit the ‘n’ key to see the sidebar menu. The 3D Print Toolbox will be a tab like this.

The 3D Printing Toolbox Add-on

Selecting your object and then clicking on Check All will give you this nice list of problems Blender thinks you will have if you try to 3D Print this object. Selecting Clean Up will try to fix the problems.

The 3D Printing Toolbox Add-on

Tab over to Edit Mode. Click in an empty area to unselect everything. Then click in all the places that show problems. Blender will light up the object in the places that provoked that problem, giving you a chance to fix them.
To export an STL file for 3D Printing:
1. Click here and select a folder for the file
2. Click here to write the file

*.stl* is the most common 3D printing file format.

“STL” stands for Stereolithography.
The word “stereolithography” comes from the Greek words for “3D” and “writing.”

---

**Thanks for Coming!**

Blender: Serious 3D for Students Who Think of Themselves as 3D Artists, Animators, Engineers, or Scientists

[Logo]

Mike Bailey
mjb@cs.oregonstate.edu

[Logo]