**Blender Shortcuts You Will Use a Lot**

<table>
<thead>
<tr>
<th>Shortcut</th>
<th>What it Does</th>
</tr>
</thead>
<tbody>
<tr>
<td>RMB</td>
<td>Select something</td>
</tr>
<tr>
<td>Shift-RMB</td>
<td>Add something else to the selection</td>
</tr>
<tr>
<td>Alt-RMB</td>
<td>Select the next thing over and thus select the entire strip</td>
</tr>
<tr>
<td>MMB</td>
<td>Rotate the scene</td>
</tr>
<tr>
<td>Shift-MMB</td>
<td>Pan the scene</td>
</tr>
<tr>
<td>Scroll Wheel</td>
<td>Zoom in and out</td>
</tr>
<tr>
<td>Tab</td>
<td>Toggle between Object Mode and Edit Mode</td>
</tr>
<tr>
<td>a</td>
<td>Select all / Unselect all</td>
</tr>
<tr>
<td>Alt-a</td>
<td>Start / Pause an animation</td>
</tr>
<tr>
<td>Escape</td>
<td>Get you out of almost anything (including stopping a render or an animation)</td>
</tr>
<tr>
<td>b</td>
<td>Border select</td>
</tr>
<tr>
<td>Control-b</td>
<td>Bevel (see Bevel parameters at the bottom of the Object Tools menu)</td>
</tr>
<tr>
<td>c</td>
<td>Circle select</td>
</tr>
<tr>
<td>All-c</td>
<td>Turn 3D text into a mesh object</td>
</tr>
<tr>
<td>SNR-d</td>
<td>Duplicate</td>
</tr>
<tr>
<td>e</td>
<td>Extrude (in edit mode)</td>
</tr>
<tr>
<td>Control-f</td>
<td>Fix-up: connect all selected vertices into a line or polygon</td>
</tr>
<tr>
<td>g</td>
<td>Grab (translate) an object</td>
</tr>
<tr>
<td>h</td>
<td>Group</td>
</tr>
<tr>
<td>Alt-h</td>
<td>Ungroup</td>
</tr>
<tr>
<td>Control-h</td>
<td>Establish a Hook to the selected vertices</td>
</tr>
<tr>
<td>i</td>
<td>Insert a keyframe</td>
</tr>
<tr>
<td>Control-i</td>
<td>Join 2 or more objects</td>
</tr>
<tr>
<td>m</td>
<td>Bring up the Assign Layers menu</td>
</tr>
<tr>
<td>n</td>
<td>Toggle the Object Properties menu</td>
</tr>
<tr>
<td>p</td>
<td>Partition (only in edit mode)</td>
</tr>
<tr>
<td>Control-p</td>
<td>Establish a parent-child relationship (last object selected will be the parent)</td>
</tr>
<tr>
<td>All-p</td>
<td>Destroy a parent-child relationship</td>
</tr>
<tr>
<td>r</td>
<td>Rotate an object</td>
</tr>
<tr>
<td>s</td>
<td>Scale an object</td>
</tr>
<tr>
<td>t</td>
<td>Toggle the Object Tools menu</td>
</tr>
<tr>
<td>x</td>
<td>Delete whatever is selected</td>
</tr>
<tr>
<td>Control-z</td>
<td>Redo</td>
</tr>
<tr>
<td>Control-Shift-z</td>
<td>Redo</td>
</tr>
<tr>
<td>F12</td>
<td>Render a scene image</td>
</tr>
<tr>
<td>F11</td>
<td>Return to the interactive scene</td>
</tr>
</tbody>
</table>

**What is Blender?**

Blender is a free program that lets you do professional-looking modeling, rendering, and animation.

You can get Blender for yourself by going to the web site: [http://www.blender.org](http://www.blender.org)

Note: The version number changes often. These notes were written against Blender version 2.79.

Blender 2.80 is coming! It has a lot of new features, but the user interface is very different from 2.79 and earlier.
Next Gen – a Blender-Animated Movie

See the trailer at:
https://www.netflix.com/title/80988892

Why Do We Have These Notes?

Blender has thousands of buttons you can press. It is difficult to understand them all. These notes are here to show you what certain combinations of buttons do in order to learn them, and to remind you later when you’ve forgotten.

In these notes, what do these icons mean?

They tell you that if you go to our notes web site:
http://cs.oregonstate.edu/~mjb/blender

you will find pre-created Blender input files (*.blend) and pre-created animation movie files (*.mp4).

You can read a .blend file right into Blender so that you can experiment with these examples without having to first create them yourself.

You can play an .mp4 movie file right from your browser so that you can see how these examples look without having to run Blender at all.

A warning about me and the Notes

What Blender does
What I know
What the notes cover
1. Navigating the Screen Layout

There are Many Types of Windows in Blender

You can see the different types by clicking here

These are the different types. You can change a window’s type just by clicking one of them.
The Object Tools Menu

Transformation

Duplicate or Delete an object

Smooth or Flat shading (very handy!)

Toggled on and off with the 't' key

This is the Create tab – you will spend a lot of time here!

Create geometry

Create lights

Create other cool stuff

Toggled on and off with the 't' key

The Object Properties Panel

Toggled on and off with the 'n' key

The Blender Interface Widgets

If Blender shows you something that looks like this …

… you are expected to click a button to put yourself in a particular mode

If Blender shows you something that looks like this …

… you are expected to click in the box to bring up something else, like this
The Blender Interface Widgets

If Blender shows you something that looks like this …

- Shadeless
- Tangent Shading
- Cubic Interpolation

… you are expected to turn features on and off by clicking in all or none of the checkboxes.

If Blender shows you something that looks like this …

- Mask
- Z Transparency
- Raytrace

… you are expected to make a choice of just one of these options.

The Blender Interface Widgets

If Blender shows you something that looks like this …

- Intensity: 0.500

... you are expected to either left-click in the box and (keeping the left button down) drag the mouse left-right like a slider, or single-click in the box and type in a new value.

If Blender shows you something that looks like this …

- Space: World Space

... you are expected to click in the box and then select from the resulting list.

The Blender Interface Widgets

If Blender shows you an “Apply” button …

- Apply

... it means that you can click this button to get rid of your original model and replace it with a model that has the edits you have just made.

If Blender shows you this icon (with or without the word “Open” …

- New
- Open

... it means that you can click this button to open a file.

If Blender shows you something that looks like this …

... the red color is telling you that you haven’t yet entered enough information in this panel.

If Blender shows you something that looks like this …

- Copy Location

... you are expected to click in the box and select from a list of other objects in the scene.

The Blender Interface Widgets

If Blender shows you something that looks like this …

- Target:

... you are expected to click in the box and select from a list of other objects in the scene.

If Blender shows you something that looks like this …

... the red color is telling you that you haven’t yet entered enough information in this panel.

If Blender shows you something that looks like this …

- Target

- Copy Location

... you are expected to click in the box and select from a list of other objects in the scene.

If Blender shows you something that looks like this …

... the red color is telling you that you haven’t yet entered enough information in this panel.
The Blender Interface Widgets

If Blender shows you something that looks like this …

… it allows you to hide and unhide something (the Outliner is where you use this most often). Hiding an object is useful for decluttering your scene.

Hint #1: If you no longer want an object in the scene, hiding it for a while before deleting it is usually a good thing. It is surprising how often you need something not long after you deleted it.

Hint #2: If you hide something, don’t forget that you have hidden it. It is pretty freaky to be certain that you once created something, but now can’t find it anywhere in the scene.

The File Menu

- Start a new Blender scene (thus closing the scene you currently have open)
- Open a previously-created Blender scene (thus closing the scene you currently have open)
- Save the current scene in a file
- Bring elements from another Blender file into this scene
- Bring an image or object in from somewhere else
- Send an image or object to somewhere else

The Create and Add Menus

- Add Primitive
  - Plane
  - Cube
  - Circle
  - UV Sphere
  - Ico Sphere
  - Cylinder
  - Cone
  - Torus
  - Grid
  - Monkey
- Create
  - Text
  - Armature
  - Lattice
  - Empty
  - Speaker
  - Camera
- NURBS
  - NURBS Curve
  - NURBS Circle
  - Path
- Draw Curve
- Lamp:
  - Point
  - Sun
  - Spot
  - Hemi
  - Area
- Other:
  - Plane
  - Empty
  - Speaker
  - Camera
- 2018
- Add->Object

The Render Menu

- Render Image
- Render Animation
- OpenGL Render Image
- OpenGL Render Animation
- OpenGL Render Options
- Show/Hide Render View
- Play Rendered Animation
The Help Menu

The Spacebar Lets you Type Part of a Command in Order to Find It

The Difference Between New, Open, Link, and Append

New closes the scene you currently have, then initiates a new Blender scene.

Open closes the scene you currently have, then reads in a previously-stored Blender scene.

Append leaves the scene you currently have open, and adds elements of a previously-created scene into it.

Link is like Append, but every time you open the scene again, it will look at the file you are Linking from to see if changes have been made, and if so, will bring those into the scene instead of the first ones.

2. Viewing in 3D
**Computer Graphics**

### 3D Coordinate Systems

- **Left-handed**
- **Right-handed**

Blender uses this convention.

### The Coordinate and Viewing System

- Right-handed coordinate system
- \( X = \text{Red} \)
- \( Y = \text{Green} \)
- \( Z = \text{Blue} \)
- Middle mouse button (MMB) – orbit
- Shift MMB – pan
- Scroll wheel – zoom
- View → Left, Right, ...
- View → Toggle Quad View
- View → View Persp/Ortho

### The View Menu

The View Menu gives you access to lots of ways to change how you are viewing the scene.

### Toggling Between Perspective and Orthographic Views

- Perspective
- Orthographic

The “View Menu”
Toggling Between Perspective and Orthographic Views

In orthographic, lines that are parallel in 3D remain parallel on the screen. Objects appear to be the same size as they get farther away.

In perspective, lines that are parallel in the 3D depth direction appear to converge on the screen. Objects appear to get smaller as they get farther away.

Use perspective when you want a more realistic view (which is most of the time). Use orthographic to see if things separated in depth are the same size.

Single View vs. Quad View

Setting the Display Mode
3. Moving Things Around in 3D

Coordinate System Conventions

- Right-handed coordinates
- Right-handed rotation rule
- Angles are in degrees

Right-handed Rotation Rule

Selecting an Object to Work On

RMB-click on the object you want to select. It will then be highlighted with an orange outline.
Selecting Multiple Objects to Work On: Three Ways to Do This

1. Hold down the Shift key while RMB-clicking

2. Hit the ‘b’ key (“Border Select”) and LMB a rectangular region around objects

3. Hit the ‘c’ key (“Circle Select”) and roll the Scroll Wheel to create a circular region around objects

Moving Things By Clicking and Dragging

- Use the click-and-drag icons
- Use Global or Local Coordinate System

Local and Global Coordinates

Local Coordinates align with the object

Global Coordinates align with the screen

Saying How to Move Things by Using the Keyboard

- RMB click to select an object
- Grab ‘g’
- Rotate ‘r’
- Scale ‘s’
- Pick global axis ‘g’ → ‘x’, etc.
- Show global vs. local coordinates
- Pick local axis: ‘g’ → ‘x’ → ‘x’
- Pick all but a particular axis ‘g’ → ‘X’, ‘g’ → ‘X’ → ‘X’, etc.
- Transform a specific distance, angle, or scale ‘r’ → ‘x’ → 45 <return>

This is important – you will use this a lot!
You have probably noticed that when you click with the Left Mouse Button (LMB), a small target appears at that point, but doesn’t appear to be attached to anything.

This is Blender’s 3D Cursor.

With this, you can point anywhere in space, but it will take a click, a scene-rotate, and another click to do it.

For example, if you want to position the 3D Cursor at the corner of the cube indicated by the yellow dot, LMB click on it. But, upon rotating, you realize that it is at the wrong depth. So, get a view roughly 90° from the last view, and click again. You might have to do this a couple more times.

You can also automatically position the 3D Cursor using the Object→Snap menu.
A Use for the 3D Cursor – Arbitrary Pivot Point

Suppose you then wanted to rotate the cube about the yellow corner point. After positioning the 3D Cursor there, you would then go to the Pivot Center menu and select 3D Cursor. Rotations and Scaling will now take place around the yellow corner.

Later, you probably want to change the pivot point back to Median Point.

An Easier Way to Set the Arbitrary Pivot Point

Select the object, de-select the object (‘a’), tab to Edit Mode, select all vertices (‘a’) and translate them (‘g’).

In Edit mode, the pivot point stays put while the vertices move.

Tab back to Object mode, and rotate the object to confirm that the pivot point has changed.

In contrast, in Object Mode, the pivot point moves with the vertices.

The Outliner

In the upper-right portion of the screen is the Outliner. Like the name implies, it shows an outline of your scene.

It is sometimes nice to have a summary of the scene so you can remind yourself of what all is in it.

Also, if your scene is cluttered, you can select on object my clicking on its name in the outliner as opposed to selecting it in the scene.

Also, you can use the outliner to hide certain objects. Just click on the eye icon to hide/unhide.

Hint: If you hide something, don't forget that you have hidden it. It is pretty freaky to be certain that you once created something, but now can't find it anywhere in the scene.

4. Modeling, I
The Create Menu

These are all the different geometry things you can add into the scene. We will cover many of them, but not all. This group is the meshes. This group is the curves.

The Add Menu is also Useful

The Mesh Objects

Making the Mesh Objects Look Nicer

Blender is able to play a graphics trick to make your curved geometry look better. Go to the Object Tools tabs and select Tools. Scroll down, and click on Smooth.

This doesn’t actually change any geometry – it’s just a really good computer graphics display trick.
Duplicating an Object from the Tools Menu

Puts the new object right on top of the old object and leaves you in **Grab mode**. Just move the mouse to separate the two objects.

---

Editing a Vertex, Edge, or Face on a Mesh

Click here, or hit the **Tab** key, to get into **Edit Mode**

Select and edit:
- A vertex
- An edge
- A face

---

Editing a Vertex

Be sure you are in vertex-editing mode
- Right click on a vertex
- Hit ‘g’ (grab) and move the mouse
- You can also hit ‘x’, ‘y’, or ‘z’ to restrict motion

---

Editing a Vertex with Proportional Editing

Be sure you have Proportional Editing enabled
- Right click on a vertex
- Hit ‘g’ (grab) and move the mouse
- You can also hit ‘x’, ‘y’, or ‘z’ to restrict motion
- The mouse Scroll Wheel changes the size of the Circle of Influence
Subdividing and Smoothing Really Show the Difference Between Localized and Proportional Editing

Editing an Edge without Proportional Editing
- Be sure you are in edge-editing mode
- Right click on an edge
- Hit ‘g’ (grab) and move the mouse
- You can also hit ‘x’, ‘y’, or ‘z’ to restrict motion

Editing an Edge with Proportional Editing
- Be sure you have Proportional Editing enabled
- Right click on an edge
- Hit ‘g’ (grab) and move the mouse
- You can also hit ‘x’, ‘y’, or ‘z’ to restrict motion
- The mouse Scroll Wheel changes the size of the Circle of Influence

Editing a Face without Proportional Editing
- Be sure you are in edge-editing mode
- Right click on a face
- Hit ‘g’ (grab) and move the mouse
- You can also hit ‘x’, ‘y’, or ‘z’ to restrict motion
**Editing a Face with Proportional Editing**

Be sure you have Proportional Editing enabled.

Right click on a face.

Hit 'g' (grab) and move the mouse.

You can also hit 'x', 'y', or 'z' to restrict motion.

The mouse Scroll Wheel changes the size of the Circle of Influence.

---

**An Unexpected Use for Proportional Editing**

Create a Plane, then go to Edit Mode → Subdivide and subdivide it several times.

---

**An Unexpected Use for Proportional Editing**

Enable Proportional Editing, then go one widget to the right and change the kind of Proportional Editing from Smooth to Random.

---

**An Unexpected Use for Proportional Editing**

Go to Edit Mode, select a point, and lift it along with those around it.
An Unexpected Use for Proportional Editing

With Subdivision Surfaces

5. Appearance, I

The Button Properties Menu

The Material Menu
**Setting Diffuse and Specular Colors**

Clicking one of these brings up a color-selection dialog box.

![Material window](image)

**Color Scales**

- Red-Green-Blue
- Hue-Saturation-Value
- Hexadecimal

**RGB Color Scale**

Blender’s RGB scale lets you give the red, green, and blue components in the range 0. – 1.

Blender’s hexadecimal scale lets you give the red, green, and blue components in the range 00 00 00 – FF FF FF

**Hue-Saturation-Value (HSV) Color Scale**

Blender’s HSV scale lets you give the hue, saturation, and value components in the range 0. – 1.
Material Lighting – The Three Components

6. Modeling, II

Mirroring an Object

Offentimes you want to create an object that is identical to another object, but is symmetric about an axis. This type of operation is called mirroring.

Create an object that is tall and skinny, such as the cylinder below.

Let’s say that we want to mirror this object left-right (y). In Object Mode, select the Tools tab, click on Mirror, and hit the ‘y’ key.

Nothing happens! Why not?

Nothing happens! Why not? The Mirror tool works around the object’s local axes, not the global axes. Since this object is symmetric about its local y axis, you didn’t see any difference.

The trick is to turn the object’s position and rotation from local-axis-plus-transformations into local-axis-only. To do this, you need to Apply the transformations. Select Object → Apply → Rotation if you want to mirror just the rotation. Do this Object → Apply → Location if you also want to mirror the position. Do the Mirror operation again.

Before

After
First, make this model:
1. Create → Cylinder
2. Tab to Edit Mode → Tools → Subdivide

Suppose you want to select the entire middle row of points in order to “tighten the belt”. The Border Select (‘b’) is the obvious way to do this. But, there are two things you should do first:
1. Go to Orthographic display mode
2. Go into Transparent Picking mode

Let’s say that you have two objects and want to join them together so that you can act on them as one object.
Intentionally Joining Two Objects

Easy! Right-click on one, then Shift-Right-Click on the other, then hit Control-‘j’ ("join") on the keyboard. The orange "selection outline" now goes around both objects and the outliner shows just one object.

Accidentally Joining Two Objects

This is one of the most common errors when using Blender.

You’ve probably noticed that both Object Mode and Edit Mode have Create abilities in their Object Tools menu. They are not the same!

If you are in Object Mode, have an existing Object selected, and add a new one, they end up as two separate objects.

If you are in Edit Mode, have an existing Object selected, and add a new one, they end up Joined into a single object.

The moral is: always, always, always unselect an existing object before adding a new one! That will keep you out of trouble later.

Separating Objects By Loose Parts

Select the Joined object. Tab over to Edit Mode. Then hit the ‘p’ key ("Partition").

You will have three options on how to partition the joined object. If you select By Loose Parts, then the Joined object will be partitioned based on the original primitives that made it up.

Separating Objects By Loose Parts

Before

After
Separating Objects By Material

Select the Joined object. Tab over to Edit Mode. Then hit the ‘p’ key (stands for “Partition”).

You will have three options on how to partition the joined object. If you select **By Material**, then the Joined object will be partitioned based on the Material settings (i.e., the different colors) of the original primitives.

Before

After

Separating Objects By Selection

Select the Joined object. Tab over to Edit Mode. Then hit the ‘p’ key (stands for “Partition”).

You will have three options on how to partition the joined object. If you select **Selection**, then the Joined object will be partitioned based on what vertices, edges, and faces have been selected. Before selecting, you might want to turn the “invisibility” select option on.

Before

After
Inset Faces (aka, Offset Curves)

Often you want to create a "face-within-a-face". In Blender, this is called an Inset Face. (CAD systems often call this sort of thing an Offset Curve.)

In Edit Mode, select a Face.

You might have to unselect everything first ('a'). You might also have to click on the Select Faces button.

Now click on Inset Faces in the Object Tools menu.

Move the mouse to decide how much to offset the new ring-of-vertices from the existing ring-of-vertices. Hit Return when you are done.

You can now Grab, Rotate, and Scale the new inner face.

Vertex Groups

Using a group of vertices together is very useful. It is used for editing (like we are doing here), but also to pin certain vertices for cloth animation, to grow hair for hair simulation, and to rig objects for animation.

For that reason, Blender allows you to select the group and give them a name for later. This is called a Vertex Group.

1. Select the vertices in Edit Mode
2. Select Object Data
3. Under Vertex Groups, click the + to add a new one.
4. Double-click on whatever the default name is and type in a descriptive name for this Vertex Group
5. Click Assign

From now on, this group of vertices can be selected just by selecting the name from the list of Vertex Groups and clicking Select.
To create this model:
1. Create → Cube
2. Tab to Edit Mode → Tools → Subdivide → Subdivide

Suppose you want to select an entire row of faces in order to “fatten the belt.” You could select all the faces individually (RMB-click → Shift-RMB-click) or could Border Select (b) like before. But, here’s a better trick:
1. Click on one face in the row
2. Alt-RMB-click on another face down the row

Extruding Faces
Extrude Individual (cracks in between skyscrapers)
Extrude Region (no crack in between skyscrapers)

Shrink/Fatten and Push/Pull
Shrink/Fatten and Push/Pull are very much like extruding faces. Here are the differences:
Extruding lifts the selected faces along their normals. It leaves behind a “cliff” that connects them to the surrounding faces.
Shrink/Fatten lifts the selected faces along their normals, but leaves behind a “ramp” connecting those faces to the surrounding ones.
Push/Pull essentially scales the selected faces around their centroid.
For example, suppose we start with this object and these selected faces...


**Extrude, Shrink/Fatten, and Push/Pull**

<table>
<thead>
<tr>
<th></th>
<th>Extrude</th>
<th>Shrink/Fatten</th>
<th>Push/Pull</th>
</tr>
</thead>
<tbody>
<tr>
<td>Out</td>
<td><img src="#" alt="Image 1" /></td>
<td><img src="#" alt="Image 2" /></td>
<td><img src="#" alt="Image 3" /></td>
</tr>
<tr>
<td>In</td>
<td><img src="#" alt="Image 4" /></td>
<td><img src="#" alt="Image 5" /></td>
<td><img src="#" alt="Image 6" /></td>
</tr>
</tbody>
</table>

**Adding 3D Text**

To change the text string, go into Edit mode (here, or use the Tab key). The white rectangle acts as a text cursor. Backspace over “Text” and type your new text. The return key works.

**Changing the Style of 3D Text**

To change the style and alignment of 3D text, go back to Object Mode, then click on the Font button.

- **Offset**: make the letters wider
- **Extrude**: give the letters height
- **Depth**: bevel the top and bottom
- **Resolution**: round the bevel

**Changing the Style and Alignment of 3D Text**

- **Character style**
- **Horizontal and vertical character alignment**
The Button Properties Menu

This is the Button Properties Menu

- Render
- Layers
- World
- Scene
- Object
- Constraints
- Modifiers
- Data
- Texture
- Physics

The Constraints Menu

Copy Constraint

Forces one object to undergo the same translations, rotations, or scaling as another object does.

- Object being copied to
- Object being copied from
- Whether or not to maintain the same offset between the objects as they currently have
- Influence that the object being copied from has on the object being copied to (1.000 is an exact match, less than that causes the copied-to object to lag some)

Maintain Volume Constraint

When one dimension gets scaled, the other dimensions adjust automatically to maintain the volume of the object.

- Object this applies to
- Which axis doesn’t get distorted (in this case, you would scale in Z which would automatically scale X and Y)
- This is fun to play with!
- Its main use is in animation, where you might want an object to “squish” as it hits a wall or a floor.
Modifiers don’t actually change the object’s permanent geometry – just the object’s appearance on the screen. The geometry gets permanently changed when you click the Apply button.

Array Modifier

The Array Modifier is used to duplicate an object according to a particular pattern. Suppose we want to turn a block into a staircase. We start with the block and add an Array modifier.

How to decide how much duplication to do

The duplication count

How much to offset each duplication. It can be Constant, that is, based on a number of units. Or it can be Relative, that is, based on a number of size-of-this-object

Array Modifier to Make Stairs

Move each block in X and Z to make the next stair step

A More General Use of the Array Modifier

Start with a generic object and transform it:

In this case, the object is a cube, and the transform involves swinging it around a pivot
A More General Use of the Array Modifier

Now select the object to be Array’ed

This time do an Object Offset and specify the cube. Blender will apply the same transform to the selected object as was just applied to the cube.

Bevel Modifier

Apply button

How much to bevel

Smooth shading makes bevels look much better!

Remember Venn Diagrams (Boolean Operators)?

Two Overlapping Shapes

Union

Intersection

Difference

Booleans (also known as Constructive Solid Geometry)

Think of them as Venn diagrams in 3D!
Select the cube, click on Object Modifiers, and select the Modifier called **Boolean**.

1. **Select Difference, Union, or Intersect**
2. Select which object you want the cube to Boolean with
3. "Apply" means to get rid of your original model and replace it with the Boolean’ed one

**The Resolution of the Second Object Determines the Resolution of the Resulting Surface**

Hit ‘g’ (grab) and slide the cylinder away
**Decimate Modifier**

This modifier reduces the number of polygons in your object. It is really handy when you have imported an object and it has so much detail that you can’t interact with it well.

“Apply” means to get rid of your original model and replace it with the decimated one.

This sets the fraction of polygons you want to end up with.

How many polygons you are down to

**Original**

**Decimated**

**Subdivision Surface Modifier**

This modifier increases the number of polygons in your object. At the same time, it smooths your object out. Be careful! It very quickly increases your polygon count.

This controls how much to subdivide.

Fun: try it on a cube!

**Wireframe Modifier**

Turns each polygon into thick lines outlining each polygon.

How thick to make the thick lines

**Modifier Order Matters!**

Subdivision Surface, then Wireframe

Wireframe, then Subdivision Surface
Lattice Modifier – Creating the Lattice

Smoothly sculpting a many-vertex object is hard. Sculpting a box is easier. A Lattice is a box that you place around a piece of your geometry. You then sculpt the box and the geometry inside the box comes along for the ride. This will make more sense when you see the example.

We want to sculpt the bunny’s ear. To do this, we will surround the ear with a Lattice box and then sculpt it.

1. Create a Lattice object: Create → Lattice
2. Position it so that it surrounds the geometry you want to edit. You can either position it here, or you can position it with the usual translation, rotation, and scaling on-screen user interactions.

Lattice Modifier – Defining the Lattice Detail

We have a U of 2, a V of 2, and a W of 2.

Lattice Modifier – Connecting the Lattice to the Object

5. Select the object to be sculpted
6. Attach the Lattice to that object by creating a Lattice modifier
7. Specify the name of the lattice object to attach to this object
8. Don’t click Apply until you are done sculpting

Lattice Modifier – Edit the Lattice to Sculpt the Object

9. Select the Lattice object, tab into Edit mode, and edit its vertices
Importing Objects from Other Places

Select File → Import

- Collada = export format from game modeling systems
- Stl = 3D printer format
- 3ds = format from Autodesk 3D Studio
- Obj = Probably world’s most common export format (there are a ton of .obj models for free on the Internet!)

File = dino.obj
As-is, flat shaded

- Subdivision surfaced
- Smooth shaded

.obj files are also pretty straightforward to create. So, if you have a shape in mind and can write a computer program to generate it, you can write your own .obj file and Import it into Blender.
Exporting Objects to Other Places

Blender has a number of file formats it knows how to export to. If you are looking for a nice, general one to experiment with, try the .obj format.

Just be sure to use the Object Mode Tools menu to be in Smooth Mode first.

If you want texture coordinates exported, be sure to set them up before exporting.

In the export dialog, be sure to click on Write Normals and Triangulate Faces.

Layers

Like many CAD packages, Blender lets you group objects into "buckets" called Layers. There are 20 total layers you can use. Each object can be in any of the layers. Each object can be in multiple layers.

By default, each object starts out in Layer #1. To change this, select the object and hit the ‘m’ key. This brings up the Layers menu.

Click in a box to put the selected object into that layer. Putting the object into a new layer turns off the old layer. To put the object into multiple layers, hold down the Shift key while clicking.

Modeling Hint:

Permanently Applying Transformations to an Object

Many of Blender’s transformations are non-destructive, that is, the original model is intact and it just remembers what you’ve asked to have done with it.

Sometimes it would be nice to permanently apply the current set of transformations to the object.

To do that, use the Object → Apply menu.
**Hooks: A Modeling Aid**

If it would make your editing easier, you can group a collection of vertices together and move them as a single unit. This is called a **Hook**.

1. Select the vertices you want to edit as a group
2. Hit Control-h
3. Left-click **Hook to New Object**. This creates an Empty object to which those vertices are movement-constrained.

**Shape Keys: A Modeling Aid**

Shape keys are a way to do a variable morphing between two versions of the same object. The two (or more) instances must have the same number of vertices, but the vertices can (and should) be in different locations. Shape keys let you interpolate vertex coordinates between those instances.

1. Select the object
2. Click on **Object Data**
3. Under **Shape Keys**, click the plus sign +. This establishes the Basis shape.

4. Under **Shape Keys**, click the plus sign + again. Give the new Shape key a more descriptive name.
5. Now edit the original object by moving vertices, edges, or faces. Do this in Edit Mode.
6. When you're done editing, go back to Object Mode and change the Value slider. A Value of 0 gives you the Basis object. A Value of 1 gives you the edited object. Experiment with values in-between.
Shape Keys: A Modeling Aid

Normally, the Value slider should go between 0. and 1., but it doesn’t have to. By changing Value’s Min and max value beyond that range, you can do object extrapolation as well as interpolation.

Parent-Child Relationships in Modeling

Many times, one object is connected to another object. In modeling, this is called a Parent-Child relationship. (It is also sometimes called a Hierarchical Relationship.)

When the Parent moves, the Child moves with them.

When the Child moves, the Parent is unaffected.

This is really useful!

To do this in Blender:
1. RMB-click on the Child piece
2. Shift-RMB-click on the Parent piece
3. Hit Control-‘p’ on the keyboard

You can create as many levels of Parent-Child relationships as you want:

“The foot bone’s connected to the ankle bone, the ankle bone’s connected to the leg bone, the leg bone’s connected to the thigh bone…”

7. Rendering
“Rendering” is Blender’s process for creating really high-quality images.

Clicking on the Render button will allow you to set various rendering parameters. The one you care about the most is pixel resolution.

Anti-aliasing is a good-news bad-news joke.
- Good news: the scene looks much smoother
- Bad news: the scene takes longer to generate
- Good news: you probably want to do it anyway
The view that is rendered is not the same orientation that you see on the screen. It is from the **Camera position**, which needs to be set separately.

The **Camera**

Where the eye is looking towards

The “up vector”

The eye’s position

The camera is just like any other object in the scene.
1. It can be selected with a RMB click
2. It has its own local coordinate system attached to it.

Note the local coordinate system for the camera:
- X is to the right of where the eye is looking
- Y is the up-vector
- Z is opposite of where the eye is looking

This is useful to know. For example, to dolly the camera in or out, select it and then move it in its local coordinates:

'g' → 'z' → 'z'

Aligning The Camera to Your Current Screen View

But, if you like your current screen view and want to move the camera there, just do this:

View → Align View → Align Active Camera to View
Let's say that you are in Solid Shading Mode and your scene situation looks like this:

You now Render and get this:

Blech!

But why?

The answer is that Solid Shading Mode doesn't require your scene to be lit, but Rendering does. Texture Shading mode does want your scene to be lit, but if it isn't, even that won't let you know how bad your rendering is going to turn out:

To make this work, you need to Create and position some Lamps:

There are five types of Lamps that you can Add:

1. A Point Lamp shines light in all directions. The light is local to the scene. This is usually the best type of light to start out with.
2. A Sun Lamp appears to come from a single direction and its rays are parallel. This acts as if the light is very far away.
3. A Spot Lamp is like a Point Lamp, but only shines in one particular direction.
4. A Hemi Lamp is meant to emulate a cloudy day – light is coming from a glowing dome.
5. An Area Lamp is light coming from a finite surface, like most lights really are.
1. Get into Texture Shading Mode
2. Add a Point Lamp
3. Position the Lamp ("g").
4. The Point Lamp has no obvious local coordinate system, so it just uses the global coordinate system.
5. As you move the Lamp, you will see the lighting of the scene change.
6. You will probably have to rotate the scene (MMB) to get the position where you think it should be. Or, you can also use the Quad View mode.

This side is dark because the light has not been moved enough in X.

What the eye sees

$$E_e = L_e * M_e$$

What the material can reflect

$$E_R = L_R * M_R$$
$$E_G = L_G * M_G$$
$$E_B = L_B * M_B$$

Be sure this is clicked on in order to get shadows during the rendering.
In modeling, rendering, and animation, there are two major roles that lights play:

1. Key
2. Fill

Let's say we want to put a spotlight on the Monkey (and who doesn't?). We add a Spot Lamp. We position it over the Monkey and angle it down, like this. This is our “Key Light”. It does what we most want to do.

We render and get this.

The Key Light is working really well, but the rest of the scene is too dark. We now need to use one or more Fill Lights.

We add a Point Lamp and position it over the scene. Because we are in Texture Shading mode, we can interactively see when we have it positioned well. We render, and get this:

The scene looks much better. But, there are still two problems.

1. The rest of the scene is now bright enough that our “star” is no longer highlighted.
2. The Fill Light is casting another shadow which is distracting.

We lower its brightness.

So, we make two adjustments to our Fill Light:

- We lower its brightness.
- We force it to not cast shadows.
The Button Properties Menu

Set them up in this order:
1. Material
2. Textures

Material
Texture

In a Venn-diagram-sense, Blender considers texture-setting to be a sub-category in material-setting. Sometimes the texture completely hides the surface of the object, sometimes it lets the material color pop through in places. That’s why you do them in this order.

Blender has these Built-in Procedural Textures

I like this one

textures.blend

Procedural Texturing is using an equation to draw a pattern on a surface.

Preview both the texture and its mapping to the material

Each type of texture has its own parameters that are fun to play with

The default here is UV, but change it to Generated, Object, or Global.
The Material Color Acts as the Background Color
– here is where you set the Foreground Color
(This is down near the bottom of the Texture menu area. Keep scrolling. You’ll find it.)

Warning – you won’t see the effect of this until you do a Render.

Procedural Texturing – Geometry Influence
This says that you also want to use the texture to decide where and how much to move the geometry perpendicular (“normal”) to the surface of the sphere.

Image Texturing
Says that you want to read a texture image from a file
Choosing the proper projection is really important. Pick the type that most closely matches your object.

Most of the time you want objects to both cast and receive shadows, but you don't have to.
Z Transparency

Z-transparency basically blends foreground objects into background objects. It doesn’t do refraction, but it is fast!

Ray-traced Transparency does Refraction

Ray-traced transparency takes into account the Index of Refraction. You must do a Render to see this.

A Tale of Two Transparencies

Z-Transparency has no light bending due to refraction

Raytrace Transparency does bend light due to refraction

The Physics of Refraction

Snell’s Law of Refraction:
\[
\frac{\sin \theta_B}{\sin \theta_A} = \frac{n_A}{n_B}
\]

Material | Index of Refraction
---|---
Vacuum | 1.0000
Air | 1.0029
Ice | 1.309
Water | 1.333
Plexiglass | 1.49
Glass | 1.60
Diamond | 2.42

http://en.wikipedia.org/wiki/Refractive_index
Law of Reflection:

\[ \theta_r = \theta_i \]

How much light reflects (in this case it's set to 80%, which means that 20% of the object's original color comes through). You must do a Render to see this effect.

Subsurface Scattering

We could launch into a big mathematical discussion about what subsurface scattering is all about, but instead let's just look at before-and-after images.

Now, what do you think subsurface scattering does differently?
Subsurface Scattering

What material to emulate ("Skim Milk" is a reasonable first choice.) You must do a Render to see this effect.

Reflection, Refraction, and Subsurface Scattering Together

More fun than useful...

Another Type of Rendering

There is an additional internal renderer called Freestyle. Suppose you start with this scene:

Another Type of Rendering

You render it, and it looks like this:

Now, go to the Render button in the Button Menu and turn on Freestyle.
Freestyle Rendering

You render it, and now you get this:

The computer graphics world calls this Non-Photorealistic Rendering, or NPR. It is good for illustrations where you want to see objects and outlines more than you want to see realism.

Freestyle Rendering

If you look under the Rendering Layers button, you will find a lot of Freestyle adjustments that you can make.

And, Even One More Type of Rendering

There is a per-object rendering option called Wireframe. Suppose you start with this scene again:

And, Even One More Type of Rendering

Select one of the objects, go to the Modifiers and select Wireframe.
But, it’s more than just drawing lines! What Blender is really doing is to replace your edges with 4-sided polyhedra, so those edges really do have thickness.

If you’re in the Wireframe dialog box, you will find a lot of adjustments that you can make. Try increasing the thickness. Notice that, because these edges are real polygons, they can cast and receive shadows.

This shows up in the lower-left corner of Blender after you’ve rendered.
Saving a Rendered Image to a File

After you do Image → Save As Image, this will show up in the Object Tools menu on the left.

Saving a Rendered Image to a File

In addition to the usual File dialog box information, Blender will also ask you to specify an image file type. There are a bunch of possibilities for this, but know that JPEG and PNG are the two that are most supported by web browsers. This would let you place your image on a web page.

The exact items in the Dialog box change depending on the format you pick.

Quality lets you set the file size vs. image quality trade-off. In general, unless you are really concerned with making your image files small, keep the quality high.

If this slider says Compression, it means loss-less compression and any value should be OK. The default 90% is good.

There is an important trade-off between image file size and the image Quality you set. There is also a trade-off between image size and web page download time.

Importing an Image into PowerPoint

Importing an Image into HTML

Add this line to your HTML file:

```html
<img src="monkey.png">
```
It starts at the eye:

The pixel is painted the color of the nearest object that is hit.

It's also easy to see if this point lies in a shadow:

Fire another ray towards each light source. If the ray hits anything, then the point does not receive that light.

It's also easy to handle reflection

Fire another ray that represents the bounce from the reflection. Paint the pixel the color that this ray sees.

It's also easy to handle refraction

Fire another ray that represents the bend from the refraction. Paint the pixel the color that this ray sees.
9. Stereographics, I

Stereoscopy is not new – it’s been in common use since the 1950s. But, with virtual reality and 3D movies being so popular, stereoscopy has made a big comeback. And, you can get at it through Blender! For more information on stereoscopy, see: https://en.wikipedia.org/wiki/Stereoscopy

We Humans have Binocular Vision

In everyday living, part of our perception of depth comes from the slight difference in how our two eyes see the world around us. This is known as binocular vision. We care about this because computer graphics can simulate that slight viewing difference and thus create the binocular viewing of a synthetic scene.

Step #1 – Turn the Stereographics On – Do this First

Enable the Views checkbox and select Stereo 3D. You need to do this first. Be sure these are both checked.
Select your Camera (in the scene or in the Outliner) and then open the Camera Data menu. Any of these will work well. I’m kind of partial to Off-Axis or Tow-In.

Open the Object Properties menu (hit ‘n’ on the keyboard). This tells the Renderer to produce both a left and right view, and to make a red-cyan stereopair from them.

Open the Render menu. On the screen, the Rendered display will always be a Red-Cyan anaglyph. This menu controls how it will be drawn when you write a file after a Render.

Click on Stereo 3D. On the screen, the Rendered display will always be a Red-Cyan anaglyph. This menu controls how it will be drawn when you write a file after a Render.
Step #6 – (if you want)
Write out a Stereographics Image File

This assumes you have already done Steps #4 and #5.

How Deep does the Scene Appear to be into and out of the Computer Screen? Setting the Convergence Plane

The Convergence Plane is in front of the object – the object will appear to be inside the monitor.

The Convergence Plane is behind the object – the object will appear to be in the air in front of the monitor.

I like placing the Convergence Plane about 1/3 of the way through the object.

How Deep your Scene Appears to be into and out of the Computer Screen -- Setting the Convergence Plane

Select your Camera (in the scene or in the Outliner) and then open the Camera Data menu.

The Convergence Plane Distance controls how much the scene appears to exist behind or in front of the display screen.

Use a small distance to make the scene look like it is living in the monitor.

Use a larger distance to make the scene look like it is living in the air in front of the monitor. (Don't go too crazy with this – it will look less cool than you are expecting.)

There are many ways to display the correct view into the correct eye.

- Use polarized glasses to view the stereoscopic image.
- Use a special anaglyph viewer that converts the image into red/cyan.
- Use a polarization filter that only allows one eye to see the corresponding image.
10. Sculpting

Sculpting Options
There are actually many sculpting “brush” options. Click here to see them all.

Sculpting
- Radius of the brush
- Whether to add material or take it away
- Whether to add material on top of material
- Good values of the stroke

Smooth Sculpting
- Add material
- Subtract material

Use the DynaTopo option with Brush Detail to get a smooth sculpt like this.
Smooth Sculpting – How Does it Really Work?

With DynaTopo turned on, as you sculpt, Blender is dividing your surface into smaller and smaller triangles.
Particle System Examples

(Particles don’t have to actually be particles.)

Particles Bouncing Off Other Objects

You can make particles bounce off of other objects by declaring those other objects to be Collision-ready.

Select the object.

Click on its Physics button.

Click on Collision.

Set any Collision parameters you care to.
12. Physics Animation
Quick Explode

Quick Fur

Quick Smoke

The Button Properties Menu

This is the Button Properties Menu
There are Nine Types of Physics Simulations

Rigid Body Collision Example

Set this up using what you know about modeling. Slightly rotate the left-most domino to the right so that it will tip and start the sequence.

Let Blender Know You Want to do Rigid Body Physics

Tell the Object Tools which Objects will be Involved

For each object that will be pulled by gravity (the dominos and the ball), select it and click Add Active.

For each object that will not be pulled by gravity but will still be involved in the collisions (the floor), select it and click Add Passive.
Turn the Animation On

Or hit Alt-A to start the animation
Hit the Escape key to stop the animation

Setting Gravity

In order to do physics animations, Blender needs to have an idea of what Gravity is. The acceleration due to gravity near the surface of the earth is 9.81 meters/sec² (pointing down), which also equals 32.2 feet/sec².

You can set this by clicking on the Scene button and then scrolling down to the Gravity dialog area.

This is the default, but you can set Gravity to anything you want, including turning it off completely, or making it point upwards, or making it point sideways.

Gravity on Other Bodies

The acceleration due to gravity is not the same on all bodies. It depends on the mass of the body and its radius.

For fun, try setting gravity to what other bodies have in our solar system:

<table>
<thead>
<tr>
<th>Body</th>
<th>Gravity Acceleration (m/sec²)</th>
<th>g's</th>
</tr>
</thead>
<tbody>
<tr>
<td>Mercury</td>
<td>3.70</td>
<td>0.38</td>
</tr>
<tr>
<td>Venus</td>
<td>8.87</td>
<td>0.90</td>
</tr>
<tr>
<td>Earth</td>
<td>9.81</td>
<td>1.00</td>
</tr>
<tr>
<td>Moon</td>
<td>1.62</td>
<td>0.17</td>
</tr>
<tr>
<td>Mars</td>
<td>3.71</td>
<td>0.38</td>
</tr>
<tr>
<td>Jupiter</td>
<td>24.79</td>
<td>2.53</td>
</tr>
<tr>
<td>Saturn</td>
<td>10.44</td>
<td>1.06</td>
</tr>
<tr>
<td>Uranus</td>
<td>8.69</td>
<td>0.89</td>
</tr>
<tr>
<td>Neptune</td>
<td>11.15</td>
<td>1.14</td>
</tr>
</tbody>
</table>

Or, invent your own planet! Pick a different m/sec².

https://www.universetoday.com/35015/gravity-on-other-planets/
One really good use for Force Fields is to blow particles around this gets you to physics functions – one of which is the Force Field.

Ironically, one of the most useful objects is the one you can’t see. Blender calls this an Empty.

It’s invisible on the screen, but you can treat it like a real object, and can attach forces to it. These forces will influence the behavior of other objects.

Find the Empty under the Create tab on the Object Tools. When you click on it, this sub-menu pops up.

Add a Single Arrow Empty to the scene. Position it and orient it so that it is pointing at the particles.

Hint: it is easiest to position it in Global Coordinates (‘g’ → ‘x’) and easiest to rotate it in Local Coordinates (‘r’ → ‘x’ → ‘x’).

Now, with the Empty selected, click on:
- Physics
- Click Force Field
- And, under Type, select Wind

For this exercise, pick the Single Arrow.
Blowing the Particles

Turn on the animation (Control-‘a’). You can adjust the **Strength** of the Wind while the animation is playing to get just the effect you want.

Changing the **Strength** causes changes to these circles to let you know you are doing something.

Another Cool Thing: Modeling Cloth

Pixar

Modeling Cloth – Start with a Cube and a Grid

Modeling Cloth -- Enable Collision with the Cube

Select the cube, then go here. Then here.

You don’t need to set any other parameters (unless you want to)
Modeling Cloth – Subdivide the Grid into More Pieces

Select the grid, then select Modifiers. Then click Add Modifier and select Subdivision Surface.

Then, use these sliders to set how much subdivision to do on the screen (View) and when rendering (Render). Don’t go crazy with this – you want just enough subdivision to make this look good, but not so much that things slow down.

Modeling Cloth – Tell the Grid that it is Really a Piece of Cloth

Add a preset by selecting the plus sign (+). Then click on the up/down arrows to select a material. I like denim.

Modeling Cloth – Run the Animation

Alt-a

Baking the Cloth Animation

Why does the animation run so slowly? That is because it is computing the simulation while it is animating.

Instead, tell it to precompute the animation. You do this by selecting the Bake button (and waiting and waiting). Now try animating (Alt-a).
One of the many fun parts of cloth animation is pinning some of the vertices. There are lots of reasons to do this, such as to pin the edge of a flag to its flagpole, or to pin a cloth to a clothesline.

To do this, get into Edit Mode, select the vertices to be pinned, and create a Vertex Group from them. (This was described in more detail in the Modeling section of these notes).

Then, in the Cloth section of the Physics menu, turn Pinning on and select the name of the Vertex Group to be pinned.

When you re-animate, those vertices will be stationary.

This kicks off the rendering of all your animation frames in order.

Hint: if this is just a test render, and you have lots of time-consuming visual effects going on, you might cut down the resolution and/or the number of rendered frames to speed things up.

This brings up a separate window and plays back your animation.
Setting up a Fluids Simulation – Create at Least Three Objects

Everything here is drawn in wireframe so you can see it all. The Domain usually hides everything else.

The **Domain** – in how large a volume the fluid can flow around in

The **Fluid** – glob of fluid to start with

The **Obstacle(s)** – what the fluid can hit, but not pass through

Everything here is drawn in wireframe so you can see it all. The Domain usually hides everything else.

Setting up a Fluids Simulation

- Select the **Domain** object
- Click on the **Physics** button, then select **Fluid**, then select **Domain**

Setting up a Fluids Simulation

- Select the **Fluid** object
- Click on the **Physics** button, then select **Fluid**, then select **Fluid**

Setting up a Fluids Simulation

- Select the **Obstacle(s)** object(s)
- Click on the **Physics** button, then select **Fluid**, then select **Obstacle**
Starting the Fluids Simulation

Select the Domain object, then click on Bake. The status bar will count up to 100%.

You will then have an animation playing. Hit Escape to stop it.

Playing the Animation

Select here to start the animation playing. Hit Escape to stop it.

Rendering a Fluids Simulation

You can also render the animation. Click on Render Animation, watch the bar count up, then click on Play Rendered Animation

You Can Also Set Transparency and Reflection

Like all Renders, don't forget to set the camera and the lights
13. Keyframe Animation

Clicking on the Render button will allow you to set various animation parameters. The one you care about the most is the End Frame number.

Setting Up a Keyframe Animation

Go to the Default box at the top of the Blender window, bring up the pull-down menu, and change the Default window configuration to Animation.
Setting Up a Keyframe Animation

This makes your screen look like this. These new sections are:
- **Dope sheet** – ignore this for now.
- **Graph Window** – will let us sculpt the animation curves.
- **Timeline Window** – keeps track of what frame number we are on.

Specifying the First Keyframe

1. Position the cube off to the edge in the -Y direction.
2. Hit the 'i' key to insert a keyframe.
3. When you do that, this box pops up. Select **Location** from the pop-up menu.

Specifying the Last Keyframe

1. Slide the vertical green line up to Frame #100.
2. Position the cube off to the edge in the +Y direction.
3. Hit the 'i' key to insert a keyframe.
4. Again, select **Location** from the pop-up menu.

The Graph Editor Window

Your Graph Editor window should now look about like this.

Note that Blender has filled in the in-between Y values for you between Frame #0 and Frame #100. (This is called “In-Betweening.”) Also notice that Blender has smoothed out the values of Y so that the cube starts from rest, speeds up, slows down, and then glides to a stop.
The Graph Editor Window

Click on the triangle next to Location. This gives you access to all three Location curves. Clicking on the eye toggles whether or not you can see a curve. Clicking on the name of the curve makes that the current curve. You can then edit it.

A Smooth Interpolation Curve

In this case, this type of smooth curve makes a lot of sense – the object starts from a slope (speed) of 0, and ends with a slope (speed) of 0.

The slope of the curve is its speed at that point.

A Smooth Interpolation Curve

While we’re at it, let’s take a closer look at this curve. It starts at one value, ends at another value, and its slope (speed) is 0 at both ends. The idea of a smooth interpolation curve like this is common to a lot of computer graphics applications. It’s a good basic equation to have. It’s equation is:

\[ y = 3x^2 - 2x^3 \]

0. ≤ x ≤ 1.

0. ≤ y ≤ 1.

The Graph Editor Window

Shortcuts when the cursor is in the Graph Window:

<table>
<thead>
<tr>
<th>Shortcut</th>
<th>What it does</th>
</tr>
</thead>
<tbody>
<tr>
<td>Control-LMB</td>
<td>Adds a keyframe to the current curve</td>
</tr>
<tr>
<td>RMB</td>
<td>Select a keyframe dot</td>
</tr>
<tr>
<td>Scroll wheel</td>
<td>Zoom in and out of the Graph</td>
</tr>
<tr>
<td>MMB</td>
<td>Pan the Graph</td>
</tr>
<tr>
<td>Shift-scroll wheel</td>
<td>Pan just in Time (horizontal)</td>
</tr>
<tr>
<td>Alt-scroll wheel</td>
<td>Pan just in Value (vertical)</td>
</tr>
<tr>
<td>Control-MMB</td>
<td>Scale in Time</td>
</tr>
</tbody>
</table>
Let's give the box a “hop-up” in the middle of the animation. Make it so we can see the Z Location curve, and make it current. Control-LMB out in the curve somewhere to add a keyframe here.

RMB-click the newly-added keyframe dot and lift it up. Blender creates a smooth hop for you. Try the animation (Alt-'a' from the 3D window).

In this attempt, the hop was too high, and lasted for the entire animation sequence (hardly a "hop"). RMB-click on the keyframe dot and lower it. To make the hop more localized, add two more keyframes (Control-LMB) and push them in towards the center.

Hit the ‘n’ key. Like in the 3D View, a Number Panel pops up. Scroll down and click on Add Modifier.
From the list of Modifiers, select Noise.

Try adjusting each of these and then run the animation. Can you describe what these two inputs do based on what you observed?

To avoid a collision, the money jumps up and the cube squishes

Cameras and Lamps are just like any other object. As you have seen, they can be positioned. They can also be keyframe-animated. Like other objects, just select them and hit the 'i' key to insert a keyframe.
Animating (almost) Any Parameter

One of the many cool things about Blender is that you can do more than just keyframe-animate the objects, you can also keyframe-animate the parameters you are setting. For example, suppose you want to animate the Specular Hardness (hey, it could happen). To set a keyframe for this, right click on the Hardness slider and select Insert Keyframe from the pop-up menu.

Animating a Human-ish Form

Start with this … and turn it into a Blender model:

model.blend

But, it's more than just a collection of parts!

Be sure that the origins of the different parts are where you want the part to pivot around.

Then establish the proper parent-child relationships.

Now tell Blender to do all rotations around each part's origin

Selecting this … causes object rotation to happen about the previously-set origin.
Now try rotating the individual parts. Be sure you are rotating in local coordinates, e.g., ‘r’-‘y’-‘y’.

It’s helpful if the axes are set to show the local coordinates.

There is a time-honored tradition in stop-motion animation to use an internal support, called an armature, to help position the object at each frame.

Digital animation has adopted the same technique, and has even retained the same terminology, armature.

The process of creating this digital armature is referred to as Rigging.

Let’s say we have a cheesy noodle character named Mac. We would like to rig him to bend.

The first step is to create Mac’s geometry. In this case, one cylinder was Boolean-subtracted from another.

The second step is to go to the Create tab on the Object Tools and click on Armature. This brings up the sub-menu here.

Grab it just like you would any other object and position it next to Mac. This is what the pieces of a Blender armature look like. The three sections of one of these bones are the root, the body, and the tip.
Rigging for Animation

We could put lots of bones in place to animate Mac, but, for simplicity we will just use two.

Select (right-click) the bone, tab into Edit Mode, then select Extrude. This will add a second bone on top of the first and connect them tip-to-root. Move the mouse to make the second bone actually show up. Grab and move its tip around some to make it parallel to the first bone and about that same size.

In the Outliner, you can see the bones you have created. (You might have to click the circled plus signs to expand the tree.)

When you click the Armature Properties button, a bunch of new information comes up. The most important for right now is in the Display panel:

- Display
- Object Data
- Names
- Show
- Hide
- Delete

Try these. They change the appearance of the Bones.

Click on Names. It puts the name of the Bone next to it so you know which one is which.

It's always good to name your Bones. In the Outliner, double-left-click on Bone.001 and rename it Top. Double-left-click on Bone and rename it Bottom. Your display now looks like this:

Also, in the Properties buttons, you will see that there is now an Armature Button.
We next need to make the armature a Parent and the object (i.e., Mac) its Child. Select Mac (right-click) and then include-select the armature (shift-right-click). (The order is important!)

To create the Parent-Child relationship, hit Control-P. In the pop-up menu, select Armature Deform With Automatic Weights.

There are two ways to know that the parenting worked. A dashed line will go from the Armature to Mac and the Outliner will show that Mac is part of the Armature.

Almost there – the last step is to assign which vertices on Mac will be deformed by the Bottom Bone and which will be deformed by the Top Bone. These groups do not need to be mutually exclusive – they can have vertices in common.

Earlier in these notes we talked about selecting multiple vertices and Vertex Groups. We are going to do that again. We are going to put some of Mac’s vertices into a Vertex Group called Bottom, and some into a Vertex Group called Top. These must match the names of the respective Bones exactly.

1. Tab into Edit Mode
2. Select View → Persp/Ortho to place yourself in orthographic display mode
3. Turn on the transparency button
4. Hit ‘a’ to unselect everything
5. Use the Border Select to select the top 2/3 of Mac’s vertices
6. Create a Vertex Group with them called Top
7. Hit ‘a’ to unselect everything
8. Use the Border Select to select the bottom 2/3 of Mac’s vertices
9. Create a Vertex Group with them called Bottom

Select the armature and go to Pose Mode. Select the different Bones and try grabbing, rotating, and scaling them. Obviously, a serious Mac animation will require more than two Bones! Bone transformation can be keyframed just like transformation parameters of any other object.
Cutting Down the Resolution and/or the Number of Frames

Changes the image resolution as a percent of "big." Preserves the same aspect ratio too.

Renders every frame, every other frame, every third frame, etc. Preserves the same Start and End frame, but cuts down the total number.

Rendering an Animation to a File

Before kicking off the animation rendering, you need to specify the file name to put the animation into C:\tmp\mjb.avi and the type of file that it is to be.

Rendering an Animation to a File

Here are the animation file types that Blender supports.

<table>
<thead>
<tr>
<th>Movie File Type</th>
<th>File Size</th>
<th>Displayed?</th>
<th>Import into PowerPoint?</th>
</tr>
</thead>
<tbody>
<tr>
<td>AVI JPEG</td>
<td>Didn’t work</td>
<td></td>
<td></td>
</tr>
<tr>
<td>AVI Raw</td>
<td>148 MB</td>
<td>Yes</td>
<td>Yes</td>
</tr>
<tr>
<td>Frame Server</td>
<td>Didn’t work</td>
<td></td>
<td></td>
</tr>
<tr>
<td>H.264 AVI</td>
<td>96 KB</td>
<td>Yes</td>
<td>Yes</td>
</tr>
<tr>
<td>MPEG</td>
<td>164 KB</td>
<td>Yes</td>
<td>Yes</td>
</tr>
<tr>
<td>Ogg Theora</td>
<td>48 KB</td>
<td>Yes</td>
<td>No</td>
</tr>
<tr>
<td>Xvid AVI</td>
<td>124 KB</td>
<td>Yes</td>
<td>Yes</td>
</tr>
</tbody>
</table>

Note: this scene is simple and compresses well. The mileage you get may vary.

Importing an Animation into YouTube

YouTube accepts videos in AVI and MPEG formats.
### Importing an Animation into PowerPoint

<table>
<thead>
<tr>
<th>Movie File Type</th>
<th>File Size</th>
<th>Displayed?</th>
<th>Import into PowerPoint?</th>
</tr>
</thead>
<tbody>
<tr>
<td>AVI JPEG</td>
<td>Didn’t work</td>
<td></td>
<td></td>
</tr>
<tr>
<td>AVI Raw</td>
<td>148 MB</td>
<td>Yes</td>
<td>Yes</td>
</tr>
<tr>
<td>Frame Server</td>
<td>Didn’t work</td>
<td></td>
<td></td>
</tr>
<tr>
<td>H.264 AVI</td>
<td>96 KB</td>
<td>Yes</td>
<td>Yes</td>
</tr>
<tr>
<td>MPEG</td>
<td>164 KB</td>
<td>Yes</td>
<td>Yes</td>
</tr>
<tr>
<td>Ogg Theora</td>
<td>48 KB</td>
<td>Yes</td>
<td>No</td>
</tr>
<tr>
<td>Quick AVI</td>
<td>124 KB</td>
<td>Yes</td>
<td>Yes</td>
</tr>
</tbody>
</table>

### Animation Tricks

1. In this example, we added the first keyframe, then the last keyframe, then three keyframes in the middle. Sometimes it is easiest to work that way. Other times it is easier to add them in sequential order.

2. Sometimes it is easier if you initially add a bunch of duplications of the object in various positions to get a feel for the motion, edit those positions as you see fit, and then use them as keyframe positions.

3. Extending from each keyframe dot is a line. That line can be twisted to change the slope of the curve at that keyframe. Select the dots at the end of that line and move them.

4. The Camera position and the Lamps can be animated too. For each, define an Empty object, force the Camera or Lamp to follow it (it’s one of the Constraints), then animate the Empty. Be sure to give the Empty a descriptive name – all Empties look alike.

### John Lasseter’s Principles of Animation

1. **Squash and Stretch** -- Defining the rigidity and mass of an object by distorting its shape during an action.
2. **Timing** -- Spacing actions to define the weight and size of objects and the personality of characters.
3. **Anticipation** -- The preparation for an action.
4. **Staging** -- Presenting an idea so that it is unmistakably clear.
5. **Follow Through and Overlapping Action** -- The termination of an action and establishing its relationship to the next action.
6. **Straight Ahead Action and Pose-To-Pose Action** -- The two contrasting approaches to the creation of movement.
7. **Slow In and Out** -- The spacing of the inbetween frames to achieve subtlety of timing and movement.
8. **Arches** -- The visual path of action for natural movement.
9. **Exaggeration** -- Accentuating the essence of an idea via the design and the action.
10. **Secondary Action** -- The action of an object resulting from another action.
11. **Appeal** -- Creating a design or an action that the audience enjoys watching.

---


---

14. **3D Printing**
The Process

"3D Printing" is defined by some sort of "additive" process. The current frenzy in 3D Printing consists mostly of systems that deposit layers of molten plastic:

```
<table>
<thead>
<tr>
<th>solid</th>
</tr>
</thead>
<tbody>
<tr>
<td>facet normal 0.00 0.00 -1.00</td>
</tr>
<tr>
<td>outer loop</td>
</tr>
<tr>
<td>vertex -2.000000 -2.000000 0.250000</td>
</tr>
<tr>
<td>vertex -1.980000 -1.980000 0.250000</td>
</tr>
<tr>
<td>vertex -1.980000 -2.000000 0.250000</td>
</tr>
<tr>
<td>endloop</td>
</tr>
<tr>
<td>endfacet</td>
</tr>
<tr>
<td>facet normal 0.00 0.00 -1.00</td>
</tr>
<tr>
<td>outer loop</td>
</tr>
<tr>
<td>vertex -2.000000 -2.000000 0.250000</td>
</tr>
<tr>
<td>vertex -2.000000 -1.980000 0.250000</td>
</tr>
<tr>
<td>vertex -1.980000 -1.980000 0.250000</td>
</tr>
<tr>
<td>endloop</td>
</tr>
<tr>
<td>endfacet</td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td>endsolid</td>
</tr>
</tbody>
</table>
```

The 3D Printing Geometry File

3D Printers are fed a file called an "STL File", which lists all the triangles in the object. Blender (as well as all CAD systems) can produce this type of file for you.

Object Rules for 3D Printing

1. The object must be a mesh and **consist only of triangles**.
2. The object must be a legal solid. It must have a definite inside and a definite outside. It can’t have any missing face pieces.
The Simplified Euler's Formula* for Legal Solids

\[ F - E + V = 2 \]

*sometimes called the Euler-Poincaré formula

For a cube, \( 6 - 12 + 8 = 2 \)

The full formula is:

\[ F - E + V - L = 2(B - G) \]

Watches Out for Overhangs!

Some 3D printers handle this by leaving unused material in place to support the overhangs.

Some 3D printers handle this by using software to add "support structures" to the overhangs.

Some 3D printers handle this better than others...

Object Rules for 3D Printing

3. You can't make an object by simply overlapping two objects in 3D. If you want both shapes together, do a Boolean union on them so that they become one complete object.
What Happens if You Do Overlap Objects?

Here’s what one of the 3D Printers in the OSU Library did:

Overlapped in 3D

Boolean union

Not bad – it could have been lots worse …

Object Rules for 3D Printing

4. Each edge in the mesh must bound 2 and only 2 triangles (this is known as the Vertex-to-Vertex Rule)

Blender’s 3D Printing Options show up as a Tab in the Object Tools Menu

...but only if it’s installed properly ...

Blender’s 3D Printing Options aren’t there by Default

By default, Blender doesn’t let you see its 3D Printing options. You need to tell Blender to turn these on.

If you are on a system that doesn’t show a 3D Printing option in the Object Tools tabs, do this:

1. Click File → User Preferences
2. Click on the Addons tab and on these Support Levels
3. Scroll down to the Mesh Addons, or click on Mesh

4. Click the **Mesh: 3D Print Toolbox**

Options for 3D Printing

Objects destined for 3D Printing must be "legal solids". Clicking on **Check All** will try to determine if that is true.

The **Check All** output is here. You might have to scroll down to see it.
The fact that all of these are zero is good. Any of them being non-zero would probably mean that your object cannot be 3D-printed, or at least will not be 3D-printed well.

An overhang face is not necessarily a bad thing. The entire bottom of the part will consist of, by necessity, overhang faces. However, overhang faces that are not on the bottom of the part could be a problem.

Non-planar faces can be fixed by clicking here. Blender then turns those non-planar quadrilaterals into triangles. You can click on Check All to confirm this.

To export an STL file for 3D Printing:
1. Click here and select a folder for the file
2. Click here to write the file

“STL” stands for Stereolithography. .stl is the most common 3D printing file format.
Want to see 3D Printing in Action?

OSU's library has 3D Printers for use by OSU students. To see them via webcam, go to: http://webcam.oregonstate.edu/3dprinter

Click here to see the live, streaming view.

15. Vertex Painting

Setting up for Vertex Painting

1. Create an object (a UV Sphere is nice).
2. Add a Subdivision Surface modifier to it to give it more vertices. In the Subdivision Surface menu, click Apply to make those vertices permanent.
3. Give it a new Material and turn on Vertex Color Paint.
4. Change from Object Mode to Vertex Paint mode.
A Word on Brush Size

Note: the brush size does not scale with zooming in or out. It stays the same size.

How Does Vertex Painting Work?

The "paintbrush" only drops "paint" when a vertex gets inside the circle brush. This means that the paint does not smear along a nice line, but looks splotchy like this.

How Do We Make it Less Splotchy?

1. Make the object look smaller. That way more vertices will end up inside the brush circle.
2. Use Subdivision Surfaces to add more vertices

How Do We Make it Less Splotchy?

3. Use the sculpting DynaTopo (with Brush Detail) to add more vertices where you want to paint.
16. Cycles Rendering

What is Cycles?

Cycles is a new renderer recently added to Blender. Its resulting images are generally more realistic than ray-tracing, or at least has certain realistic effects, such as soft shadows, depth of field, motion blur, caustics, ambient occlusion, and indirect lighting that ray-tracing has a hard time creating.

All of the light arriving at a particular point in the scene is then modified by characteristics of the object’s material using a mathematical function known as the Bidirectional Reflectance Distribution Function (BRDF) to reflect some of that light towards your eye.

One of the great reasons to experiment with Cycles is that it is implemented in Blender using the compute power of the graphics card (if you have an NVIDIA card) and can be accomplished semi-interactively. That is, the render takes place as you are modifying the scene, not waiting for you to hit the F12 key.

For more information on Path Tracing, see: https://en.wikipedia.org/wiki/Path_tracing

Step #1: Change the Renderer from Blender Render to Cycles Render

This pull-down menu is at the top of the Blender screen.
**Step #2: Turn on CUDA**

CUDA is NVIDIA’s Compute Unified Device Architecture, a way to run programs on the super-fast graphics card.

1. Click on the System tab
2. Click on CUDA
3. Click on Save User Settings

**Step #3: Enable GPU Computing**

- Select GPU Compute

**Step #4: Set the Sampling Values Higher**

- Increase the number of samples in the Sampling settings.
Step #5: Make a New Scene and Set the Materials

Make a new scene using the Create tab, just like you have done before.

When you go to set the Material, you will see a different menu than you did when using Blender Renderer.

Set the color here.

This tab is used to set the BSDF of the material, that is, how it reacts to light being shined on it. Path Tracing has complicated parameters, so rather than make you set them all, Blender gives you a choice of “descriptions”. (see next page)
When you interact with the scene or the objects in it, Cycles does a fast, crude scene render at first, then gradually fills in the missing pixels. In computer graphics, this is known as Progressive Refinement.

Why a Second Chapter on Stereographics? This will get you into Virtual Reality!

In this section, you will see how to generate dynamic stereographics for your phone inside a VR headset.

The process is a little involved, but, if you do it, you will discover that it is well worth it!

This has a very high Coolness-Factor.
You must be using the Cycles Renderer

The first trick is that you must be using the Cycles Renderer. Select it at the top of the screen.

This is the scene from our previous notes on using the Cycles Renderer. Elements of the scene have been duplicated to give us more to look around in.

Set the Rendering Image Size to have an Aspect Ratio of 2:1

Set the rendering image resolution to an aspect ratio of 2:1.

Position the Camera into the Scene

Select the Camera and move it (drag its colored axes) to place it in the center of the scene.

Then, make it point horizontally by setting its Rotation angles to 90°, 0°, and -90°.

If you don’t see this dialog box, hit the ‘n’ key.

Let Blender know that you are doing Stereo 3D

In the Display › Views menu, turn on the checkbox and turn on Stereo 3D.
In the Stereoscopy menu, click Left to eliminate any distracting red-cyan imagery. If you don’t see this dialog, hit the ‘n’ key.

But, we only want to work with the Left eye view for now.

Set the Perspective Field-of-View Angle

With the Camera selected, click the Camera Settings button and set the Perspective Field of View to 90°.

Set a Panoramic Lens with Type Equirectangular

With the Camera selected, click the Camera Settings button, select the Panoramic button, and set the Type to Equirectangular.

What is “equirectangular”, anyway? It is a standard map projection that maps longitude lines to vertical lines of constant spacing, and latitude lines to horizontal lines of constant spacing. It’s a handy way to represent images for computer graphics.

Set the Convergence Plane

Set the Camera’s Convergence Plane Distance to a distance that touches the outer objects in the scene.

You can see the Convergence Plane as a translucent sheet.
Ask for Spherical Stereo Rendering

Turn on the Camera’s **Spherical Stereo** rendering.

This is what Spherical Rendering will look like. The partial cube on the left and the partial cube on the right are the same cube!

Set the Depth of Field Aperture

Scroll down some more in the Camera Settings menu until you find **Depth of Field**. Set the **Radius Size** to 0. to keep any of your scene from becoming fuzzy.

Render the Spherical Panoramic Scene

Render the scene (F12). A Panoramic Spherical Projection looks like this

Save the Image

Image → Save As Image

Then select:
- JPEG
- High quality (>= 90%)
- Stereo 3D
- Top-Bottom
Here’s What the Image Looks Like

Left Eye View

Right Eye View

Here’s How to View this in VR on your Phone

Go to: http://vrais.io

VRAIS stands for:
• VR – Awesome In Space
• It’s also the French word for “true”

If you’ve already registered, sign in here.
If not, sign up here.

Here’s How to View this in VR on your Phone

Go to: http://vrais.io

VRAIS stands for:
• VR – Awesome In Space
• It’s also the French word for “true”

If you’ve already registered, sign in here.
If not, sign up here.

Uploading your Image into the VRAIS Cloud Server

Click here and Browse to your JPEG file.
Click Upload.
Supply the Title, Description, and Convergence distance.
If you don’t remember your Convergence distance, don’t worry about it.

Uploading your Image into the VRAIS Cloud Server

The VRAIS app exists for both Android and iOS. Load it on your phone. Run it and login with the same information you registered on the VRAIS web site.

True
Not sure why it says this. My phone indeed has a gyroscope, and in a moment, this app will successfully use it.

Click here to move on
Viewing on Your Phone

You will see this welcoming screen. Swipe a couple of times to the right until you see Your Images screen. Click on the image you want to load. Be patient – it might take a few seconds.

Viewing in a VR Headset

You get this stereopair. If you rotate your phone, you see that the view changes to look in that direction.

If you have a viewer, plug your phone into it.

Voila! (that’s the French word for “voila” 😊)

Here’s How to Get a VR Headset

Go to http://amazon.com and enter: View-Master

Here is the Mattel View-Master Deluxe VR Viewer. It sells for under $25. Mine is an earlier model of this one, and I am very happy with it. I trust View-Master to get the mechanical design and the optics right. They’ve been doing this for years.

But, really, anything that claims to be compatible with Google Cardboard should work.

18. References
Blender References

http://cs.oregonstate.edu/~mjb/blender
http://blender.org
http://www.blender.org/education-help/
http://www.blenderguru.com/


I think this is the best of the Blender books