Camp Blender

http://cs.oregonstate.edu/~mjb/blender
# Blender Shortcuts You Will Use a Lot

<table>
<thead>
<tr>
<th>Shortcut</th>
<th>What it Does</th>
</tr>
</thead>
<tbody>
<tr>
<td>LMB</td>
<td>Select something</td>
</tr>
<tr>
<td>Shift-LMB</td>
<td>Add something else to the selection</td>
</tr>
<tr>
<td>MMB</td>
<td>Rotate the scene</td>
</tr>
<tr>
<td>Shift-MMB</td>
<td>Pan the scene</td>
</tr>
<tr>
<td>Scroll Wheel</td>
<td>Zoom in and out</td>
</tr>
<tr>
<td>Tab</td>
<td>Toggle between Object Mode and Edit Mode</td>
</tr>
<tr>
<td>Control-Tab</td>
<td>Bring up Mode <a href="#">pie menu</a></td>
</tr>
<tr>
<td>` (back quote)</td>
<td>Bring up View <a href="#">pie menu</a></td>
</tr>
<tr>
<td>a</td>
<td>Select all</td>
</tr>
<tr>
<td>Click in empty space</td>
<td>Unselect all</td>
</tr>
<tr>
<td>Alt-a</td>
<td>Unselect all</td>
</tr>
<tr>
<td>Escape</td>
<td>Get you out of almost anything (including stopping a render or an animation)</td>
</tr>
<tr>
<td>b, c</td>
<td>Box or circle select</td>
</tr>
<tr>
<td>Shift-d</td>
<td>Duplicate</td>
</tr>
<tr>
<td>e</td>
<td>Extrude (in edit mode)</td>
</tr>
<tr>
<td>F3</td>
<td>Search</td>
</tr>
<tr>
<td>g</td>
<td>Grab (translate) an object</td>
</tr>
</tbody>
</table>
# Blender Shortcuts You Will Use a Lot

<table>
<thead>
<tr>
<th>Shortcut</th>
<th>What it Does</th>
</tr>
</thead>
<tbody>
<tr>
<td>Shift-g</td>
<td>Group</td>
</tr>
<tr>
<td>i</td>
<td>Insert a keyframe</td>
</tr>
<tr>
<td>Control-j</td>
<td>Join 2 or more objects</td>
</tr>
<tr>
<td>m</td>
<td>Send object to a collection (layer)</td>
</tr>
<tr>
<td>n</td>
<td>Toggle the Sidebar menu</td>
</tr>
<tr>
<td>Shift-n</td>
<td>Recalculate normals</td>
</tr>
<tr>
<td>p</td>
<td>Partition (only in edit mode)</td>
</tr>
<tr>
<td>Control-p</td>
<td>Establish a parent-child relationship (last object selected will be the parent)</td>
</tr>
<tr>
<td>Alt-p</td>
<td>Destroy a parent-child relationship</td>
</tr>
<tr>
<td>Control-Alt-q</td>
<td>Toggle quad viewing</td>
</tr>
<tr>
<td>r</td>
<td>Rotate an object</td>
</tr>
<tr>
<td>s</td>
<td>Scale an object</td>
</tr>
<tr>
<td>Shift-s</td>
<td><strong>Pie menu</strong> for using the 3D Cursor</td>
</tr>
<tr>
<td>Spacebar</td>
<td>Start / Pause an animation</td>
</tr>
<tr>
<td>t</td>
<td>Toggle the Object Tools menu</td>
</tr>
<tr>
<td>x</td>
<td>Delete whatever is selected</td>
</tr>
<tr>
<td>z</td>
<td>Bring up a display mode pie menu</td>
</tr>
<tr>
<td>Control-z</td>
<td>Undo</td>
</tr>
<tr>
<td>Alt-z</td>
<td>Toggle x-ray mode</td>
</tr>
<tr>
<td>Control-Shift-z</td>
<td>Redo</td>
</tr>
<tr>
<td>F12</td>
<td>Render a scene image</td>
</tr>
<tr>
<td>F11</td>
<td>Return to the interactive scene</td>
</tr>
</tbody>
</table>
What is Blender?

Blender is a free program that lets you do professional-looking modeling, rendering, and animation.

You can get Blender for yourself by going to the web site: http://www.blender.org

Note: The version number changes often. These notes were written against Blender version 2.8.3.
Next Gen – a Blender-Animated Movie

See the trailer at: https://www.netflix.com/title/80988892
Blender has thousands of buttons you can press. It is difficult to understand them all. These notes are here to show you what certain combinations of buttons do in order to learn them, and to remind you later when you’ve forgotten.
In these notes, what do these icons mean?

They tell you that if you go to our notes web site:

http://cs.oregonstate.edu/~mjb/blender

you will find Blender input files (*.blend), texture map files (*.bmp), and animation movie files (*.mp4).

You can read a .blend file right into Blender (File → Open) so that you can experiment with these examples without having to first create them yourself.

You can play an .mp4 movie file right from your browser so that you can see how these examples look without having to run Blender at all.
A warning about me and the Notes

What Blender does

What I know

What the notes cover
What We Will Cover in these Notes

1. Navigating the screen layout
2. Viewing in 3D
3. Moving things around in 3D
4. Modeling, I
5. Appearance, I
6. Modeling, II
7. Rendering
8. Particle Systems
9. Physics Animation
10. Appearance, II
11. Vertex Sculpting
12. Vertex Painting
13. Keyframe Animation
14. 3D Printing
15. References
1. Navigating the Screen Layout
Full Screen Layout

- Object Tools (‘t’)
- Main Menu
- Property-specific Options
- Object Properties (‘n’)
- Outliner
- Animation Controls
The Object Tools Menu

- Select
- Cursor
- Transform
- Move
- Rotate
- Scale
- Annotate
- Measure

Toggled on and off with the ‘t’ key
The Add Menu

This is the Add tab – you will spend a lot of time here!

Create geometry

Create lights

Create other cool stuff
The Add→Mesh Menu

You will especially spend a lot of time here!
The Sidebar Panels

Toggled on and off with the ‘n’ key

University

Computer Graphics
The Blender Interface Widgets

If Blender shows you something that looks like this …

… you are expected to click a button to put yourself in a particular mode
If Blender shows you something that looks like this …

… you are expected to click in the box to bring up something else, like this.
The Blender Interface Widgets

If Blender shows you something that looks like this …

… you are expected to turn features on and off by clicking in all or none of the checkboxes.

If Blender shows you something that looks like this …

… you are expected to make a choice of just one of these options.
The Blender Interface Widgets

If Blender shows you something that looks like this …

![Power 100 W widget](image)

… you are expected to either left-click in the box and (keeping the left button down) drag the mouse left-right like a slider, or single-click in the box and type in a new value.

If Blender shows you something that looks like this …

![Space selection widget](image)

… you are expected to click in the box and then select from the resulting list.
The Blender Interface Widgets

If Blender shows you an “Apply” button …

… it means that you can click this button to get rid of your original model and replace it with a model that has the edits you have just made.

If Blender shows you this icon (with or without the word “Open” …

… it means that you can click this button to open a file.
The Blender Interface Widgets

If Blender shows you something that looks like this …

… you are expected to click in the box and select from a list of other **objects** in the scene.

If Blender shows you something that looks like this …

… the red color is telling you that you haven’t yet entered enough information in this panel.
The Blender Interface Widgets

If Blender shows you something that looks like this …

… it allows you to hide and unhide something (the Outliner is where you use this most often). Hiding an object is useful for decluttering your scene.

Hint #1: If you no longer want an object in the scene, hiding it for a while before deleting it is usually a good thing. It is surprising how often you need something not long after you deleted it. 😊

Hint #2: If you hide something, don’t forget that you have hidden it. It is pretty freaky to be certain that you once created something, but now you can’t find it anywhere in the scene. 😞
The File Menu

- **New**: Start a new Blender scene (thus closing the scene you currently have open)
- **Open...**: Open a previously-created Blender scene (thus closing the scene you currently have open)
- **Save**
  - **Save As...**: Save the current scene in a file
- **Link...**
- **Append...**: Bring elements from another Blender file into this scene
- **Import**
- **Export**
  - **Send an image or object to somewhere else**

Computer Graphics
The Difference Between New, Open, Link, and Append

**New** closes the scene you currently have, then initiates a new Blender scene.

**Open** closes the scene you currently have, then reads in a previously-stored Blender scene.

**Append** leaves the scene you currently have open, and adds elements of a previously-created scene into it.

**Link** is like Append, but every time you open the scene again, it will look at the file you are Linking from to see if changes have been made, and if so, will bring those into the scene instead of the first ones.
The Render Menu
The Help Menu
2. Viewing in 3D
3D Coordinate Systems

Left-handed

Right-handed

Blender uses this convention
The Coordinate and Viewing System

- Right-handed coordinate system
- X = Red
- Y = Green
- Z = Blue
- Middle mouse button (MMB) – orbit
- Shift MMB – pan
- Scroll wheel – zoom
- View → Left, Right, …
- View → Toggle Quad View
- View → View Persp/Ortho
The View Menu gives you access to lots of ways to change how you are viewing the scene.
Toggling Between Perspective and Orthographic Views

- Perspective/Orthographic
  - Orthographic
  - Perspective
Toggling Between Perspective and Orthographic Views

In orthographic, lines that are parallel in 3D remain parallel on the screen. Objects appear to be the same size as they get farther away.

In perspective, lines that are parallel in the 3D depth direction appear to converge on the screen. Objects appear to get smaller as they get farther away.

“Vanishing Point”

Use perspective when you want a more realistic view (which is most of the time).

Use orthographic to see if things separated in depth are the same size.
Toggling Between Perspective and Orthographic Views

Use perspective when you want a more realistic view (which is most of the time):

Use orthographic to see if things separated in depth are the same size:
Single View vs. Quad View

Or hit Control-Alt-q
Setting the initial Rendering Mode

On the vertical strip of icons on the right, click this one.

And then be sure the Render Engine is set to **Eevee**.
Setting the initial Display Mode

X-ray

Wireframe

Viewport Shading

Rendered

Use **Viewport Shading** to start. It gives good generic lighting.

Later, when we cover Rendering, we will use Rendered lighting.
3. Moving Things Around in 3D
We will get into this in more detail later, but just so that you have something on the screen, here is the Add Menu

These are all the different geometry things you can add into the scene. We will cover many of them, but not all.

This group is the **meshes**.

This group is the **curves**.
The Add→Mesh Menu

The UV Sphere, Torus, and Monkey are my favorites
Summary of the Mesh Objects
Coordinate System Conventions

- Right-handed coordinates
- Right-handed rotation rule
- Angles are in degrees
Right-handed Rotation Rule
Selecting an Object to Work On

LMB-click on the object you want to select. It will then be highlighted with an orange outline.
Selecting Multiple Objects to Work On: Two Ways to Do This

1. Hold down the Shift key while RMB-clicking

2. LMB a rectangular region around objects
Moving Things By Clicking and Dragging

- Translate ("grab")
- Rotate
- Scale

Use Global or Local Coordinate System
Local and Global Coordinates

Local Coordinates align with the object

Global Coordinates align with the screen
Saying How to Move Things by Using the Keyboard

- LMB click to select an object
- Grab ‘g’
- Rotate ‘r’
- Scale ‘s’
- Grab using global axis ‘g’ → ‘x’, etc.
- Grab using local axis: ‘g’ → ‘x’ → ‘x’
- Pick all but a particular axis ‘g’ → ‘X’, ‘g’ → ‘X’ → ‘X’, etc.
- Grab a specific distance ‘g’ → ‘x’ → 12.25 <return>
- Rotate a specific angle ‘r’ → ‘x’ → 45 <return>
- Scale a specific factor ‘s’ → 2.0 <return>
- Scale a specific factor ‘s’ → ‘x’ → 2.0 <return>

This is important – you will use this a lot!
You Can Also Use the Sidebar Panel

Hit the ‘n’ key to toggle this panel
In the upper-right portion of the screen is the Outliner. Like the name implies, it shows an outline of your scene.

It is sometimes nice to have a summary of the scene so you can remind yourself of what all is in it.

Also, if your scene is cluttered, you can select an object by clicking on its name in the outliner as opposed to selecting it in the scene.

Double-clicking on a name will allow you to rename that object to something more sensible than, say, “sphere”

Also, you can use the outliner to hide certain objects. Just click on the eye icon to hide/unhide.

Hint: If you hide something, don’t forget that you have hidden it. It is pretty freaky to be certain that you once created something, but now can’t find it anywhere in the scene. 😊
4. Modeling, I
The Add Menu

These are all the different geometry things you can add into the scene. We will cover many of them, but not all.

This group is the **meshes**.

This group is the **curves**.
The Add→Mesh Menu

The UV Sphere, Torus, and Monkey are my favorites
When you Add a Mesh, a Small Menu Appears in the LL Corner
When you Add a Mesh, a Small Menu Appears in the LL Corner

Try clicking on it.

The small menu lets you modify how the last thing you did works. In this case, the most important thing it is doing is letting you change the polygon resolution of the sphere. But, this menu only exists until you do something else. After that, the ability to change these values is gone.

Personally, I like changing these two values to 64 and 32, respectively.
Summary of the Mesh Objects
Blender is able to play a graphics trick to make your curved geometry look better. Select the object (LMB) then click the RMB and select **Shade Smooth**.

This doesn’t actually change any geometry – it’s just a really good computer graphics display trick. There are other ways to truly create smoother geometry.
Select the object (LMB) then click the RMB and select **Duplicate Objects**. This leaves the new object right on top of the old object and leaves you in **Grab mode**. Just move the mouse to separate the two objects.
Oftentimes you want to create an object that is identical to itself, but is symmetric about an axis. This type of operation is called **mirroring**.

Create an object, in this case, Suzanne the Monkey.

Let’s say that we want to mirror this object left-right (y). Select the monkey, right click, then select **Mirror**, and then select **Y Global**.
Click here, or hit the **Tab** key, to get into Edit Mode

Select and edit:

- A vertex
- An edge
- A face

Using the Tab key is so common, that “tab” has become a verb in the Blender community. “Just tab over into edit mode.”
Editing a Vertex

Be sure you are in vertex-editing mode

Left click on a vertex

Hit ‘g’ (grab) and move the mouse

You can also hit ‘x’, ‘y’, or ‘z’ to restrict motion
Editing a Vertex with Proportional Editing

Be sure you have Proportional Editing enabled

LMB click on a vertex

Hit ‘g’ (grab) and move the mouse

You can also hit ‘x’, ‘y’, or ‘z’ to restrict motion

The mouse Scroll Wheel changes the size of the Circle of Influence

You can also LMB select an edge or a face for editing or proportional editing.
Subdividing and Smoothing Really Show the Difference Between Localized and Proportional Editing
An Unexpected Use for Proportional Editing

Create a **Plane**, then go to **Edit Mode**, then box select all the edges, then click on **Edge → Subdivide** and subdivide it several times.
An Unexpected Use for Proportional Editing

Enable **Proportional Editing**, then go one widget to the right and change the kind of Proportional Editing from **Smooth** to **Random**.
An Unexpected Use for Proportional Editing

Go to **Edit Mode**, select a vertex, and lift it along with those around it.
An Unexpected Use for Proportional Editing

Original

With Subdivision Surfaces
5. Appearance, I
The Button Properties Menues

Tells you that we are in the Button Properties Menu

- Render Properties
- Output Properties
- View Layer Properties
- Scene Properties
- World Properties
- Object Properties
- Modifier Properties
- Particle Properties
- Physics Properties
- Object Constraint Properties
- Object Data Properties
- Material Properties (colors)
- Texture Properties

Clicking one of these brings up a much more detailed menu of options
Using the Material Properties Menu

Click on this … to get this

Then, click on New
To make our lives simpler for now, click here to turn off Use Nodes mode.
Using the Material Properties Menu

Use Nodes mode has been turned off

Clicking in here brings up a color wheel
The Color Wheel

Click in here to change the **Hue** and **Saturation**

**Hue** is angle around the wheel

**Saturation** is the radius

Click in here to change the **Value**

**Value** is a color’s brightness

These are the possible ways the color will be defined

If you know the color definition numbers you want, you can type or slider them here

Oregon State University
Computer Graphics
The Color Wheel in Action
Color Scales

Red-Green-Blue
Hue-Saturation-Value
Hexadecimal

Eyedropper
(lets you select a color you see somewhere else on the screen)
Blender’s RGB scale lets you give the red, green, and blue components in the range 0. – 1.

Blender’s hexadecimal scale lets you give the red, green, and blue components in the range 00 00 00 – FF FF FF
Hue-Saturation-Value (HSV) Color Scale

Blender’s HSV scale lets you give the hue, saturation, and value components in the range 0. – 1.
Controlling Shininess

- Get to the Material Properties menu
- Turn Use Nodes off
- Set the Base Color
- Play with these 3 settings to control shininess

- Base Color
- Metallic
- Specular
- Roughness
6. Modeling, II
Adding 3D Text

To change the text string, tab into Edit mode. The white rectangle acts as a text cursor. Backspace over “Text” and type your new text. The return key will let you enter multiple lines.
Changing the Style of 3D Text

So far, not very 3D, huh?
Tab back to **Object Mode**, click on your text, then click on this **Font button**

**Extrude**: give the letters height
**Depth**: bevel the top and bottom
**Resolution**: round the bevel
Changing the Look of 3D Text

From here on, your 3D text acts like any other 3D object. It can be grabbed (translated), rotated, and scaled.

It can be colored, too.
Edit Mode Subdivision

The Edit Mode subdivision feature adds more vertices, but doesn’t do any sort of smoothing (like the Subdivision Surface Modifier does). So, when you are done, you will have more vertices to sculpt with, but, in Object Mode, your object will look exactly the same as it did before.

1. Object Mode
2. Tab into Edit Mode
3. Get Ready to Edit Faces
4. Right-click Subdivide

5. You now have more vertices

6. Tab back into Object Mode
A Multi-Vertex Picking Hint

First, make this model:
1. **Object Mode** → **Add** → **Mesh** → **Cylinder**
2. Tab to **Edit Mode** → **RMB** → **Subdivide**

- **Edit a vertex**
A Multi-Vertex Picking Hint

Now, LMB-sweep over these vertices. (I call them the “equator” or the “belt”.)

But, if you do that, you will only end up selecting the front vertices, that is, the ones you can see.

The trick is to go into X-ray Mode, by clicking here.

This will now let you select all the points in the belt.
A Multi-Vertex Picking Hint

Why do that? Well, if you have those vertices selected and you hit the s key (for scale) and move the mouse, then you can get this:

Or, this:
A Multi-Face Picking Hint

To create this model:
1. Add → Cube
2. Tab to Edit Mode → RMB → Subdivide → Subdivide

Suppose you want to select an entire row of faces in order to “fatten the belt”. You could select all the faces individually (LMB → Shift-LMB). But, here’s a better trick

1. Click on one face in the row
2. Alt-LMB on another face down the row
A Multi-Face Picking Hint

Scaling (‘s’)
Similarly, if you put yourself into face-picking mode:

And click on the top face of the cylinder (don’t need the belt and don’t need to be in X-ray Mode for this):

And hit the r and z keys (for rotate about the z axis) and move the mouse, then you get this:
Intentionally Joining Two Objects

Let’s say that you have two objects and want to join them together so that you can act on them as one object.
Intentionally Joining Two Objects

Easy! **LMB** on one, then **Shift-LMB** on the other, then hit **Control-’j’** ("join") on the keyboard. The orange “selection outline” now goes around both objects and the outliner shows just one object.
Separating Objects By Loose Parts

Select the Joined object. Tab over to **Edit Mode**. Then hit the ‘p’ key ("Partition"). You will then have three options on how to partition the joined object. If you select **By Loose Parts**, then the Joined object will be partitioned based on the original primitives that made it up.
Inset Faces (aka, Offset Curves)

Often you want to create a “face-within-a-face”. In Blender, this is called an Inset Face. (CAD systems often call this sort of thing an Offset Curve.)

In Edit Mode, select the top face.

Then, either RMB → Inset Faces, or click on this icon on the left side:
Inset Faces (aka, Offset Curves)

With the LMB, push the little handle down until the Inset Face is the size you want.

At this point, you can select the inner face and hit \textbf{g} and \textbf{z} (grab in the \textbf{z} direction) to do this, or this.

Try rotating or scaling the inner face.

You can also create a new inset face inside the inset face you just created.
Vertex Groups

Using a group of vertices together is very useful. It is used for editing (like we are doing here), but also to pin certain vertices for cloth animation, to grow hair for hair simulation, and to rig objects for animation.

For that reason, Blender allows you to select the group and give them a name for later. This is called a **Vertex Group**.

1. Select the vertices in Edit Mode (Shift-LMB)

2. Select the **Object Data Properties** button

3. Click the + to add this as a new Vertex Group
Vertex Groups

4. Double-click on whatever the default name is ("Group" in this case) and type in a descriptive name for this Vertex Group.

5. Click Assign.

From now on, this group of vertices can be selected just by selecting the name from the list of Vertex Groups and clicking Select.
Extruding Faces – three ways

**Extrude Individual Faces** (cracks in between skyscrapers)

**Extrude Faces** (push each face along the group average perpendicular to the surface)

**Extrude Faces Along Normals** (push each face perpendicular to the surface)

Face Select Mode
Shrink/Fatten and Push/Pull are very much like extruding faces. Here are the differences:

**Extruding** lifts the selected faces along their normals. It leaves behind a “cliff” that connects them to the surrounding faces.

**Shrink/Fatten** lifts the selected faces along their normals, but leaves behind a “ramp” connecting those faces to the surrounding ones.

**Push/Pull** essentially scales the selected faces around their centroid.

For example, suppose we start with this object and these selected faces.

Every one of the edit-icons that has a little arrow in the lower-right corner expands in this same way. Check ‘em out!
## Extrude, Shrink/Fatten, and Push/Pull

<table>
<thead>
<tr>
<th></th>
<th>Extrude</th>
<th>Shrink/Fatten</th>
<th>Push/Pull</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Out</strong></td>
<td><img src="image1" alt="Extrude Out" /></td>
<td><img src="image2" alt="Shrink/Fatten Out" /></td>
<td><img src="image3" alt="Push/Pull Out" /></td>
</tr>
<tr>
<td><strong>In</strong></td>
<td><img src="image4" alt="Extrude In" /></td>
<td><img src="image5" alt="Shrink/Fatten In" /></td>
<td><img src="image6" alt="Push/Pull In" /></td>
</tr>
</tbody>
</table>
The Button Properties Menues, Again

Tells you that we are in the Button Properties Menu

Clicking one of these brings up a much more detailed menu of options
Modifiers don’t actually change the object’s *permanent geometry* – just the object’s *appearance* on the screen. The geometry gets permanently changed only if you click the **Apply** button.
My Favorite Modifier -- Subdivision Surface

This modifier increases the number of polygons in your object. At the same time, it smooths your object out. Be careful! It very quickly increases your polygon count.

This controls how much to subdivide. Here we’ve changed this value from 1 to 2.

Fun: try it on a cube!
Bevel Modifier

Beveling causes edges to be rounded instead of sharp.

How much to bevel:

- Smooth shading makes bevels look much better!

Examples:

- No beveling
- Segments = 1
- Segments = 2
- Segments = 3
Remember Venn Diagrams (Boolean Operators)?

Two Overlapping Shapes

Union

Intersection

Difference
Booleans (also known as Constructive Solid Geometry)

Think of them as Venn diagrams in 3D!

Two Overlapping Solids

Intersection

Union

Difference
1. Select the cube
2. Click on **Modifiers**
3. Select the Modifier called **Boolean**
4. Specify the **Difference** Operator
5. Specify the **Cylinder** as what to the difference with
6. Click **Apply**

“Block minus Cylinder”
Select the cylinder, hit it **g** (grab) and slide the cylinder away
The Resolution of the Second Object Determines the Resolution of the Resulting Surface
The Mirror Modifier

Let’s say that you want to create a mirror image of the monkey, but by using a Modifier, the mirror monkey will be linked to the original monkey so that any edits you do to the original will automatically end up in the mirror object.

But, that mirrored object will reflect about the object origin, this little dot right here. Which means that you will end up with something like this, which is probably not what you wanted.
The Mirror Modifier

So, the first thing we need to do is to move the object away from the little dot. You do this by Tabbing into **Edit Mode** and grabbing all the vertices and sliding them \((gy)\). In Edit Mode, the dot doesn’t move when you do this:

Now, Tab back to **Object Mode**, add the **Mirror Modifier**, and select \(Y\).
The Mirror Modifier

So, now if you sculpt the original object, the mirrored object will get the same edits.

This is often good for creating a full object by only creating one half of it (e.g., a car) and mirroring it.
Array Modifier

The Array Modifier is used to duplicate an object according to a particular pattern. Suppose we want to turn a block into a staircase. We start with the block and add an Array modifier.

- **Apply** button (if we want to make this permanent)
- The duplication count
- How much to offset each duplication. It can be Constant, that is, based on a number of units. Or it can be Relative, that is, based on a number of size-of-this-object
Array Modifier to Make Stairs

Move each block in Y and Z to make the next stair step

How many total steps to make
Wireframe Modifier

- Turns each polygon into thick lines outlining each polygon.
- How thick to make the thick lines.
- But, these lines have thickness, keeping this as a Mesh.

Computer Graphics
Modifier Order Matters!

Subdivision Surface, then Wireframe

Wireframe, then Subdivision Surface
Editing with Lattices

Add a **UV Sphere**
In **Edit Mode**, select a group of sphere vertices and assign them as a **Vertex Group**.

**Hints:**

1. Select the vertices in **Orthographic** and **X-ray** display modes.
2. Double-click on the default name of the Vertex Group to give it a better name.
Add a Lattice to the scene.

Click the **Lattice button** and (perhaps) add more lattice detail.
Add a **Lattice Modifier** to the sphere. Tell it the name of the lattice and the name of the Vertex Group to use.
Editing with Lattices

In Edit Mode, grab vertices and slide them:
Start with a cube

Tab into **Edit Mode**.

Select **X-ray mode** and select **all vertices**

Tab into **Edit Mode**.

Click on the **Extrude Tool**
Extrude Tool

I like **XYZ mode** so that you can extrude in any direction.

Grab one of the `+`'s and pull.

You can even keep doing it.

When you get back to Object Mode, you will find that all of these are part of the same object.
Start with a cube translated along the x axis ($g_x$)

Tab into Edit Mode.
Click on the **Spin Tool**

Tab into Edit Mode.
Click on the Spin Tool
Spin Tool

Pick the number of duplicates to make

Be sure all of the object's vertices are selected.
Grab one of the blue +’s and rotate

Pick the axis/axes about which to spin
Texture Pattern Displacements

Click on the **Texture Property button**

**Remember the texture “name”** (Texture.002) – you will need it later.

Select which texture you want for the displacement pattern.

I like **Voronoi** because of the cells.
Texture Pattern Displacements

Create an object, add a couple of levels of Subdivision Surface Modifier, then add a Displace Modifier.
Texture Pattern Displacements

Displace Modifier

Click here and select the texture name (*Texture.002*) from before.

Select *Normal*.

Experiment with different values of Strength.
Texture Pattern Displacements

Aren’t you glad you didn’t have to sculpt this yourself? 😊
Metaball Objects

Metaball Objects are another way to 3D model:
Metaball Objects

The cool thing is that, if you move (g) them close enough, they will “glom” into a single object.
Metaball Objects

There is a special Metaball properties menu to control their characteristics:

![Metaball properties menu screenshot]

- Resolution View: 0.25 m
- Render: 0.13 m
- Influence Threshold: 0.700
- Update on Edit: Always
Metaball Objects

But, Metaball Objects are not meshes, so you cannot do a lot of the cool editing that you can with meshes. But, you can turn such an object into a mesh by selecting **Object → Convert To → Mesh from Curve/Meta/Surf/Text**

![Image of object conversion](image-url)

After tabbing into Edit Mode
Importing Objects from Other Places

Collada = export format from game modeling systems

Stl = 3D printer format

3ds = format from Autodesk 3D Studio

Obj = Probably world’s most common export format There are a ton of .obj models for free on the Internet! Google the phrase: free obj files

.obj files are also pretty straightforward to create. So, if you have a shape in mind and can write a computer program to generate it, you can write your own .obj file and Import it into Blender.
Importing Objects from Other Places

File = dino.obj

You can get this file from the web page:
http://cs.oregonstate.edu/~mjb/blender

As-is, flat shaded

Subdivision surfaced
+ Smooth shaded
Importing Objects from Other Places
Blender has a number of file formats it knows how to export to. If you are looking for a nice, general one to experiment with, try the `.obj` format.

Just be sure to use the RMB menu to select **Shade Smooth** first

Select **File → Export → Wavefront (.obj)**
Exporting to an OBJ File

This is the Blender file-output selection dialog box:

Obj-specific settings (see next slide)
In the export dialog, be sure to click on
• **Write Normals**
• **Include UVs**
• **Triangulate Faces**
7. Rendering
We have been using this one. This one gave you good generic lighting so you could model without worrying about light sources.

Now switch to this one. This one will give you a pretty-good preview of what happens when you actually render the scene. But, we now have to deal with Rendering specifics.
“Rendering” is Blender’s process for creating really high-quality images. Click on Render → Render Image or hit the F12 key (you might have to hit the fn key at the same time). The rendering operation can often take some time, depending on how complex your scene is.
Clicking on the **Render Properties** button will allow you to set various rendering parameters. The one you care about the most is pixel resolution.

You want at least some **Anti-Aliasing**, which is done by making more than one sample per pixel. 64 and 16 are good values.

The rest of these are interesting, but not needed right now.
What is Anti-aliasing?

Anti-aliasing is a good-news bad-news joke.
Good news: the scene looks much smoother
Bad news: the scene takes longer to generate
Good news: you probably want to do it anyway
Anti-aliasing is implemented by oversampling within each pixel.
Let’s say that you are in **Solid Shading Mode** and your scene situation looks like this. You now change to **Render Mode** and get this:

Blech! Where did the bottom part of my scene go?
The answer is that **Solid Shading Mode** doesn’t require your scene to be lit, but **Render Mode** does.
By default, your scene has a single light in it. It looks like this.

If you can’t find it, try zooming out.

If you still can’t find it, select it in the **Outliner**.

This is like any other object.
A light is like any other object. It can be LMB clicked on. It can be grabbed (g) and moved around. Moving it around will change how the lighting looks.
But, to make this work better, you probably want to add more lights.
There are four types of **Lights** that you can **Add**

1. A **Point** Lamp shines light in all directions. The light is local to the scene. This is usually the best type of light to start out with.

2. A **Sun** Lamp appears to come from a single direction and its rays are parallel. This acts as if the light is very far away.

3. A **Spot** Lamp is like a Point Lamp, but only shines in one particular direction.

4. An **Area** Lamp is light coming from a finite surface, like most lights really are.
Lighting – try this

1. Add another Point Light

2. Position the Light (‘g’).

3. The Point Light has no obvious local coordinate system, so it just uses the global coordinate system.

4. As you move the Light, you will see the lighting of the scene change.

5. You will probably have to rotate the scene (MMB) to get the light position where you think it should be. Or, you can also toggle the Quad View mode (Control-Alt-q).
Lighting – Quad View
Lighting – Properties

This shows how the light spreads out from the Light

What color to make the Light

How bright to make the Light shine.

Be sure this is clicked on in order to get this light to cast shadows
Lighting – What does it Mean to Have a Colored Light?

What the light can produce

\[ E_R = L_R \times M_R \]
\[ E_G = L_G \times M_G \]
\[ E_B = L_B \times M_B \]

What the eye sees

White Light

Green Light

What the material can reflect

Oregon State University
Computer Graphics

mjb – August 2, 2020
In modeling, rendering, and animation, there are two major roles that lights play:

1. Key
2. Fill

Let’s say we want to put a spotlight on the Monkey (and who doesn’t?). We add a Spot Light. We position it over the Monkey and angle it down, like this. This is our “Key Light”. It does what we most want to do.

We render and get this.

The Key Light is working really well, but the rest of the scene is too dark. We now need to use one or more Fill Lights.
We add a Point Light and position it over the scene. Because we are in Render Mode, we can interactively see when we have it positioned well.

The scene looks much better. But, there are still two problems.

1. The rest of the scene is now bright enough that our “star” is no longer highlighted.
2. The Fill Light is casting another shadow which is distracting.
So, we make two adjustments to our Fill Light:

- We lower its brightness.
- We un-click here to force it to not cast shadows.
The view that is rendered is not the same orientation that you see on the screen. It is from the **Camera position**, which needs to be set separately.

If you the Camera icon, LMB click on it. If you don’t see it, zoom out some. If you still don’t see it, click on the Camera in the Outliner.
The Camera

Where the eye is looking towards

The “up vector”

The eye’s position
The Camera

The camera is just like any other object in the scene.
1. It can be selected with a LMB click
2. It has its own local coordinate system attached to it.

Note the local coordinate system for the camera:

• X is to the right of where the eye is looking
• Y is the up-vector
• Z is opposite of where the eye is looking

This is useful to know. For example, to dolly the camera in or out, select it and then move it in its local coordinates:

‘g’ → ‘z’ → ‘z’
Aligning The Camera to Your Current Screen View

But, if you like your current screen view and want to move the camera there, just do this:

View → Align View → Align Active Camera to View
Setting a Background Color

This only takes effect when rendering! So, you must either be in **Render Preview mode**, or you must have done a **Render**.
Setting a Background Color

Click on the **World Properties button**

Click on **Color** and dial in the background color
Triggering a Rendering

What you see on your screen

What you see on the separate render window
What You See in the Separate Render Window
Saving a Rendered Image to a File
Saving a Rendered Image to a File

Amount of compression

Image file type

File Format: PNG
Color Depth: 8 bit, 16 bit
Compression: 15%
Saving a Rendered Image to a File

Different image file types
(PNG is good if you don’t have any preference)
Saving a Rendered Image to a File

If this is called **Compression**, then smaller numbers will give you a larger image file with greater image quality.

If this is called **Quality**, then larger numbers will give you a larger image file with greater image quality.
Saving a Rendered Image to a File

There is an important trade-off between image file size and the image **Quality** you set. There is also a trade-off between image size and web page download time.

<table>
<thead>
<tr>
<th>Quality Setting</th>
<th>File Size</th>
</tr>
</thead>
<tbody>
<tr>
<td>10%</td>
<td>11 KBytes</td>
</tr>
<tr>
<td>100%</td>
<td>72 KBytes</td>
</tr>
</tbody>
</table>
Importing an Image into PowerPoint

Importing an Image into HTML

Add this line to your HTML file:

```html
<img src="ball.png">
```
8. Particle Systems
Particle System Examples

Oregon State University
Computer Graphics
Particle System Examples

(Particles don’t have to actually be particles.)
Particles Bouncing Off Other Objects

particles.blend
Particles – The Setup

Select the object to emit the particles from, then click this property button.

Click the + sign to start a new particle system.

Number of particles

What material definition to color the particles with

What particles to draw (this is fun to change!)

Start with a small size, like this, but then experiment.
Click here to start the particle animation

Hit the **ESC** key when you want it to stop
1. Draw a plane to bounce particles from
2. Click the **Physics Property Button**
3. Click on the **Collision** option
4. Turn on the animation
Particles Bouncing Off Other Objects

Bouncing particles
Something fun – Tip the Plane
Something fun – Put something else in the way
9. Physics Animation
Quick Physics Cheats

Original Scene
Quick Physics Cheats

- Quick Fur
- Quick Explode
- Quick Smoke
- Quick Liquid
There are Eight Types of Physics Simulations

- Force Field
- Collision
- Cloth
- Dynamic Paint
- Soft Body
- Fluid
- Rigid Body
- Rigid Body Constraint
Rigid Body Collision Example

Set this up using what you know about modeling.

Slightly rotate the left-most domino to the right so that it will tip and start the sequence.

Or

University
Computer Graphics

dominos.blend
dominos.mp4
Let Blender Know You Want to do Rigid Body Physics

Click on the **Scene Properties Button**

Set Gravity (this value indicates gravity points downward and has a value of -9.81 meters/second$^2$)

Be sure this is turned on
For each object that will be pulled by gravity (the dominos and the ball), select the object, click on the **Physics Property Button**, click on **Rigid Body**, and set the Type to **Active**.
For each object that will *not* be pulled by gravity but will still be involved in the collisions (the floor), select it and set the Type to **Passive**.
Turn the Animation On

Hit the *Escape* key to stop the animation

dominos.blend

dominos.mp4
Setting Gravity

In order to do physics animations, Blender needs to have an idea of what Gravity is. The acceleration due to gravity near the surface of the earth is 9.81 meters/sec^2 (pointing down), which also equals 32.2 feet/sec^2.

You can set this by clicking on the **Scene Properties Button** and then scrolling down to the **Gravity** dialog area.

![](image)

This is the default, but you can set Gravity to anything you want, including turning it off completely, or making it point upwards, or making it point sideways.

**Oregon State University**

Computer Graphics
The acceleration due to gravity is not the same on all bodies. It depends on the mass of the body and its radius.

For fun, try setting gravity to what other bodies have in our solar system:

<table>
<thead>
<tr>
<th>Body</th>
<th>Gravity Acceleration (m/sec²)</th>
<th>g’s</th>
</tr>
</thead>
<tbody>
<tr>
<td>Mercury</td>
<td>3.70</td>
<td>0.38</td>
</tr>
<tr>
<td>Venus</td>
<td>8.87</td>
<td>0.90</td>
</tr>
<tr>
<td>Earth</td>
<td>9.81</td>
<td>1.00</td>
</tr>
<tr>
<td>Moon</td>
<td>1.62</td>
<td>0.17</td>
</tr>
<tr>
<td>Mars</td>
<td>3.71</td>
<td>0.38</td>
</tr>
<tr>
<td>Jupiter</td>
<td>24.79</td>
<td>2.53</td>
</tr>
<tr>
<td>Saturn</td>
<td>10.44</td>
<td>1.06</td>
</tr>
<tr>
<td>Uranus</td>
<td>8.69</td>
<td>0.89</td>
</tr>
<tr>
<td>Neptune</td>
<td>11.15</td>
<td>1.14</td>
</tr>
</tbody>
</table>

https://www.universetoday.com/35565/gravity-on-other-planets/
Gravity on Other Bodies

Or, invent your own planet! Pick a different “m/sec²”.

21st Century Fox
There is a difference in what different Mesh types will do. This needs to be a *Grid* – not a Plane!
Modeling Cloth -- Enable Collision with the Cube

Select the cube. Then go to the **Physics Property Button**. Then click on **Collision**.

You don’t need to set any other parameters (unless you want to)
If you select the grid and tab over to **Edit Mode**, you will see that it is already subdivided somewhat. To act as a cloth, we’d like it subdivided some more.

Back in Object Mode, select the grid, then select **Modifiers**.

Then click **Add Modifier** and select **Subdivision Surface**.

Change the **Viewport** parameter from 1 to 2.

Click the **Apply** button.
Modeling Cloth – Tell the Grid that it is Really a Piece of Cloth

Select the grid. Then go to the **Physics Property Button**. Then click on **Cloth**.

You can get away without changing any of these parameters, but, at some point, you will want to experiment with different values of **Stiffness** and **Damping**.

**Stiffness** and **Damping**.
Modeling Cloth – Run the Animation

Select the grid, RMB, then select Shade Smooth. Then start the animation.
Why does the animation run so slowly? That is because it is computing the simulation while it is animating.

Instead, tell it to precompute the animation. You do this by selecting the **Bake** button (and waiting and waiting).

Now try animating (Alt-a).
Cloth Animation with Color, Texture, and Lighting

cloth.mp4
Cloth Animation: Pinning Vertices

One of the many fun parts of cloth animation is pinning some of the vertices. There are lots of reasons to do this, such as to pin the edge of a flag to its flagpole, or to pin a cloth to a clothesline.

To do this, Tab into **Edit Mode**, **Shift-LMB** the vertices to be pinned, and create a **Vertex Group** from them. (This was described in more detail in the Modeling section of these notes).
Cloth Animation: Pinning Vertices

In the Cloth section of the grid’s *Physics* menu, select the name of the Vertex Group to be pinned.

When you re-animate, those vertices will be stationary.
**Rendering an Animation**

**Render Animation** kicks off the rendering of all your animation frames in order.

**View Animation** brings up a separate window and plays back your animation.

Hint: if this is just a test render, and you have lots of time-consuming visual effects going on, you might cut down the resolution and/or the number of rendered frames to speed things up.

---

**Oregon State University**
Computer Graphics
10. Appearance, II
Procedural Texturing
1. Leave **Use Nodes** turned on.

2. Select **Principled BDSF** (probably already selected)

3. Here, where you would normally select a color, click on this little circle

4. From that pop-up menu, select **Voronoi Texture** (or one of the others)

5. Change the **scale** to change the size of the Voronoi cells
Blender has these Built-in Procedural Textures
Start with a **UV Sphere** being shown in **Render Preview** mode.
Image Texturing

Says that you want to read a texture image from a file

Click here to open an image file
worldtex.bmp is a good texture to try!
Image Texturing

worldtex.bmp is a good texture to try!
Image Texturing

Sphere

Tube

Cube

Flat
Let’s Say That We Want to Render This Scene

- Cube and Monkey are opaque
- Sphere is both reflective and refractive
- Plane has a checkerboard texture on it
- Scene has lighting and shadows
- Sphere is both reflective and refractive
Making the Sphere Reflective and Refractive

Combine refraction and reflection effects together with the Mix Shader

How much to mix each shader

First shader is Glass to get the refraction

Transmission color

Index of Refraction

Second shader is Glossy to get the reflection

No inherent color in the reflection
Putting a Checkboard Pattern on the Plane

1. Leave **Use Nodes** turned on.

2. Select **Principled BDSF** (probably already selected)

3. Here, where you would normally select a color, click on this little circle

4. From that pop-up menu, select **Checker Texture** (or one of the others)

5. Here you can select the two colors making up the checkerboard

6. Change the scale to change the size of the checkerboard squares
Onscreen and Rendered Results with Eevee
Onscreen and Rendered Results with Cycles
Rendered Results with Cycles
What Actually is Ray-Tracing?

It starts at the eye:

The pixel is painted the color of the nearest object that is hit.
What Actually is Ray-Tracing?

It’s also straightforward to see if this point lies in a shadow:

Fire another ray towards each light source. If the ray hits *anything*, then the point does not receive that light.
It’s also straightforward to handle reflection

Fire another ray that represents the bounce from the reflection. Paint the pixel the color that this ray sees.
The Physics of Reflection

Law of Reflection:

\[ \theta_r = \theta_i \]

Angle of reflection = Angle of incidence
It’s also straightforward to handle refraction.

Fire another ray that represents the bend from the refraction. Paint the pixel the color that this ray sees.
The Physics of Refraction

Snell’s Law of Refraction:

\[
\frac{\sin \Theta_B}{\sin \Theta_A} = \frac{\eta_A}{\eta_B}
\]

<table>
<thead>
<tr>
<th>Material</th>
<th>Index of Refraction</th>
</tr>
</thead>
<tbody>
<tr>
<td>Vacuum</td>
<td>1.00000</td>
</tr>
<tr>
<td>Air</td>
<td>1.00029</td>
</tr>
<tr>
<td>Ice</td>
<td>1.309</td>
</tr>
<tr>
<td>Water</td>
<td>1.333</td>
</tr>
<tr>
<td>Plexiglass</td>
<td>1.49</td>
</tr>
<tr>
<td>Glass</td>
<td>1.60</td>
</tr>
<tr>
<td>Diamond</td>
<td>2.42</td>
</tr>
</tbody>
</table>

http://en.wikipedia.org/wiki/Refractive_index
11. Vertex Sculpting
Vertex Sculpting

Vertex Sculpting is, well, sculpting vertices. But, in order to do this well, we need a lot of vertices.

Start with a UV sphere mesh object.

Tab over to **Edit Mode**.  
RMB → **Subdivide** → **Subdivide**

When you get back to Object Mode, the sphere won’t look any different than before because you just subdivided the polygons, not smoothed them. If you had wanted smoothing, you could have used the **Subdivision Surface Modifier**.

Now go to **Sculpt Mode**.
Vertex Sculpting

Lots of new options will appear at the top:

- **Brush Radius** (I like 25)
- **Brush Strength** (height)
- **Add Material (+)** or **Subtract Material (-)**
- **Brush Characteristics**

- **Stroking Characteristics**
- **Surface Falloff from the Center of the Brush** (I like Smoother)
- **Symmetry Control** (I recommend you click all of these off for now.)
Vertex Sculpting

Go back and forth over the object with the brush to increase the sculpting effect

Add material
Subtract material

Sculpting usually looks better if you quick get over into **Object Mode**, RMB → **Shade Smooth**
Vertex Sculpting Options

I like this one
Vertex Sculpting with Dynamic Topology (“Dyntopo”)

This cool – you are really going to like this!

Set the Sculpt Mode to **Draw**

Set **Radius** to **20**

Set **Brush Strength** to **1.0**

Add Material (+)

Surface Falloff from the Center of the Brush to **Smother**

No Symmetry

Click **Dyntopo** on (if you get a message, just click **OK**)

Oregon State University
Computer Graphics
Vertex Sculpting with Dynamic Topology ("Dyntopo")

Set Dyntopo Detailing to **Brush Detail**

And, have at it!
Vertex Sculpting with Dynamic Topology ("Dyntopo")

How does Dyntopo Mode make such a smooth sculpt? Let’s look at this in **Sculpt Mode** and then in **Edit Mode**:

That’s why it is called **Dynamic Topology**!
12. Vertex Painting
Vertex Sculpting is, well, sculpting vertices. But, in order to do this well, we need a lot of vertices.

Start with a UV sphere mesh object.

Tab over to **Edit Mode**.

RMB → **Subdivide** → **Subdivide**

When you get back to Object Mode, the sphere won’t look any different than before because you just subdivided the polygons, not smoothed them. If you had wanted smoothing, you could have used the **Subdivision Surface Modifier**.

Now go to **Vertex Paint Mode**.
Setting up for Vertex Painting

Be in **Solid Shading mode**

- **Brush Color**
- **Brush Radius** (I like ~25)
- **Brush Intensity**
- **Brush Characteristics**
- **Stroking Characteristics**
- **Surface Falloff from the Center of the Brush** (I like **Smoother**)

Oregon State University
Computer Graphics
A Word on Brush Size

Note: the brush size does not scale with zooming in or out. It stays the same size.
The “paintbrush” only drops “paint” when a vertex is inside the circle brush. This means that the paint does not smear along a nice line, but looks splotchy like this.
How Do We Make it Less Splotchy?

Two approaches:

1. Make the object look smaller. That way more vertices will end up inside the brush circle.
2. Use **Subdivide** or **Subdivision Surfaces** to add more vertices.
Click on the small circle and select **Mix**

Then select **Multiply** or **Color Burn**

(“Mix” will change to whichever you picked)

Click here and select a color for the sphere

Click on the small circle and select **Vertex Color**

Click in here and select **Col**

Click and adjust the value of **Fac**

Be in **Rendered Shading** mode
The Effect of the Fac Parameter

Multiply
Fac = 0.00

Multiply
Fac = 0.50

Multiply
Fac = 1.00
Have a Nice Day!
13. Keyframe Animation
Keyframe Example

http://ieeexplore.ieee.org/ieee_pilot/articles/05/ttg2009050853/figures.html
Keyframe Animation

Keyframe animation is a technique that goes all the way back to the beginning of hand drawn animation (e.g., Walt Disney). Senior animators would specify key positions for the animated characters and then more junior animators would fill in the frames in between. This became known as **keyframing** and **in-betweening**.

Blender allows you to create the keyframes and gets the computer to do the in-betweening. Here, we will keyframe-animate the monkey as she slaloms around a group of colored cubes:
Keyframe Animation

Select the **Animation** workspace from the list at the top. This creates a screen layout that looks like this:

This makes your screen look like this. These new sections are:

- **Camera View Window** – what you will see if you Render
- **3D Viewport Window** – what you are used to
- **Timeline Window** – keeps track of what frame number we are on.
Keyframe Animation
Keyframe Animation

Slide the timeline indicator to what frame number you want to set, move the monkey where you want her, and **RMB-select Insert Keyframe** (or hit the ‘i’ key). From the pop-up menu, select **LocRotScale**, indicating that you want to record location, rotation, and scale factor.
Keyframe Animation

Do it again: slide the timeline indicator to what frame number you want to set, move the monkey where you want her, and RMB-select Insert Keyframe (or hit the ‘i’ key). From the pop-up menu, select LocRotScale, indicating that you want to record location, rotation, and scale factor.
Keyframe Animation

After a while, your timeline will look like this:

Then, click here and change the type of display to the **Graph Editor**:
Graph Editor
Your Graph Editor window should now look about like this.

Note that Blender has filled in the in-between values for you. (This is the “In-Betweening”.)
The Graph Editor Window

Click on the triangle. This gives you access to the curves. Clicking on the eye toggles whether or not you can see a curve. Clicking on the name of the curve makes that the current curve. You can then edit it.
The Graph Editor Window

Shortcuts when the cursor is in the Graph Window:

<table>
<thead>
<tr>
<th>Shortcut</th>
<th>What it does</th>
</tr>
</thead>
<tbody>
<tr>
<td>LMB</td>
<td>Select a keyframe dot</td>
</tr>
<tr>
<td>Scroll wheel</td>
<td>Zoom in and out of the Graph</td>
</tr>
<tr>
<td>MMB</td>
<td>Pan the Graph</td>
</tr>
<tr>
<td>Shift-scroll wheel</td>
<td>Pan just in Value (vertical)</td>
</tr>
<tr>
<td>Control-MMB</td>
<td>Scale in Time</td>
</tr>
</tbody>
</table>
Hit the ‘n’ key. Like in the 3D View, a Number Panel pops up.

Scroll down and click on **Add Modifier**.
Select **Add Modifier**. From the list of Modifiers, select **Noise**.
Use this menu to change the noise parameters. Notice what this does to the curve. Now play the animation.
Two Characters Interacting

To avoid a collision, the money jumps up and the cube squishes
Animating the Camera and the Lamps

Cameras and Lamps are just like any other object. As you have seen, they can be positioned. They can also be keyframe-animated. Like other objects, just select them and hit the ‘i’ key to insert a keyframe.
Rendering an Animation

This kicks off the rendering of all your animation frames in order.

This brings up a separate window and plays back your animation.

Hint: if this is just a test render, and you have lots of time-consuming visual effects going on, you might cut down the resolution and/or the number of rendered frames to speed things up.
Rendering an Animation to a File

Before kicking off the animation rendering, you need to specify the file name to put the animation into 

C:\tmp\mjb.avi

and the type of file that it is to be
Rendering an Animation to a File

Here are the animation file types that Blender supports.

Here is how large a 100-frame animation of the cube turned out to be.

<table>
<thead>
<tr>
<th>Movie File Type</th>
<th>File Size</th>
<th>Displayed?</th>
<th>Import into PowerPoint?</th>
</tr>
</thead>
<tbody>
<tr>
<td>AVI JPEG</td>
<td>Didn’t work</td>
<td></td>
<td></td>
</tr>
<tr>
<td>AVI Raw</td>
<td>148 MB</td>
<td>Yes</td>
<td>Yes</td>
</tr>
</tbody>
</table>

Note: this scene is simple and compresses well. The mileage you get may vary.
Importing an Animation into YouTube

YouTube accepts videos in **AVI** and **MPEG** formats
Importing an Animation into PowerPoint

<table>
<thead>
<tr>
<th>Movie File Type</th>
<th>File Size</th>
<th>Displayed?</th>
<th>Import into PowerPoint?</th>
</tr>
</thead>
<tbody>
<tr>
<td>AVI JPEG</td>
<td>Didn’t work</td>
<td></td>
<td></td>
</tr>
<tr>
<td>AVI Raw</td>
<td>148 MB</td>
<td>Yes</td>
<td>Yes</td>
</tr>
</tbody>
</table>

![PowerPoint interface showing video insertion and file types tested](image.png)
1. In this example, we added the first keyframe, then the last keyframe, then three keyframes in the middle. Sometimes it is easiest to work that way. Other times it is easier to add them in sequential order.

2. Sometimes it is easier if you initially add a bunch of duplications of the object in various positions to get a feel for the motion, edit those positions as you see fit, and then use them as keyframe positions.

3. Extending from each keyframe dot is a line. That line can be twisted to change the slope of the curve at that keyframe. Select the dots at the end of that line and move them.

4. The Camera position and the Lamps can be animated too. For each, define an Empty object, force the Camera or Lamp to follow it (it’s one of the Constraints), then animate the Empty. Be sure to give the Empty a descriptive name – all Empties look alike.
1. **Squash and Stretch** -- Defining the rigidity and mass of an object by distorting its shape during an action.

2. **Timing** -- Spacing actions to define the weight and size of objects and the personality of characters.

3. **Anticipation** -- The preparation for an action.

4. **Staging** -- Presenting an idea so that it is unmistakably clear.

5. **Follow Through and Overlapping Action** -- The termination of an action and establishing its relationship to the next action.

6. **Straight Ahead Action and Pose-To-Pose Action** -- The two contrasting approaches to the creation of movement.

7. **Slow In and Out** -- The spacing of the inbetween frames to achieve subtlety of timing and movement.

8. **Arcs** -- The visual path of action for natural movement.

9. **Exaggeration** -- Accentuating the essence of an idea via the design and the action.

10. **Secondary Action** -- The action of an object resulting from another action.

11. **Appeal** -- Creating a design or an action that the audience enjoys watching.

---

**John Lasseter’s Principles of Animation**

14. 3D Printing
The Process

“3D Printing” is defined by some sort of “additive” process. The current frenzy in 3D Printing consists mostly of systems that deposit layers of molten plastic:
The 3D Printing Geometry File

3D Printers are fed a file called an “STL File”, which lists all the triangles in the object. Blender (as well as all CAD systems) can produce this type of file for you.

```
solid

facet normal  0.00  0.00  -1.00
  outer loop
    vertex  -2.000000  -2.000000  0.250000
    vertex  -1.980000  -1.980000  0.250000
    vertex  -1.980000  -2.000000  0.250000
  endloop
endfacet

facet normal  0.00  0.00  -1.00
  outer loop
    vertex  -2.000000  -2.000000  0.250000
    vertex  -2.000000  -1.980000  0.250000
    vertex  -1.980000  -1.980000  0.250000
  endloop
endfacet

. . .

endsolid
```
Object Rules for 3D Printing

1. The object must be a mesh and \textit{consist only of triangles}.

1. \texttt{Alt-’c’} to turn a Meta object or 3D Text into a mesh

2. Modifiers $\rightarrow$ Add Modifier $\rightarrow$ Triangulate
Object Rules for 3D Printing

2. The object must be a legal solid. It must have a definite inside and a definite outside. It can’t have any missing face pieces.
The Simplified Euler's Formula* for Legal Solids

*sometimes called the Euler-Poincaré formula

\[ F - E + V = 2 \]

where:
- \( F \) is the number of faces
- \( E \) is the number of edges
- \( V \) is the number of vertices

For a cube, \( 6 - 12 + 8 = 2 \)

The full formula is:

\[ F - E + V - L = 2(B - G) \]

where:
- \( L \) is the number of inner loops (within faces)
- \( B \) is the number of bodies
- \( G \) is the genus (number of through-holes)
Watch Out for Overhangs!

These layers will build fine

This layer will fall to the plate

Note that if you build it upside-down, it will probably work fine
Watch Out for Overhangs!

Some 3D printers handle this by leaving unused material in place to support the overhangs.

Some 3D printers handle this by using software to add “support structures” to the overhangs.

Some 3D printers handle this better than others… 😊

http://twistedsifter.com/2013/08/when-3d-printing-goes-wrong/
3. You can’t make an object by simply overlapping two objects in 3D. If you want both shapes together, do a Boolean union on them so that they become one complete object.
What Happens if You Do Overlap Objects?

Here’s what one of the 3D Printers in the OSU Library did:

Overlapped in 3D

Boolean union

Not bad – it could have been lots worse …
Object Rules for 3D Printing

4. Each edge in the mesh must bound **2 and only 2** triangles (this is known as the Vertex-to-Vertex Rule)
Installing the 3D Printing Add-on

Select **Edit → Preferences**
Installing the 3D Printing Add-on

Select Add-ons → Mesh: 3D Print Toolbox
Installing the 3D Printing Add-on

Hit the ‘n’ key to see the sidebar menu. The 3D Print Toolbox will be a tab like this.
The 3D Printing Toolbox Add-on

Selecting your object and then clicking on **Check All** will give you this nice list of problems Blender thinks you will have if you try to 3D Print this object:

- Non Manifold Edge: 42
- Bad Contig. Edges: 0
- Intersect Face: 58
- Zero Faces: 0
- Zero Edges: 0
- Non-Flat Faces: 20
- Thin Faces: 17
- Sharp Edge: 0
- Overhang Face: 58

Selecting **Clean Up** will try to fix the problems.
Tab over to **Edit Mode**. Click in an empty area to unselect everything. Then click in all the places that show problems. Blender will light up the object in the places that provoked that problem, giving you a chance to fix them.
Output for 3D Printing

To export an STL file for 3D Printing:

1. Click here and select a folder for the file
2. Click here to write the file

.stl is the most common 3D printing file format

“STL” stands for Stereolithography.
The word “stereolithography” comes from the Greek words for “3D” and “writing”.

Oregon State University
Computer Graphics
Want to see 3D Printing in Action?

Oregon State University’s library has 3D Printers for use by OSU students. To see them via webcam, go to: http://webcam.oregonstate.edu/3dprinter

Click here to see the live, streaming view.
15. References
Blender References

http://cs.oregonstate.edu/~mjb/blender

http://blender.org

http://www.blender.org/education-help/

http://www.blenderguru.com/


Camp Blender

http://cs.oregonstate.edu/~mjb/blender

Mike Bailey

mjb@cs.oregonstate.edu

This work is licensed under a Creative Commons Attribution-NonCommercial-NoDerivatives 4.0 International License