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Mike Bailey
mjb@cs.oregonstate.edu
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What is Google SketchUp?

Google SketchUp is a program which lets you sketch in 3D.  It is 
excellent for creating buildings, houses, and even mechanical designs.

And, it’s easy to do.  As their tagline says “SketchUp is for Everyone”.

And, it can be downloaded for free!
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Getting Google SketchUp for Free

Go to:
http://sketchup.google.com

Follow the links to the free download 
(see the next page).  

There is also a SketchUp Pro which
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There is also a SketchUp Pro which 
costs money. 

Google SketchUp comes in Windows 2000/XP/Vista and Mac OS X versions.

1. Click here

Getting Google SketchUp for Free
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2. Then click here

This one 

Getting Google SketchUp for Free
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costs money

This one 
is free

3. Select the operating system 
(Windows or Mac)

4. Then click here

Getting Google SketchUp for Free
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SketchUp Student Learning Objectives

1. Learn that the computer can be used to enhance creativity.  It’s not just 
for nerds and gamers!

2. Learn that the computer can be used to design and plan.

3. Learn the basics of 3D interaction.  This will have further application in 
fields ranging from engineering CAD to art and animation.
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Getting Started

Double-click the Google SketchUp icon

or click:
Start →All Programs →Google SketchUp 7 →Google SketchUp

The start screen should look something like this:

This person is 5’ 9” 
tall – this sets the 

l  f  h t   
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Right now, click File→Save As – and hit Save often while you are editing

scale for what you are 
about to create

Getting Started Toolbar

The icons across the top are really important:

Draw a
line

Draw a
circle Zoom

Tape
measure

Push/
pull Rotate Orbit

Make
component

Share
model

Place
model

Get
current

view
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Select
something

Draw a
box

Draw an
arc

Move/
Copy

Erase
something

PanOffset Zoom
extents

Paint
bucket

Get
models

Toggle
terrain

Large Toolset Toolbar
Select View→Toolbars→Large Tool Set

Select something

Draw a box Draw a line

Draw an arcDraw a circle

Move/Copy

Erase something

Push/pull
Rotate

Paint bucket
Make  component

Draw a polygon Draw freehand

Follow me
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Zoom
Pan

Tape measure

Orbit

Offset

Zoom extents

Protractor

Add dimensions

Scale

Reset the Axes

Add text
Add 3D text

Previous view Next view

Look aroundPosition camera
Walk Section plane

The Views Toolbar

Select View→Toolbars→Views

3D     Top      Front   Right   Back     Left
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This is a very handy toolbar to have active 
because it lets you change to a specific view of 
your scene with one mouse click!

SketchUp “Inferences”

One of SketchUp’s key strengths is that it doesn’t require you to enter 
every little piece of information as many 3D computer programs do.  
Instead, it tries to infer what you really mean by how you do things.  
Oftentimes it uses colors to tell you what it is inferring.

• Green dots = Endpoints
• Red dots = On an edge
• Cyan dots = Midpoints of edges
• Blue dots = On a surface
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• Red line = X axis
• Blue line = Y axis
• Green line = Z axis

• Magenta line = something is parallel or 
perpendicular to an edge

• Hold SHIFT to capture and lock an 
inference
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Axis Coordinate System

Y
This is the 3D coordinate 
system that SketchUp uses.  
This is referred to as a Right-
Handed Coordinate System

This is called 
The Origin
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• Red line = X axis
• Blue line = Y axis
• Green line = Z axis 

X

Z

Drawing a 2D Box

This is called 
The Origin

Click on the Draw-a-
Box icon, then click on 
the origin, and while 
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holding down the 
mouse, drag in this 
direction

You’ll end up with 
something like this:

We are going to build a 
house, so make this square 
an appropriate size, given 
that the person is almost 
6 feet tall.  Hint: also look 
at the box in the lower-
right corner.

Notice the Bottom of the Screen

This is the
Measurement Toolbar, or 
MTB

It is used to show you the 
dimensions, size, angle, etc. that 
you are currently setting
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It can also be used to set exact values – just type 
into it while you are sizing with the mouse.  But, if 
inputting length, be sure to use units: ’ for feet 
and ” for inches.

Extruding it into a 3D Box

Click on the Push/pull
icon, then click on the 
box you just created, 
and while holding 
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down the mouse, drag 
in this direction

You’ll end up with 
something like this:

We are going to build a 
house, so make this height 
an appropriate size, given 
that the person is almost 
6 feet tall. .  Hint: also 
look at the VCB box in the 
lower-right corner.

Deleting an Object

1. Select the Select icon

2. Select the object to delete by dragging 
a box around it with the cursor

3 Hit th D l t k ( t B k )
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3. Hit the Delete key (not Backspace)

Adding more detail to an existing face

Click on the Draw-a-circle icon, then 
click on one face of the 3D solid you 
just created, and while holding down 
the mouse, drag in some direction
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Click on the Push/pull
icon, then click on the 
circle you just created, 
and while holding 
down the mouse, drag 
in this direction
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An outie or an innie  :-)
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The difference between pushing a hole and cutting a hole

If you push the circle in, 
you get a tunnel with 
walls and a back face

If you erase the circle by 
clicking on the circle, then 
hitting Delete (not

mjb – January 27, 2010

Oregon State University
Computer Graphics

walls and a back face g (
Backspace), you get a 
window cut in the wall.

Want to see it from a different view?

Click on the Orbit or Pan icon, then click 
in the scene, and while holding down the 
mouse, drag in some direction
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You can also Orbit by pushing down 
on the middle button on the mouse.  
On many mice, the middle button is 
also the scroll wheel.

Want to zoom in?

The Zoom extents icon will 
zoom in as much as possible 
without making any of your 
object disappear off the 

mjb – January 27, 2010

Oregon State University
Computer Graphics

screen 

The Zoom icon will allow you 
to zoom as much or as little 
as you want

You can also Zoom in and out with 
the scroll wheel on the mouse

Controlling the SketchUp Camera with a 3D Input Device

The systems in the Oregon State 
University Computer Graphics 
Education Lab (CGEL) are each 
equipped with a 3D input device 
called a Space Navigator (from a 
company called 3DConnexion).   
They come with a SketchUp plug-in 
that allows them to be used to move 
the camera all around
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the camera all around.

Try it!  Gently push and twist the black 
rubber handle and see what happens.  
Do it slowly and gently.

Let’s give it a roof

Click the Draw-a-Line icon to 
draw a line across the top of the 
solid.   But, you want the line to 
go midpoint-to-midpoint, which is 
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a good place to raise the roof line 
from.

So, before clicking to draw the 
line, slide the pencil back and 
forth until the cyan dot appears, 
indicating that you’ve found this 
edge’s midpoint,. 
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Let’s give it a roof
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Now click on the Move/copy
icon, then click on the line 
you just drew, and drag 
upwards

Want to bevel the edge of the roof?

1. Draw a line here

2. Move the point at the tip 
of the roof 
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Want to make it look more interesting?

1. Click on a category

2. Click on a specific color or 
pattern

Click Window→Materials
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3. Click on the surface(s) 
you want to apply it to. 

Pure colors are considered Materials too

1. Select Colors

2. Treat the color just like 
you did the material

Click Window→Materials
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Scroll up and down to 
get more colors

Dimensions

1. Click on an edge

2. Drag where you want the 
dimension to be drawn

Click Tools→Dimensions
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1. Click on the 
circumference of a circle

2. Drag where you want the 
dimension to be drawn

Dimensions are useful if 
you are giving your design 
to someone so that they 
can build it

Adding Windows

Click Windows→Components

Click Large Thumbnails

Click Windows
Click Architecture
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Adding Windows

Drag a window type onto a wall of 
the house
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Adding Landscape Components

Click Window→Components

Click Landscape

Click DC Landscape
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Adding Landscape Components

Click Dynamic Pine Tree

Drag it into the scene where you 
want it
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To release it, click on the black 
Select  Arrow icon and then click 
in some empty spot in the scene

Moving and Copying

1. Select the Select icon

2. Select the object to move

3. Click the Move icon 

4 M th bj t
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4. Move the object

5. Holding down the Control 
key will result in a Copy
instead of a Move

Scaling

1. Select the Select icon

2. Select the object to scale

3. Select Tools→Scale or click 
the Scale icon in the Large 
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g
Toolset toolbar

4. Grab a grip point and scale 
the object

Styles
Click Window→Styles

Select Default Styles

Earth Modeling – adds 
grass and sky

Shaded with textures 

Click on the style you want
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Simple Style --
this one is good

(this one is good)

Wireframe X-ray

The X-ray style is good to use 
if you want to see and place 
objects inside a structure
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Try Some of the Assorted Styles – They’re Fun!
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Tell SketchUp Where in the World you Are

Wow!  SketchUp 
even knows about 
Corvallis!

Click Window→Model Info→Location
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You care about setting your latitude because SketchUp also lets you . . .

This sets your 
latitude

Setting Shadows in SketchUp

Click Window→Shadows

Set time of day and day of year
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Projections

Click Camera→Perspective
Click Camera→Parallel Projection

In perspective, things get smaller 
as they get farther away, which 
is more realistic. In parallel, they 
don’t.  But parallel helps you see 
if front and back faces line up.

“Vanishing Point”
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Exporting an Image File

Click File→Export →2D Graphic

Your image can be exported in 
one of 4 formats:

1. BMP

2. JPEG

3 TIF

Web browsers all 
know about this 
format
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3. TIF

4. PNG 

You would do this, for example, to email 
someone an image of your scene, to import it 
into a document, or to put it on your website

You can also export the 3D scene, but in 
the free version, only to Google Earth 
format.  For more 3D formats, you need 
the Pro version.

Other Cool Things you can 
do with SketchUp
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Changing the Person’s Clothing

The person in the default 
scene is a SketchUp 
“Component”, that is, he is a 
group of geometry collected 
together.  To change his 
clothing, you need to first 
break, or “Explode”, the 
collection apart.
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Even easier, right-click on 
the person and select 
Explode from the pop-up 
menu.

After that, you can click on Window→Materials and re-color 
or re-pattern the clothing

Creating Groups

Sometimes you would like to collect several pieces of geometry 
together and be able to treat them as a single unit.  This is 
called a SketchUp Group.

Create a SketchUp Group by first clicking on the Select icon.

Then, click on the first object you want in the Group.  It will turn 
blue.

Then, hold down the Shift key and click on all other objects you 
want in the group. They will also turn blue. If you select the
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want in the group.  They will also turn blue.  If you select the 
wrong item, just click it again to un-select it.

You can select many things at once by creating a rectangle 
around all of them with the Select cursor.

When you are done, right-click and select Make Group from 
the pop-up menu.

To ungroup the objects, right click on them and select Explode
from the pop-up menu.

Hiding Geometry

Sometimes it would be nice to 
temporarily eliminate some 
geometry so that you could see 
inside something.  This is referred 
to as Hiding.

To hide one or more pieces of 
geometry, select all of them as if 
you were about to create a group.
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Then, right-click and select Hide
from the pop-up menu.  The 
selected objects look like they are 
gone, but they aren’t.  They’re just 
hidden.

This is useful for putting things into 
an object (such as furniture) or for 
editing the object (as is needed 
here).

Un-Hiding Geometry

There are two ways to bring back hidden 
geometry.

The first is to select  
Edit→Unhide→All, like this:

The second is to select 
View→Hidden Geometry.  This will 
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make hidden geometry show up like this:
From there, you can right-click on it and 
select Unhide from the pop-up menu.

Eliminating GeometryEliminating Geometry

Sometimes extruding geometry results 
in it existing places it shouldn’t.

To eliminate any geometry, take the 
Eraser tool and click on the edges of 
the geometry you want to eliminate.

As soon as an edge of a surface has 
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been eliminated, the surface will 
disappear too.

Move Tricks

You can turn the Move into a Copy by 
holding down the Control key.

You can force the Move/Copy to move along one of the 
3 axes (red, green, or blue) by holding down one of the 
arrow keys as follows:
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y
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Adding 3D Text

1. Click on Tools→3D Text

2. Type the text into the dialog box

3. Make any text settings you want

4. Place the text by clicking on an object
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Rotating an Object

1. Select the entire object

2. Click on the Rotate Tool

3. Click the Protractor onto the object

4. Rotate the Protractor with the mouse 
to align it with something (e.g., a key 
point) -- click when ready.
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5. Rotate the object.  Click when done.

Once you’ve started 
rotating, you can 
also type in an exact 
angle into the 
Measurement 
Toolbar (MTB)

A Rotation Trick

We want to rotate this group by 180º (i.e., we want to flip it 
over).  To do this, we want the rotation protractor to be vertical.

But we can’t get this, because the inference engine 
can only find a horizontal surface to latch onto

So we move over to another object 
that has vertical walls, or we make a 
dummy box, and get the inference 
engine to latch the protractor onto a 
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vertical surface, and hold down the 
Shift Key to lock it

We then proceed to use the 
protractor on the original object.

Now rotate that object 180º, and then 
delete the dummy box

An Interesting Use for Rotation -- Building a Real Model from Paper!

Start with a model.  “Boxy” models with 
flat faces work best.

For each face:
1. Select the face and its edges by double-

clicking on the face
2. Right-click the mouse to bring up the 

menu and select Make Group
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By doing this for each face, you are 
separating each face and its edges 
from the rest of the model so they 
can be rotated independently.

An Interesting Use for Rotation -- Building a Real Model from Paper!

Now, for each face, select it (and 
other unfolded faces attached to it) 
and use the Rotate function to 
“unfold” it with respect to the face next 
to it, or with respect to the ground
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At times, you might have to select 
multiple faces (hold down the Shift 
key and click on each one), so that 
they can Rotate together.

This is sometimes easier in a 
Parallel view (Camera→Parallel 
Projection )

An Interesting Use for Rotation -- Building a Real Model from Paper!

Print the unfolded scene from the 
bottom view (you might have to select 
all faces and rotate them over 
together), and then fold them up into a 
real object.
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These tabs were added to make the object 
easier to glue together.
This was a pretty sloppy job, but you get 
the point…
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Rotating a Face

Strange as it may seem, you can also 
rotate just a face.  Follow the same 
procedure, but select only the face.
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Scaling an Object

1. Select an object

2. Select Tools→Scale

3. Move the grips with the mouse

4. Hold down the Control key if you 
want scaling about the object’s 
center
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Moving a side grip 
will stretch the 
object in that 
direction.  Moving a 
diagonal grip will 
scale the object 
equally in all 
directions (“uniform 
scaling”)

You can also scale just a face

1. Select a face

2. Select Tools→Scale

3. Move the grips with the mouse

4. Hold down the Control key if you 
want scaling about the object’s 
center
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Sectioning an Object

1. Select an object

2. Select Tools→Section Plane

3. Select the section plane

4. Use the Move Tool to slide it into 
the object
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Drawing an Arc

1. Click on the Arc Tool

2. Select two points for the chord

3. Select a third point that shows 
SketchUp where to “bulge” the arc
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Arcs are Often used to Round Corners
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1. Click on both edges 
surrounding a corner.  The 
line will turn purple when you 
are the same distance from 
the corner.

2. When you place the third 
point, the inference engine 
will also tell you when the arc 
is tangent to (aligned with) 
the edges.
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Want to create Crown Molding?

Click Tools→Follow Me

Draw an arc in the corner 

Click on the arc area 

Move the cursor along the 
perimeter – don’t click again 
until you are done with the 
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full path 

Another use for Follow Me – make a Sphere

1. Create a circle

2. Copy the circle using the Move Tool with the 
Control key held down

3. Rotate the top circle 90º

4. Select the bottom circle, select Tools→Follow 
Me, and select the top circle

5 Erase the bottom circle and Delete it
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5. Erase the bottom circle and Delete it

Offsetting a Surface

1. Click on the Offset Tool

2. Select the surface to offset on

3. Move the mouse to show how 
much to offset – click when ready

4. This only creates offset edges –
you need to use the Push-Pull Tool 
to do something with it.
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Combining Several Techniques:
Making a Swimming Pool
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Start by creating a rectangle on the floor

Use the Arc Tool and the Erase Tool
to Create 4 Arcs to Round the Corners

mjb – January 27, 2010

Oregon State University
Computer Graphics

Use the Push/Pull Tool to Lift it into 3D
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Use the Offset Tool to Create an Inner Edge
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Use the Push/Pull Tool to Push the Middle Down
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Use the Move Tool with the Control Key Pressed,
to Copy the Floor of the Pool and Raise it Up

This will become the water surface
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Select Window→Materials→Tile to Apply a Surface to Your Pool

If you hold down the Control Key when adding the tile 
pattern, it will apply it to all surfaces, not just one.  This 
saves you a lot of time.

This isn’t right – the top surface of the water is 
currently tile instead.  We’ll fix this next.
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Select Window→Materials→Water and click on the top surface to 
change it to water
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Make the Water Surface Translucent

In the Materials→Water dialog box, click on the Edit tab.
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Then lower the Opacity until the water surface looks properly translucent.
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Adding Fog

Click Window→Fog
This brings up the Fog dialog box

Click here to turn the fog feature on
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This slider adjusts how far in 
front of your eye the fog starts.  
Items closer to you than this 
will not be fogged at all.

This slider adjusts how far in 
front of your eye the fog 
completely hides your scene.  
Items farther away than this 
will not be visible at all.

Adding Fog
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Adding a Vertical Chimney to a Sloped Roof

1. Draw a line along the roof using 
the pencil tool.  SketchUp’s 
inference engine will try to force it 
to be parallel to an axis.  Let it do 
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that.

2. Select the line you just drew.  Use 
the Move/Copy icon with the 
Control Key held down to lift it up 
in the air.  (The Control key will 
force it to do a Copy.)  Wiggle it a 
little bit until you get the phrase 
“On Blue Axis” to appear.  This 
indicates that you are lifting it 
straight up.

Adding a Vertical Chimney to a Sloped Roof

3. Draw lines using the pencil tool 
from the ends of this new line to 
the face of the roof.  SketchUp will 
tell you when you are there.  Be 
sure the line is a color (red in this 
case) to indicate that you are 
parallel to an axis.

4. Using the pencil tool, connect up 
all the points to form edges.  You 
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should have 9 lines in all.  (Don’t 
forget to look at the back of the 
chimney.)  SketchUp will turn the 
edges into faces as you complete 
them.  There should be 4 faces in 
all.

Adding a Vertical Chimney to a Sloped Roof

5. Use the Push/Pull tool to lift the 
top surface.

6. Use the Offset tool to make an 
inner surface on that top surface.
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7. Use the Push/Pull tool to push that 
inner surface down.

Adding a Vertical Chimney to a Sloped Roof

8. Add whatever Window→Material 
decoration you want

9. Get rid of the excess chimney under 
the roof by hiding an end face and 
erasing those edges.  (See previous 
sections.)

10. Unhide the end face when you are 
done
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Subtracting one Surface from Another

1. Create two objects

2. Use the Move Tool to overlap them

3. Select both objects

4. Select Edit→Intersect→Intersect 
with Model

5. Erase the surfaces and lines you don’t 
need
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Note the difference 
in edges

Creating a Flying Animation

1. Create a view of the scene

2. Select View→Animation→Add Scene

3. Create a different view

4. Select View→Animation→Add Scene

5. . . .

To create an animation:
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1. Select View→Animation→Play

2. Pause or stop the scene with these buttons

To play the full animation:
As you add scenes, SketchUp will list 
them.  You can click on any of them to 
get back to that view.

Animation Settings
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Set how long each scene transition lasts

How long to wait before starting the animation

Exporting Your Animation

1. Select File→Export→Animation

2. Save as an AVI file

To save an animation to a file:

Double-click on your AVI file

To play the animation file:
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1. Select Insert→Movies and Sounds→Movie from File

2. Double-click on the image when editing the slide

3. Click on the image in Slide Show mode

To import your animation into PowerPoint:

Making SketchUp Work 
with Google Earth
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What if you want to show your creation . . .
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. . . where it really belongs on the Earth?

The tacky proposed 
“Dimple Hill Beacon”
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Corvallis, Oregon, USA

Steps

1. Launch Google Earth

2. Navigate to where you want your model to go
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Navigating

Type in a city name or street 
address here

Rotate the scene CW and CCW (the right 
mouse button also does this, plus zooming)

Pan the scene (the left mouse button also 
does this)
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Zoom the scene (the mouse scroll wheel 
also does this)

Plus, the middle mouse button will rotate 
the scene to change from a top-down view 

to a 3D view 

Flying to “Corvallis, OR” and Getting a 3D View
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Next Step: Navigate to a Top-down View of Where you 
want to put Your Structure

Dimple Hill, OR
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Over in SketchUp, click on the Get Current View Icon
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This brings a grayscale 
version of the Google 

Earth scene into SketchUp
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Get
models

Place
model

Get
current

view

SketchUp Menu Icons Related to Google Earth

Get current view – copy the Google Earth 
scene into SketchUp

Toggle terrain – change the terrain in 
SketchUp from flat to 3D and back again

Place model – send your model back to 
Google Earth to see how it looks
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Share
model

Toggle
terrain

Google Earth to see how it looks

Get models – Get 3D models that others 
have created

Share models -- Publish the model so that 
others who use Google Earth can get them 
too (you need a Google account to do this)

Use SketchUp to Draw a New Model, or File→Import an Existing One
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Then, use Place model 
to ship it back to 

Google Earth

Placing the Model
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In Google Earth, select File→Save →Save image to write an image file 
of this scene, suitable for displaying on a web page or a poster 
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In Google Earth, you can also turn on the 3D Buildings layer to see 
what other buildings people have published – this is really fun
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If you want to be seriously awed,
Fly To Washington, DC or New York City 

and turn the 3D Buildings on
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Marking GIS Areas with 
SketchUp and Google Earth
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Outlining the meadow 
area of Dimple Hill

In Google Earth, Navigate to Where you Want to Be

Dimple Hill, Oregon
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Fire Up SketchUp, and Import the Google Earth Image
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Get a Top-Down View
(You might have to hit Zoom Extents to Center the View)
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Using the Line Tool, Click Multiple Times to Draw a Connected Series 
of Lines Around the Dimple Hill Meadow Area

The outline will be a little 
hard to see because the 
lines are black and the 
background is gray.  Oh well.
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Be sure the last point you 
click matches the point you 
started with.  SketchUp will 
help you do this by popping 
up the Endpoint inference.  
Click there . . .

Use the Line Tool, Click Multiple Times to Draw a Line Around the 
Dimple Hill Meadow Area

. . . to form a polygon.

You can tell that a polygon 
has been formed because it 
will color the inside like this
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will color the inside, like this.



18

Use the Push-Pull Tool to Lift the Polygon into 3D
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Turn the Google Earth Terrain into 3D, Sweep over the Entire 3D Box with the 
Selection Tool, then use the Move Tool to Push the Building Down into the Terrain

You might have to hold the Down 
Arrow key to force the 
movement to be along the 
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g
vertical (blue) axis only.

You also might need to Push-Pull 
the top of the box higher. 

Select Window → Material → Colors and Pick a Nice Color for the Box.
Holding down the Control Key, click the Paint Brush on the Box

You hold down the Control Key 
when you click the paint bucket 
on your box so that it will color 
all the faces connected to the 
one face that you click.  
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Otherwise, you will need to click 
the paint bucket on each face 
individually.  Yuch.

While We’re at it, Click on the Edit Tab and Adjust the Opacity of the Colored Box
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If you want to make the Box Look “Softer”(like it is made from Jello),
Right-Click on the Box and Select Soften/Smooth Edges, then Adjust These Two 

Controls
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Now, Send your Box Back to Google Earth
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If Google Earth has changed 
your height exaggeration, go to:

Tools  → Options

and change the Elevation 
Exaggeration back to 1.0
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Good SketchUp Web Links

General SketchUp Site

http://sketchup.google.com

Download SketchUp Models

http://sketchup.google.com/3dwarehouse

These Notes

http://cs.oregonstate.edu/~mjb/sketchup
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Tips and Tricks

http://sketchupdate.blogspot.com/search/label/Tips%20and%20Tricks

SketchUp Blogs

http://sketchupdate.blogspot.com

Step-by-Step SketchUp Examples

http://www.3dvinci.net/teacherguide

More Good SketchUp Web Links

Video Tutorials

http://sites.google.com/site/3dbasecamp2008
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Developing Plug-ins (Advanced!)

http://groups.google.com/group/SketchUp-Plugins-Dev/web/index.html

http://groups.google.com/group/SketchUp-Plugins-Dev

Reference Books

Bonnie Roskes, SketchUp 7 Hands On. Bonnie Roskes, Google SketchUp Cookbook.
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Other Examples
Hassan Sinky
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OSU’s Reser Stadium

Kris Hemenway
Chris Wasco
Oliver Forral

Other Examples – the OSU 3D Campus Map Project

Kelley Engineering Center

Kearney Hall
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Women’s Center

Weniger Hall
Clock
Tower

Milne Hall

Kidder Hall 
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