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Using SketchUp !

Mike Bailey
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http://cs.oregonstate.edu/~mjb/sketchup
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International License
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What is SketchUp?

SketchUp is a program which lets you sketch in 3D.  It is excellent for creating 
buildings, houses, and even mechanical designs.

And, it’s easy to do.  As their tagline says, SketchUp is ”3D for Everyone”.
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Getting SketchUp for Free

Go to:

https://app.sketchup.com/app?hl=en

This is a free web-based version of SketchUp.

There are also downloadable versions of SketchUp
which cost money. Go to:

https://www.sketchup.com/plans-and-pricing

for more information.
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SketchUp Student Learning Objectives

1. Learn that the computer can be used to enhance creativity.  
It’s not just for programmers and gamers!

2. Learn that the computer can be used to design and plan.

3. Learn the basics of 3D interaction.  This will have further application 
in fields ranging from engineering CAD to art and animation.
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Getting Started

In the Oregon State CGEL, double-click the SketchUp icon

or click:
Start →All Programs → SketchUp 2019

The start screen should look something like this:

Right now, click File→Save As – and navigate to C:\temp
Hit Save often while you are editing

This specific person 
changes from version 
to version.  They are 
always between 5’6” 
and 6’ tall.
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Getting Started Toolbar

The icons across the top are really important:

Select
something

Draw a
line

Erase
something

Draw a
box, etc.

Draw an
arc

Rotate
Paint

bucket

Zoom

Pan

Draw
text

labels
Move/
Copy Scale

Orbit

Tape
measure

Zoom
extents

Offset
curve

Push/Pull

Extension
Manager

User
Info

Extension
warehouse

Layout

3D
warehouse
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7Large Toolset Toolbar
Select View→Toolbars→Large Tool Set

Select something

Draw a line Draw freehand

Draw rotated rectangleDraw a box

Draw an arc

Erase something

Move axes
Draw text labels

Rotate

Drw an arc

Draw an arc

Protractor

Push/Pull

Add 3D Text

Paint bucket
Make  component

Scale

Draw a circle Draw a polygon

Draw an arc

Follow Me

Move

Tape measure

Offset Curve
Add Dimensions

Orbit Pan

Zoom boxZoom

Zoom extents Section plane
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8The Views Toolbar

Select View→Toolbars→Views

3D    Top    Front  Right   Back  Left

This is a very handy toolbar to have active 
because it lets you change to a specific view of 
your scene with one mouse click!
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SketchUp “Inferences”

One of SketchUp’s key strengths is that it doesn’t require you to enter 
every little piece of information as many 3D computer programs do.  
Instead, it tries to infer what you really mean by how you do things.  
Oftentimes it uses colors to tell you what it is inferring.

• Green dots = Endpoints
• Red dots = On an edge
• Cyan dots = Midpoints of edges
• Blue dots = On a surface

• Red line = X axis
• Blue line = Y axis
• Green line = Z axis

• Magenta line = something is parallel or 
perpendicular to an edge

• Hold SHIFT to capture and lock an 
inference
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Axis Coordinate System

• Red line = X axis
• Blue line = Y axis
• Green line = Z axis 

X

Z

Y
This is the 3D coordinate system 
that SketchUp uses.  This is 
referred to as a 
Right-Handed Coordinate System

This is called 
The Origin
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Moving the Scene Around in 3D

• Scroll Wheel:  zoom in and out

• Middle Button: orbit

• Shift-Middle Button: pan
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Drawing a 2D Box

This is called 
The Origin

Click on the Draw-a-Box
icon, then click on the 
origin, and while holding 
down the mouse, drag in 
this direction

You’ll end up with 
something like this:

We are going to build a 
house, so make this square 
an appropriate size, given 
that the person is almost 
6 feet tall.  Hint: also look 
at the box in the lower-
right corner.
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Notice the Bottom-Right of the Screen

This is the Measurement Toolbar, or MTB

It is used to show you the 
dimensions, size, angle, etc. that 
you are currently setting

It can also be used to set exact values – just type into it while you are 
sizing with the mouse.  But, if inputting length, be sure to use units: ‛ for 
feet and ” for inches.
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Extruding it into a 3D Box

Click on the Push/Pull icon, 
then click on the box you just 
created, and while holding 
down the mouse, drag in this 
direction

You’ll end up with 
something like this:

We are going to build a 
house, so make this height 
an appropriate size, given 
that the person is almost 
6 feet tall. .  Hint: also 
look at the VCB box in the 
lower-right corner.
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15Deleting an Object

1. Select the Select icon

2. Select the object to delete by dragging 
a box around it with the cursor

3. Hit the Delete key (not Backspace)
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16Adding more detail to an existing face

Click on the Draw-a-circle icon, 
then click on one face of the 3D 
solid you just created, and while 
holding down the mouse, drag 
in some direction

Click on the Push/pull
icon, then click on the 
circle you just created, 
and while holding 
down the mouse, drag 
in this direction
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An outie or an innie  :-)
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The difference between pushing a hole and cutting a hole

If you push the circle in, 
you get a tunnel with 
walls and a back face

If you erase the circle by 
clicking on the circle, then 
hitting Delete (not
Backspace), you get a 
window cut in the wall.
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19Want to see it from a different view?

Click on the Orbit or Pan icon, then click 
in the scene, and while holding down the 
mouse, drag in some direction

You can also Orbit by pushing down 
on the middle button on the mouse.  
On many mice, the middle button is 
also the scroll wheel.
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20Want to zoom in?

The Zoom extents icon will 
zoom in as much as possible 
without making any of your 
object disappear off the 
screen 

The Zoom icon will allow you 
to zoom as much or as little 
as you want

You can also Zoom in and out with 
the scroll wheel on the mouse
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21Style Menu

View→Toolbars→Style

X-ray Back edges
dashed

Wireframe Hidden
Line

Shaded Shaded
with

Textures

Monochrome

X-ray
Back edges

dashed Wireframe Hidden Line

Shaded
Shaded with

Textures Monochrome
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22One, Two, and Three Clicks

Single-click
(selects just the face or edge)

Double-click
(selects the face and the edge)

Triple-click
(selects everything on that object)
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23Let’s give it a roof

Click the Draw-a-Line icon to 
draw a line across the top of the 
solid.   But, you want the line to 
go midpoint-to-midpoint, which is 
a good place to raise the roof line 
from.

So, before clicking to draw the 
line, slide the pencil back and 
forth until the cyan dot appears, 
indicating that you’ve found this 
edge’s midpoint,. 
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Let’s give it a roof

Now click on the Move/copy
icon, then click on the line 
you just drew, hold down the 
up-arrow key, and drag 
upwards
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25Want to Bevel the edge of the roof?

1. Draw a line here

2. Move the point at the tip 
of the roof 
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26The Move Icon is Good to Get to Know!

1. Create an Object

2. Select it

3. Click the Move and slide it in one of the 
red, green, blue directions
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27The Control-Move Does a Copy

1. Create an Object

2. Select it

3. Click the Move while holding down the 
Ctrl key

You can move the 
object interactively, 
or you can type a 
distance in the MTB.  
For example, try 
typing 5’ (5 feet).
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28The Control-Move Does a Copy

1. Create an Object

2. Select it

3. Click the Move while holding down the 
Ctrl key

You can move the 
object interactively, 
or you can type a 
distance in the MTB.  
For example, try 
typing 5’ (5 feet).

You can also 
generate more than 
one copy by typing, 
for example, 10x,
into the MTB.
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29A Move/Copy Trick

… force the Move/Copy to move along one of the 3 principal directions 
(red, green, or blue) by holding down one of the arrow keys as follows:

You can get SketchUp to move/copy in one of the three principal 
directions (red, green, or blue) by moving in that direction.  
SketchUp’s “inference engine” will figure it out.  But, you can also…
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Scaling

1. Select the Select icon

2. Select the object to scale

3. Select Tools→Scale or click 
the Scale icon 

4. Grab a grip point and scale 
the object
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Rotating an Object

1. Select the entire object (triple-click)

2. Click on the Rotate Tool

3. Click the Protractor onto the object

4. If necessary, hit arrow keys to change 
the Protractor direction

5. Rotate the Protractor with the mouse 
to align it with something (e.g., a key 
point) -- click when ready.

6. Rotate the object.  Click when done.

Once you’ve started 
rotating, you can 
also type in an exact 
angle into the 
Measurement 
Toolbar (MTB)
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A Rotation Trick

We want to rotate this group by 180º (i.e., we want to flip it 
over).  To do this, we want the rotation protractor to be vertical.

But we can’t get this, because the inference engine 
can only find a horizontal surface to latch onto

So we move over to another object 
that has vertical walls, or we make a 
dummy box, and get the inference 
engine to latch the protractor onto a 
vertical surface, and hold down the 
Shift Key to lock it

We then proceed to use the 
protractor on the original object.

Now rotate that object 180º, and then 
delete the dummy box
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33Want to make the house look more interesting?

1. Click on a category

2. Click on a specific color or 
pattern

3. Click on the surface(s) 
you want to apply it to. 

Click Materials
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34Pure colors are considered Materials too

1. Select Colors

2. Treat the color just like 
you did the material

Scroll up and down to 
get more colors
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35You Could Even Put Vegetation on the Roof!

But, who would ever think to do that?!

Well, the Vancouver (British Columbia) 
Convention Center would!
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1. Click on the 
circumference of a circle

2. Drag where you want the 
dimension to be drawn

Dimensions

1. Click on an edge

2. Drag where you want the 
dimension to be drawn

Click Tools→Dimensions

Dimensions are useful if 
you are giving your design 
to someone so that they 
can build it



7

mjb – August 1, 2020Computer Graphics

37Styles

Click Styles

Each one of these will bring up several 
more styles to experiment with
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38Try Some of the Assorted Styles – They’re Fun!
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39Setting Shadows in SketchUp

Window→Model Info→Geo-location→Set Manual Location
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40Setting Shadows in SketchUp

If you live in the Corvallis, Oregon area, type these values:
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41Setting Shadows in SketchUp

Click Shadows

Set time of day and day of year

Click this box to turn shadows on
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Projections

Click Camera→Perspective

Click Camera→Parallel Projection

In perspective, things get smaller 
as they get farther away, which 
is more realistic. In parallel, they 
don’t.  But parallel helps you see 
if front and back faces line up.

Perspective Parallel

“Vanishing Point”
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Exporting an Image File

Click File→Export →2D Graphic

Your image can be exported in 
one of 4 formats:

1. BMP

2. JPEG

3. TIF

4. PNG

5. PDF 

You would do this, for example, to email someone an 
image of your scene, to import it into a document, or to 
put it on your website

Web browsers all 
know about this 
format
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Exporting a 3D Object

Click File→Export →3D Model

Your image can be exported in one of 11 formats.  The ones you 
really care about are:

1. OBJ – as close to a universal 3D file format that there is

2. STL – used for 3D printing

3. DAE – Collada format, compatible with many artist programs

4. 3DS – compatible with AutoDesk’s 3D Studio Max
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45Changing the Person’s Clothing

The person in the default 
scene is a SketchUp 
“Component”, that is, he is a 
group of geometry collected 
together.  To change his 
clothing, you need to first 
break, or “Explode”, the 
collection apart.

Even easier, right-click on 
the person and select 
Explode from the pop-up 
menu.

After that, you can click on Materials and re-color or re-
pattern the clothing
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46Creating Groups

Sometimes you would like to collect several pieces of geometry 
together and be able to treat them as a single unit.  This is 
called a SketchUp Group.

Create a SketchUp Group by first clicking on the Select icon.

Then, click on the first object you want in the Group.  It will turn 
blue.

Then, hold down the Shift key and click on all other objects you 
want in the group.  They will also turn blue.  If you select the 
wrong item, just click it again to un-select it.

You can select many things at once by creating a rectangle 
around all of them with the Select cursor.

When you are done, right-click and select Make Group from 
the pop-up menu.

To ungroup the objects, right click on them and select Explode
from the pop-up menu.
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47Hiding Geometry

Sometimes it would be nice to 
temporarily eliminate some geometry 
so that you could see inside 
something.  This is referred to as 
Hiding.

To hide one or more pieces of 
geometry, select all of them as if you 
were about to create a group.

Then, right-click and select Hide from 
the pop-up menu.  The selected 
objects look like they are gone, but 
they aren’t.  They’re just hidden.

This is useful for putting things into an 
object (such as furniture) or for editing 
the object (as is needed here).
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48Un-Hiding Geometry

There are two ways to bring back hidden 
geometry.

The first is to select  
Edit→Unhide→All, like this:

The second is to select 
View→Hidden Geometry.  This will 
make hidden geometry show up like this:
From there, you can right-click on it and 
select Unhide from the pop-up menu.
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49Eliminating GeometryEliminating Geometry

Sometimes extruding geometry results 
in it existing places it shouldn’t.

To eliminate any geometry, take the 
Eraser tool and click on the edges of 
the geometry you want to eliminate.

As soon as an edge of a surface has 
been eliminated, the surface will 
disappear too.
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Adding 3D Text

1. Click on Tools→3D Text

2. Type the text into the dialog box

3. Make any text settings you want

4. Place the text by clicking on an object
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An Interesting Use for Rotation -- Building a Real Model from Paper!

Start with a model.  “Boxy” models with 
flat faces work best.

For each face:

1. Select the face and its edges by double-
clicking on the face

2. Right-click the mouse to bring up the 
menu and select Make Group

By doing this for each face, you are 
separating each face and its edges 
from the rest of the model so they 
can be rotated independently.
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An Interesting Use for Rotation -- Building a Real Model from Paper!

Now, for each face, select it (and 
other unfolded faces attached to it) 
and use the Rotate function to 
“unfold” it with respect to the face next 
to it, or with respect to the ground

At times, you might have to select 
multiple faces (hold down the Shift 
key and click on each one), so that 
they can Rotate together.

This is sometimes easier in a 
Parallel view (Camera→Parallel 
Projection )
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An Interesting Use for Rotation -- Building a Real Model from Paper!

Print the unfolded scene from the 
bottom view (you might have to select 
all faces and rotate them over 
together), and then fold them up into a 
real object.

These tabs were added to make the object 
easier to glue together.
This was a pretty sloppy job, but you get 
the point… mjb – August 1, 2020Computer Graphics
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Rotating a Face

Strange as it may seem, you can also 
rotate just a face.  Follow the same 
procedure, but select only the face.
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55You can also scale a face

1. Select a face

2. Select Tools→Scale

3. Move the grips with the mouse

4. Hold down the Control key if you 
want scaling about the object’s 
center
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Drawing an Arc

1. Click on the Arc Tool

2. Select two points for the chord

3. Select a third point that shows 
SketchUp where to “bulge” the arc
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Arcs are Often used to Round Corners

1. Click on both edges 
surrounding a corner.  The 
line will turn purple when you 
are the same distance from 
the corner.

2. When you place the third 
point, the inference engine 
will also tell you when the arc 
is tangent to (aligned with) 
the edges.
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Want to create Crown Molding?

Click Tools→Follow Me

Draw an arc in the corner 

Click on the arc area 

With th eleft button still down, move the 
cursor along the perimeter – don’t click 
again until you are done with the full path 

mjb – August 1, 2020Computer Graphics

59
Another use for Follow Me – Extruding a Surface

1. Create an object

2. Draw a line and some arcs from one corner of the 
object

3. Select Follow Me

4. Click on one face of the object and, with the left 
mouse button still down, slide the cursor along the 
curve

5. Using the pink eraser, erase the connecting lines
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60Another use for Follow Me – make a Sphere

1. Create a circle

2. Copy the circle using the Move Tool with the 
Control key held down

3. Rotate the upper circle 90º

4. Move the upper circle so that its bottom is at the 
lower circle’s center

5. Select the lower circle, select Tools→Follow Me, 
and then select the upper circle

6. Delete the lower circle
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61
Offsetting a Surface

1. Click on the Offset Tool

2. Select the surface to offset on

3. Move the mouse to show how 
much to offset – click when ready

4. This only creates offset edges –
you need to use the Push-Pull Tool 
to do something with it.
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Combining Several Techniques:

Making a Swimming Pool

Start by creating a rectangle on the floor
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63Use the Arc Tool and the Erase Tool
to Create 4 Arcs to Round the Corners
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64Use the Push/Pull Tool to Lift it into 3D

mjb – August 1, 2020Computer Graphics

65Use the Offset Tool to Create an Inner Edge
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66Use the Push/Pull Tool to Push the Middle Down
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67Use the Move Tool with the Control Key Pressed,
to Copy the Floor of the Pool and Raise it Up

This will become the water surface
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68Select Materials→Tile to Apply a Surface to Your Pool

If you hold down the Control Key when adding 
the tile pattern, it will apply it to all surfaces, not 
just one.  This saves you a lot of time.

This isn’t right – the top surface of the water is 
currently tile instead.  We’ll fix this next.
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69Select Materials→Water and click on the top surface to change it 
to water
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70Make the Water Surface Translucent

In the Materials→Water dialog box, click on the Edit tab.

Then lower the 
Opacity until the 
water surface looks 
properly translucent.
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71Adding Fog

Click Fog

Click here to turn the fog feature on

This slider adjusts how far in 
front of your eye the fog starts.  
Items closer to you than this 
will not be fogged at all.

This slider adjusts how far in 
front of your eye the fog 
completely hides your scene.  
Items farther away than this 
will not be visible at all.
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72Adding Fog
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73Adding a Vertical Chimney to a Sloped Roof

1. Draw a line along the roof using 
the pencil tool.  SketchUp’s
inference engine will try to force it 
to be parallel to an axis.  Let it do 
that.

2. Select the line you just drew.  Use 
the Move/Copy icon with the 
Control Key held down to lift it up 
in the air.  (The Control key will 
force it to do a Copy.)  Wiggle it a 
little bit until you get the phrase 
“On Blue Axis” to appear.  This 
indicates that you are lifting it 
straight up.
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74Adding a Vertical Chimney to a Sloped Roof

3. Draw lines using the pencil tool from the 
ends of this new line to the face of the 
roof.  SketchUp will tell you when you 
are there.  Be sure the line is a color 
(red in this case) to indicate that you are 
parallel to an axis.

4. Using the pencil tool, connect up all the 
points to form edges.  You should have 
9 lines in all.  (Don’t forget to look at the 
back of the chimney.)  SketchUp will turn 
the edges into faces as you complete 
them.  There should be 4 faces in all.
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75Adding a Vertical Chimney to a Sloped Roof

5. Use the Push/Pull tool to lift the 
top surface.

6. Use the Offset tool to make an 
inner surface on that top surface.

7. Use the Push/Pull tool to push 
that inner surface down.
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76Adding a Vertical Chimney to a Sloped Roof

8. Add whatever Material decoration 
you want

9. Get rid of the excess chimney under 
the roof by hiding an end face and 
erasing those edges. 

10. Unhide the end face when you are 
done
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77Solid Tools

View→Toolbars→Solid Tools

Outer Shell Intersect Union Subtract Trim Split

1. Start with two objects
2. Select the box (triple-click), then right-click and select Make Group
3. Select the cylinder (triple-click), then right-click and select Make Group
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78Solid Tools

View→Toolbars→Solid Tools

Outer Shell Intersect Union Subtract Trim Split

Overlap them in 3D: View→Face Style→X-ray:
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79Solid Tools

View→Toolbars→Solid Tools

Outer Shell Intersect Union Subtract Trim Split

Select them both, then select Intersect:
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80Solid Tools

View→Toolbars→Solid Tools

Outer Shell Intersect Union Subtract Trim Split

Select them both, then select Union:
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81Solid Tools

View→Toolbars→Solid Tools

Outer Shell Intersect Union Subtract Trim Split

Select the cylinder, then select Subtract, then select the box:
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82Section Planes

Create
Section
Plane

Toggle
Section
Planes

Toggle
Section

Cuts

Toggle
Section

Fill

Start with something like this
(shown here in X-ray style so you can see what is inside it)

View→Toolbars→Section
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83Section Planes

You can use the arrow keys 
to change the orientation of 
the section plane
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84Section Planes

Use the Move icon to move the section 
plane down into the object
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85You Can Create Section Planes in All Three Directions

mjb – August 1, 2020Computer Graphics

86Creating a Flying Animation

1. Create a view of the scene

2. Select View→Animation→Add Scene

3. Create a different view

4. Select View→Animation→Add Scene

5. . . .

1. Select View→Animation→Play

2. Pause or stop the scene with these buttons

To create an animation:

To play the full animation:
As you add scenes, SketchUp will list 
them.  You can click on any of them to 
get back to that view.
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87Animation Settings

Set how long each scene transition lasts

How long to wait before starting the animation
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88Exporting Your Animation

1. Select File→Export→Animation

2. Save as an MP4 file

To save an animation to a file:

Double-click on your MP4 file

To play the animation file:

1. Select Insert→Video→Video on My PC

2. Double-click on the image when editing the slide

3. Click on the image in Slide Show mode

To import your animation into PowerPoint:

mjb – August 1, 2020Computer Graphics

89Be Sure that Internet Explorer is not your Default Browser
(I like FireFox)
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90Logging into the 3D Warehouse

mjb@engr.oregonstate.edu

Corv@llis72542

Click 3D Warehouse
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913D Warehouse Example -- Adding Picture Windows

Click 3D Warehouse

Type what you hope to find

Click on the one you’d like
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92Adding Picture Windows
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93

Put it where you want it.

You might have to scale 
and/or rotate it.

Adding Picture Windows
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94Use 3D Warehouse to Add other Components

But, be careful!
Too much scene detail will 
overwhelm your graphics card!
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95The SketchUp Extensions

mjb@engr.oregonstate.edu

Corv@llis72542
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96The SketchUp Sandbox

View→Toolbars→Sandbox Create a 
Sandbox 
grid
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97The SketchUp Sandbox
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98

Create 
smooth hills

The SketchUp Sandbox

Type a number to change the smoothing radius

Double-click
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99The SketchUp Sandbox

Lift up or 
push down
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Select Stamp

Hover a 3D object 
over the terrain to 
create a flat area 
to place that object 
down on

The SketchUp Sandbox
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101The SketchUp Sandbox
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102SketchUp Quick Reference Card
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103Lots of Menus are Available
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SketchUp Examples That Some 
of My OSU Students Did!
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Other Examples

Hassan Sinky

OSU’s Reser Stadium
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Kris Hemenway
Chris Wasco
Oliver Forral

Other Examples – the OSU 3D Campus Map Project

Kelley Engineering Center

Kearney Hall

Women’s Center

Weniger Hall

Clock
Tower

Milne Hall

Kidder Hall 
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Using SketchUp !

Mike Bailey

mjb@cs.oregonstate.edu

http://cs.oregonstate.edu/~mjb/sketchup

This work is licensed under a Creative Commons 
Attribution-NonCommercial-NoDerivatives 4.0 
International License


