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Getting Started

Double-click the Google SketchUp icon

or click:
Start →All Programs →Google SketchUp 7 →Google SketchUp

The start screen should look something like this:
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Right now, click File→Save As – and hit Save often while you are editing
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Getting Started Toolbar

The icons across the top are really important:

Draw a
line

Draw a Tape Push/

Make
component

SharePlace

Get
current
view

circle Zoom
p

measure pull Rotate Orbit
Share
model

Place
model
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Select
something

Draw a
box

Draw an
arc

Move/
Copy

Erase
something

PanOffset Zoom
extents

Paint
bucket

Get
models

Toggle
terrain

The Large Toolset Toolbar

Select View→Toolbars→Large Tool Set
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The Views Toolbar

Select View→Toolbars→Views

3D     Top      Front   Right   Back     Left

This is a very handy toolbar to have active 
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because it lets you change to a specific view of 
your scene with one mouse click!

SketchUp “Inferences”

One of SketchUp’s key strengths is that it doesn’t require you to enter 
every little piece of information as many 3D computer programs do.  
Instead, it tries to infer what you really mean by how you do things.  
Oftentimes it uses colors to tell you what it is inferring.

• Green dots = Endpoints
• Red dots = On an edge
• Cyan dots = Midpoints of edges
• Blue dots = On a surface

• Red line = X axis
• Blue line = Y axis
• Green line = Z axis
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• Magenta line = something is parallel or 
perpendicular to an edge

• Hold SHIFT to capture and lock an 
inference
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Axis Coordinate System

Y
This is the 3D coordinate 
system that SketchUp uses.  
This is referred to as a Right-
H d d C di t  S t

This is called 
The Origin Handed Coordinate SystemThe Origin
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• Red line = X axis
• Blue line = Y axis
• Green line = Z axis 

X

Z

Exporting an Image File

Click File→Export →2D Graphic

Your image can be exported in 
one of 4 formats:one of 4 formats:

1. BMP

2. JPEG

3. TIF

4. PNG 

You would do this  for example  to email 
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You would do this, for example, to email 
someone an image of your scene, to import it 
into a document, or to put it on your website

You can also export the 3D scene, but in 
the free version, only to Google Earth 
format.  For more 3D formats, you need 
the Pro version.
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Changing the Person’s Clothing

The person in the default 
scene is a SketchUp
“Component”, that is, he is a 
group of geometry collected 
together.  To change his 
clothing, you need to first 
break, or “Explode”, the 
collection apart.

Even easier, right-click on 
the person and select 
Explode from the pop-up 
menu.
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After that, you can click on Window→Materials and re-color 
or re-pattern the clothing

Creating Groups

Sometimes you would like to collect several pieces of geometry 
together and be able to treat them as a single unit.  This is 
called a SketchUp Group.

Create a SketchUp Group by first clicking on the Select icon.

Then, click on the first object you want in the Group.  It will turn 
blue.

Then, hold down the Shift key and click on all other objects you 
want in the group.  They will also turn blue.  If you select the 
wrong item, just click it again to un-select it.

You can select many things at once by creating a rectangle 
around all of them with the Select cursor.
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When you are done, right-click and select Make Group from 
the pop-up menu.

To ungroup the objects, right click on them and select Explode
from the pop-up menu.
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Hiding Geometry

Sometimes it would be nice to 
temporarily eliminate some 
geometry so that you could see 
inside something.  This is referred 
to as Hiding.to as Hiding.

To hide one or more pieces of 
geometry, select all of them as if 
you were about to create a group.

Then, right-click and select Hide
from the pop-up menu.  The 
selected objects look like they are 
gone, but they aren’t.  They’re just 
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hidden.

This is useful for putting things into 
an object (such as furniture) or for 
editing the object (as is needed 
here).

Un-Hiding Geometry

There are two ways to bring back hidden 
geometry.

The first is to select  
Edit→Unhide→All, like this:

The second is to select 
View→Hidden Geometry.  This will 
make hidden geometry show up like this:
From there, you can right-click on it and 
select Unhide from the pop-up menu.
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Eliminating GeometryEliminating Geometry

Sometimes extruding geometry results 
in it existing places it shouldn’t.

To eliminate any geometry, take the 
Eraser tool and click on the edges of 
the geometry you want to eliminate.

As soon as an edge of a surface has 
been eliminated, the surface will 
disappear too.
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Move Tricks

You can turn the Move into a Copy by 
holding down the Control key.

You can force the Move/Copy to move along one of the 
3 axes (red, green, or blue) by holding down one of the 
arrow keys as follows:
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Dimensions

Click Tools→Dimensions

1. Click on an edge

2. Drag where you want the 
dimension to be drawn
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1. Click on the 
circumference of a circle

2. Drag where you want the 
dimension to be drawn

Projections

Click Camera→Perspective
Click Camera→Parallel Projection

In perspective, things get smaller 
as they get farther away  In 

“Vanishing Point”

as they get farther away. In 
parallel, they don’t.  But parallel 
helps you see if front and back 
faces line up.
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Drawing an Arc

1. Click on the Arc Tool

2. Select two points for the chord

3. Select a third point that shows 
SketchUp where to “bulge” the arcp g
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Offsetting a Surface

1. Click on the Offset Tool

2. Select the surface to offset on

3. Move the mouse to show how 
much to offset – click when readyy

4. This only creates offset edges –
you need to use the Push-Pull Tool 
to do something with it.
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Making a Swimming Pool:
Arcs and Offset Surface Edges

1. Create a rectangle on the floor

mjb – February 26 ,2009
Oregon State University

Computer Graphics

Create an Arc in each Corner to Round the Corners

2. Use the Arc Tool
3. Click on one edge, then click on the 

dj t d
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adjacent edge
4. The third point will define where the arc 

goes through.  Mouse around until 
SketchUp tells you that the arc is now 
tangent to the edge

5. When you’re done with the four corners, 
use the Eraser Tool to erase the old 
sharp corners
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6. Use the Push/Pull Tool to Lift it into 3D
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7. Use the Offset Tool to create an Inner Edge, then 
8. Use the Push/Pull Tool to Push it Down
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9. Use the Window → Materials Dialog Box to Add Tile and Water 

If you hold down the Control 
Key when adding the tile 
pattern, it will apply it to all 
surfaces, not just one.  This 
saves you a lot of time.

Then add the water pattern 
after that.

mjb – February 26 ,2009
Oregon State University

Computer Graphics

Adding Fog

Click Window→Fog
This brings up the Fog dialog box

Click here to turn the fog feature on

This slider adjusts how far in 
front of your eye the fog starts.  
Items closer to you than this 
will not be fogged at all
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will not be fogged at all.
This slider adjusts how far in 
front of your eye the fog 
completely hides your scene.  
Items farther away than this 
will not be visible at all.
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Adding Fog
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Adding 3D Text

1. Click on Tools→3D Text

2. Type the text into the dialog box

3. Make any text settings you want

4. Place the text by clicking on an object
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Rotating an Object

1. Select the entire object

2. Click on the Rotate Tool

3 Click the Protractor onto the object3. Click the Protractor onto the object

4. Rotate the Protractor with the mouse 
to align it with something (e.g., a key 
point) -- click when ready.

5. Rotate the object.  Click when done.
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Rotating a Face

Strange as it may seem, you can also 
rotate just a face.  Follow the same 
procedure, but select only the face.
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Scaling an Object

1. Select an object

2. Select Tools→Scale

3. Move the grips with the mouse

4 H ld d th C t l k if4. Hold down the Control key if you 
want scaling about the object’s 
center
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You can also scale just a face

1. Select a face

2. Select Tools→Scale

3. Move the grips with the mouse

4 H ld d th C t l k if4. Hold down the Control key if you 
want scaling about the object’s 
center
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Sectioning an Object

1. Select an object

2. Select Tools→Section Plane

3. Select the section plane

4 U th M T l t lid it i t4. Use the Move Tool to slide it into 
the object
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Want to create Crown Molding?

Click Tools→Follow Me

Draw an arc in the corner 

Click on the arc area 

Move the cursor along the 
perimeter – don’t click again 
until you are done with the 
full path 
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Subtracting one Surface from Another

1. Create two objects

2. Use the Move Tool to overlap them

3. Select both objects

4 S l t Edit I t t I t t4. Select Edit→Intersect→Intersect 
with Model

5. Erase the surfaces and lines you don’t 
need
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Note the difference 
in edges

Adding a Vertical Chimney to a Sloped Roof

1. Draw a line along the roof using 
the pencil tool.  SketchUp’s
inference engine will try to force it 
to be parallel to an axis.  Let it do 
that.

2. Select the line you just drew.  Use 
the Move/Copy icon with the 
Control Key held down to lift it up 
in the air (The Control key will
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in the air.  (The Control key will 
force it to do a Copy.)  Wiggle it a 
little bit until you get the phrase 
“On Blue Axis” to appear.  This 
indicates that you are lifting it 
straight up.
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Adding a Vertical Chimney to a Sloped Roof

3. Draw lines using the pencil tool 
from the ends of this new line to 
the face of the roof.  SketchUp will 
tell you when you are there.  Be 
sure the line is a color (red in thissure the line is a color (red in this 
case) to indicate that you are 
parallel to an axis.

4. Using the pencil tool, connect up 
all the points to form edges.  You 
should have 9 lines in all.  (Don’t 
forget to look at the back of the 
chimney.)  SketchUp will turn the 
edges into faces as you complete 
them.  There should be 4 faces in 
all
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all.

Adding a Vertical Chimney to a Sloped Roof

5. Use the Push/Pull tool to lift the 
top surface.

6. Use the Offset tool to make an 
inner surface on that top surface.

7 U th P h/P ll t l t h th t
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7. Use the Push/Pull tool to push that 
inner surface down.
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Adding a Vertical Chimney to a Sloped Roof

8. Add whatever Window→Material
decoration you want

9. Get rid of the excess chimney under 
the roof by hiding an end face andthe roof by hiding an end face and 
erasing those edges.  (See previous 
sections.)

10. Unhide the end face when you are 
done
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Creating a Flying Animation

1. Create a view of the scene

2. Select View→Animation→Add Scene

3. Create a different view

To create an animation:

4. Select View→Animation→Add Scene

5. . . .

1. Select View→Animation→Play

2. Pause or stop the scene with these buttons

To play the full animation:
As you add scenes, SketchUp will list 
them.  You can click on any of them to 
get back to that view.
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Animation Settings
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Set how long each scene transition lasts

How long to wait before starting the animation

Exporting Your Animation

1. Select File→Export→Animation

2. Save as an AVI file

To save an animation to a file:

Double-click on your AVI file

To play the animation file:

1. Select Insert→Movie→Movie from File

2 D bl li k th i h diti th lid

To import your animation into PowerPoint:
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2. Double-click on the image when editing the slide

3. Click on the image in Slide Show mode
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Good SketchUp Web Links

General SketchUp Site

These Notes

http://cs.oregonstate.edu/~mjb/sketchup

General SketchUp Site

http://sketchup.google.com

Download SketchUp Models

http://sketchup.google.com/3dwarehouse

Tips and Tricks
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Tips and Tricks

http://sketchupdate.blogspot.com/search/label/Tips%20and%20Tricks

SketchUp Blogs

http://sketchupdate.blogspot.com

More Good SketchUp Web Links

Video Tutorials

http://sites.google.com/site/3dbasecamp2008

Developing Plug-ins (Advanced!)

http://groups.google.com/group/SketchUp-Plugins-Dev/web/index.html

http://groups.google.com/group/SketchUp-Plugins-Dev
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http://groups.google.com/group/SketchUp Plugins Dev
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Reference Books

Bonnie Roskes and Bob de Witt, The SketchUp Book.
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Aidan Chopra, Google SketchUp for Dummies.

Other Examples

 d   k
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OSU’s Reser Stadium, Hassan Sinky
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