Camp Blender

http://cs.oregonstate.edu/~mjb/blender

Mike Bailey

mjb@cs.oregonstate.edu

This work is licensed under a Creative Commons Attribution-NonCommercial-NoDerivatives 4.0 International License
For Those of you on Zoom, I Apologize in Advance for the Barking You Might Hear in the Background 😊

They mean well, but delivery vans are just too-tempting a bark-target…
# Handy Blender Shortcuts

<table>
<thead>
<tr>
<th>Shortcut</th>
<th>What it Does</th>
</tr>
</thead>
<tbody>
<tr>
<td>LMB</td>
<td>Select something</td>
</tr>
<tr>
<td>Shift-LMB</td>
<td>Add something else to the selection</td>
</tr>
<tr>
<td>MMB</td>
<td>Rotate the scene</td>
</tr>
<tr>
<td>Shift-MMB</td>
<td>Pan the scene</td>
</tr>
<tr>
<td>Shift-spacebar</td>
<td>Bring up the transformation menu</td>
</tr>
<tr>
<td>Scroll Wheel</td>
<td>Zoom in and out</td>
</tr>
<tr>
<td>Tab</td>
<td>Toggle between Object Mode and Edit Mode</td>
</tr>
<tr>
<td>Control-Tab</td>
<td>Bring up Mode <strong>pie menu</strong></td>
</tr>
<tr>
<td>` (back quote)</td>
<td>Bring up View <strong>pie menu</strong></td>
</tr>
<tr>
<td>a</td>
<td>Select all</td>
</tr>
<tr>
<td>Click in empty space</td>
<td>Unselect all</td>
</tr>
<tr>
<td>Alt-a</td>
<td>Unselect all</td>
</tr>
<tr>
<td>Escape</td>
<td>Get you out of almost anything (including stopping a render or an animation)</td>
</tr>
<tr>
<td>b, c</td>
<td>Box or circle select</td>
</tr>
<tr>
<td>C</td>
<td>Center the scene (good if you are lost in 3D)</td>
</tr>
<tr>
<td>Shift-d</td>
<td>Duplicate</td>
</tr>
<tr>
<td>e</td>
<td>Extrude (in edit mode)</td>
</tr>
<tr>
<td>F3</td>
<td>Search</td>
</tr>
<tr>
<td>g</td>
<td>Grab (translate) an object</td>
</tr>
</tbody>
</table>
## Handy Blender Shortcuts

<table>
<thead>
<tr>
<th>Shortcut</th>
<th>What it Does</th>
</tr>
</thead>
<tbody>
<tr>
<td>Shift-g</td>
<td>Group</td>
</tr>
<tr>
<td>i</td>
<td>Insert a keyframe</td>
</tr>
<tr>
<td>Control-j</td>
<td>Join 2 or more objects</td>
</tr>
<tr>
<td>m</td>
<td>Send object to a collection (layer)</td>
</tr>
<tr>
<td>n</td>
<td>Toggle the Sidebar menu</td>
</tr>
<tr>
<td>Shift-n</td>
<td>Recalculate normals</td>
</tr>
<tr>
<td>p</td>
<td>Partition (only in edit mode)</td>
</tr>
<tr>
<td>Control-p</td>
<td>Establish a parent-child relationship (last object selected will be the parent)</td>
</tr>
<tr>
<td>Alt-p</td>
<td>Destroy a parent-child relationship</td>
</tr>
<tr>
<td>Control-Alt-q</td>
<td>Toggle quad viewing</td>
</tr>
<tr>
<td>r</td>
<td>Rotate an object</td>
</tr>
<tr>
<td>s</td>
<td>Scale an object</td>
</tr>
<tr>
<td>Shift-s</td>
<td>Pie menu for using the 3D Cursor</td>
</tr>
<tr>
<td>Spacebar</td>
<td>Start / Pause an animation</td>
</tr>
<tr>
<td>t</td>
<td>Toggle the Object Tools menu</td>
</tr>
<tr>
<td>x</td>
<td>Delete whatever is selected</td>
</tr>
<tr>
<td>z</td>
<td>Bring up a display mode [pie menu]</td>
</tr>
<tr>
<td>Control-z</td>
<td>Undo</td>
</tr>
<tr>
<td>Alt-z</td>
<td>Toggle x-ray mode</td>
</tr>
<tr>
<td>Control-Shift-z</td>
<td>Redo</td>
</tr>
<tr>
<td>F12</td>
<td>Render a scene image</td>
</tr>
<tr>
<td>F11</td>
<td>Return to the interactive scene</td>
</tr>
</tbody>
</table>
If you would like to be able to rotate the entire scene around a particular object, click on the object and then select:

**View → Frame Selected**

You can also hit the period (.) on the number pad on the keyboard.
What is Blender?

Blender is a *free* program that lets you do professional-looking 3D modeling, rendering, and animation. This, not this. ☹

You can get Blender for yourself by going to: [http://www.blender.org](http://www.blender.org)

Note: The version number changes often. These notes have been written against Blender version 4.1
Next Gen – a Blender-Animated Movie

See the trailer at: https://www.netflix.com/title/80988892
(Go to the bottom of the screen to see the trailer and teaser.)
Blender has thousands of buttons you can press. It is difficult to understand them all. These notes are here to show you what certain combinations of buttons do in order to learn them, and to remind you later when you’ve forgotten.
In these notes, what do these icons mean?

They tell you that if you go to our notes web site:

http://cs.oregonstate.edu/~mjb/blender

you will find Blender input files (*.blend), texture map files (*.bmp), and animation movie files (*.mp4).

You can read a .blend file right into Blender (File → Open) so that you can experiment with these examples without having to first create them yourself.

You can play an .mp4 movie file right from your browser so that you can see how these examples look without having to run Blender at all.
A warning about me and the Notes

What Blender does

What I know

What the notes cover
What We Will Cover in these Notes

1. Navigating the screen layout
2. Viewing in 3D
3. Moving things around in 3D
4. Modeling, I
5. Appearance, I
6. Modeling, II
7. Rendering
8. Particle Systems
9. Physics Animation

10. Appearance, II
11. Vertex Sculpting
12. Vertex Painting
13. Keyframe Animation
14. 3D Printing
15. Stereographics
16. References
1. Navigating the Screen Layout
Full Screen Layout

- Object Tools (‘t’)
- Main Menu
- Property-specific Options
- Object Properties (‘n’)
- Outliner
- View Control
- Animation Controls

Computer Graphics
The Object Tools Menu

- Select
- Cursor
- Move
- Rotate
- Scale
- Transform
- Annotate
- Measure
- Add Cube

Toggled on and off with the ‘t’ key
The Add Menu

This is the Add tab – you will spend a lot of time here!

Create geometry

Create lights

Create other cool stuff
The Add→Mesh Menu

You will especially spend a lot of time here!
The Sidebar Panels

Toggled on and off with the ‘n’ key
The Blender Interface Widgets

If Blender shows you something that looks like this …

… you are expected to click a button to put yourself in a particular mode
The Blender Interface Widgets

If Blender shows you something that looks like this …

… you are expected to click in the box to bring up something else, like this
The Blender Interface Widgets

If Blender shows you something that looks like this …

… you are expected to turn features on and off by clicking in all or none of the checkboxes.

If Blender shows you something that looks like this …

… you are expected to make a choice of just one of these options.
The Blender Interface Widgets

If Blender shows you something that looks like this …

… you are expected to either left-click in the box and (keeping the left button down) drag the mouse left-right like a slider, or single-click in the box and type in a new value.

If Blender shows you something that looks like this …

… you are expected to click in the box and then select from the resulting list.
The Blender Interface Widgets

If Blender shows you an “Apply” button …

… it means that you can click this button to get rid of your original model and replace it with a model that has the edits you have just made.

If Blender shows you this icon (with or without the word “Open” …

… it means that you can click this button to open a file.
The Blender Interface Widgets

If Blender shows you something that looks like this …

… you are expected to click in the box and select from a list of other **objects** in the scene.

If Blender shows you something that looks like this …

… the red color is telling you that you haven’t yet entered enough information in this panel.
The Blender Interface Widgets

If Blender shows you something that looks like this …

… it allows you to hide and unhide something (the Outliner is where you use this most often). Hiding an object is useful for decluttering your scene.

Hint #1: If you no longer want an object in the scene, hiding it for a while before deleting it is usually a good thing. It is surprising how often you need something not long after you deleted it.

Hint #2: If you hide something, don’t forget that you have hidden it. It is pretty freaky to be certain that you once created something, but now you can’t find it anywhere in the scene.
The File Menu

- Start a new Blender scene (thus closing the scene you currently have open)
- Open a previously-created Blender scene (thus closing the scene you currently have open)
- Save the current scene in a file
- Bring elements from another Blender file into this scene
- Bring an image or object in from somewhere else
- Send an image or object to somewhere else
The Difference Between New, Open, Link, and Append

**New** closes the scene you currently have, then initiates a new Blender scene.

**Open** closes the scene you currently have, then reads in a previously-stored Blender scene.

**Append** leaves the scene you currently have open, and adds elements of a previously-created scene into it.

**Link** is like Append, but every time you open the scene again, it will look at the file you are Linking from to see if changes have been made, and if so, will bring those into the scene instead of the first ones.
The Edit Menu

Control-Z or Edit→Undo are two of your best friends!

You can also select Undo History and go back in time to several commands ago.
The Render Menu

![Render Menu](image)
The Help Menu
When Blender launches, there are four sub-windows visible. But Blender has 23 Possible sub-window types that you can bring up and change the size of.
Changing the Border Line on Blender Windows

To change a sub-window boundary, **left-click** on the horizontal or vertical border line, wait for the cursor to change to a double-arrow, then move the mouse up/down or left/right.
To change a sub-window boundary to create a new window, hover over the boundary, wait for the cursor to change to a double-arrow, then right-click. This menu will pop up. Select **Vertical Split** or **Horizontal Split** and move the mouse up/down or left/right. This will create a copy of a Blender sub-window that you already have.
Changing the Type of a Blender Window

“This will create a copy of a Blender sub-window you already have.” Well, what good is that?

Blender sub-windows have a type, designated by the icon in the upper-left corner.
Changing the Type of a Blender Window

Clicking the down arrow, will bring up the list of the 23 types you can change that sub-window into:

<table>
<thead>
<tr>
<th>General</th>
<th>Animation</th>
<th>Scripting</th>
<th>Data</th>
</tr>
</thead>
<tbody>
<tr>
<td>3D Viewport</td>
<td>Shift F5</td>
<td>Text Editor</td>
<td>Shift F11</td>
</tr>
<tr>
<td>Image Editor</td>
<td>Shift F10</td>
<td>Python Console</td>
<td>Shift F4</td>
</tr>
<tr>
<td>UV Editor</td>
<td>Shift F10</td>
<td>Info</td>
<td></td>
</tr>
<tr>
<td>Compositor</td>
<td>Shift F3</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Texture Node Editor</td>
<td>Shift F3</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Geometry Node Editor</td>
<td>Shift F3</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Shader Editor</td>
<td>Shift F3</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Video Sequencer</td>
<td>Shift F8</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Movie Clip Editor</td>
<td>Shift F2</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

Congratulations! You have now added a new Blender sub-window to your display.
Deleting a Blender Window

To delete a window, hover over the boundary, wait for the cursor to change to a double-arrow, then right-click. This menu will pop up. Select **Join Areas** and move the mouse up/down or left/right. This symbol shows you which window will be eliminated when you click the mouse button.
2. Viewing in 3D
3D Coordinate Systems

Left-handed

Right-handed

Blender uses this convention
The Coordinate and Viewing System

- Right-handed coordinate system
- **X** = Red
- **Y** = Green
- **Z** = Blue
- Middle mouse button (MMB) – orbit (rotate)
- Shift MMB – pan
- Scroll wheel – zoom
- View → Viewpoint → Left, Right, …
- View → Area → Toggle Quad View
- View → View Perspective/Orthographic
The View Menu

The View Menu gives you access to lots of ways to change how you are viewing the scene.
Rotating About a Particular Object

If you would like to be able to rotate the entire scene around a particular object, click on the object and then select:

**View → Frame Selected**

You can also hit the period (.) on the number pad on the keyboard.
Toggling Between Perspective and Orthographic Views

Orthographic

Perspective
Toggling Between Perspective and Orthographic Views

In orthographic, lines that are parallel in 3D remain parallel on the screen. Objects appear to be the same size as they get farther away.

In perspective, lines that are parallel in the 3D depth direction appear to converge on the screen. Objects appear to get smaller as they get farther away.

“Vanishing Point”

Use perspective when you want a more realistic view (which is most of the time).

Use orthographic to see if things separated in depth are the same size.
Toggling Between Perspective and Orthographic Views

Use perspective when you want a more realistic view (which is most of the time):

Use orthographic to see if things separated in depth are the same size:
Single View vs. Quad View

Or hit **Control-Alt-q**
Setting the initial Rendering Mode

On the vertical strip of icons on the right, click this one:

And then be sure the Render Engine is set to **Eevee** for now.
Setting the initial Display Mode

X-ray  Wireframe  Viewport Shading  Rendered

Use Viewport Shading to start. It gives good generic lighting.

Later, when we cover Rendering, we will use Rendered lighting, but not now.
3. Moving Things Around in 3D
We will get into this in more detail later, but just so that you have something on the screen, here is the Add Menu.

These are all the different geometry things you can add into the scene. We will cover many of them, but not all.

This group is the **meshes**.

This group is the **curves**.
The Add→Mesh Menu

The UV Sphere, Torus, and Monkey are my favorites
Summary of the Mesh Objects
Coordinate System Conventions

- Right-handed coordinates
- Right-handed rotation rule
- Angles are in degrees
Right-handed Rotation Rule
Selecting an Object to Work On

LMB-click on the object you want to select. It will then be highlighted with an orange outline.
Selecting *Multiple* Objects to Work On: Two Ways to Do This

1. Hold down the Shift key while RMB-clicking

2. LMB a rectangular region around objects
Moving Things By Clicking and Dragging

Translate (“grab”)

Rotate

Scale

Use Global or Local Coordinate System
Global and Local Coordinates

Global Coordinates
- Align with the screen

Local Coordinates
- Align with the object
Saying How to Move Things by Using the Keyboard

• LMB click to select an object
• Grab: g
• Rotate: r
• Scale: s
• Grab using global axis: g → x, etc.
• Grab using local axis: g → x → x
• Pick all *but* a particular axis: g → X, g → X → X, etc.
• Grab a specific distance: g → x → 12.25 <return>
• Rotate a specific angle: r → x → 45 <return>
• Scale a specific factor: s → 2.0 <return>
• Scale a specific factor: s → x → 2.0 <return>

This is *important* – you will use this a lot!

The arrows (→) mean “and then hit”
You Can Also Use the Sidebar Panel

Hit the ‘n’ key to toggle this panel on and off
Applying the Transformation

When you transform an object, Blender *doesn’t change the object’s coordinates*. It keeps the object’s original coordinates plus a record of the transformation. So, for example, if you scale an object by 2.0, Blender remembers it like this:
Applying the Transformation

If you want to actually \textit{alter} the object’s coordinates, choose \textbf{Object} → \textbf{Apply}

You can pick a specific transformation to apply, but most of the time it is easiest to select \textbf{All Transforms}
Applying the Transformation

Once you apply the transformation, the Object Properties Box looks like this:

Before

![Before Image]

After

![After Image]
The Outliner

In the upper-right portion of the screen is the Outliner. Like the name implies, it shows an outline of your scene.

It is sometimes nice to have a summary of the scene so you can remind yourself of what all is in it.

Also, if your scene is cluttered, you can select an object by left-clicking on its name in the outliner as opposed to selecting it in the scene.

Double-clicking on a name will allow you to rename that object to something more sensible than, say, “sphere”.

Also, you can use the outliner to hide certain objects. Just click on the eye icon to hide/unhide.

Hint: If you hide something, don’t forget that you have hidden it. It is pretty freaky to be certain that you once created something, but now can’t find it anywhere in the scene. 😐
You have probably noticed that when you start up Blender, there is a mysterious cursor positioned at the origin.

This is Blender’s **3D View Editor Cursor**.

With this, you can point *anywhere* in space.
One way to position the 3D View Editor Cursor is to click on the **Cursor icon** and start left-clicking around the scene.

When you are done, be sure to let go of the 3D Cursor by clicking here.
Positioning the 3D Cursor

But, it is hard to get the 3D Cursor exactly where you want it to be. For example, if you want to position the 3D Cursor at the corner of the cube indicated by the yellow dot, LMB click on it. But, upon rotating, you realize that it is at the wrong depth. So, get a view roughly 90° from the last view, and click again. You might have to do this a couple more times.
The 3D Cursor

You can also automatically position the 3D Cursor using the **Object → Snap** menu.

For example, choosing **Cursor to Selected** will move the 3D Cursor to the median point of the object you have most recently selected. Choosing **Selected to Cursor** will move the selected object’s median point to where the 3D Cursor is.
A Use for the 3D Cursor – Arbitrary Pivot Point

Suppose you then wanted to rotate the cube about the yellow corner point. After positioning the 3D Cursor there, you would then go to the Pivot Center menu and select 3D Cursor. Rotations and Scaling will now take place around the yellow corner.

Later, you probably want to change the pivot point back to Median Point.
Another Way to Set the Arbitrary Pivot Point

Select the object, tab to **Edit Mode**, select all vertices (‘a’) and translate them (‘g’).

**In Edit mode, the pivot point stays put while the vertices move.**

Tab back to Object mode, and rotate the object to confirm that the pivot point has changed.

**In contrast, in Object Mode, the pivot point moves with the vertices.**

The little orange dot is the pivot point.
4. Modeling, I
The Add Menu

These are all the different geometry things you can add into the scene. We will cover many of them, but not all.

This group is the **meshes**.

This group is the **curves**.
The Add→Mesh Menu

The UV Sphere, Torus, and Monkey are my favorites
When you Add a Mesh, a Small Menu Appears in the LL Corner

Add UV Sphere
When you Add a Mesh, a Small Menu Appears in the LL Corner

Try clicking on it.

The small menu lets you modify how the last thing you did works. In this case, the most important thing it is doing is letting you change the polygon resolution of the sphere. But, this menu only exists until you do something else. After that, the ability to change these values is gone.

Personally, I like changing these two values to 64 and 32, respectively.
Summary of the Mesh Objects
Blender is able to play a graphics trick to make your curved geometry look better. Select the object (LMB) then click the RMB and select **Shade Smooth**. To go back, select **Shade Flat**.

This doesn’t actually change any geometry – it’s just a really good computer graphics display trick. There are other ways to truly create smoother underlying geometry.
How to Find Out How Detailed a Mesh Object Is

In the overlay menu, turn on **Statistics**

The number of Vertices, Edges, Faces, and Triangles show on the left side of the screen.
Duplicating an Object from the RMB Menu

Select the object (LMB) then click the RMB and select **Duplicate Objects**. This leaves the new object right on top of the old object and leaves you in **Grab mode**. Just move the mouse to separate the two objects.
Mirroring an Object

Oftentimes you want to create an object that is identical to itself but is symmetric about an axis. This type of operation is called mirroring.

Create an object, in this case, Suzanne the Monkey.

Let’s say that we want to mirror this object left-right (y). Select the monkey, right click, then select Mirror, and then select Y Global.
Editing a Vertex, Edge, or Face on a Mesh

Click here, or hit the **Tab** key, to get into Edit Mode

Select and edit:

- A vertex
- An edge
- A face

Using the **Tab key** is so common, that “tab” has become a *verb* in the Blender community. As we like to say, “Just tab over into edit mode.”
Editing a Vertex

Be sure you are in vertex-editing mode

Left click on a vertex

Hit ‘g’ (grab) and move the mouse

You can also hit ‘x’, ‘y’, or ‘z’ to restrict motion
Editing a Vertex with Proportional Editing

Be sure you have Proportional Editing enabled

LMB click on a vertex

Hit ‘g’ (grab) and move the mouse

You can also hit ‘x’, ‘y’, or ‘z’ to restrict motion

The mouse Scroll Wheel changes the size of the Circle of Influence

You can also LMB select an edge or a face for editing or proportional editing.
Subdividing and Smoothing Really Show the Difference Between Localized and Proportional Editing
An Unexpected Use for Proportional Editing

Create a **Plane**, then go to **Edit Mode**, then box select all the edges, then click on **Edge → Subdivide** and subdivide it several times.
An Unexpected Use for Proportional Editing

Enable **Proportional Editing**, then go one widget to the right and change the kind of Proportional Editing from **Smooth** to **Random**.
An Unexpected Use for Proportional Editing

Go to Edit Mode, select a vertex, and lift it along with those around it.
In **Edit Mode**, you can delete things. For example, here four faces have been selected. **Right-click** and select **Delete Faces** from the pop-up menu.

Here’s what you get:
You can also **right-click** and select **Dissolve Faces** from the pop-up menu.

In which case, you get this:
5. Appearance, I
The Button Properties Menus

- Render Properties
- Output Properties
- View Layer Properties
- Scene Properties
- World Properties
- Collection Properties
- Object Properties
- Modifier Properties
- Particle Properties
- Physics Properties
- Object Constraint Properties
- Object Data Properties
- Material Properties (colors)
- Texture Properties

Clicking one of these brings up a much more detailed menu of options.
Using the Material Properties Menu

Click on this … to get this

Then, click on New
Using the Material Properties Menu

To make our lives simpler for now, click here to turn off *Use Nodes* mode.
Using the Material Properties Menu

Use Nodes mode has been turned off

Clicking in here brings up a color wheel
Controlling Shininess

Turn Use Nodes off

Most matte

Most glossy
The Color Wheel

Click in here to change the **Hue** and **Saturation**

**Hue** is angle around the wheel

**Saturation** is the radius

These are the possible ways the color will be defined

If you know the color definition numbers you want, you can type or slider them here

Click in here to change the **Value** (brightness)
Color Scales

Red-Green-Blue

Hue-Saturation-Value

Hexadecimal

Eyedropper
(lets you select a color you see somewhere else on the screen)
RGB Additive Color Scale

Blender’s RGB scale lets you give the red, green, and blue components in the range 0. – 1.

Blender’s hexadecimal scale lets you give the red, green, and blue components in the range 00 00 00 – FF FF FF
Blender’s HSV scale lets you give the hue, saturation, and value components in the range 0. – 1.
Subtractive Colors (CMYK)

R = Red
G = Green
B = Blue
W = White
C = Cyan
M = Magenta
Y = Yellow
K = Black
Subtractive Color (CMYK)

R = Red
G = Green
B = Blue
W = White
C = Cyan
M = Magenta
Y = Yellow
K = Black
Color Printing

• Uses subtractive colors
• Uses 3 (CMY) or 4 (CMYK) passes
• CMYK printers have a better-looking black

R = Red
G = Green
B = Blue
W = White
C = Cyan
M = Magenta
Y = Yellow
K = Black
You See Lots of Color Printing Tests Like This!
So Far We Have Been Using Viewport Shading

We have gotten pretty good views of our objects without having to position light sources, cameras, etc.
We Could Switch to Rendered Shading

But, that *would* require us to position light sources, cameras, etc. We’re not ready for that yet.
But, here comes *MatCap*, a More Creative Use of Viewport Shading

Click on Viewport Shading and then click on the down-facing arrow

Studio Lighting is what you have been using. Instead, select **MatCap**, which stands for “Material Capture”.

Then, click on the sphere.
Up Pops a Lot of Material Options!

Try them, especially the shiny ones!
6. Modeling, II
Adding 3D Text

Select Add → Text

It ends up giving you the fairly-useless line “Text”

To change the text string, tab into Edit mode. The white rectangle acts as a text cursor. Backspace over “Text” and type your new text. The return key will let you enter multiple lines.
Changing the Style of 3D Text

So far, not very 3D, huh?
Tab back to **Object Mode**, click on your text, then click on this **Font button**

Go to the **Geometry** sub-menu

- **Extrude**: give the letters height
- **Depth**: bevel the top and bottom
- **Resolution**: round the bevel
Changing the Look of 3D Text

From here on, your 3D text acts like any other 3D object. It can be grabbed (translated), rotated, and scaled.

It can be colored, too.
The Edit Mode subdivision feature adds more vertices, but doesn’t do any sort of smoothing (like the Subdivision Surface Modifier does). So, when you are done, you will have more vertices to sculpt with, but, in Object Mode, your object will look exactly the same as it did before.

1. Object Mode

2. Tab into Edit Mode

3. Get Ready to Edit Faces
4. Right-click Subdivide

5. You now have more vertices

6. Tab back into Object Mode
A Multi-Vertex Picking Hint

First, make this model:
1. **Object Mode → Add → Mesh → Cylinder**
2. Tab to **Edit Mode → RMB → Subdivide**

![Edit Mode Icon]
A Multi-Vertex Picking Hint

Now, **LMB-sweep** over these vertices. (I call them the “equator” or the “belt”.)

But, if you do that, you will only end up selecting the front vertices, that is, *the ones you can see*.

The trick is to go into **X-ray Mode**, by clicking here.

This will now let you select *all* the points in the belt.
A Multi-Vertex Picking Hint

Why do that? Well, if you have those vertices selected and you hit the `s` key (for scale) and move the mouse, then you can get this:

Or, this:
A Multi-Face Picking Hint

To create this model:
1. **Add → Cube**
2. Tab to **Edit Mode → RMB → Subdivide → Subdivide**

Suppose you want to select an entire row of faces in order to “fatten the belt”. You could select all the faces individually (**LMB → Shift-LMB**). But, here’s a better trick:

1. Click on one face in the row
2. **Alt-LMB** on another face down the row
A Multi-Face Picking Hint

Scaling (‘s’)
Similarly, if you put yourself into face-picking mode:

And click on the top face of the cylinder (don’t need the belt and don’t need to be in X-ray Mode for this):

And hit the r and z keys (for rotate about the z axis) and move the mouse, then you get this:
Intentionally Joining Two Objects

Let’s say that you have two objects and want to join them together so that you can act on them as one object.
Intentionally Joining Two Objects

Easy! LMB on one, then **Shift-LMB** on the other, then hit **RMB → Join** (or **Control-’j’** on the keyboard). The orange “selection outline” now goes around both objects and the outliner shows just one object.
Separating Objects By Loose Parts

Select the Joined object. Tab over to **Edit Mode**. Then hit the ‘p’ key (“Partition”). You will then have three options on how to partition the joined object. If you select **By Loose Parts**, then the Joined object will be partitioned based on the original primitives that made it up.
Inset Faces (aka, Offset Curves)

Often you want to create a “face-within-a-face”. In Blender, this is called an **Inset Face**. (CAD systems often call this sort of thing an **Offset Curve**.)

In **Edit Mode**, select the top face.

Then, either **RMB → Inset Faces**, or click on this icon on the left side:
Inset Faces (aka, Offset Curves)

With the LMB, push the little handle down until the Inset Face is the size you want.

At this point, you can select the inner face and hit g and z (grab in the z direction) to do this, or this.

Try rotating or scaling the inner face.

You can also create a new inset face inside the inset face you just created.
Select X-ray mode and select all vertices.

Tab into Edit Mode. Click on the Extrude Tool.
Extrude Tool

I like **XYZ mode** so that you can extrude in any direction.

Grab one of the `+'s and pull.

You can even keep doing it.

When you get back to Object Mode, you will find that all of these are part of the same object.
Spin Tool

Start with a cube translated along the x axis ($g_x$)

Tab into Edit Mode. Click on the **Spin Tool**
Spin Tool

Pick the number of duplicates to make

Pick the axis/axes about which to spin

Be sure all of the object’s vertices are selected.
Grab one of the blue +’s and rotate
Vertex Groups

Using a group of vertices together is very useful. It is used for editing (like we are doing here), but also to pin certain vertices for cloth animation, to grow hair for hair simulation, and to rig objects for animation.

For that reason, Blender allows you to select the group and give them a name for later. This is called a **Vertex Group**.

1. Select the vertices in Edit Mode (Shift-LMB)

2. Select the **Object Data Properties** button

3. Click the **+** to add this as a new Vertex Group
Vertex Groups

4. Double-click on whatever the default name is (“Group” in this case) and type in a descriptive name for this Vertex Group

5. Click Assign

From now on, this group of vertices can be selected just by selecting the name from the list of Vertex Groups and clicking Select.
Extruding Faces – three ways

First, tab into **Edit Mode**. Then select one or more faces. Then right-click and select:

- **Extrude Individual Faces** (cracks in between skyscrapers)
- **Extrude Faces Along Normals** (push each face perpendicular to the surface)
- **Extrude Faces** (push each face along the group average perpendicular to the surface)

Face Select Mode
Shrink/Fatten and Push/Pull are very much like extruding faces. Here are the differences:

**Extruding** lifts the selected faces along their normals. It leaves behind a “cliff” that connects them to the surrounding faces.

**Shrink/Fatten** lifts the selected faces along their normals, but leaves behind a “ramp” connecting those faces to the surrounding ones.

**Push/Pull** essentially scales the selected faces around their centroid.

For example, suppose we start with this object and these selected faces.

Every one of the edit-icons that has a little arrow in the lower-right corner expands in this same way. Check ’em out!
## Extrude, Shrink/Fatten, and Push/Pull

<table>
<thead>
<tr>
<th></th>
<th>Extrude</th>
<th>Shrink/Fatten</th>
<th>Push/Pull</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Out</strong></td>
<td><img src="image1" alt="Extrude Out" /></td>
<td><img src="image2" alt="Shrink/Fatten Out" /></td>
<td><img src="image3" alt="Push/Pull Out" /></td>
</tr>
<tr>
<td><strong>In</strong></td>
<td><img src="image4" alt="Extrude In" /></td>
<td><img src="image5" alt="Shrink/Fatten In" /></td>
<td><img src="image6" alt="Push/Pull In" /></td>
</tr>
</tbody>
</table>
The Button Properties Menus, Again

Clicking one of these brings up a much more detailed menu of options

- Render Properties
- Output Properties
- View Layer Properties
- Scene Properties
- World Properties
- Object Properties
- Modifier Properties
- Particle Properties
- Physics Properties
- Object Constraint Properties
- Object Data Properties
- Material Properties (colors)
- Texture Properties
Modifiers don’t actually change an object’s *permanent geometry* – just the object’s *appearance* on the screen. The geometry only gets permanently changed if you click the **Apply** button.
The *Edit* Modifiers

![Image of the Edit Modifiers menu in Computer Graphics software]

- **Search...**
- **Geometry Nodes**
  - **Edit**
  - Generate
  - Deform
  - Physics
- **Hair**
  - Data Transfer
  - Mesh Cache
  - Mesh Sequence Cache
  - Normal Edit
  - Weighted Normal
  - UV Project
  - UV Warp
  - Vertex Weight Edit
  - Vertex Weight Mix
  - Vertex Weight Proximity
The *Generate* Modifiers

![Image of the Generate Modifiers in Blender's modifier stack]

- Array
- Bevel
- Boolean
- Build
- Decimate
- Edge Split
- Mask
- Mirror
- Multiresolution
- Remesh
- Screw
- Skin
- Solidify
- Subdivision Surface
- Triangulate
- Volume to Mesh
- Weld
- Wireframe
The *Deform* Modifiers

![Image of the Add Modifier menu highlighting Deform, Displace, Lattice, and Shrinkwrap modifiers.](image-url)
The *Physics* Modifiers
The *Hair* Modifiers
Modifiers don’t actually change the object’s *permanent geometry* – just the object’s *appearance* on the screen.

You Create an Original Object

You Apply a Blender Modifier

You See a Modified Object on the Screen

Cube with Bevel Modifier in Edit Mode
The Modifiers Menu

Modifiers don’t actually change the object’s *permanent geometry* – just the object’s *appearance* on the screen.

Example: Here a cube has been beveled (one of the Modifiers). In **Edit Mode** you can see both the beveled cube and the original cube. You can edit the vertices and the new shape will get beveled as you edit.
My Favorite Modifier -- Subdivision Surface

This modifier increases the number of polygons in your object. At the same time, it smooths your object out. Be careful! It very quickly increases your polygon count.

This controls how much to subdivide. Here we’ve changed this value from 1 to 2.

Fun: try it on a cube!
Deleting and Moving Modifiers

Oftentimes you have a list of several Modifiers that are used with a single object. The Modifiers take effect in the order that they are in the list. To change this, you can:

• Delete a Modifier
• Move a Modifier elsewhere in the list and thus change how it modifies the object
Making Your Modifier Effect Permanent

Despite the name, Modifiers do not actually modify the object’s underlying coordinates. They create an “alternate representation” that you can see. Most of the time, this is good. It lets you edit the underlying coordinates and have the Modifier then use them. If you want the Modifier to change the object’s underlying coordinates permanently, bring up this sub-menu and click on **Apply**.
Bevel Modifier

Beveling causes edges to be rounded instead of sharp.

How much to bevel:
- Amount: 0.16 m
- Segments: 40
- Limit Method: Angle
  - Angle: 30°

Smooth shading makes bevels look much better!行われるのに

No beveling
Segments = 1
Segments = 2
Segments = 3
Remember Venn Diagrams (Boolean Operators)?

Two Overlapping Shapes

Union

Intersection

Difference
Booleans (also known as Constructive Solid Geometry)

Think of them as Venn diagrams in 3D!

Two Overlapping Solids

Union

Intersection

Difference
1. Select the cube
2. Click on **Modifiers**
3. Click on **Add Modifier → Generate → Boolean**
4. Specify the **Difference** Operator
5. Specify the **Cylinder** as what to the difference with
6. Click **Apply**
Boolean Modifier

Select the cylinder, hit it `g` (grab) and slide the cylinder away
The Resolution of the Second Object Determines the Resolution of the Resulting Surface

First object  Resulting surface  Second object
Remember 3D Text? One Fun Thing to do with Booleans is to Attach Text to a Block

Start with a block and the text:

You cannot Boolean with text, so convert the text to a mesh first. **RMB → Convert To → Mesh**
Now, Cut Down the Triangle Detail in the Text

Unfortunately, meshing text gives it a lot of scrawny triangles, which doesn't work well with Booleans. We need to collapse some detail using the **Decimate** Modifier.

Now turn down the **Ratio** until you see the text start to distort
Cutting Down Triangle Detail on the Text

Now turn down the **Ratio** until you see the text start to distort.

Now turn the **Ratio** back up a little until the text looks OK.

Go to the down arrow and select **Apply**.
Now Boolean the Text with the Block

Union

Difference
The Mirror Modifier

Let’s say that you want to create a mirror image of the monkey, but by using a Modifier, the mirror monkey will be linked to the original monkey so that any edits you do to the original will automatically end up in the mirror object.

But, that mirrored object will reflect about the object origin, this little dot right here. Which means that you will end up with something like this, which is probably not what you wanted.
So, the first thing we need to do is to move the object away from the little dot. You do this by Tabbing into Edit Mode and grabbing all the vertices and sliding them (gy). In Edit Mode, the dot doesn’t move when you do this:

Now, Tab back to Object Mode, add the Mirror Modifier, and select Y.
The Mirror Modifier

So, now if you sculpt the original object, the mirrored object will get the same edits.

This is often good for creating a full object by only creating one half of it (e.g., a car) and mirroring it.
The Array Modifier is used to duplicate an object according to a particular pattern. Suppose we want to turn a block into a staircase. We start with the block and add an Array modifier.

- **Duplicate Count**: How much to offset each duplication.
- **Relative Offset**: It can be Constant, that is, based on a number of units. Or it can be Relative, that is, based on a number of size-of-this-object.

**Apply** button (if we want to make this permanent)
Array Modifier to Make Stairs

Move each block in Y and Z to make the next stair step

How many total steps to make

---

Oregon State University
Computer Graphics
Screw Modifier

Before

After
**Wireframe Modifier**

Turns each polygon into thick lines outlining each polygon.

---

How thick to make the thick lines.

But, these lines have thickness, keeping this as a Mesh.
Modifier Order Matters!

Subdivision Surface, then Wireframe

Wireframe, then Subdivision Surface
Add a **UV Sphere**
The Lattice Modifier

In **Edit Mode**, select a group of sphere vertices and assign them as a **Vertex Group**

**Hints:**
1. Select the vertices in **Orthographic** and **X-ray** display modes
2. Double-click on the default name of the Vertex Group to give it a better name
The Lattice Modifier

Click the **Lattice button** and (perhaps) add more lattice detail.

Add a Lattice to the scene.
Add a **Lattice Modifier** to the sphere. **Tell it the name of the lattice and the name of the Vertex Group to use**
The Lattice Modifier

In Edit Mode, grab vertices and slide them:
Turn on both **X-ray Mode** and **Wireframe Mode**

Add a UV Sphere and a Cone. Either scale the sphere up or scale the cone down so the cone is inside the sphere.
The Shrinkwrap Modifier

Click on the sphere and select the Shrinkwrap Modifier

Select the cone as the Target

Adjust the Offset value. Positive values make most sense, but negative values are fun too!
The Shrinkwrap Modifier

Offset = 2
Offset = 1
Offset = 0
Offset = -1
Offset = -2
The Build Modifier

I suspect this is more applicable to engineering-ish objects, but it fun no matter what. Let’s use our old friend Suzanne the monkey.

Go to **Modifiers → Select Modifier → Build**
You get the following Modifier box. All the values are good defaults:

At this point, Suzanne has disappeared. What!? To bring her back, grab the blue animation time slider and slowly move it to the right:
The Build Modifier
The Displace Modifier

This Modifier pushes vertices out perpendicular to the surface. I would describe it as “puffing out the object”.

Go to **Modifiers → Select Modifier → Displace**
You get the following Modifier box. If your object suddenly looks weird, don’t worry! Set this value to 0:

Now, slowly increase to Strength to be greater than 0. What happens? Is it possible to set it to a value less than 0? What happens?
The Displace Modifier

Strength = 0.0

Strength = 0.3

Strength = -0.3
Texture Pattern Displacements

Click on the **Texture Property button**

Remember the texture “name” (**Texture.002**) – you will need it later.

Select which texture you want for the displacement pattern. I like **Voronoi** because of the cells.
Texture Pattern Displacements

Create an object, add a couple of levels of **Subdivision Surface Modifier**, then add a **Displace Modifier**.
Texture Pattern Displacements

Displace Modifier

Click here and select the texture name from before.

Select **Normal** (in computer graphics, *normal* means “perpendicular to the surface”).

Experiment with different values of Strength.
Texture Pattern Displacements

Aren’t you glad you didn’t have to sculpt this yourself? 😊
You Can Also Go Back to the Texture Pattern and Change Some Things There

These two are especially fun to play with!
Metaball Objects

Metaball Objects are another way to 3D model:
Metaball Objects

The cool thing is that, if you move (g) them close enough, they will “glom” into a single object.
Metaball Objects

There is a special Metaball properties menu to control their characteristics:
Metaball Objects

But, Metaball Objects are not meshes, so you cannot do a lot of the cool editing that you can with meshes. But, you can turn such an object into a mesh by selecting Object → Convert To → Mesh from Curve/Meta/Surf/Text.

After tabbing into Edit Mode
Parent-Child Relationships in Modeling

Many times, one object is connected to another object. In modeling, this is called a **Parent-Child relationship**. (It is also sometimes called a Hierarchical Relationship.)

When the Parent moves, the Child moves with them.

When the Child moves, the Parent is unaffected.

This is *really* useful!

To do this in Blender:

1. Move the Child’s pivot-point to where you want it connected to the Parent
2. Select the Child piece
3. Shift-select the Parent piece
4. Hit **Control-’p’** on the keyboard

You can create as many levels of Parent-Child relationships as you want: As the song goes:

“The foot bone’s connected to the ankle bone, the ankle bone’s connected to the leg bone, the leg bone’s connected to the thigh bone, …”
Parent-Child Relationships in Modeling

If you rotate the blue (child) piece, then just it will move.

If you rotate the yellow (parent) piece, then both it and the child piece will move.
Importing Objects from Other Places

Select **File → Import**

**Collada** = export format from game modeling systems

**Stl** = 3D printer format

**3ds** = format from Autodesk 3D Studio

**Obj** = Probably world’s most common export format There are a *ton* of .obj models for free on the Internet! Google the phrase: **free obj files**

.obj files are also pretty straightforward to create. So, if you have a shape in mind and can write a computer program to generate it, you can write your own .obj file and Import it into Blender.
Importing Objects from Other Places

File = dino.obj

You can get this file from the web page: http://cs.oregonstate.edu/~mjb/blender

As-is, flat shaded

Subdivision surfaced
  + Smooth shaded
Importing Objects from Other Places

Abusively edited
Importing Objects from Other Places

Here are some places to find OBJ files to use yourself:

- https://polyhaven.com/
- http://thefree3dmodels.com
- https://free3d.com/3d-models/star-wars
- http://lodbook.com/models
- http://people.sc.fsu.edu/~jburkardt/data/data.html
- https://sketchfab.com/features/free-3d-models

Or, Google the phrase: "free obj files"

Links checked: June 19, 2024
Exporting Objects to Other Places

Blender has a number of file formats it knows how to export to. If you are looking for a nice, general one to experiment with, try the .obj format.

Just be sure to use the RMB menu to select Shade Smooth first

Select File → Export → Wavefront (.obj)
Exporting to an OBJ File
Exporting to an OBJ File

This is the Blender file-output selection dialog box:

OBJ-specific settings (see next slide)
In the export dialog, be sure to click on

- **Write UV Coordinates**
- **Write Normals**
- **Write Triangulated Mesh**
7. Rendering
On-screen Rendering Mode

We have been using this one. This one gave you good generic lighting so you could model without worrying about light sources.

Now switch to this one. This one will give you a pretty-good preview of what happens when you actually render the scene. But, we now have to deal with Rendering specifics.
“Rendering” is Blender’s process for creating really high-quality images. Click on Render → Render Image or hit the F12 key (you might have to hit the fn key at the same time). The rendering operation can often take some time, depending on how complex your scene is.
Clicking on the **Rendering Properties** button will allow you to set various rendering parameters. The one you care about the most is Sampling resolution.

You want at least some **Anti-Aliasing**, which is done by making more than one sample per pixel. 64 and 16 are good values.

The rest of these are interesting, but not needed right now.
Clicking on the **Output Properties** button will allow you to set various rendering parameters. The one you care about the most is pixel resolution.

These are OK values, but you can improve your rendering speed by making them smaller. Don’t make them smaller by changing the 1920x1080, make them smaller by changing the **100%**.

Notice that the image aspect ratio being used here is 16:9 (=1920:1080). This is the most common aspect ratio today for TVs and computer monitors.

The rest of these are interesting, but not needed right now.
What is Anti-aliasing?

Anti-aliasing is a good-news bad-news joke.
Good news: the scene looks much smoother
Bad news: the scene takes longer to generate
Good news: you probably want to do it anyway
Anti-aliasing is Implemented by Oversampling within Each Pixel

4x

16x

NVIDIA
Let’s say that you are in **Solid Shading Mode** and your scene situation looks like this.

You now change to **Render Mode** and get this:

Blech! Why is the bottom part of my scene so dark?
The answer is that **Solid Shading Mode** doesn’t require your scene to be lit but **Render Mode** does.
By default, your scene has a single light in it. It looks like this.

If you can’t find it, try zooming out.

If you still can’t find it, select it in the Outliner.

This is like any other object.
A light is like any other object. It can be LMB clicked on (or selected in the Outliner). It can be grabbed (g) and moved around. Moving it around will change how the lighting looks.
But, to make this work better, you probably want to add more lights.
There are four types of **Lights** that you can **Add**

1. **A Point** Lamp shines light in all directions. The light is local to the scene. This is usually the best type of light to start out with.

2. **A Sun** Lamp appears to come from a single direction and its rays are parallel. This acts as if the light is very far away.

3. **A Spot** Lamp is like a Point Lamp, but only shines in one particular direction.

4. **An Area** Lamp is light coming from a finite surface, like most lights really are.
Lighting – try this

1. Add another Point Light

2. Position the Light (‘g’).

3. The Point Light has no obvious local coordinate system, so it just uses the global coordinate system.

4. As you move the Light, you will see the lighting of the scene change.

5. You will probably have to rotate the scene (MMB) to get the light position where you think it should be. Or, you can also toggle the Quad View mode (Control-Alt-q).
Lighting – Quad View
Lighting – Quad View
Lighting – Properties

This preview shows how the Light spreads out.

What color to make the Light.

How bright to make the Light shine.

Be sure this is clicked on in order to get this light to cast shadows.
Lighting – What does it Mean to Have a Colored Light?

What the light can produce:
- \( L_R \)
- \( L_G \)
- \( L_B \)

What the eye sees:
- \( E_R \)
- \( E_G \)
- \( E_B \)

What the material can reflect:
- \( M_R \)
- \( M_G \)
- \( M_B \)

\[
E_R = L_R * M_R \\
E_G = L_G * M_G \\
E_B = L_B * M_B
\]
In modeling, rendering, and animation, there are two major roles that lights play:

1. **Key**
2. **Fill**

Let’s say we want to put a spotlight on the Monkey (and who doesn’t?). We add a Spot Light. We position it over the Monkey and angle it down, like this. This is our “Key Light”. It does what we most want to do.

We render and get this.

The Key Light is working really well, but the rest of the scene is too dark. We now need to use one or more Fill Lights.
We Add a Point Light and position it over the scene. Because we are in Render Mode, we can interactively see when we have it positioned well.

The scene looks much better. But, there are still two problems.

1. The rest of the scene is now bright enough that our “star” is no longer highlighted.
2. The Fill Light is casting another shadow which is distracting.
So, we make two adjustments to our Fill Light:

We lower its brightness.

We un-click here to force it to not cast shadows.
The view that is rendered is not the same orientation that you see on the screen. It is from the **Camera position**, which needs to be set separately.

If you the Camera icon, LMB click on it. If you don’t see it, zoom out some. If you still don’t see it, click on the Camera in the Outliner.
The Camera

Where the eye is looking towards

The “up vector”

The eye’s position
The camera is just like any other object in the scene.
1. It can be selected with a LMB click
2. It has its own local coordinate system attached to it.

Note the local coordinate system for the camera:

• X is to the right of where the eye is looking
• Y is the up-vector
• Z is opposite of where the eye is looking

This is useful to know. For example, to dolly the camera in or out, select it and then move it in its local coordinates:

\[ \mathbf{g} \rightarrow \mathbf{z} \rightarrow \mathbf{z} \]
Aligning The Camera to Your Current Screen View

But, if you like your current screen view and want to move the camera there, just do this:

**View → Align View → Align Active Camera to View**
Setting a Background Color

Click on the **World Properties button**

Click on **Color** and dial in the background color
Screen Space Ambient Occlusion

Ambient Occlusion is a great computer graphics trick in which crevices are artificially darkened, heightening the sense of 3D-ness. You must be using the Eevee renderer to make this happen.
Bloom

Bloom is a rendering technique that emphasizes lighting “flares”. You must be using the **Eevee renderer** to make this happen.
Screen Space Reflections are a quick way to generate the appearance of internal reflections in your object. You must be using the **Eevee renderer** to make this happen.
Superimposed Wireframes

I don’t know why I find this so pleasing to look at. I just do.
Triggering a Rendering

What you see on your screen

What you see on the separate render window
What You See in the Separate Render Window

![Blender Render Window](image)

University
Computer Graphics
Saving a Rendered Image to a File
Saving a Rendered Image to a File

- Amount of compression
- Image file type

![Blender File View](image-url)
Saving a Rendered Image to a File

Different image file types
(PNG is good if you don’t have any preference)
Saving a Rendered Image to a File

If this is called **Compression**, then smaller numbers will give you a larger image file with greater image quality.

If this is called **Quality**, then larger numbers will give you a larger image file with greater image quality.
Saving a Rendered Image to a File

There is an important trade-off between image file size and the image Quality you set. There is also a trade-off between image size and web page download time.

<table>
<thead>
<tr>
<th>JPEG: 10% Quality setting</th>
<th>JPEG: 100% Quality setting</th>
</tr>
</thead>
<tbody>
<tr>
<td>11 KBytes</td>
<td>72 KBytes</td>
</tr>
</tbody>
</table>
Importing an Image into PowerPoint
Importing an Image into HTML (i.e., a web page)

Add this line to your HTML file:

```html
<img src="ball.png">
```
There is an additional internal renderer called Freestyle. Suppose you start with this scene:
Another Type of Rendering

You render it, and the image looks like this:

Now, go to the Render Properties menu and turn on Freestyle.
Freestyle Rendering

You render it again, and now you get this:

The computer graphics world calls this **Non-Photorealistic Rendering**, or NPR. It is good for illustrations where you want to see objects and outlines more than you want to see realism.
If you look under the View Layer Properties button, you will find a lot of Freestyle adjustments that you can make.
8. Particle Systems
Particle System Examples
Particle System Examples

(Particles don’t have to actually be particles.)
Particles Bouncing Off Other Objects
1. Select the object to emit the particles from, then click this property button.

2. Click the + sign to start a new particle system.

3. Set the number of particles.

   Optional: Set the particles’ initial velocities – see the next slide.

Optional: Set the rendering properties -- see two slides from here.
Particles – Expand the *Velocity* Dialog Box

The velocity perpendicular to the surface

The velocity parallel to the surface
Particles – Expand the *Render* and *Viewport Display* Dialog Boxes

What material definition to color the particles with

What particles to draw (this is fun to change!)

If you like physics, change this to velocity

Start with a small size, like this, but then experiment
Click here to at the bottom of the screen start the particle animation

Hit the **ESC** key when you want it to stop
Particles Bouncing Off Other Objects

1. Draw a plane to bounce particles from
2. Click the **Physics Property Button**
3. Click on the **Collision** option
4. Turn on the animation
Particles Bouncing Off Other Objects

Physics properties of the surface being bounced off of

Bouncing particles
Something fun – Tip the Plane
Something Fun – Put Something Else in the Way

Need to make it a **Collision** surface too.
More Fun – Make the Particles Another Object
To Blow particles, We need a Force Field – Attach it to an Empty Object

Ironically, one of the most useful objects is the one you can’t see. Blender calls this an Empty.

It’s invisible on the screen, but you can treat it like a real object, and can attach forces to it. These forces will influence the behavior of other objects.

Find the Empty under the Add tab at the top of the screen. When you click on it, this sub-menu pops up.
We need a Force Field – Attach it to an Empty Object

Surprise! Even though it is invisible, an Empty has a shape!

For this exercise, pick the Single Arrow

On the screen, it will look like this:
Blowing the Particles -- Force Fields

A really good use for **Force Fields** is to blow particles and cloth around

With the **Empty** Object selected, click on the Physics icon and then click on **Force Field**
Using the usual object-rotate commands, orient the **Empty** so that it is pointing at the particles.

**Hint:** it is easiest to *position* it in Global Coordinates \((g \rightarrow x)\) and easiest to *rotate* it in Local Coordinates \((r \rightarrow x \rightarrow x)\).

And, under **Force Field Type**, select **Wind**

You will use this to change the **Strength** of the wind.

It will look like this on the screen:
Blowing the Particles

Turn on the animation (Control-’a’). You can adjust the orientation and the **Strength** of the Wind while the animation is playing to get just the effect you want.

blowing.blend
1. Select the object to emit the hair from, then click this property button.

2. Click the + sign to start a new particle system.

3. Select Hair.

4. Set the number of strands.

5. Set the hair length.

6. Set the number of segments per strand.

7. Apply physics to the hairs.

8. Set the rendering properties.
It Will Start Out Looking *Terrible*

Try setting the hair length to something small-ish like 0.5
Making the Hair Droop

Turn on and expand Hair Dynamics

Start animating
Making the Droop Permanent

Get the droop the way you want it

Select **Modifiers** – a ParticleSystem modifier will already magically be there

Click on **Convert to Mesh**. This will turn the hair into a mesh object.
Making the Droop Permanent

Before clicking **Convert**

But, this new mesh is *independent* of the object that particle’d it. To make them one object, select both and hit **Control-j** (“join”)
Making the Droop Permanent
**Boids** are a special particle system technique to simulate living things that naturally want to group together such as flocks of birds, schools of fish, etc.

As before, create an object and attach a particle system to it. Select **Emitter** for the type. Under the **Physics** tab, change Newtonian to **Boids**.
Select the **Boid Brain** tab.

Click the **plus sign** (+), Select **Follow Leader** from the menu, and use the **arrow symbols** to move it to the top of the list.
Create a new object and animate it (keyframe or physics). This will become the “leader” that the boids will follow. If you want to see it, leave it visible. Otherwise, turn its eyeballs off in the Outliner.

Now select the object that the boids were created from. In the boids menu area, click in the Object area and select the name of the object you animated.

Now, turn on animation and watch the boids follow that object.
Boids Particle Systems

The boids now follow the leader
Boids Particle Systems

If you just want to see the boids and not the emitter object, go to the Viewport Display tab and click the Show Emitter checkbox off.
9. Physics Animation
Quick Physics Cheats

Original Scene

Oregon State University
Computer Graphics
Quick Physics Cheats

Quick Fur
Quick Explode
Quick Smoke
Quick Liquid
There are Eight Types of Physics Simulations

- Force Field
- Soft Body
- Collision
- Fluid
- Cloth
- Rigid Body
- Dynamic Paint
- Rigid Body Constraint
Set this up using what you know about modeling.

Slightly rotate the left-most domino to the right so that it will tip and start the sequence.
Let Blender Know You Want to do Rigid Body Physics

Click on the Scene Properties Button

Set Gravity (this value indicates gravity points downward and has a value of \(-9.8 \text{ meters/second}^2\))

Be sure this is turned on
Tell the Physics which Objects will be Involved

For each object that will be pulled by gravity (the dominos and the ball), select the object, click on the **Physics Property Button**, click on **Rigid Body**, and set the Type to **Active**.
Tell the Physics which Objects will be Involved

For each object that will *not* be pulled by gravity but will still be involved in the collisions (the floor), select it and set the Type to **Passive**
Turn the Animation On

Hit the *Escape* key to stop the animation

Computer Graphics
Setting Gravity

In order to do physics animations, Blender needs to have an idea of what Gravity is. The acceleration due to gravity near the surface of the earth is 9.81 meters/sec\(^2\) (pointing down), which also equals 32.2 feet/sec\(^2\).

You can set this by clicking on the **Scene Properties Button** and then scrolling down to the **Gravity** dialog area.

![Gravity dialog](image)

This is the default, but you can set Gravity to anything you want, including turning it off completely, or making it point upwards, or making it point sideways.
Gravity on Other Worlds

The acceleration due to gravity is not the same on all worlds. It depends on the mass of the body and its radius.

For fun, try setting the gravity to the Gravity Acceleration that other bodies have in our solar system:

<table>
<thead>
<tr>
<th>Body</th>
<th>Gravity Acceleration (m/sec$^2$)</th>
<th>g’s</th>
</tr>
</thead>
<tbody>
<tr>
<td>Mercury</td>
<td>3.70</td>
<td>0.38</td>
</tr>
<tr>
<td>Venus</td>
<td>8.87</td>
<td>0.90</td>
</tr>
<tr>
<td>Earth</td>
<td>9.81</td>
<td>1.00</td>
</tr>
<tr>
<td>Moon</td>
<td>1.62</td>
<td>0.17</td>
</tr>
<tr>
<td>Mars</td>
<td>3.71</td>
<td>0.38</td>
</tr>
<tr>
<td>Jupiter</td>
<td>24.79</td>
<td>2.53</td>
</tr>
<tr>
<td>Saturn</td>
<td>10.44</td>
<td>1.06</td>
</tr>
<tr>
<td>Uranus</td>
<td>8.69</td>
<td>0.89</td>
</tr>
<tr>
<td>Neptune</td>
<td>11.15</td>
<td>1.14</td>
</tr>
</tbody>
</table>

https://www.universetoday.com/35565/gravity-on-other-planets/
Gravity on Other Bodies

Or, invent your own planet! Pick a different “m/sec^2”.

21st Century Fox
Another Cool Thing: Modeling Cloth
There is a difference in what different Mesh types will do. This needs to be a **Grid** – not a Plane!

Scale the **Grid** by 3 (s3) and move it in z (gz)
Modeling Cloth -- Enable Collision with the Cube

1. Select the cube.
2. Then go to the **Physics Property Button**.
3. Then click on **Collision**

You don’t need to set any other parameters (unless you want to)
Modeling Cloth – Subdivide the Grid into More Pieces

If you select the grid and tab over to **Edit Mode**, you will see that it is already subdivided somewhat. To act as a cloth, we’d like it subdivided some more.

4. Back in Object Mode, select the grid, then select **Modifiers**.

5. Then click **Add Modifier** and select **Subdivision Surface**.

6. Change the **Viewport** parameter from 1 to 2

7. Click the **Apply** button.
You can get away without changing any of these parameters, but, at some point, you will want to experiment with different values of **Stiffness** and **Damping**.
9. Select the grid, RMB, then select Shade Smooth.

10. Start the animation.
Baking the Cloth Animation

Why does the animation run so slowly? That is because it is computing the simulation while it is animating.

Instead, tell it to precompute the animation. You do this by selecting the Bake button (and waiting and waiting).

Now try animating.
Cloth Animation with Color, Texture, and Lighting

cloth.mp4
What if You Want the Cloth to Retain its Animated Shape Forever?

That is, supposing you have used a cloth animation to drape a tablecloth over a table and now want to leave it that way.

You start with this:

Then, with the cloth selected, go to the **Modifier** menu. You will see the **Cloth** modifier already magically there. Select the down arrow and click on **Apply**.

Animate to get this:
Cloth Animation: Pinning Vertices

One of the many fun parts of cloth animation is pinning some of the vertices. There are lots of reasons to do this, such as to pin the edge of a flag to its flagpole, or to pin a cloth to a clothesline.

To do this, Tab into **Edit Mode**, **Shift-LMB** the vertices to be pinned, and create a **Vertex Group** from them. (This was described in more detail in the Modeling section of these notes).
In the Cloth section of the grid’s **Physics** menu, select the name of the Vertex Group to be pinned. When you re-animate, those vertices will be stationary.
Rendering an Animation

Render Animation kicks off the rendering of all your animation frames in order.

View Animation brings up a separate window and plays back your animation.

Hint: if this is just a test render, and you have lots of time-consuming visual effects going on, you might cut down the resolution and/or the number of rendered frames to speed things up.
Cloth Flag Animation: Pinning Vertices

We previously had this note-slide in which we looked at creating a vertex group that would become pinned in place. *This slide shows what we did before for pinning the cloth horizontally. Starting on the next slide, we will pin a column of vertices to create a flag waving.*

To do this, Tab into **Edit Mode**, **Shift-LMB** the vertices to be pinned, and create a **Vertex Group** from them. (This was described in more detail in the Modeling section of these notes).
Create a grid, scale it up, rotate in to be vertical, and subdivide it in Edit mode.
Still in Edit mode, switch to **Orthographic** mode and rotate so the cloth is perpendicularly facing you. Unselect everything (click in empty space) then box-select one column of vertices.
Cloth Flag Animation: Pinning Vertices

Click on this icon.

Find the **Vertex Groups** area. Click on the plus sign (+) then click on **Assign**. You can leave these vertices labeled as **Group**, or give them something more descriptive, like **Column**. Tab back to **Object Mode**. Go back to **Perspective Projection**.
With the cloth selected, go to the Physics icon and select Cloth. Scroll down to the Shape tab and set the Pin Group to whatever name you gave your column of points (Group, here).
Color and texture the cloth any way you’d like, and turn on the Animation.
To Blow Cloth, We need a Force Field – Attach it to an Empty Object

Ironically, one of the most useful objects is the one you can’t see. Blender calls this an Empty.

It’s invisible on the screen, but you can treat it like a real object, and can attach forces to it. These forces will influence the behavior of other objects.

Find the Empty under the Add tab at the top of the screen. When you click on it, this sub-menu pops up.
We need a Force Field – Attach it to an Empty Object

Surprise! Even though it is invisible, an Empty has a shape!

For this exercise, pick the Single Arrow

On the screen, it will look like this:
Blowing the Cloth -- Force Fields

A really good use for **Force Fields** is to blow particles and cloth around.

With the **Empty** Object selected, click on the Physics icon and then click on **Force Field**.
Position and Orient the Empty

Using the usual object-rotate commands, orient the **Empty** so that it is pointing at the particles.

Hint: it is easiest to *position* it in Global Coordinates \((g \rightarrow x)\) and easiest to *rotate* it in Local Coordinates \((r \rightarrow x \rightarrow x)\).

And, under **Force Field Type**, select **Wind**

You will use this to change the **Strength** of the wind

It will look like this on the screen:
Cloth Flag Animation: Adjusting the Amount of Fluttering

In the **Empty** object, increase the **Strength** and the **Wind Factor**.

In the **Cloth** object, scroll down to the **Field Weights** and increase the **Wind**.
Cloth Fluttering Flag Animation

fluttering.blend
fluttering.mkv
Cloth Fluttering Flag Animation 😊
**Setting up a Fluids Simulation – Create the Domain Object**

**Step #1:** Create the Domain, the volume in which the fluid will be simulated. Here, I scaled the default cube by 3 in X, 3 in Y, and 5 in Z.

**Step #2:** With the cube selected, go to the Physics menu, click on Fluid, select Domain, and select Liquid.

---

**fluidmonkeycone.blend**
**Step #3:** Scroll down in the **Physics-Fluid** menu until you find the **Mesh** tab. Turn it on.
Setting up a Fluids Simulation – Create the Flow Object

**Step #4:** Create a mesh object that will be the original location and shape of the fluid. A UV-Sphere works well. A monkey works even better! 😊 This object must lie totally within the Domain. You should probably toggle into **wireframe** mode so you can see inside the Domain.

Position this object near the *top of the Domain*.
Setting up a Fluids Simulation – Create the Flow Object

**Step #5:** With this object selected, go to the **Physics** menu, click on **Fluid**, select **Flow**, and select **Liquid**
Setting up a Fluids Simulation – Miscellaneous

**Step #6: Miscellaneous Things:**

- Change the color of the Domain object (cube) to the color you want the fluid to be. Feel free to change the **Metallic** and **Roughness** parameters as well.

- Change the shading type of the Domain object to **Shade Smooth**

- Hide the Flow object (monkey?) by clicking off its eyeballs in the Outliner

- Select the Domain object, go to the **Physics** menu, scroll down until you see this: Be sure **Liquid** is turned on. Now, go here and select the *other option*. It doesn’t make a huge difference which one you pick, but changing the option resets the fluid simulation.
Running the Fluids Simulation

**Step #7:** Run the animation! Go to **Viewport Shading mode** and hit **Play**. The first time through will seem slow because it is computing the frames and storing them. After that, the animation will be much smoother because Blender is playing back your frames.
**Step #8:** Add some shape (a cone perhaps) into the middle of the Domain. Give it a color and the proper shading type. Then, go to the **Physics** menu, click on **Fluid**, and select **Effector**.
Adding a Barrier

**Step 9:** Select the Domain object, go to the **Physics** menu, scroll down until you see this again: Go here and select the *other option*. It doesn't make a huge difference which one you pick, but changing the option resets the fluid simulation.

**Step 10:** Hit Play!
10. Appearance, II
Procedural Texturing
1. Leave **Use Nodes** turned on.

2. Select **Principled BSDF** (probably already selected)

3. Here, where you would normally select a color, click on this little circle

4. From that pop-up menu, select **Voronoi Texture** (or one of the others)
4. From that pop-up menu, select **Voronoi Texture** (or one of the others)

5. Change the **Scale** to change the size of the Voronoi cells

6. Try changing the **Randomness** as well!

7. As before, changing **Metallic** and **Roughness** affects the shininess.
Blender has these Built-in Procedural Textures
Start with a **UV Sphere** being shown in **Render Preview** mode
Image Texturing

Says that you want to read a texture image from a file

Click here to open an image file
worldtex.bmp is a good texture to try!
Image Texturing

worldtex.bmp is a good texture to try!
Image Texturing

Sphere

Tube

Cube

Flat
Places to Find Good Texture Images

https://www.shutterstock.com/search/texture

https://ambientcg.com/list?sort=Popular

https://www.freepik.com/photos/texture

Links checked: June 19, 2024
Turning on the Cycles Renderer

We have been using the Eevee renderer and have gotten some very nice results. But, we can do even better with the Cycles renderer.

In the Rendering Properties menu, select **Cycles** instead of **Eevee**.

And then select **GPU Compute** instead of **CPU** (it's faster!).
Turning on the Cycles Renderer

Then, right below that, turn on **Denoise**
Selecting the GPU Options

Select **Edit** → **Preferences**

In the **Preferences** menu, select **System**. These are your GPU options. All might work on your system, or none might work on your system. Depends on what graphics hardware you have.

Try them all to see which you have and which give the fastest Cycles render. On my system, **OptiX** is fastest, followed by CUDA, and HIP and oneAPI aren't available.
Back to Cycles: Let’s Say That We Want to Render This Scene

Cube and Monkey are opaque.

Sphere is both reflective and refractive.

Plane has a checkerboard texture on it.

Scene has lighting and shadows.

Sphere is both reflective and refractive.

reflrefr.blend
Making the Sphere Reflective and Refractive

Combine refraction and reflection effects together with the Mix Shader.

How much to mix each shader.

First shader is **Glass** to get the refraction.

Transmission color

Index of Refraction

Second shader is **Glossy** to get the reflection.

No inherent color in the reflection.
1. Leave **Use Nodes** turned on.

2. Select **Principled BSDF** (probably already selected)

3. Here, where you would normally select a color, click on this little circle

4. From that pop-up menu, select **Checker Texture** (or one of the others)

5. Here you can select the two colors making up the checkerboard

6. Change the scale to change the size of the checkerboard squares
Onscreen and Rendered Results with *Eevee*
Onscreen and Rendered Results with *Cycles*
Rendered Results with Cycles
You may have noticed some “sparkling” in the rendered image on the previous slide. That is a natural artifact of the path-tracing algorithm that Cycles uses. In computer graphics, this is called “render noise”. Blender has a denoising feature. All you have to do is turn it on in the Denoising tab of the Render Properties menu.

No Denoising
1 minute, 39 seconds

Denoising
2 minutes, 14 seconds
Rendered Results with Cycles

No Denoising
1 minute, 39 seconds

Denoising
2 minute, 14 seconds

BTW, I *don’t* recommend you turn Denoising on for the Viewport display. It really slows down your interaction when using Cycles.
What is Ray-Tracing?

It starts at the eye:

The pixel is painted the color of the nearest object that is hit.
It’s also straightforward to see if this point lies in a shadow:

Fire another ray towards each light source. If the ray hits *anything*, then the point does not receive that light.
It’s also straightforward to handle reflection.

Fire another ray that represents the bounce from the reflection. Paint the pixel the color that this ray sees.
The Physics of Reflection

Law of Reflection:

\[ \theta_r = \theta_i \]

Angle of reflection = Angle of incidence
It’s also straightforward to handle refraction. Fire another ray that represents the bend from the refraction. Paint the pixel the color that this ray sees.
The Index of Refraction, $\eta$

The Index of Refraction (IOR) is a measure of how much light slows down as it passes through a particular material. The larger the IOR, the slower the speed of light in that material. The larger the change in IOR, the more the light will bend as it passes from one material to another.

Snell’s Law of Refraction says that:

$$\frac{\sin \theta_2}{\sin \theta_1} = \frac{\eta_1}{\eta_2}$$

Or:

$$\sin \theta_2 = \sin \theta_1 \frac{\eta_1}{\eta_2}$$

Notice that there are certain combinations of the $\eta$’s that require $\sin \Theta_2$ to be outside the range $-1 \rightarrow +1$, which is not possible. This indicates that the refraction has actually become a reflection.

https://en.wikipedia.org/wiki/Snell’s_law
The Physics of Refraction

Snell’s Law of Refraction:

\[
\frac{\sin \Theta_B}{\sin \Theta_A} = \frac{\eta_A}{\eta_B}
\]

<table>
<thead>
<tr>
<th>Material</th>
<th>Index of Refraction</th>
</tr>
</thead>
<tbody>
<tr>
<td>Vacuum</td>
<td>1.00000</td>
</tr>
<tr>
<td>Air</td>
<td>1.00029</td>
</tr>
<tr>
<td>Ice</td>
<td>1.309</td>
</tr>
<tr>
<td>Water</td>
<td>1.333</td>
</tr>
<tr>
<td>Plexiglass</td>
<td>1.49</td>
</tr>
<tr>
<td>Glass</td>
<td>1.60</td>
</tr>
<tr>
<td>Diamond</td>
<td>2.42</td>
</tr>
</tbody>
</table>

http://en.wikipedia.org/wiki/Refractive_index
Common Indices of Refraction

<table>
<thead>
<tr>
<th>Material</th>
<th>Index of Refraction</th>
</tr>
</thead>
<tbody>
<tr>
<td>Vacuum</td>
<td>1.00000</td>
</tr>
<tr>
<td>Air</td>
<td>1.00029</td>
</tr>
<tr>
<td>Ice</td>
<td>1.309</td>
</tr>
<tr>
<td>Water</td>
<td>1.333</td>
</tr>
<tr>
<td>Plexiglass</td>
<td>1.49</td>
</tr>
<tr>
<td>Glass</td>
<td>1.60</td>
</tr>
<tr>
<td>Diamond</td>
<td>2.42</td>
</tr>
</tbody>
</table>

**Something New: Moissanite**

\[ \eta = 2.62 \]
You Can Also use a Mix Shader to Blend Glass and a Texture
11. Vertex Sculpting
Vertex Sculpting is, well, sculpting vertices. But, in order to do this well, we need a lot of vertices.

Start with a UV sphere mesh object.

Tab over to **Edit Mode**.  
**RMB → Subdivide → Subdivide**

When you get back to Object Mode, the sphere won’t look any different than before because you just subdivided the polygons, not smoothed them. If you had wanted smoothing, you could have used the **Subdivision Surface Modifier**.

Now go to **Sculpt Mode**.
Vertex Sculpting

Lots of new options will appear at the top:

- **Brush Radius** (I like 25-100, depending on the size of the object)
- **Brush Strength** (height)
- **Add Material (+) or Subtract Material (-)**
- **Brush Characteristics**

- **Stroking Characteristics**
- **Surface Falloff from the Center of the Brush** (I like Smoother)
- **Symmetry Control** (I recommend you click all of these off for now.)
Vertex Sculpting

Go back and forth over the object with the brush to increase the sculpting effect.

- Add material
- Subtract material

Sculpting usually looks better if you quick get over into **Object Mode**, RMB → **Shade Smooth**
Vertex Sculpting Options

I like this one
# Vertex Sculpting Options

<table>
<thead>
<tr>
<th>Brush</th>
<th>Meaning</th>
</tr>
</thead>
<tbody>
<tr>
<td>Blob</td>
<td>Change the local mesh into a spherical shape</td>
</tr>
<tr>
<td>Brush</td>
<td>Moves vertices in or out</td>
</tr>
<tr>
<td>Clay</td>
<td>Like Brush, but lets you set a plane of action</td>
</tr>
<tr>
<td>Clay Strips</td>
<td>Like Clay, but uses a cube to limit the action</td>
</tr>
<tr>
<td>Crease</td>
<td>Creates ridges by pulling/pushing vertices and pinching them</td>
</tr>
<tr>
<td>Fill/Deepen</td>
<td></td>
</tr>
<tr>
<td>Flatten/Cont</td>
<td>Push/pull vertices towards a plane</td>
</tr>
<tr>
<td>Grab</td>
<td>Grab and move a single vertex</td>
</tr>
<tr>
<td>Inflate/Deflate</td>
<td>Like Brush, but vertices are moved in the direction of their normal</td>
</tr>
<tr>
<td>Layer</td>
<td>Like Brush, but the height is capped</td>
</tr>
<tr>
<td>Mask</td>
<td>??</td>
</tr>
<tr>
<td>Nudge</td>
<td>Slightly push vertices in a certain direction</td>
</tr>
<tr>
<td>Pinch/Magnify</td>
<td>Pinches vertices towards the brush’s center</td>
</tr>
<tr>
<td>Polish</td>
<td>??</td>
</tr>
<tr>
<td>Scrape/Peak</td>
<td>Like Flatten?</td>
</tr>
<tr>
<td>Sculpt Draw</td>
<td>Moves vertices in or out</td>
</tr>
<tr>
<td>Smooth</td>
<td>Smooth a region by averaging out vertex coords</td>
</tr>
<tr>
<td>Snake Hook</td>
<td>Pulls vertices along the brush’s path</td>
</tr>
<tr>
<td>Thumb</td>
<td>Like Nudge, but over a larger area</td>
</tr>
<tr>
<td>Twist</td>
<td>Rotate a single vertex</td>
</tr>
</tbody>
</table>
Vertex Sculpting with Dynamic Topology ("Dyntopo")

This cool – you are really going to like this!

Set the Sculpt Mode to **Draw**

Set Radius to **20**

Set Brush Strength to **1.0**

Add Material (+)

Surface Falloff from the Center of the Brush to **Smoother**

No Symmetry

Click **Dyntopo** on (if you get a message, just click **OK**).
Vertex Sculpting with Dynamic Topology ("Dyntopo")

Set Dyntopo Detailing to **Brush Detail**

And, have at it!
Vertex Sculpting with Dynamic Topology ("Dyntopo")

How does Dyntopo Mode make such a smooth sculpt? Let’s look at this in **Sculpt Mode** and then in **Edit Mode**:

That’s why it is called **Dynamic Topology**!
12. Vertex Painting
Vertex Sculpting is, well, sculpting vertices. But, in order to do this well, we need a lot of vertices.

Start with a UV sphere mesh object.

Tab over to **Edit Mode**.
**RMB → Subdivide → Subdivide**

When you get back to Object Mode, the sphere won’t look any different than before because you just subdivided the polygons, not smoothed them. If you had wanted smoothing, you could have used the **Subdivision Surface Modifier**.

Now go to **Vertex Paint Mode**.
Setting up for Vertex Painting

Be in **Solid Shading mode**

- **Brush Color**
- **Brush Radius** (I like 25-100)
- **Strength** 1.000
- **Brush Intensity**
- **Brush Characteristics**
- **Stroking Characteristics**
- **Surface Falloff from the Center of the Brush** (I like **Smoother**)

Oregon State University
Computer Graphics

mjb – June 29, 2024
A Word on Brush Size

Note: the brush size does not scale with zooming in or out. It stays the same size.
How Does Vertex Painting Work?

The “paintbrush” only drops “paint” when a vertex is inside the circle brush. This means that the paint does not smear along a nice line but looks splotchy like this.
How Do We Make it Less Splotchy?

Two approaches:
1. Make the object look smaller. That way more vertices will end up inside the brush circle.
2. Use Subdivide or Subdivision Surfaces to add more vertices
Making Your Vertex Painting Show Up

Be in **Rendered Shading** mode

Click on the small circle and select **Mix (Legacy)** from the pop-up menu.
Making Your Vertex Painting Show Up

Then click **here** and select **Color Burn** or **Multiply** from the pull-down menu ("Mix" will change to whichever you picked)
Making Your Vertex Painting Show Up

Click on the small circle and select **Color Attribute** from the left column of the pop-up menu.

Click and adjust the value of **Fac** (the interpolation Factor).

Click here and select a color for the sphere.

Base Color: **Color Burn**

- **Fac**: 0.362
- **Color1**: Light Blue
- **Color2**: Color Attribute | Color
The *Fac* Parameter Tells Blender What to do on the Parts of Your Object that have both an Object Color and a Paint Color

- **Multiply**
  - Fac = 0.00
  - All Object Color

- **Multiply**
  - Fac = 0.50
  - Half of Each

- **Multiply**
  - Fac = 1.00
  - All Paint Color
Have a Nice Day!
13. Keyframe Animation
Keyframe Example

http://ieeexplore.ieee.org/ieee_pilot/articles/05/ttg2009050853/figures.html
Keyframe Animation

Keyframe animation is a technique that goes all the way back to the beginning of hand-drawn animation (e.g., Walt Disney). Senior animators would specify key positions for the animated characters and then more junior animators would fill in the frames in between. This became known as **keyframing** and **in-betweening**.

Blender allows you to create the keyframes and gets the computer to do the in-betweening. Here, we will keyframe-animate the monkey as she slaloms around a group of colored cubes:
Keyframe Animation

Select the **Animation** workspace from the list at the top. This creates a screen layout that looks like this:

This makes your screen look like this. These new sections are:

- **3D Viewport Window** – what you are used to
- **Camera View Window** – what you will see if you Render
- **Timeline Window** – keeps track of what frame number we are on.
Keyframe Animation
Keyframe Animation

Slide the **timeline indicator** to what frame number you want to set, position the object (grab, scale, rotate) how you want it to be (grab, scale, rotate), and **RMB → Insert Keyframe** (or hit the ‘i’ key). From the pop-up menu, select **Location, Rotation, and Scale**, indicating that you want to record location, rotation, and scale factor.
Keyframe Animation

Do it again: slide the timeline indicator to what frame number you want to set, position the object how you want it to look, and RMB → Insert Keyframe (or hit the ‘i’ key). From the pop-up menu, select **Location, Rotation, and Scale**, indicating that you want to record location, rotation, and scale factor.
Keyframe Animation

After a while, your timeline will look like this:

Then, click here and change the type of display to the **Graph Editor**:
Graph Editor
Keyframe Animation

Your **Graph Editor** window should now look about like this.

Note that Blender has filled in the in-between values for you. (This is the “In-Betweening”.)
The Graph Editor Window

Click on the triangle. This gives you access to the curves. Clicking on the eye toggles whether or not you can see a curve. Clicking on the name of the curve makes that the current curve. You can then edit it.
The Graph Editor Window

Shortcuts when the cursor is in the **Graph Window**:  

<table>
<thead>
<tr>
<th>Shortcut</th>
<th>What it does</th>
</tr>
</thead>
<tbody>
<tr>
<td>LMB</td>
<td>Select a keyframe dot</td>
</tr>
<tr>
<td>Scroll wheel</td>
<td>Zoom in and out of the Graph</td>
</tr>
<tr>
<td>MMB</td>
<td>Pan the Graph</td>
</tr>
<tr>
<td>Shift-scroll wheel</td>
<td>Pan in Value (vertical)</td>
</tr>
<tr>
<td>Shift-MMB</td>
<td>Pan in Value (vertical) and Time (horizontal)</td>
</tr>
<tr>
<td>Control-MMB</td>
<td>Scale in Value (vertical) and Time (horizontal)</td>
</tr>
</tbody>
</table>
Hit the ‘n’ key. Like in the 3D View, a Number Panel pops up.

Click on the **Modifier** tab.

Then click on **Add Modifier**.
Select **Add Modifier**. From the list of Modifiers, select **Noise**.
Animation Mischief 😊

Use this menu to change the noise parameters **scale** and **strength**. Notice what this does to the curve. Now play the animation.
Two Characters Interacting

To avoid a collision, the monkey jumps up and the cube squishes
Cameras and Lamps are just like any other object. As you have seen, they can be positioned. They can also be keyframe-animated. Like other objects, just select them and hit the ‘i’ key to insert a keyframe.
Animating (almost) Any Parameter

One of the many cool things about Blender is that you can do more than just keyframe-animate the objects, you can also keyframe-animate the parameters you are setting. For example, suppose you want to animate the Metallic-ness. To set a keyframe for this, right click on the Metallic box and select Insert Keyframe from the pop-up menu. Do this for two keyframes and then animate.

![Image showing the properties panel in Blender with Metallic and Specular settings highlighted and keyframe icons for two frames displayed.](image-url)
Animating a Human-ish Form

Start with this …

… and turn it into a Blender model:

model.blend
modelmoved.blend
Animating a Human-ish Form

But, it’s more than just a collection of parts!

Be sure that the origins of the different parts are where you want the part to pivot around.

Then establish the proper parent-child relationships.
Animating a Human-ish Form

Now tell Blender to do all rotations around each part’s origin

Selecting this … causes object rotation to happen about the previously-set origin
Now try rotating the individual parts.

Be sure you are rotating in local coordinates, e.g., \( r \rightarrow y \rightarrow y \)
There is a time-honored tradition in stop-motion animation to use an internal support, called an armature, to help position the object at each frame.

Digital animation has adopted the same technique, and has even retained the same terminology, armature.

The process of creating this digital armature is referred to as Rigging.
Let’s say we have a cheesy noodle character named Mac. We would like to rig him to bend.

The first step is to create Mac’s geometry. In this case, one cylinder was Boolean-subtracted from another and then was Edit → Subdivide’d a couple of times.

The second step is to go to the Add tab on the Object Tools and click on Armature. This brings up the sub-menu here.
Rigging for Animation

Grab the armature just like you would any other object and position it next to Mac. (I scaled it up a couple of times to make it more visible.)

This is what the pieces of a Blender armature look like. The three sections of one of these bones are the root, the body, and the tip.
Rigging for Animation

We could put lots of bones in place to animate Mac, but, for simplicity we will just use two.

Tab into **Edit Mode**, select the **Armature**, then select **Extrude**. Lift up on the **plus sign**. This will add a second armature on top of the first and connect them tip-to-root. Click here to let go. Tab back to **Object Mode**.
Rigging for Animation

In the **Outliner**, you can see the bones you have created.

![Outliner screenshot](image)

Also, in the Properties buttons, you will see that there are now **Armature** and **Bone** buttons.
When you click the **Armature Properties** button, a bunch of new information comes up. The most important for right now is in the **Viewport Display** tab:

Try these. They change the appearance of the Bones.

Click on **Names**. It puts the name of the Bone next to it so you know which one is which.
It’s always good to name your Bones. In the Outliner, double-left-click on **Bone.001** and rename it **Top**. Double-left-click on **Bone** and rename it **Bottom**. Your display now looks like this:
We next need to make the armature a Parent and the object (i.e., Mac) its Child. Select Mac and then shift-select the armature. (The order is important!)

To create the Parent-Child relationship, hit **Control-P**. In the pop-up menu, select **Armature Deform With Automatic Weights**.

To verify that this worked, the **Outliner** will show that Mac is now part of the Armature.
Almost there – the last step is to assign which vertices on Mac will be deformed by the Bottom Bone and which will be deformed by the Top Bone. These groups do not need to be mutually exclusive – they can (and should) have vertices in common.

Earlier in these notes we talked about selecting multiple vertices and Vertex Groups. We are going to do that again. We are going to put some of Mac’s vertices into a Vertex Group called **Bottom**, and some into a Vertex Group called **Top**. These must match the names of the respective Bones *exactly*,

1. Select Mac
2. In the properties area, select the **Object Data Properties**
3. Tab into **Edit Mode**
4. Select **View → Perspective/Orthographic** to place yourself in orthographic display mode
5. Turn on the **X-ray** button at the top
6. Hit ‘a’ to unselect everything
Rigging for Animation

7. Use the Border Select to select the top 2/3 of Mac’s vertices
8. Create a Vertex Group with them called Top by clicking on Top and then clicking on Assign
9. Hit ‘a’ to unselect everything
10. Use the Border Select to select the *bottom 2/3* of Mac’s vertices
11. Create a Vertex Group with them called Top by clicking on **Bottom** and then clicking on **Assign**
12. Hit ‘a’ to unselect everything
13. Turn off **X-ray** mode and go back to **Perspective**
14. Tab back to **Object Mode**
Rigging for Animation

Select the **Armature** and go to **Pose Mode**.

Select the different Bones and try grabbing, rotating, and scaling them. Obviously, a serious Mac animation will require more than two Bones! Bone transformation can be keyframed just like transformation parameters of any other object.
Rendering an Animation

This kicks off the rendering of all your animation frames in order.

This brings up a separate window and plays back your animation.

Hint: if this is just a test render, and you have lots of time-consuming visual effects going on, you might cut down the resolution and/or the number of rendered frames to speed things up.
Before saving the animation rendering, you need to specify the file name to put the animation into. In my case, this was:

C:\tmp\mjb.avi

and the type of file format that it is to have.

First, go to **Output Properties**.
Here are the animation file types that Blender supports.

Here is how large a 100-frame animation of the monkey turned out to be.

<table>
<thead>
<tr>
<th>Movie File Type</th>
<th>File Size</th>
<th>Displayed?</th>
<th>Import into PowerPoint?</th>
</tr>
</thead>
<tbody>
<tr>
<td>AVI JPEG</td>
<td>~5 MB</td>
<td>Yes</td>
<td>Yes</td>
</tr>
<tr>
<td>AVI Raw</td>
<td>~607 MB</td>
<td>Yes</td>
<td>Yes</td>
</tr>
<tr>
<td>FFmpeg Video</td>
<td>~200 KB</td>
<td>Yes</td>
<td>Yes</td>
</tr>
</tbody>
</table>

Note: this scene is simple and compresses well. The mileage you get may vary.
Importing an Animation into YouTube

YouTube accepts videos in **AVI** and **MPEG** formats
Importing an Animation into PowerPoint

<table>
<thead>
<tr>
<th>Movie File Type</th>
<th>File Size</th>
<th>Displayed?</th>
<th>Import into PowerPoint?</th>
</tr>
</thead>
<tbody>
<tr>
<td>AVI JPEG</td>
<td>~5 MB</td>
<td>Yes</td>
<td>Yes</td>
</tr>
<tr>
<td>AVI Raw</td>
<td>~607 MB</td>
<td>Yes</td>
<td>Yes</td>
</tr>
<tr>
<td>FFmpeg Video</td>
<td>~200 KB</td>
<td>Yes</td>
<td>Yes</td>
</tr>
</tbody>
</table>
1. In this example, we added the first keyframe, then the last keyframe, then three keyframes in the middle. Sometimes it is easiest to work that way. Other times it is easier to add them in sequential order.

2. Sometimes it is easier if you initially add a bunch of duplications of the object in various positions to get a feel for the motion, edit those positions as you see fit, and then use them as keyframe positions.

3. Extending from each keyframe dot is a line. That line can be twisted to change the slope of the curve at that keyframe. Select the dots at the end of that line and move them.

4. The Camera position and the Lamps can be animated too. For each, define an Empty object, force the Camera or Lamp to follow it (it’s one of the Constraints), then animate the Empty. Be sure to give the Empty a descriptive name – all Empties look alike.
1. **Squash and Stretch** -- Defining the rigidity and mass of an object by distorting its shape during an action.

2. **Timing** -- Spacing actions to define the weight and size of objects and the personality of characters.

3. **Anticipation** -- The preparation for an action.

4. **Staging** -- Presenting an idea so that it is unmistakably clear.

5. **Follow Through and Overlapping Action** -- The termination of an action and establishing its relationship to the next action.

6. **Straight Ahead Action and Pose-To-Pose Action** -- The two contrasting approaches to the creation of movement.

7. **Slow In and Out** -- The spacing of the inbetween frames to achieve subtlety of timing and movement.

8. **Arcs** -- The visual path of action for natural movement.

9. **Exaggeration** -- Accentuating the essence of an idea via the design and the action.

10. **Secondary Action** -- The action of an object resulting from another action,

11. **Appeal** -- Creating a design or an action that the audience enjoys watching.

14. 3D Printing
In the Beginning, Manufacturing was “Subtractive”

1. The whirling drill bit follows a 3D path
2. Chips of metal (or wood or wax) fly
3. A block of metal becomes a part
3D Printing is Additive

“3D Printing” is defined by some sort of “additive” process. The current trend in desktop 3D Printing consists mostly of systems that deposit layers of molten plastic:
Examples of 3D Printing
Portland’s Laika uses Color 3D Printing for Stop-motion Movies

*Kubo and the Two Strings*
The 3D Printing Geometry File

3D Printers are fed a file called an “STL File”, which lists all the triangles in the object. Blender (as well as all CAD systems) can produce this type of file for you.

In this particular file, these coordinates were in units of inches.

Some 3D Printers still use inches, but most now use millimeters.

Check! It matters!

Note: there are 25.4 mm/inch
Advice on 3D Printing

Don’t make the part too big – it will take a long time to 3D print. It’s nice if you can fit several models in a single run.

Try to rotate the part so the smallest dimension is vertical. It’s stronger that way, and it builds faster.

The 3D Printer will like it better if the part gets smaller as it goes up, not the other way around.

Don’t design the part with long, thin edges. They will likely snap right off.

Don’t make walls too thin – they might break.
Object Rules for 3D Printing

Rule #1: The object must be a mesh and *consist only of triangles*.

1. Select the mesh object
2. **Modifiers** → **Add Modifier** → **Generate** → **Triangulate** → **Apply**

**RMB** → **Convert To** → **Mesh** to turn a Meta object or 3D Text into a mesh first.
Object Rules for 3D Printing

Rule #2: The object must be a legal solid. It must have a definite inside and a definite outside. It can’t have any missing face pieces.
The Simplified Euler's Formula* for Legal Solids

*sometimes called the Euler-Poincaré formula

\[ F - E + V = 2 \]

F - Faces
E - Edges
V - Vertices

For a cube, 6 - 12 + 8 = 2 \( \checkmark \)
Watch Out for Overhangs!

This layer will fall to the plate

These layers will build fine

Note that if you build it upside-down, it will probably work fine
Watch Out for Overhangs!

Some 3D printers handle this by leaving unused material in place to support the overhangs.

Some 3D printers handle this by using software to add “support structures” to the overhangs.

Some 3D printers handle this better than others… 😊

http://twistedsifter.com/2013/08/when-3d-printing-goes-wrong/
Rule #3: You can’t make a new object by simply overlapping two objects in 3D. If you want both shapes together, do a Boolean union on them so that they become one complete object.
What Happens if You Do Overlap Objects?

Here’s what one of the 3D Printers in the OSU Library did:

Overlapped in 3D

Boolean union

Not bad – it could have been lots worse …
Object Rules for 3D Printing

**Rule #4:** Each edge in the mesh must bound **2 and only 2** triangles (this is known as the Vertex-to-Vertex Rule). If this is not true, then your model has cracks in it.
Installing the Blender 3D Printing Add-on

Select Edit → Preferences
Installing the Blender 3D Printing Add-on

Select **Add-ons → Mesh: 3D-Print Toolbox**
Installing the Blender 3D Printing Add-on

Hit the ‘n’ key to see the sidebar menu. The 3D Print Toolbox will be a tab like this.
Selecting your object and then clicking on **Check All** will give you this nice list of problems Blender thinks you will have if you try to 3D Print this object.

Selecting **Clean Up** will try to fix the problems.
The Blender 3D Printing Toolbox Add-on

Tab over to **Edit Mode**.
Click in an empty area to unselect everything.
Then click in all the places that show problems.
Blender will light up the object in the places that provoked that problem, giving you a chance to fix them.
Output for 3D Printing

To **export** an STL file for 3D Printing:

1. Select the triangulated mesh object
2. **File → Export → Stl (.stl)**
3. Navigate to where you want to save the file
4. Give it a filename that ends in .stl
5. Click **Export STL**

**.stl** is the most common 3D printing file format

“STL” stands for **Stereolithography**

The word “stereolithography” comes from the Greek words for “3D” and “writing”.
Want to see 3D Printing in Action?

Oregon State University’s library has 3D Printers for use by OSU students. To see them via webcam, go to: http://webcam.oregonstate.edu/3dprinter

Click here to see the live, streaming view.
15. Stereographics
Stereoscopy is not new – it’s been in common use since the 1950s

But, with virtual reality and 3D movies being so popular, stereoscopy has made a big comeback. And, you can get at it through Blender!

For more information on stereoscopy, see: https://en.wikipedia.org/wiki/Stereoscopy
And, even longer than that in stills

Newport Maritime Museum

Portland Art Museum’s Ansel Adams Exhibit
We Humans have Binocular Vision

In everyday living, part of our perception of depth comes from the slight difference in how our two eyes see the world around us. This is known as binocular vision. We care about this because computer graphics can simulate that slight viewing difference and thus create the binocular viewing of a synthetic scene.
Step #1a – Be Sure You are Using the Eevee Renderer, not Cycles

Open the **Render Properties** menu
Step #1b – Turn the Stereographics On

Open the **Output Properties** menu

Enable the **Stereoscopy** checkbox and open the menu

Select **Stereo 3D**.

Be sure these are both checked
Step #1c – Turn the Stereographics On

While still in the Output Properties menu ...

Click on **Stereo 3D**.

Pick one of these here

Red-Cyan is good here if you picked Analglyph before. On the screen, the display will always be a Red-Cyan anaglyph. This menu controls how it will be drawn when you write a file after a **Render**.
Step #2 – Set the Stereo Cameras

Select your **Camera** (in the scene or in the Outliner) and then open the **Camera Data** menu.

Any of these will work well. I’m kind of partial to **Off-Axis** or **Tow-In**.

These are interesting to experiment with. They control how deep the stereo focuses and how easy the stereo images are to converge.
Step #3 – Tell the Renderer to Produce both a Left and Right View

Open the Object Properties menu (hit ‘n’ on the keyboard) and click on the View tab.

This tells the Renderer to produce both a left and right view, and to make a red-cyan stereopair from them.
Step #4 – Render → Render Image
Red-Cyan Glasses

No, they are not *red-blue* glasses!
No, they are not *red-green* glasses!
They are *red-cyan* glasses!

The universal convention is:
• Red goes over the left eye
• Cyan goes over the right eye

If you want to buy your own red-cyan glasses, my go-to is:

[https://www.3dglassesonline.com/products/anaglyphic/](https://www.3dglassesonline.com/products/anaglyphic/)
Step #5 – (if you want): From the Render window, write out a Stereographics Image File

This assumes you have already done the other steps
How Deep your Scene Appears to be into and out of the Computer Screen -- Setting the Convergence Plane

Select your **Camera** (in the scene or in the Outliner) and then open the **Camera Data** menu.

The **Convergence Plane Distance** controls how much the scene appears to exist behind or in front of the display screen. Use a small distance to make the scene look like it is living in the monitor.

Use a larger distance to make the scene look like it is living in the air in front of the monitor. (Don’t go too crazy with this – it will look less cool than you are expecting.)
How Deep does the Scene Appear to be into and out of the Computer Screen? Setting the Convergence Plane

The Convergence Plane is in front of the object – the object will appear to be inside the monitor.

The Convergence Plane is behind the object – the object will appear to be in the air in front of the monitor.

I like placing the Convergence Plane about 1/3 of the way through the object.
There are many ways to display the correct view into the correct eye
16. References
Blender References I Like

http://cs.oregonstate.edu/~mjb/blender

http://blender.org

http://www.blender.org/education-help/

http://www.blenderguru.com/


Camp Blender
http://cs.oregonstate.edu/~mjb/blender

This work is licensed under a Creative Commons Attribution-NonCommercial-NoDerivatives 4.0 International License