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OpenDX 

• Started out life as IBM Visualization Data Explorer

• When the product was cancelled, IBM put it into Open 
Source and renamed it OpenDX

• Basic premise is a series of interconnected modules, 
living together in an environment called the Visual 
Program Editor (VPE)

• There are lots of provided modules

• You can also write your own

http://www.opendx.org

http://www.vizsolutions.com

http://eecs.oregonstate.edu/~mjb/opendx
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Inputs

Outputs

Code that does 
something useful
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The Structure of an OpenDX Module
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Steps in Creating a Visualization
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Seven Steps to Creating a Visualization

1. Get the data

2. Formulate a scientific strategy.  What do you want to show?  
How do you want to show it?

3. Import the data

4. Create a simple OpenDX network

5. Incrementally embellish the network.  Save it often!

6. Choose what quantities you want to interact with.  Change 
the Interactor styles to match the quantities being modified.

7. Create the output.
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Computer Graphics Education Lab
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Starting OpenDX on the OSU CGEL Systems

1. Start → All Programs → WRQ Reflection → Reflection X

2. In the View menu, click off X Desktop

3. Minimize the Reflection X window (the _ in the upper right corner)

4. Start → All Programs → OpenDX → DX

Quitting OpenDX on the OSU CGEL Systems

1. Select Quit from the OpenDX Main Menu

2. Maximize the Reflection X window by clicking here in the Task Bar

3. In the File menu, select Exit
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The OpenDX Main Menu
and

Categories of Modules
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The OpenDX Main Menu

Get into the Data 
Prompter 
program

Run an OpenDX network 
without seeing the 
network

Create a new OpenDX 
network

Load, and be able to edit, 
one of the OpenDX 
sample networks

Run an OpenDX 
network and be 
able to edit the 
network

Run the internal 
OpenDX tutorial

Exit OpenDX
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Nine Categories of OpenDX Modules

Import & Export Rendering

Realization

Transformation

Special

Structuring

Annotation Interactor

Debugging
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• AutoAxes – creates an axis box for whatever data you are plotting

• AutoGlyph – designs and produces glyphs for the data based on the data values

• Caption – creates caption text for an image

• ColorBar -- creates a colorbar to be displayed

• Format – creates a string from a number (used to create file names)

• Glyph – produces an identical glyph for every point in the data

• Legend – produces a legend to be displayed

• Plot – creates a 2D plot

• Ribbon – creates a flow field ribbon

• Text – displays text in 3D space

• Tube – creates a flowfield tube

Annotation OpenDX Modules
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Debugging OpenDX Modules

• Describe – describes an object

• Print – prints information about a field to the Message Window
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• Export – writes data from OpenDX into a file

• Import – reads data into OpenDX from a file

• ImportSpreadsheet – reads data into OpenDX from a tabular file

• Include – includes or excludes points in a field based on their data values

• ReadImage – reads an image into OpenDX from a file

• Reduce – filters and resamples a field into a lower resolution

• Refine – interpolates a field into a higher resolution

• Slab – takes a positional subset of the data

• Slice – takes a positional slice through the data

• WriteImage – writes an image from OpenDX into a file

Import & Export OpenDX Modules
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• FileSelector – presents a dialog box to let you select a file

• Integer – allows the user to input an integer number

• Scalar – allows the user to input a floating point number

• Selector – allows the user to select one of a number of options

• String – allows the user to input a string

• Toggle – allows the user to select one of two options

• Vector – allows the user to input a vector

Interactor OpenDX Modules
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• AutoGrid – maps a set of scattered points onto a grid

• Band – divides a field into bands

• Connect – creates triangle connections for scattered data points in a field

• IsoSurface – creates surfaces or lines of constant data value

• MapToPlane – projects a data field onto an arbitrary plane

• RubberSheet – deforms a surface field by the amount of the data value at each point

• ShowBox – creates a bounding box for display

• ShowConnections – displays the outline of connectivity elements in a field

• ShowPositions – displays the positions in a field

• Streakline – computes an advection path through a changing flow field

• Streamline – computes a path through a non-changing flow field

Realization OpenDX Modules
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• AmbientLight – specifies the ambient light

• Arrange – creates a single side-by-side image from a collection of images

• AutoCamera – selects a good camera view of the data

• Camera – specifies a camera view

• Display – a more elaborate image-rendering system than Image

• Image – renders and displays field data

• Light – specifies a distant (parallel) light source

• Normals – compute point or face normals for shading a surface

• Render – renders a field and creates an image

• Rotate – rotates field data

• Scale – scales field data

• Shade – specifies object-shading parameters

• Transform – performs a general matrix transform of an object

• Translate – translates field data

Rendering OpenDX Modules
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Colormap – presents an interactive tool for specifiying color vs. data value

Receiver – receives the output of a Transmitter

Sequencer – creates an animation “VCR” display

Transmitter – “wirelessly” connects a network to a receiver

Special OpenDX Modules
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• Collect – collects objects into a group

• Inquire – returns information about a field

• Mark – marks a new field component as “data” (e.g., for Compute)

• Remove – removes a specified component from a field

• Rename – renames a specified component in a field

• Unmark – undoes the effects of Mark

Structuring OpenDX Modules
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• AutoColor – automatically color a data field (blue→green →red)

• Color – assign a color by name of by RGB values

• Compute – perform point-by-point arithmetic on a field’s “data” component

• DivCurl – computes the divergence and curl of a flow field

• Equalize – apply histogram equalization to a field

• Gradient – computes the gradient of a scalar field

• Histogram – creates a histogram that can be rendered with Plot

• Map – projects one field’s data onto another field’s geometry

• Measure – calculates surface area and volume of a geometry (e.g., isosurface)

• SimplifySurface – reduces the size of the triangular mesh

• Statistics – computes the mean, standard deviation, variance, minimum, and maximum of 
a field’s data

Transformation OpenDX Modules
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Adding and Connecting Modules
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Adding a Module into the Visual Editing Area

1. Left-click on the module category to list its modules.

2. Left-click on the module you want to add

3. Move the cursor into the Editing Area and left-click

It’s not drag-and-drop, 
it’s click-and-click
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Connecting Modules in the Visual Editing Area

1. Left-click on the output tab of the module you are connecting from

2. Keeping the left button down, drag to the input tab of the module you are connecting to

3. When you get close, the tabs to which a connection make sense will highlight in green

4. Move the cursor on top of the tab you want to connect to, and release the left mouse button

5. To disconnect, reverse the process.  Click on the input tab and drag back to the output tab.

If an input tab is “down”, then it has 
already been set to a constant within the 
module itself, and cannot take an 
external connection until that constant 
has been un-set.

If an input tab is in the “up” position, 
you are allowed to try to connect to it.

Just because an input tab is up, however, 
doesn’t mean that this input is data-
compatible with the output you are trying 
to connect to it.  Data-compatability is 
indicated by the input tab(s) turning 
bright green.

This, however, still doesn’t imply that the 
connection makes logical sense.  ☺
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Some Modules Can Have Variable 
Numbers of Tabs

Edit→Input/Output Tabs→Add Input Tab

Collect and Compute are two common 
modules that work this way
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Terrain Visualization
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Import/Export

Transformation

Rendering

Terrain Visualization

Start simply, then embellish !
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Import/Export

Interactor

The Import and FileSelector Modules

You can type a filename into the Import 
module, but hooking in a FileSelector
module makes it way easier and friendlier
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Interactor

Transformation

Realization

Structuring
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The Colormap Editor Module

• The first input “tab” is the field input.

• Click on the Hue, Saturation, Value, or 
Opacity labels to edit that curve.

• Double-click on a line to add a control point 
there.

• Click on a control point to select it.

• Sweep a box over several control points to 
select them all.

• Hold down the left mouse button on a control 
point to move it.  If several are currently 
selected, all will move together,

• Edit → Delete to remove selected control 
point(s).

The data value range over which the colors 
apply is determined by scanning the data itself.

Special
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Special

The Colormap Editor in Action
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Special

Rubbersheeting the Terrain Surface
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The Image Window
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Image Window Options

The AutoAxes option has many ways to 
embellish the visualization with axes, labels, 
grids, etc.
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Image Window Options

The Mode option lets you set what scene 
transformation the mouse will perform.
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Image Window Options

The View Control option lets you set various 
aspects of how the scene will appear.

Same as the Mode option

Set a pre-defined view

Specify Perspective or 
Orthographic 3D projection

If using Perspective, this 
specifies the field-of-view 
angle.  The larger this number, 
the more severe the perspective 
will be.
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Debugging
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Second argument is a string with one or more characters:

• r recursively traverse the object

• o print only the top level of the object

• d print first and last 25 items in arrays, as well as 
headers

• D print all the items in arrays as well as headers

• n print object to n levels.

The Print Module

Debugging

First argument is the field to print

“rD” works well
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Printing to a File (“logging”)

Checkbox to turn logging on/off

Specify the file to write to
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Scalar Visualization
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Glyphs
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3D Cutting Plane – Interpolated Colors

Realization

MapToPlane interpolates the 3D field onto the given plane.  
The first argument is the field, the second is a 3D point on 
the plane, and the third argument is a 3D normal to the plane.
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3D Cutting Plane – Contours

Realization



22

mjb – March 10, 2008
Oregon State University

Computer Graphics

Isosurfaces

Realization
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Direct Volume Rendering

These are the 
“Transfer Function”

A Volume Rendering “Transfer Function” relates data scalar value to 
its corresponding color and opacity.  For volume rendering, OpenDX 
uses the color Value as the opacity, not the color Opacity.

The direct volume 
rendering part of the 
Image module will only 
work in Orthographic 
projection.
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Mapping Another Data Field onto Isosurfaces

Transformation
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Vector Visualization
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Vector Cloud

Annotation
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Speed Isosurfaces
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Streamline Ribbon

Realization
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Streamline Tube

Annotation
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Curl

Transformation
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Divergence

Transformation
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Animation
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The Compute Module

Does arithmetic on the point-by-point Data component 
of a field, and outputs the modified field

Transformation

The 3 (in this case) inputs

}

The output expression, in this case, a 3-vector with a newly-created Z value
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The Compute Module

Does arithmetic on the point-by-point Data component of 
a field, and outputs the modified field. But, what if you 
want to do arithmetic on a different component?

The Mark module renames the Data component to 
something temporary, and renames a component you select 
to “Data”.  Compute then acts on this component.

The Unmark module changes the component names back to 
what they were originally.

Structuring
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Special

Animation:
The Sequencer Module

Sequencer outputs a series of integers.  You set 
minimum, maximum, and delta using Edit→Configuration.

Reverse

Frame Control

Forward Stop Pause

Forward-
Forward 

Loop

Forward-
Reverse 

Loop
Single-step 

mode
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In this case, Compute turns an integer into a scalar to be 
used to animate an isovalue

The Sequencer Module: Usually Used with the Compute Module 
to turn the Integer into an Animation Parameter
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The Sequencer Module: “Percent Units Strategy”

A good Sequencer Strategy:
Run the sequence from 1-100 
(or 0-100).

Then, base the Compute
quantity on these “Percent 
Units”.
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In this case, Compute turns an integer into a scalar to be 
used to animate the isovalue

The Sequencer Module: Setting a Scalar Isovalue
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The Sequencer Module: Setting a Scalar Isovalue
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In this case, Compute turns an integer into a 3-element 
vector to be used to animate the position of the cutting plane

The Sequencer Module: Setting a Vector
to act as a Plane Location
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The Sequencer Module: Setting a Vector
to act as a Plane Location
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In this case, Compute turns an integer into a 
rotation angle in degrees.

The Sequencer Module: Setting a Transformation
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Translate by [-15,-15,-15]

Translate by [15,15,15]

Why Does the Rotation Occur around the 
Edge of the Cube, not about its Center?

Rotation and Scaling always occur about the origin.  To 
change this to the center of the volume, translate the 
volume to the origin, perform the rotation or scale, and 
then translate it back.
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Writing Out a MIFF 
Animation File
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Click on: Start→All Programs →Accessories →Command Prompt

Converting a MIFF Animation File into an Animated 
GIF File using the ImageMagick Package
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Converting a MIFF Animation File into an Animated 
GIF File using the ImageMagick Package

Type: convert  anim.miff anim.gif
(where anim is the name of your MIFF animation file written from the  Image module)

http://www.imagemagick.org
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Double-click on the animated GIF file

Animated GIF Files work in Windows Explorer
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<img src=“anim.gif”>

Animated GIF Files work in Web Pages
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Animated GIF Files work in PowerPoint

Insert→Picture →From File…

In a presentation, the image will start animating when this 
slide becomes active
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Interactors
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Editing Interactor Attributes

Select an Interactor by Left-Clicking its Label.

Then, click Edit.  You can change the Interactor’s Style, Layout, 
Attributes, and Label. Under Set Attributes, clicking on the Continuous
checkbox is usually a good thing.

{
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Ganging Interactors

You can place all Interactors in a single window by using 
the middle mouse button to drag them over.  This copies 
them, not moves them.  Then select the original Interactor
in its original window and Edit-Delete it.
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Transmitters and Receivers
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It’s Easy to Get Cluttered, Especially Around Import and ColorMap!
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It’s Also Easy to Get Un-cluttered with Transmitter and Receiver

Notice how this lets you create separate “regions”
for different functions.  Wouldn’t it be nice if you 
could put each region on its own page?
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Using Transmitter and Receiver, You 
Can Also Spread the Network Out on 

Multiple “Pages”

Click Edit→Page →Create Empty Page to make a new page

Double-click on the page’s tab, type in the page’s name, 
and hit Enter

You can create from scratch in the other pages, or cut-
and-paste from where you started
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Switching, Selecting, and Toggling
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Edit→Set Attributes

Selecting from Multiple Objects: Selector and Switch

The Switch module sends nothing through 
when its first input is 0.  It sends the 
second input through when the first input is 
1.  It sends the third input through when 
the first input is 2, etc.
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Toggling Objects On and Off : Toggle and Switch

Edit→Set Attributes

The Switch module sends nothing through when its 
first input is 0.  It sends the second input through 
when the first input is 1.  It sends the third input 
through when the first input is 2, etc.
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Captions
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Placing a Caption on a Visualization
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Setting the Color of the Caption

Click here to get a list of 
simple colors, or type the 
name of a color here
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slatebluemediumvioletredlightgraydarkslategrey

skybluemediumturquoiselightbluedarkslategray

siennamediumspringgreenkhakidarkslateblue

seagreenmediumslateblueindianreddarkorchid

yellowgreensalmonmediumseagreengreydarkoliveggreen

yellowredmediumorchidgreenyellowdarkgreen

whiteplummediumgoldenrodgreencyan

wheatpinkmediumforestgreengraycornflowerblue

violetredpalegreenmediumbluegoldenrodcoral

violetorchidmediumaquamarinegoldcadetblue

turquoiseorangeredmaroonforestgreenbrown

thistleorangemagentafirebrickblueviolet

tannavybluelimegreendimgreyblue

steelbluenavylightsteelbluedimgrayblack

springgreenmidnightbluelightgreydarkturquoiseaquamarine

Color Names you can use in the Color Module 
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Placing a Data-formatted Caption on a Visualization
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Importing Your Own Data
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OpenDX Data Grid Types

Surfaces

Volumes

Irregular:
IR positions,

IR connections

Deformed Regular:
IR positions,

R connections

R = “regular”
IR = “irregular”

Regular:
R positions,

R connections
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Creating an OpenDX Data Descriptor File using the Data Prompter
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Most of the time, this is 
what you want

Regular positions, 
regular connections

One scalar value at each point
Doesn’t matter here, but a 
good value for other data

See next page
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Enter the data 
filename Describe the data at 

each point (type and 
data dimension)Enter the spatial dimensions

Doesn’t matter here, but a 
good value for other data

These get filled in for you 
when you enter the data 
dimensions – change them 
if you want
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File → Save As …

This saves the .general file, which will eventually tell OpenDX 
where to find the data and how to handle it.
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file = Z:\CS419h\pts.dat
grid = 32 x 32 x 32
format = ascii
interleaving = field
majority = row
field = field0
structure = scalar
type = float
dependency = positions
positions = regular, regular, regular, 0, 1, 0, 1, 0, 1

end

The OpenDX .general File for a 3D Scalar Dataset

3D

Scalar

Regular positions
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See next page
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This all gets created automatically!  
Pretty amazing, huh?



49

mjb – March 10, 2008
Oregon State University

Computer Graphics

file = Z:\OpenDX\or.dat
grid = 201 x 105
format = ascii
interleaving = record
majority = column
field = field0
structure = scalar
type = float
dependency = positions
positions = regular, regular, 0, 1, 0, -1

end

Terrain Visualization .general File

2D

Scalar

Regular positions
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file = Z:\OpenDX\vecs.dat
grid = 16 x 16 x 16
format = ascii
interleaving = record-vector
majority = column
field = velocity
structure = 3-vector
type = float
dependency = positions
positions = regular, regular, regular, 0, 1, 0, 1, 0, 1

end

Vector Field Visualization .general File

3D

3-element Vector

Regular positions
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Visualizing Points on a Scattered Grid
(e.g., Digital Elevation Mapping)

-360.78   128.438   2.25

-360.75   128.428   2.31

-360.80   128.405   2.20

-360.81   128.370   1.99

-360.91   128.369   1.75

-361.00   128.359   1.65

-361.16   128.354   1.77

-361.21   128.344   1.70

-361.25   128.344   1.76

· · ·

West→East South→North Elevation
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Scattered Data 
(irregular positions, 
irregular connections)

Data Dimension: a scalar value 
at each position

Spatial Dimension: 2D

See next page
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File → Save as…
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A Scattered Grid .general File

file = Z:\OpenDX\exportxyz.dat
points = 1022
format = ascii
interleaving = field
field = locations, field0
structure = 2-vector, scalar
type = float, float

end

A 1D list

Each location has 2 values (X,Y).  Each data is a single value (scalar).

Each entry has a location and data values
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Visualizing Points from a Scattered Grid
(e.g., Digital Elevation Mapping)

Realization

Realization
Connect creates triangles from 
scattered points.

ShowConnections creates 
graphics to show how the 
scattered point connections were 
made.
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Regridding a Dataset
(especially good for writing out a Connect’ed Scattered Grid as a Rectangular Array)

You might be doing this to downsize a dataset or to 
create a regular grid from a scattered grid

Creates a new grid to 
project the data onto

Projects the original 
data onto the new grid

Writes out the new 
grid data file

If Scattered data, route 
through Connect first.
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Regridding a Dataset

Coordinates at the lower 
corner of the dataset

Step size in each 
dimension

How many steps to 
make in the grid

Note: the upper corner coordinates will be 

“origin + (counts-1)*delta”
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Writing a .general Dataset as a Native OpenDX .dx Dataset

Says that you want to Export the data in 
a native OpenDX .dx file form.

The .dx file format embeds the data description information, 
the positions, and the data values in one file.  This makes it 
easier to keep track of and easier to give to other people.
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Send comments and suggestions on these notes to:

Mike Bailey
Professor, Computer Science
Oregon State University
2117 Kelley Engineering Center
Corvallis, OR  97331-5501
541-737-2542
FAX: 541-737-1300
mjb@cs.oregonstate.edu
http://eecs.oregonstate.edu/~mjb
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“These are not the modules you are looking for.”
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“An OpenDX User You Shall Be”


